Fix download site location.

Bump to 0.8.3 for misc fixes. Two original patches don't seem to be needed
anymore as the DNOTIFY code is now #ifdef'd away and the wireless applet
is conditionally built. zh_TW translation has crept in which breaks with
the system base gettext tools, so the pkgsrc ones override it. Two patches
are added to make sure those gettext tools are used rather than whatever is
found first in $PATH.
This commit is contained in:
Matt Dainty 2005-01-01 22:43:12 +00:00 committed by Thomas Klausner
parent 8b65db8288
commit 639c884afa
7 changed files with 73 additions and 67 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.4 2004/06/08 00:31:35 xtraeme Exp $
# $NetBSD: Makefile,v 1.5 2005/01/01 22:43:12 mattd Exp $
#
DISTNAME= matchbox-panel-0.8.1
DISTNAME= matchbox-panel-0.8.3
CATEGORIES= x11
MASTER_SITES= http://matchbox.handhelds.org/sources/matchbox-panel/0.8/
MASTER_SITES= ftp://ftp.handhelds.org/projects/matchbox/sources/matchbox-panel/0.8/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= tech-pkg@NetBSD.org
@ -18,13 +18,30 @@ USE_GNU_TOOLS+= make
USE_PKGLOCALEDIR= yes
USE_X11= yes
GNU_CONFIGURE= yes
AUTOCONF_REQD= 2.53
CONFIGURE_ARGS+= --enable-small-icons
CONFIGURE_ARGS+= --enable-startup-notification
CONFIGURE_ARGS+= --enable-nls
CONFIGURE_ENV+= XGETTEXT=${LOCALBASE}/bin/xgettext
CONFIGURE_ENV+= GMSGFMT=${LOCALBASE}/bin/msgfmt
CONFIGURE_ENV+= MSGFMT=${LOCALBASE}/bin/msgfmt
CONFIGURE_ENV+= MSGMERGE=${LOCALBASE}/bin/msgmerge
# Regenerate files after patching. This will disappear in next version,
# patches have been sent upstream.
#
pre-configure:
cd ${WRKSRC}; \
${ACLOCAL}; \
${AUTOHEADER}; \
${AUTOMAKE} -a --foreign -i; \
${AUTOCONF}
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../fonts/Xft2/buildlink3.mk"
.include "../../wip/libmatchbox/buildlink3.mk"
.include "../../x11/startup-notification/buildlink3.mk"
.include "../../mk/automake.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2004/06/08 00:31:35 xtraeme Exp $
@comment $NetBSD: PLIST,v 1.3 2005/01/01 22:43:12 mattd Exp $
bin/matchbox-panel
bin/mb-applet-clock
bin/mb-applet-launcher
@ -17,6 +17,7 @@ ${PKGLOCALEDIR}/locale/en_GB/LC_MESSAGES/matchbox-panel.mo
${PKGLOCALEDIR}/locale/es_ES/LC_MESSAGES/matchbox-panel.mo
${PKGLOCALEDIR}/locale/fi_FI/LC_MESSAGES/matchbox-panel.mo
${PKGLOCALEDIR}/locale/fr_FR/LC_MESSAGES/matchbox-panel.mo
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/matchbox-panel.mo
share/pixmaps/broken-0.png
share/pixmaps/mbmenu.png
share/pixmaps/mbterm.png

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2004/06/08 00:31:35 xtraeme Exp $
$NetBSD: distinfo,v 1.3 2005/01/01 22:43:12 mattd Exp $
SHA1 (matchbox-panel-0.8.1.tar.bz2) = 4e8832d9e8a1b93f70a79e4730a195fd491d591a
Size (matchbox-panel-0.8.1.tar.bz2) = 152532 bytes
SHA1 (patch-aa) = f2085259dbcf93c4f22ee07e2dfbeb10db497c2a
SHA1 (patch-ab) = 9f068959f73a27c51252cde792ceed4d229eeaea
SHA1 (matchbox-panel-0.8.3.tar.bz2) = 095394efca518f01ecc5c38d9f3cf61d24e2fb22
Size (matchbox-panel-0.8.3.tar.bz2) = 156141 bytes
SHA1 (patch-ac) = 5cfd619ca9d7660025e88652b94521785892873d
SHA1 (patch-ad) = 589644f8bdad3313f99168ef2c1c0d2ee2be021d

View file

@ -1,31 +0,0 @@
$NetBSD: patch-aa,v 1.2 2004/06/08 00:31:35 xtraeme Exp $
--- applets/mb-applet-menu-launcher.c.orig 2004-06-08 02:18:05.000000000 +0200
+++ applets/mb-applet-menu-launcher.c 2004-06-08 02:22:24.000000000 +0200
@@ -716,11 +716,15 @@
if (is_released) app_data->button_is_down = False;
sigemptyset(&block_sigset);
+#ifdef __linux__
sigaddset(&block_sigset, SIGRTMIN);
+#endif
if (is_released && !next_cancels)
{
+#ifdef __linux__
sigaddset(&block_sigset, SIGRTMIN);
+#endif
menu_get_popup_pos (app, &abs_x, &abs_y);
mb_menu_activate (app_data->mbmenu, abs_x, abs_y);
@@ -817,8 +821,9 @@
&& ev->xclient.data.l[0] == MB_CMD_SHOW_EXT_MENU )
{
sigemptyset(&block_sigset);
+#ifdef __linux__
sigaddset(&block_sigset, SIGRTMIN);
-
+#endif
if (!mb_menu_is_active(app_data->mbmenu))
{
int abs_x, abs_y;

View file

@ -1,27 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/03/19 18:04:50 xtraeme Exp $
--- applets/Makefile.in.orig 2004-03-19 19:08:23.000000000 +0100
+++ applets/Makefile.in 2004-03-19 19:09:00.000000000 +0100
@@ -148,7 +148,7 @@
mb_applet_clock_SOURCES = mb-applet-clock.c
mb_applet_menu_launcher_SOURCES = mb-applet-menu-launcher.c
-mb_applet_wireless_SOURCES = mb-applet-wireless.c
+mb_applet_wireless_SOURCES =
mb_applet_launcher_SOURCES = mb-applet-launcher.c
mb_applet_system_monitor_SOURCES = mb-applet-system-monitor.c
@@ -160,13 +160,11 @@
CONFIG_CLEAN_FILES =
@WANT_APM_TRUE@bin_PROGRAMS = mb-applet-clock$(EXEEXT) \
@WANT_APM_TRUE@ mb-applet-menu-launcher$(EXEEXT) \
-@WANT_APM_TRUE@ mb-applet-wireless$(EXEEXT) \
@WANT_APM_TRUE@ mb-applet-launcher$(EXEEXT) \
@WANT_APM_TRUE@ mb-applet-system-monitor$(EXEEXT) \
@WANT_APM_TRUE@ mb-applet-battery$(EXEEXT)
@WANT_APM_FALSE@bin_PROGRAMS = mb-applet-clock$(EXEEXT) \
@WANT_APM_FALSE@ mb-applet-menu-launcher$(EXEEXT) \
-@WANT_APM_FALSE@ mb-applet-wireless$(EXEEXT) \
@WANT_APM_FALSE@ mb-applet-launcher$(EXEEXT) \
@WANT_APM_FALSE@ mb-applet-system-monitor$(EXEEXT)
PROGRAMS = $(bin_PROGRAMS)

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ac,v 1.1 2005/01/01 22:43:12 mattd Exp $
--- configure.ac.orig 2004-08-30 18:15:49.000000000 +0000
+++ configure.ac
@@ -92,6 +92,8 @@ if test x$enable_nls = xyes; then
INTLIBS="" ))
AC_CHECK_PROG(XGETTEXT, xgettext, xgettext)
+ AC_CHECK_PROG(MSGMERGE, msgmerge, msgmerge)
+ AC_CHECK_PROG(MSGFMT, msgfmt, msgfmt)
if test "$XGETTEXT" != ""; then
if $XGETTEXT --help 2>&1 | grep illegal >/dev/null ; then
@@ -252,4 +254,4 @@ echo "
Building mb-applet-battery: ${miniapm_enabled}
Building mb-applet-wireless: ${wifi_enabled}
-"
\ No newline at end of file
+"

View file

@ -0,0 +1,26 @@
$NetBSD: patch-ad,v 1.1 2005/01/01 22:43:12 mattd Exp $
--- po/Makefile.am.orig 2004-06-28 13:00:08.000000000 +0000
+++ po/Makefile.am
@@ -16,10 +16,10 @@ POTFILES = \
SUFFIXES = .po .mo
.po.mo:
- msgfmt -o $@ $<
+ $(MSGFMT) -o $@ $<
matchbox.pot: $(POTFILES)
- xgettext --default-domain=matchbox \
+ $(XGETTEXT) --default-domain=matchbox \
--add-comments --keyword=_ $(POTFILES)
if cmp -s matchbox.po matchbox.pot; then \
rm -f matchbox.po; \
@@ -31,7 +31,7 @@ update.po: matchbox.pot
for n in $(CATALOGS) __DuMmY ; do \
if test "$$n" -a "$$n" != "__DuMmY" ; then \
l=`basename $$n .mo`; \
- msgmerge --update $$l.po matchbox.pot; \
+ $(MSGMERGE) --update $$l.po matchbox.pot; \
fi; \
done