PyOSD is a python module for displaying text on your X display, much like the
"On Screen Displays" used on TVs and some monitors.
This commit is contained in:
parent
cae2a8f413
commit
63cd7eca3e
6 changed files with 84 additions and 0 deletions
2
py-osd/DESCR
Normal file
2
py-osd/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
PyOSD is a python module for displaying text on your X display, much like the
|
||||
"On Screen Displays" used on TVs and some monitors.
|
20
py-osd/Makefile
Normal file
20
py-osd/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/11/13 05:56:49 dhowland Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pyosd-0.2.14
|
||||
PKGNAME= ${PYPKGPREFIX}-osd-0.2.14
|
||||
CATEGORIES= x11 python
|
||||
MASTER_SITES= http://repose.cx/pyosd/
|
||||
|
||||
MAINTAINER= dhowland@users.sourceforge.net
|
||||
HOMEPAGE= http://repose.cx/pyosd/
|
||||
COMMENT= Display text on an X11 display
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-twisted>=2.0.0:../../wip/py-twisted
|
||||
|
||||
PYDISTUTILSPKG= yes
|
||||
PYBINMODULE= yes
|
||||
|
||||
.include "../../x11/xosd/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
py-osd/PLIST
Normal file
9
py-osd/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2005/11/13 05:56:49 dhowland Exp $
|
||||
${PYSITELIB}/_pyosd.so
|
||||
${PYSITELIB}/pyosd/__init__.py
|
||||
${PYSITELIB}/pyosd/__init__.pyc
|
||||
${PYSITELIB}/pyosd/__init__.pyo
|
||||
${PYSITELIB}/pyosd/daemon.py
|
||||
${PYSITELIB}/pyosd/daemon.pyc
|
||||
${PYSITELIB}/pyosd/daemon.pyo
|
||||
@dirrm ${PYSITELIB}/pyosd
|
20
py-osd/buildlink3.mk
Normal file
20
py-osd/buildlink3.mk
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2005/11/13 05:56:49 dhowland Exp $
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
PY_OSD_BUILDLINK3_MK:= ${PY_OSD_BUILDLINK3_MK}+
|
||||
|
||||
.if !empty(BUILDLINK_DEPTH:M+)
|
||||
BUILDLINK_DEPENDS+= pyosd
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Npyosd}
|
||||
BUILDLINK_PACKAGES+= pyosd
|
||||
|
||||
.if !empty(PY_OSD_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.pyosd+= ${PYPKGPREFIX}-pyosd>=0.2.14
|
||||
BUILDLINK_PKGSRCDIR.pyosd?= ../../wip/py-osd
|
||||
.endif # PY_OSD_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
6
py-osd/distinfo
Normal file
6
py-osd/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/11/13 05:56:49 dhowland Exp $
|
||||
|
||||
SHA1 (pyosd-0.2.14.tar.gz) = e3d1c83563bfbeb88e91b8f1c73ebc468b014773
|
||||
RMD160 (pyosd-0.2.14.tar.gz) = b9c8fcee64784216d7e9059f55c606c192a2558b
|
||||
Size (pyosd-0.2.14.tar.gz) = 20845 bytes
|
||||
SHA1 (patch-aa) = cc91036fbe46069aa41e04c54541a1ab0bb07e30
|
27
py-osd/patches/patch-aa
Normal file
27
py-osd/patches/patch-aa
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/11/13 05:56:49 dhowland Exp $
|
||||
|
||||
--- setup.py.orig 2005-08-29 03:25:40.000000000 -0400
|
||||
+++ setup.py
|
||||
@@ -1,6 +1,9 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
from distutils.core import setup, Extension
|
||||
+import os
|
||||
+
|
||||
+LOCALBASE = os.environ.get('LOCALBASE', '/usr/pkg')
|
||||
|
||||
setup (name = "pyosd",
|
||||
version = "0.2.14",
|
||||
@@ -8,9 +11,11 @@ setup (name = "pyosd",
|
||||
url = "http://repose.cx/pyosd/",
|
||||
author = "Damien Elmes",
|
||||
author_email = "pyosd@repose.cx",
|
||||
+ include_dirs = ['%s/include' % LOCALBASE],
|
||||
packages = ['pyosd'],
|
||||
ext_modules = \
|
||||
[Extension("_pyosd", ["_pyosd.c"],
|
||||
- libraries=["xosd"])]
|
||||
+ libraries=["xosd"],
|
||||
+ library_dirs=['%s/lib' % LOCALBASE])]
|
||||
)
|
||||
|
Loading…
Reference in a new issue