Use upstream version of miniupnpnc patch.

Remove cerr patches, upstream fixed them differently.
This commit is contained in:
Thomas Klausner 2014-08-22 21:43:41 +00:00
parent d9cf302c2f
commit 646aad775f
8 changed files with 4 additions and 99 deletions

View file

@ -1,9 +1,3 @@
$NetBSD: distinfo,v 1.1 2014/08/18 08:25:24 thomasklausner Exp $
$NetBSD: distinfo,v 1.2 2014/08/22 21:43:41 thomasklausner Exp $
SHA1 (patch-3rdParty_LibMiniUPnPc_src_miniupnpc_connecthostport.c) = 0b376d3289684962afd468a6a8166bad9856cb8e
SHA1 (patch-Swiften_Client_ClientSession.cpp) = cbd284f648b67d8fc51821bd249a95e912879f9c
SHA1 (patch-Swiften_FileTransfer_IBBReceiveSession.cpp) = 1b30c24f5d225d233339e0b86e586d8024522e74
SHA1 (patch-Swiften_FileTransfer_IncomingFileTransferManager.cpp) = 51e8b185be2557b11578c0ecb120e0697f0658b6
SHA1 (patch-Swiften_Jingle_JingleResponder.cpp) = 2b6d1d04638e84ee2379b632fcfdb1d1b6e45e81
SHA1 (patch-Swiften_Parser_PayloadParsers_JingleS5BTransportMethodPayloadParser.cpp) = fd41cdbc6a8730131206c37c9d6cb3ca7449b014
SHA1 (patch-Swiften_Serializer_PayloadSerializers_JingleContentPayloadSerializer.cpp) = 5145f8ff242411644617aec44feb10d37c0af88f
SHA1 (patch-3rdParty_LibMiniUPnPc_src_miniupnpc_connecthostport.c) = 99d0d5c3dde8c3d201d303755c3b189cd3f5b6fd

View file

@ -1,4 +1,4 @@
$NetBSD: patch-3rdParty_LibMiniUPnPc_src_miniupnpc_connecthostport.c,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
$NetBSD: patch-3rdParty_LibMiniUPnPc_src_miniupnpc_connecthostport.c,v 1.2 2014/08/22 21:43:41 thomasklausner Exp $
Include missing header for struct timeval.
@ -8,7 +8,7 @@ Include missing header for struct timeval.
#ifndef USE_GETHOSTBYNAME
#include <sys/types.h>
#include <sys/socket.h>
+#include <sys/time.h>
+#include <sys/select.h>
#endif /* #ifndef USE_GETHOSTBYNAME */
#endif /* #else WIN32 */

View file

@ -1,15 +0,0 @@
$NetBSD: patch-Swiften_Client_ClientSession.cpp,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
Make cerr a member of std.
--- Swiften/Client/ClientSession.cpp.orig 2014-08-18 06:33:47.000000000 +0000
+++ Swiften/Client/ClientSession.cpp
@@ -46,6 +46,8 @@
#include <Swiften/TLS/ServerIdentityVerifier.h>
#include <Swiften/Base/Log.h>
+#include <iostream>
+
#ifdef SWIFTEN_PLATFORM_WIN32
#include <Swiften/Base/WindowsRegistry.h>
#endif

View file

@ -1,14 +0,0 @@
$NetBSD: patch-Swiften_FileTransfer_IBBReceiveSession.cpp,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
Make cerr a member of std.
--- Swiften/FileTransfer/IBBReceiveSession.cpp.orig 2014-08-18 06:33:47.000000000 +0000
+++ Swiften/FileTransfer/IBBReceiveSession.cpp
@@ -15,6 +15,7 @@
#include <Swiften/Queries/SetResponder.h>
#include <cassert>
+#include <iostream>
namespace Swift {

View file

@ -1,15 +0,0 @@
$NetBSD: patch-Swiften_FileTransfer_IncomingFileTransferManager.cpp,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
Make cerr a member of std.
--- Swiften/FileTransfer/IncomingFileTransferManager.cpp.orig 2014-08-18 06:33:47.000000000 +0000
+++ Swiften/FileTransfer/IncomingFileTransferManager.cpp
@@ -16,6 +16,8 @@
#include <Swiften/Jingle/Jingle.h>
#include <Swiften/FileTransfer/IncomingJingleFileTransfer.h>
+#include <iostream>
+
namespace Swift {
IncomingFileTransferManager::IncomingFileTransferManager(

View file

@ -1,15 +0,0 @@
$NetBSD: patch-Swiften_Jingle_JingleResponder.cpp,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
Make cerr a member of std.
--- Swiften/Jingle/JingleResponder.cpp.orig 2014-08-18 06:33:47.000000000 +0000
+++ Swiften/Jingle/JingleResponder.cpp
@@ -13,6 +13,8 @@
#include <Swiften/Base/Log.h>
+#include <iostream>
+
namespace Swift {
JingleResponder::JingleResponder(JingleSessionManager* sessionManager, IQRouter* router) : SetResponder<JinglePayload>(router), sessionManager(sessionManager), router(router) {

View file

@ -1,15 +0,0 @@
$NetBSD: patch-Swiften_Parser_PayloadParsers_JingleS5BTransportMethodPayloadParser.cpp,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
Make cerr a member of std.
--- Swiften/Parser/PayloadParsers/JingleS5BTransportMethodPayloadParser.cpp.orig 2014-08-18 06:33:47.000000000 +0000
+++ Swiften/Parser/PayloadParsers/JingleS5BTransportMethodPayloadParser.cpp
@@ -7,6 +7,8 @@
#include <boost/lexical_cast.hpp>
#include <boost/optional.hpp>
+#include <iostream>
+
#include "JingleS5BTransportMethodPayloadParser.h"
#include <Swiften/Base/Log.h>

View file

@ -1,15 +0,0 @@
$NetBSD: patch-Swiften_Serializer_PayloadSerializers_JingleContentPayloadSerializer.cpp,v 1.1 2014/08/18 08:25:25 thomasklausner Exp $
Make cerr a member of std.
--- Swiften/Serializer/PayloadSerializers/JingleContentPayloadSerializer.cpp.orig 2014-08-18 06:33:47.000000000 +0000
+++ Swiften/Serializer/PayloadSerializers/JingleContentPayloadSerializer.cpp
@@ -20,6 +20,8 @@
#include <Swiften/Serializer/PayloadSerializers/JingleIBBTransportPayloadSerializer.h>
#include <Swiften/Serializer/PayloadSerializers/JingleS5BTransportPayloadSerializer.h>
+#include <iostream>
+
namespace Swift {
JingleContentPayloadSerializer::JingleContentPayloadSerializer() {