Base runtime components of KDE4.
This commit is contained in:
parent
b9cba3ff38
commit
6577ded31a
9 changed files with 7551 additions and 0 deletions
0
kdebase-runtime4/DESCR
Normal file
0
kdebase-runtime4/DESCR
Normal file
32
kdebase-runtime4/Makefile
Normal file
32
kdebase-runtime4/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/12/12 03:25:42 mwdavies Exp $
|
||||
|
||||
DISTNAME= kdebase-runtime-${_KDE_VERSION}
|
||||
CATEGORIES= x11
|
||||
COMMENT= Runtime requirements for the KDE integrated X11 desktop
|
||||
|
||||
.include "../../wip/kde4/Makefile.kde4"
|
||||
|
||||
# BUILD_MAKE_FLAGS+= VERBOSE=1
|
||||
|
||||
REPLACE_BASH+= pics/oxygen/scalable/export_pngs.sh
|
||||
|
||||
REPLACE_PERL+= \
|
||||
khelpcenter/searchhandlers/khc_docbookdig.pl.cmake \
|
||||
khelpcenter/searchhandlers/khc_htdig.pl.cmake \
|
||||
khelpcenter/searchhandlers/khc_htsearch.pl \
|
||||
khelpcenter/searchhandlers/khc_mansearch.pl \
|
||||
kioslave/info/kde-info2html
|
||||
|
||||
CONF_FILES+= ${PREFIX}/share/examples/kdebase-runtime4/kde-information.menu \
|
||||
${PKG_SYSCONFDIR}/xdg/menus/kde-information.menu
|
||||
|
||||
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
|
||||
|
||||
.include "../../wip/kde4/kde4.mk"
|
||||
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../multimedia/xine-lib/buildlink3.mk"
|
||||
.include "../../wip/kdelibs4/buildlink3.mk"
|
||||
.include "../../wip/kdepimlibs4/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
7452
kdebase-runtime4/PLIST
Normal file
7452
kdebase-runtime4/PLIST
Normal file
File diff suppressed because it is too large
Load diff
2
kdebase-runtime4/TODO
Normal file
2
kdebase-runtime4/TODO
Normal file
|
@ -0,0 +1,2 @@
|
|||
Check through kde3 patches - see which are still relevant
|
||||
look at optional bits.
|
22
kdebase-runtime4/buildlink3.mk
Normal file
22
kdebase-runtime4/buildlink3.mk
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2007/12/12 03:25:44 mwdavies Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
KDEBASE_RUNTIME_BUILDLINK3_MK:= ${KDEBASE_RUNTIME_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= kdebase-runtime
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nkdebase-runtime}
|
||||
BUILDLINK_PACKAGES+= kdebase-runtime
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}kdebase-runtime
|
||||
|
||||
.if ${KDEBASE_RUNTIME_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.kdebase-runtime+= kdebase-runtime>=3.97.0
|
||||
BUILDLINK_PKGSRCDIR.kdebase-runtime?= ../../wip/kdebase-runtime4
|
||||
.endif # KDEBASE_RUNTIME_BUILDLINK3_MK
|
||||
|
||||
.include "../../wip/kdelibs4/buildlink3.mk"
|
||||
#.include "../../wip/kdepimlibs4/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
7
kdebase-runtime4/distinfo
Normal file
7
kdebase-runtime4/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/12/12 03:25:44 mwdavies Exp $
|
||||
|
||||
SHA1 (kdebase-runtime-3.97.0.tar.bz2) = dcb1de1015de1f10ceead049b692c047e72a4992
|
||||
RMD160 (kdebase-runtime-3.97.0.tar.bz2) = 361eb30accc717c2eae6544e2258098552b83069
|
||||
Size (kdebase-runtime-3.97.0.tar.bz2) = 57549383 bytes
|
||||
SHA1 (patch-aa) = c11f2ee0041d00a7fd435bf4c779cf355766ab15
|
||||
SHA1 (patch-ab) = b7e168f12e0137891befdcc94fa13ec9b269d03a
|
12
kdebase-runtime4/patches/patch-aa
Normal file
12
kdebase-runtime4/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/12/12 03:25:44 mwdavies Exp $
|
||||
|
||||
--- CMakeLists.txt.orig 2007-12-03 15:31:09.000000000 +1300
|
||||
+++ CMakeLists.txt
|
||||
@@ -16,6 +16,7 @@ include(CheckFunctionExists)
|
||||
include(CheckIncludeFiles)
|
||||
|
||||
check_include_files(sys/wait.h HAVE_SYS_WAIT_H)
|
||||
+check_include_files(sys/time.h HAVE_SYS_TIME_H)
|
||||
|
||||
configure_file (config-runtime.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-runtime.h )
|
||||
|
13
kdebase-runtime4/patches/patch-ab
Normal file
13
kdebase-runtime4/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2007/12/12 03:25:44 mwdavies Exp $
|
||||
|
||||
dont install hicolor/index.theme as hicolor-icon-theme pkg will
|
||||
|
||||
--- pics/CMakeLists.txt.orig 2007-10-26 01:21:45.000000000 +1300
|
||||
+++ pics/CMakeLists.txt
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-add_subdirectory( hicolor )
|
||||
+#add_subdirectory( hicolor )
|
||||
add_subdirectory( emoticons )
|
||||
add_subdirectory( oxygen )
|
||||
|
11
kdebase-runtime4/patches/patch-ac
Normal file
11
kdebase-runtime4/patches/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2007/12/12 03:25:44 mwdavies Exp $
|
||||
|
||||
--- kcontrol/menus/CMakeLists.txt.orig 2007-12-07 01:45:22.000000000 +1300
|
||||
+++ kcontrol/menus/CMakeLists.txt
|
||||
@@ -4,5 +4,5 @@
|
||||
########### install files ###############
|
||||
|
||||
install( FILES kde-information.menu
|
||||
- DESTINATION ${SYSCONF_INSTALL_DIR}/xdg/menus/)
|
||||
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/kdebase-runtime4/)
|
||||
install( FILES kde-information.directory DESTINATION ${XDG_DIRECTORY_INSTALL_DIR} )
|
Loading…
Reference in a new issue