Another round of patch updates.

This commit is contained in:
Hauke Fath 2014-02-20 20:53:59 +00:00 committed by Thomas Klausner
parent 6790a45b82
commit 69878e18a1
11 changed files with 41 additions and 65 deletions

View file

@ -1,12 +1,11 @@
$NetBSD: distinfo,v 1.3 2014/02/14 12:06:45 hfath Exp $
$NetBSD: distinfo,v 1.4 2014/02/20 20:53:59 hfath Exp $
SHA1 (patch-config.c) = 8e1789f38bedc5d4cc136e706f6715a390cfca69
SHA1 (patch-config.h) = 1e73b3a064cefd4e7dc7816456a664a824cf111e
SHA1 (patch-makeman.pl) = 3b746d36f4168c74a5a23816ec14fcd710ee5c4d
SHA1 (patch-pcf2vpnc) = 4341b3c6aed524b32a5bcc41ddba6f43e50f9d6a
SHA1 (patch-sysdep.c) = 69bac52506c09ed4c68dcb27f6f7872ca472e2a5
SHA1 (patch-sysdep.h) = c23e871f16f691b5a7278169b5b31b7ecc2a8676
SHA1 (patch-tunip.c) = 157b8b54f49411da0fe2e9873e7aa1bce2cba31e
SHA1 (patch-vpnc.c) = f7a864d2d49d81f2bec35a0118ba54db63a4966e
SHA1 (patch-vpnc_disconnect) = 083225589698d8080f740fbfcfe7d3a71411a2a5
SHA1 (patch-vpnc_script) = dc07f6075640f1ffbadcec5fc5347c471b175af7
SHA1 (patch-config.c) = 313a76fa5c5784a93f06a4e31927e3b42a9a6fdf
SHA1 (patch-config.h) = 2917b54525315d59646a1ca759138a14021ee674
SHA1 (patch-makeman.pl) = d87e77fe71a2a37265409b5f88e53cbf1373a9b0
SHA1 (patch-pcf2vpnc) = e04d8167c95ff89496ff4d9603adc57b6da2a457
SHA1 (patch-sysdep.c) = 30f4122e686ccb1757cec5869d296495738e6be6
SHA1 (patch-tunip.c) = 3bc4968d5e51577185813b033786092f8a981a90
SHA1 (patch-vpnc.c) = 7d677152e39477202c7b57b7063e77f174859884
SHA1 (patch-vpnc_disconnect) = a38c6f7cf978d063be0db3791b29962ceaeb5b9e
SHA1 (patch-vpnc_script) = 1fb5b4d3d98b6a0ae67d8800d08f92876a0ea694

View file

@ -1,8 +1,8 @@
$NetBSD: patch-config.c,v 1.2 2014/02/14 12:06:45 hfath Exp $
$NetBSD: patch-config.c,v 1.3 2014/02/20 20:53:59 hfath Exp $
--- config.c.orig 2014-02-14 11:46:47.000000000 +0000
--- config.c.orig 2014-02-20 20:27:20.000000000 +0000
+++ config.c
@@ -188,12 +188,12 @@ static const char *config_def_app_versio
@@ -362,12 +362,12 @@ static const char *config_def_app_versio
static const char *config_def_script(void)
{
@ -17,7 +17,7 @@ $NetBSD: patch-config.c,v 1.2 2014/02/14 12:06:45 hfath Exp $
}
static const char *config_def_vendor(void)
@@ -201,6 +201,16 @@ static const char *config_def_vendor(voi
@@ -375,6 +375,16 @@ static const char *config_def_vendor(voi
return "cisco";
}
@ -34,9 +34,9 @@ $NetBSD: patch-config.c,v 1.2 2014/02/14 12:06:45 hfath Exp $
static const char *config_def_target_network(void)
{
return "0.0.0.0/0.0.0.0";
@@ -469,6 +479,21 @@ static const struct config_names_s {
"Target network in dotted decimal or CIDR notation\n",
config_def_target_network
@@ -650,6 +660,20 @@ static const struct config_names_s {
"path to password program or helper name\n",
NULL
}, {
+ CONFIG_DNS_UPDATE, 1, 1,
+ "--dns-update",
@ -52,11 +52,10 @@ $NetBSD: patch-config.c,v 1.2 2014/02/14 12:06:45 hfath Exp $
+ "DEPRECATED extension from Debian",
+ config_def_networks_list
+ }, {
+
0, 0, 0, NULL, NULL, NULL, NULL, NULL
}
};
@@ -477,7 +502,7 @@ static char *get_config_filename(const c
@@ -658,7 +682,7 @@ static char *get_config_filename(const c
{
char *realname;
@ -65,7 +64,7 @@ $NetBSD: patch-config.c,v 1.2 2014/02/14 12:06:45 hfath Exp $
return realname;
}
@@ -716,8 +741,8 @@ void do_config(int argc, char **argv)
@@ -894,8 +918,8 @@ void do_config(int argc, char **argv)
}
if (!got_conffile) {

View file

@ -1,11 +1,11 @@
$NetBSD: patch-config.h,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
$NetBSD: patch-config.h,v 1.2 2014/02/20 20:53:59 hfath Exp $
--- config.h.orig 2012-05-23 13:52:36.000000000 +0000
--- config.h.orig 2014-02-20 20:27:20.000000000 +0000
+++ config.h
@@ -59,6 +59,8 @@ enum config_enum {
CONFIG_AUTH_MODE,
@@ -60,6 +60,8 @@ enum config_enum {
CONFIG_CA_FILE,
CONFIG_CA_DIR,
CONFIG_PASSWORD_HELPER,
+ CONFIG_DNS_UPDATE,
+ CONFIG_TARGET_NETWORKS,
LAST_CONFIG

View file

@ -1,6 +1,6 @@
$NetBSD: patch-makeman.pl,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
$NetBSD: patch-makeman.pl,v 1.2 2014/02/20 20:53:59 hfath Exp $
--- makeman.pl.orig 2012-05-23 13:52:36.000000000 +0000
--- makeman.pl.orig 2014-02-20 20:27:20.000000000 +0000
+++ makeman.pl
@@ -1,2 +1,2 @@
-#! /usr/bin/env perl

View file

@ -1,6 +1,6 @@
$NetBSD: patch-pcf2vpnc,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
$NetBSD: patch-pcf2vpnc,v 1.2 2014/02/20 20:53:59 hfath Exp $
--- pcf2vpnc.orig 2012-05-23 13:52:36.000000000 +0000
--- pcf2vpnc.orig 2014-02-20 20:27:20.000000000 +0000
+++ pcf2vpnc
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl

View file

@ -1,6 +1,6 @@
$NetBSD: patch-sysdep.c,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
$NetBSD: patch-sysdep.c,v 1.2 2014/02/20 20:53:59 hfath Exp $
--- sysdep.c.orig 2012-05-23 13:52:36.000000000 +0000
--- sysdep.c.orig 2014-02-20 20:27:20.000000000 +0000
+++ sysdep.c
@@ -666,7 +666,7 @@ int tun_get_hwaddr(int fd, char *dev, ui
}
@ -33,12 +33,3 @@ $NetBSD: patch-sysdep.c,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
return 0;
#else
/* todo: implement using SIOCGLIFADDR */
@@ -751,7 +759,7 @@ void error(int status, int errornum, con
#endif
#ifndef HAVE_GETLINE
-int getline(char **line, size_t * length, FILE * stream)
+ssize_t getline(char **line, size_t * length, FILE * stream)
{
size_t len;
#ifdef HAVE_FGETLN

View file

@ -1,13 +0,0 @@
$NetBSD: patch-sysdep.h,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
--- sysdep.h.orig 2012-05-23 13:52:36.000000000 +0000
+++ sysdep.h
@@ -233,7 +233,7 @@ struct ether_arp {
extern void error(int fd, int errorno, const char *fmt, ...);
#endif
#ifndef HAVE_GETLINE
-extern int getline(char **line, size_t * length, FILE * stream);
+extern ssize_t getline(char **line, size_t * length, FILE * stream);
#endif
#ifndef HAVE_VASPRINTF
#include <stdarg.h>

View file

@ -1,6 +1,6 @@
$NetBSD: patch-tunip.c,v 1.1.1.1 2012/05/23 15:37:12 hfath Exp $
$NetBSD: patch-tunip.c,v 1.2 2014/02/20 20:53:59 hfath Exp $
--- tunip.c.orig 2012-05-23 13:52:36.000000000 +0000
--- tunip.c.orig 2014-02-20 20:27:20.000000000 +0000
+++ tunip.c
@@ -177,7 +177,8 @@ static int encap_rawip_recv(struct sa_bl
return -1;

View file

@ -1,6 +1,6 @@
$NetBSD: patch-vpnc.c,v 1.2 2014/02/14 12:06:45 hfath Exp $
$NetBSD: patch-vpnc.c,v 1.3 2014/02/20 20:54:00 hfath Exp $
--- vpnc.c.orig 2014-02-14 11:46:47.000000000 +0000
--- vpnc.c.orig 2014-02-20 20:27:20.000000000 +0000
+++ vpnc.c
@@ -389,6 +389,8 @@ static void config_tunnel(struct sa_bloc
{

View file

@ -1,6 +1,6 @@
$NetBSD: patch-vpnc_disconnect,v 1.2 2014/02/14 12:06:46 hfath Exp $
$NetBSD: patch-vpnc_disconnect,v 1.3 2014/02/20 20:54:00 hfath Exp $
--- vpnc-disconnect.orig 2014-02-14 11:46:47.000000000 +0000
--- vpnc-disconnect.orig 2014-02-20 20:27:20.000000000 +0000
+++ vpnc-disconnect
@@ -1,6 +1,6 @@
#!/bin/sh

View file

@ -1,8 +1,8 @@
$NetBSD: patch-vpnc_script,v 1.2 2013/03/18 20:49:19 hfath Exp $
$NetBSD: patch-vpnc_script,v 1.3 2014/02/20 20:54:00 hfath Exp $
--- vpnc-script.orig 2013-03-12 21:00:57.000000000 +0000
--- vpnc-script.orig 2014-02-20 20:27:20.000000000 +0000
+++ vpnc-script
@@ -77,9 +77,10 @@ PATH=/sbin:/usr/sbin:$PATH
@@ -78,9 +78,10 @@ PATH=/sbin:/usr/sbin:$PATH
OS="`uname -s`"
@ -16,7 +16,7 @@ $NetBSD: patch-vpnc_script,v 1.2 2013/03/18 20:49:19 hfath Exp $
SCRIPTNAME=`basename $0`
# some systems, eg. Darwin & FreeBSD, prune /var/run on boot
@@ -162,7 +163,7 @@ do_ifconfig() {
@@ -163,7 +164,7 @@ do_ifconfig() {
fi
if [ -z "$MTU" ]; then
@ -25,7 +25,7 @@ $NetBSD: patch-vpnc_script,v 1.2 2013/03/18 20:49:19 hfath Exp $
fi
# Point to point interface require a netmask of 255.255.255.255 on some systems
@@ -284,11 +285,11 @@ else # use route command
@@ -285,11 +286,11 @@ else # use route command
# isn't -n supposed to give --numeric output?
# apperently not...
# Get rid of lines containing IPv6 addresses (':')
@ -39,7 +39,7 @@ $NetBSD: patch-vpnc_script,v 1.2 2013/03/18 20:49:19 hfath Exp $
}
del_vpngateway_route() {
@@ -622,6 +623,20 @@ do_pre_init() {
@@ -623,6 +624,20 @@ do_pre_init() {
}
do_connect() {