Update to 3.2.0b2.
Add package.mk for Zope 3 additional packages.
This commit is contained in:
parent
a03483f8f7
commit
698abfd62e
10 changed files with 133 additions and 52 deletions
|
@ -1,5 +1,5 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.5 2005/12/10 17:54:03 ykomatsu Exp $
|
||||
$NetBSD: MESSAGE,v 1.6 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
|
||||
To run Zope, you need to make a new Zope instance home.
|
||||
|
||||
|
@ -8,6 +8,9 @@ To run Zope, you need to make a new Zope instance home.
|
|||
|
||||
${PREFIX}/bin/mkzopeinstance --dir=${VARBASE}/zope3
|
||||
|
||||
Additionally, you need to edit ${VARBASE}/zope3/etc/zope.conf
|
||||
if you want to run ZEO client.
|
||||
|
||||
2) If you want to run ZEO storage server,
|
||||
please run the following command:
|
||||
|
||||
|
@ -20,14 +23,14 @@ and edit /etc/rc.conf.
|
|||
1) If you want to run standalone Zope or ZEO client,
|
||||
please run the following commands:
|
||||
|
||||
${CHOWN} -R ${ZOPE3_USER}:${ZOPE3_GROUP} ${VARBASE}/zope3
|
||||
${ECHO} 'zope3_user="${ZOPE3_USER}"' >> /etc/rc.conf
|
||||
chown -R ${ZOPE3_USER}:${ZOPE3_GROUP} ${VARBASE}/zope3
|
||||
echo 'zope3_user="${ZOPE3_USER}"' >> /etc/rc.conf
|
||||
|
||||
2) If you want to run ZEO storage server,
|
||||
please run the following commands:
|
||||
|
||||
${CHOWN} -R ${ZOPE3_USER}:${ZOPE3_GROUP} ${VARBASE}/zss3
|
||||
${ECHO} 'zss3_user="${ZOPE3_USER}"' >> /etc/rc.conf
|
||||
chown -R ${ZOPE3_USER}:${ZOPE3_GROUP} ${VARBASE}/zss3
|
||||
echo 'zss3_user="${ZOPE3_USER}"' >> /etc/rc.conf
|
||||
|
||||
If you want to run Zope with following protocols, you need to
|
||||
install corresponding packages.
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.10 2005/12/10 17:54:03 ykomatsu Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Zope-3.2.0b1
|
||||
PKGNAME= zope3-unstable-3.2.0b1
|
||||
DISTNAME= Zope-3.2.0b2
|
||||
PKGNAME= zope3-unstable-3.2.0b2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.zope.org/Products/Zope3/3.2.0b1/
|
||||
MASTER_SITES= http://www.zope.org/Products/Zope3/3.2.0b2/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ykomatsu@akaumigame.org
|
||||
|
@ -14,16 +14,14 @@ COMMENT= Zope 3 Application Server
|
|||
CONFLICTS= zope3-3.1.0* zope3-unstable-3.1.0*
|
||||
DEPENDS+= ${PYPKGPREFIX}-xml>=0.8.4:../../textproc/py-xml
|
||||
|
||||
ZOPE3_DIR= ${PREFIX}/share/zope3
|
||||
ZOPE3_DOCDIR= ${PREFIX}/share/doc/zope3
|
||||
.include "Makefile.common"
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-python ${PYTHONBIN} \
|
||||
--prefix ${ZOPE3_DIR} \
|
||||
--force
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if !empty(MACHINE_PLATFORM:MNetBSD-1.[0-6]*)
|
||||
EXTRACT_USING= gtar
|
||||
.endif
|
||||
|
@ -32,20 +30,12 @@ BUILD_TARGET= build
|
|||
|
||||
USE_PKGINSTALL= yes
|
||||
RCD_SCRIPTS= zope3 zss3
|
||||
ZOPE3_GROUP?= zope3
|
||||
ZOPE3_USER?= zope3
|
||||
PKG_GROUPS= ${ZOPE3_GROUP}
|
||||
PKG_USERS= ${ZOPE3_USER}:${ZOPE3_GROUP}::Zope3\ user
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 24
|
||||
|
||||
MESSAGE_SUBST+= ZOPE3_USER="${ZOPE3_USER}" \
|
||||
ZOPE3_GROUP="${ZOPE3_GROUP}" \
|
||||
VARBASE="${VARBASE}" \
|
||||
CHOWN="${CHOWN}" ECHO="${ECHO}"
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
VARBASE="${VARBASE}"
|
||||
|
||||
pre-install:
|
||||
${FIND} ${WRKSRC} -name "*.orig" -type f -print | ${XARGS} ${RM} -f
|
||||
|
@ -59,4 +49,5 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/Zope/ZopePublicLicense.txt ${ZOPE3_DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/Zope/doc/*.txt ${ZOPE3_DOCDIR}
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
12
zope3-unstable/Makefile.common
Normal file
12
zope3-unstable/Makefile.common
Normal file
|
@ -0,0 +1,12 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
#
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 24
|
||||
|
||||
ZOPE3_DIR= ${PREFIX}/share/zope3
|
||||
ZOPE3_DOCDIR= ${PREFIX}/share/doc/zope3
|
||||
|
||||
ZOPE3_GROUP?= zope3
|
||||
ZOPE3_USER?= zope3
|
||||
|
||||
.include "../../lang/python/application.mk"
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2005/12/08 07:42:46 ykomatsu Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
bin/mkzeoinstance
|
||||
bin/mkzopeinstance
|
||||
bin/zopetest
|
||||
|
@ -6105,9 +6105,18 @@ share/zope3/lib/python/zope/app/content/configure.zcml
|
|||
share/zope3/lib/python/zope/app/content/interfaces.py
|
||||
share/zope3/lib/python/zope/app/content/interfaces.pyc
|
||||
share/zope3/lib/python/zope/app/content/interfaces.pyo
|
||||
share/zope3/lib/python/zope/app/content_types.py
|
||||
share/zope3/lib/python/zope/app/content_types.pyc
|
||||
share/zope3/lib/python/zope/app/content_types.pyo
|
||||
share/zope3/lib/python/zope/app/content_types/__init__.py
|
||||
share/zope3/lib/python/zope/app/content_types/__init__.pyc
|
||||
share/zope3/lib/python/zope/app/content_types/__init__.pyo
|
||||
share/zope3/lib/python/zope/app/content_types/mime.types
|
||||
share/zope3/lib/python/zope/app/content_types/tests/__init__.py
|
||||
share/zope3/lib/python/zope/app/content_types/tests/__init__.pyc
|
||||
share/zope3/lib/python/zope/app/content_types/tests/__init__.pyo
|
||||
share/zope3/lib/python/zope/app/content_types/tests/mime.types-1
|
||||
share/zope3/lib/python/zope/app/content_types/tests/mime.types-2
|
||||
share/zope3/lib/python/zope/app/content_types/tests/testContentTypes.py
|
||||
share/zope3/lib/python/zope/app/content_types/tests/testContentTypes.pyc
|
||||
share/zope3/lib/python/zope/app/content_types/tests/testContentTypes.pyo
|
||||
share/zope3/lib/python/zope/app/copypastemove/__init__.py
|
||||
share/zope3/lib/python/zope/app/copypastemove/__init__.pyc
|
||||
share/zope3/lib/python/zope/app/copypastemove/__init__.pyo
|
||||
|
@ -7070,11 +7079,21 @@ share/zope3/lib/python/zope/app/locales/extract.pyc
|
|||
share/zope3/lib/python/zope/app/locales/extract.pyo
|
||||
share/zope3/lib/python/zope/app/locales/fr/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/fr/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/hu/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/hu/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/interfaces.py
|
||||
share/zope3/lib/python/zope/app/locales/interfaces.pyc
|
||||
share/zope3/lib/python/zope/app/locales/interfaces.pyo
|
||||
share/zope3/lib/python/zope/app/locales/it/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/it/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/ja/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/ja/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/ml/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/ml/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/nl/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/nl/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/pl/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/pl/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/pt_BR/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/pt_BR/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/pygettext.py
|
||||
|
@ -7085,6 +7104,12 @@ share/zope3/lib/python/zope/app/locales/ru/LC_MESSAGES/zope.po
|
|||
share/zope3/lib/python/zope/app/locales/tests.py
|
||||
share/zope3/lib/python/zope/app/locales/tests.pyc
|
||||
share/zope3/lib/python/zope/app/locales/tests.pyo
|
||||
share/zope3/lib/python/zope/app/locales/tr/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/tr/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/zh_CN/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/zh_CN/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/zh_TW/LC_MESSAGES/zope.mo
|
||||
share/zope3/lib/python/zope/app/locales/zh_TW/LC_MESSAGES/zope.po
|
||||
share/zope3/lib/python/zope/app/locales/zope.pot
|
||||
share/zope3/lib/python/zope/app/location/__init__.py
|
||||
share/zope3/lib/python/zope/app/location/__init__.pyc
|
||||
|
@ -8295,6 +8320,10 @@ share/zope3/lib/python/zope/app/server/tests/test_zpasswd.pyo
|
|||
share/zope3/lib/python/zope/app/server/wsgi.py
|
||||
share/zope3/lib/python/zope/app/server/wsgi.pyc
|
||||
share/zope3/lib/python/zope/app/server/wsgi.pyo
|
||||
share/zope3/lib/python/zope/app/server/zopeskel/bin/debugzope.in
|
||||
share/zope3/lib/python/zope/app/server/zopeskel/bin/runzope.in
|
||||
share/zope3/lib/python/zope/app/server/zopeskel/bin/zopectl.in
|
||||
share/zope3/lib/python/zope/app/server/zopeskel/etc/zope.conf.in
|
||||
share/zope3/lib/python/zope/app/server/zpasswd.py
|
||||
share/zope3/lib/python/zope/app/server/zpasswd.pyc
|
||||
share/zope3/lib/python/zope/app/server/zpasswd.pyo
|
||||
|
@ -8599,6 +8628,9 @@ share/zope3/lib/python/zope/app/twisted/accesslog.py
|
|||
share/zope3/lib/python/zope/app/twisted/accesslog.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/accesslog.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/accesslog.xml
|
||||
share/zope3/lib/python/zope/app/twisted/asyncore_main_loop.py
|
||||
share/zope3/lib/python/zope/app/twisted/asyncore_main_loop.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/asyncore_main_loop.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/configure.zcml
|
||||
share/zope3/lib/python/zope/app/twisted/controller.py
|
||||
share/zope3/lib/python/zope/app/twisted/controller.pyc
|
||||
|
@ -8662,9 +8694,6 @@ share/zope3/lib/python/zope/app/twisted/log.txt
|
|||
share/zope3/lib/python/zope/app/twisted/main.py
|
||||
share/zope3/lib/python/zope/app/twisted/main.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/main.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/mkzopeinstance.py
|
||||
share/zope3/lib/python/zope/app/twisted/mkzopeinstance.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/mkzopeinstance.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/schema.xml
|
||||
share/zope3/lib/python/zope/app/twisted/server.py
|
||||
share/zope3/lib/python/zope/app/twisted/server.pyc
|
||||
|
@ -8678,15 +8707,21 @@ share/zope3/lib/python/zope/app/twisted/tests/__init__.pyo
|
|||
share/zope3/lib/python/zope/app/twisted/tests/test_accesslog.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_accesslog.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_accesslog.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_asyncore_main_loop.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_asyncore_main_loop.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_asyncore_main_loop.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_docs.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_docs.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_docs.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_mkzopeinstance.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_mkzopeinstance.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_mkzopeinstance.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_inputbuffering.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_inputbuffering.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_inputbuffering.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_schema.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_schema.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_schema.pyo
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_zeo.py
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_zeo.pyc
|
||||
share/zope3/lib/python/zope/app/twisted/tests/test_zeo.pyo
|
||||
share/zope3/lib/python/zope/app/undo/SETUP.cfg
|
||||
share/zope3/lib/python/zope/app/undo/__init__.py
|
||||
share/zope3/lib/python/zope/app/undo/__init__.pyc
|
||||
|
@ -8730,6 +8765,11 @@ share/zope3/lib/python/zope/app/wsgi/README.txt
|
|||
share/zope3/lib/python/zope/app/wsgi/__init__.py
|
||||
share/zope3/lib/python/zope/app/wsgi/__init__.pyc
|
||||
share/zope3/lib/python/zope/app/wsgi/__init__.pyo
|
||||
share/zope3/lib/python/zope/app/wsgi/configure.zcml
|
||||
share/zope3/lib/python/zope/app/wsgi/fileresult.py
|
||||
share/zope3/lib/python/zope/app/wsgi/fileresult.pyc
|
||||
share/zope3/lib/python/zope/app/wsgi/fileresult.pyo
|
||||
share/zope3/lib/python/zope/app/wsgi/fileresult.txt
|
||||
share/zope3/lib/python/zope/app/wsgi/interfaces.py
|
||||
share/zope3/lib/python/zope/app/wsgi/interfaces.pyc
|
||||
share/zope3/lib/python/zope/app/wsgi/interfaces.pyo
|
||||
|
@ -9889,6 +9929,7 @@ share/zope3/lib/python/zope/publisher/ftp.pyo
|
|||
share/zope3/lib/python/zope/publisher/http.py
|
||||
share/zope3/lib/python/zope/publisher/http.pyc
|
||||
share/zope3/lib/python/zope/publisher/http.pyo
|
||||
share/zope3/lib/python/zope/publisher/httpresults.txt
|
||||
share/zope3/lib/python/zope/publisher/interfaces/__init__.py
|
||||
share/zope3/lib/python/zope/publisher/interfaces/__init__.pyc
|
||||
share/zope3/lib/python/zope/publisher/interfaces/__init__.pyo
|
||||
|
@ -11270,6 +11311,9 @@ share/zope3/zopeskel/var/README.txt
|
|||
@dirrm share/zope3/lib/python/zope/app/site/tests
|
||||
@dirrm share/zope3/lib/python/zope/app/site
|
||||
@dirrm share/zope3/lib/python/zope/app/session
|
||||
@dirrm share/zope3/lib/python/zope/app/server/zopeskel/etc
|
||||
@dirrm share/zope3/lib/python/zope/app/server/zopeskel/bin
|
||||
@dirrm share/zope3/lib/python/zope/app/server/zopeskel
|
||||
@dirrm share/zope3/lib/python/zope/app/server/tests
|
||||
@dirrm share/zope3/lib/python/zope/app/server
|
||||
@dirrm share/zope3/lib/python/zope/app/securitypolicy/tests
|
||||
|
@ -11321,12 +11365,28 @@ share/zope3/zopeskel/var/README.txt
|
|||
@dirrm share/zope3/lib/python/zope/app/mail/tests
|
||||
@dirrm share/zope3/lib/python/zope/app/mail
|
||||
@dirrm share/zope3/lib/python/zope/app/location
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/zh_TW/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/zh_TW
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/zh_CN/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/zh_CN
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/tr/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/tr
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/ru/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/ru
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/pt_BR/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/pt_BR
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/pl/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/pl
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/nl/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/nl
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/ml/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/ml
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/ja/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/ja
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/it/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/it
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/hu/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/hu
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/fr/LC_MESSAGES
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/fr
|
||||
@dirrm share/zope3/lib/python/zope/app/locales/es/LC_MESSAGES
|
||||
|
@ -11397,6 +11457,8 @@ share/zope3/zopeskel/var/README.txt
|
|||
@dirrm share/zope3/lib/python/zope/app/dav
|
||||
@dirrm share/zope3/lib/python/zope/app/copypastemove/tests
|
||||
@dirrm share/zope3/lib/python/zope/app/copypastemove
|
||||
@dirrm share/zope3/lib/python/zope/app/content_types/tests
|
||||
@dirrm share/zope3/lib/python/zope/app/content_types
|
||||
@dirrm share/zope3/lib/python/zope/app/content
|
||||
@dirrm share/zope3/lib/python/zope/app/container/tests
|
||||
@dirrm share/zope3/lib/python/zope/app/container/ftests
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.5 2005/12/08 07:42:46 ykomatsu Exp $
|
||||
$NetBSD: distinfo,v 1.6 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
|
||||
SHA1 (Zope-3.2.0b1.tgz) = 7b699bba41287d469ce504e9bac38ced5fc89a1b
|
||||
RMD160 (Zope-3.2.0b1.tgz) = 02a58fa3376ddd2bd3980f6666530a194d6ec4c5
|
||||
Size (Zope-3.2.0b1.tgz) = 5883257 bytes
|
||||
SHA1 (patch-aa) = 8eb78912766b7ace838b01bdb501044201dd6f85
|
||||
SHA1 (patch-ab) = c043fc6daf4154317ebd2109bc97d49b13d913c6
|
||||
SHA1 (patch-ac) = d9db6df283ddee99841a597d230289d68c2e2049
|
||||
SHA1 (patch-ad) = 68e44ca9cf5503620e9a3abd7f8f61ad508066f1
|
||||
SHA1 (Zope-3.2.0b2.tgz) = 6e61eb82bd635988f33262dc8ee11341b153e7b7
|
||||
RMD160 (Zope-3.2.0b2.tgz) = fda0369228f6bb6fae5d174537de6a138b188226
|
||||
Size (Zope-3.2.0b2.tgz) = 6557368 bytes
|
||||
SHA1 (patch-aa) = 23501eb93ab857e0c1afe8daa9d779487a2689e5
|
||||
SHA1 (patch-ab) = f53c3f179b56768bdcd7dacd09948a8e49c31678
|
||||
SHA1 (patch-ac) = f2e11b4f1fead2232f7a66fcdcc1e5137c1d1480
|
||||
SHA1 (patch-ad) = abf1b00b2c2a05aa1bcd98ce24c9b8526f9e3d1c
|
||||
|
|
13
zope3-unstable/package.mk
Normal file
13
zope3-unstable/package.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: package.mk,v 1.1 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
#
|
||||
|
||||
DEPENDS+= zope3-unstable>=3.2.0b2:../../wip/zope3-unstable
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-python ${PYTHONBIN} \
|
||||
--prefix ${ZOPE3_DIR} \
|
||||
--force
|
||||
|
||||
BUILD_TARGET= build
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/12/08 07:42:48 ykomatsu Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
|
||||
--- Dependencies/ZConfig-Zope-3.2.0b1/ZConfig/scripts/zconfig.orig 2005-12-06 01:38:10.000000000 +0900
|
||||
+++ Dependencies/ZConfig-Zope-3.2.0b1/ZConfig/scripts/zconfig
|
||||
--- Dependencies/ZConfig-Zope-3.2.0b2/ZConfig/scripts/zconfig.orig 2005-12-24 08:07:53.000000000 +0900
|
||||
+++ Dependencies/ZConfig-Zope-3.2.0b2/ZConfig/scripts/zconfig
|
||||
@@ -41,2 +41,15 @@
|
||||
|
||||
+if __name__ == "__main__":
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ab,v 1.3 2005/12/08 07:42:48 ykomatsu Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
|
||||
--- Dependencies/ZConfig-Zope-3.2.0b1/ZConfig/scripts/zconfig_schema2html.orig 2005-12-06 01:38:10.000000000 +0900
|
||||
+++ Dependencies/ZConfig-Zope-3.2.0b1/ZConfig/scripts/zconfig_schema2html
|
||||
--- Dependencies/ZConfig-Zope-3.2.0b2/ZConfig/scripts/zconfig_schema2html.orig 2005-12-24 08:07:53.000000000 +0900
|
||||
+++ Dependencies/ZConfig-Zope-3.2.0b2/ZConfig/scripts/zconfig_schema2html
|
||||
@@ -17,2 +17,15 @@
|
||||
|
||||
+if __name__ == "__main__":
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ac,v 1.3 2005/12/08 07:42:48 ykomatsu Exp $
|
||||
$NetBSD: patch-ac,v 1.4 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
|
||||
--- Dependencies/zdaemon-Zope-3.2.0b1/zdaemon/zdctl.py.orig 2005-12-06 01:38:49.000000000 +0900
|
||||
+++ Dependencies/zdaemon-Zope-3.2.0b1/zdaemon/zdctl.py
|
||||
--- Dependencies/zdaemon-Zope-3.2.0b2/zdaemon/zdctl.py.orig 2005-12-24 08:08:03.000000000 +0900
|
||||
+++ Dependencies/zdaemon-Zope-3.2.0b2/zdaemon/zdctl.py
|
||||
@@ -60,2 +60,13 @@
|
||||
sys.path.append(dirname(scriptdir))
|
||||
+ # Add the zope3 library directory to the module search path
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ad,v 1.3 2005/12/08 07:42:48 ykomatsu Exp $
|
||||
$NetBSD: patch-ad,v 1.4 2005/12/26 10:17:38 ykomatsu Exp $
|
||||
|
||||
--- Dependencies/zdaemon-Zope-3.2.0b1/zdaemon/zdrun.py.orig 2005-12-06 01:38:49.000000000 +0900
|
||||
+++ Dependencies/zdaemon-Zope-3.2.0b1/zdaemon/zdrun.py
|
||||
--- Dependencies/zdaemon-Zope-3.2.0b2/zdaemon/zdrun.py.orig 2005-12-24 08:08:03.000000000 +0900
|
||||
+++ Dependencies/zdaemon-Zope-3.2.0b2/zdaemon/zdrun.py
|
||||
@@ -85,2 +85,13 @@
|
||||
sys.path.append(dirname(scriptdir))
|
||||
+ # Add the zope3 library directory to the module search path
|
||||
|
|
Loading…
Reference in a new issue