Remove obsoleted patches, ossaudio buildlink does the work,

s/-lossaudio/${LIBOSSAUDIO}/. Thanks to Thomas Klausner.
This commit is contained in:
Juan Romero Pardines 2003-05-14 08:06:06 +00:00
parent c58b95c09b
commit 6abbef2739
4 changed files with 4 additions and 44 deletions

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2003/05/09 09:54:29 xtraeme Exp $
$NetBSD: distinfo,v 1.2 2003/05/14 08:06:06 xtraeme Exp $
SHA1 (darkice-0.13.1.tar.gz) = b86bda90862840f57c8b0e033b90d9c2d09b51c6
Size (darkice-0.13.1.tar.gz) = 323578 bytes
SHA1 (patch-aa) = 5a3f792b9f89addf04cce52c7703d7cfff512327
SHA1 (patch-ab) = 6cf9285316e7f7bf0cce835c89881c2ed0bd8439
SHA1 (patch-ac) = ec927674c9d9e00a8178545ee8def243e5258b14
SHA1 (patch-ad) = 6a81af90d01e37c6c08bbf0bb867907a5d2a9c42
SHA1 (patch-ae) = 740e82a667b38308bbabdd09858465c9c2389199
SHA1 (patch-ae) = 25b82e37c87e74d2aa1fb376bef89b6dc757e777

View file

@ -1,25 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/05/09 09:54:29 xtraeme Exp $
--- src/OssDspSource.cpp.orig 2003-05-08 04:48:52.000000000 +0200
+++ src/OssDspSource.cpp 2003-05-08 04:50:01.000000000 +0200
@@ -82,10 +82,18 @@
#ifdef HAVE_SYS_SOUNDCARD_H
#include <sys/soundcard.h>
-#else
-#error need sys/soundcard.h
+#endif
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#include <soundcard.h>
#endif
+#if defined(__FreeBSD__)
+#if defined(__sparc__) || defined(__powerpc__)
+#define AFMT_S16_NE AFMT_S16_BE
+#else
+#define AFMT_S16_NE AFMT_S16_LE
+#endif
+#endif
#include "Util.h"
#include "Exception.h"

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/05/09 09:54:29 xtraeme Exp $
--- src/AudioSource.h.orig 2003-05-08 04:40:46.000000000 +0200
+++ src/AudioSource.h 2003-05-08 04:41:56.000000000 +0200
@@ -218,7 +218,7 @@
/*------------------------------------------------------------------------------
* Determine the kind of audio device based on the system
*----------------------------------------------------------------------------*/
-#if defined( HAVE_SYS_SOUNDCARD_H )
+#if defined( HAVE_SYS_SOUNDCARD_H ) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
// we have an OSS DSP sound source device available
#define SUPPORT_OSS_DSP

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ae,v 1.1.1.1 2003/05/09 09:54:30 xtraeme Exp $
$NetBSD: patch-ae,v 1.2 2003/05/14 08:06:07 xtraeme Exp $
--- src/Makefile.in.orig 2003-05-09 10:56:50.000000000 +0200
+++ src/Makefile.in 2003-05-09 10:58:22.000000000 +0200
@ -7,7 +7,7 @@ $NetBSD: patch-ae,v 1.1.1.1 2003/05/09 09:54:30 xtraeme Exp $
CXXFLAGS = -O2 -pedantic -Wall @PTHREAD_CFLAGS@
INCLUDES = @LAME_INCFLAGS@ @VORBIS_INCFLAGS@
-LDADD = @PTHREAD_LIBS@ @LAME_LDFLAGS@ @VORBIS_LDFLAGS@
+LDADD = @PTHREAD_LIBS@ @LAME_LDFLAGS@ @VORBIS_LDFLAGS@ -lossaudio
+LDADD = @PTHREAD_LIBS@ @LAME_LDFLAGS@ @VORBIS_LDFLAGS@ ${LIBOSSAUDIO}
darkice_SOURCES = AudioEncoder.h\
AudioSource.h\