- honour PKG_SYSCONFDIR
- add GOLEM_WITH_SOUND option, default NO - add conditional Xinerama support - enable I18N - s/USE_X11BASE/USE_X11/ - sort PLIST - make DESCR a bit more readable
This commit is contained in:
parent
5d9e33246f
commit
6adeca0511
7 changed files with 218 additions and 91 deletions
20
golem/DESCR
20
golem/DESCR
|
@ -1,14 +1,16 @@
|
||||||
Golem is an X11 Window Manager. Design goals are that it be fast and
|
Golem is an X11 Window Manager. Design goals are that it be fast
|
||||||
lightweight, as well as very customizable in any way that will not prevent
|
and lightweight, as well as very customizable in any way that will
|
||||||
the first goal from being realized.
|
not prevent the first goal from being realized.
|
||||||
|
|
||||||
Some features:
|
Notable features:
|
||||||
- Small memory footprint
|
- Small memory footprint
|
||||||
- Window decoration customization (theming) with multiple decoration
|
|
||||||
styles (dgroups)
|
|
||||||
- Multiple disjoint large virtual desktops
|
- Multiple disjoint large virtual desktops
|
||||||
- Hotkeys
|
|
||||||
- Supports various focusing styles (sloppy, pointer, click)
|
|
||||||
- Useful stuff for multiscreen displays (special focus cycling modes, etc)
|
|
||||||
- Xinerama support for multimonitor screens
|
- Xinerama support for multimonitor screens
|
||||||
|
- Supports various focusing styles (sloppy,
|
||||||
|
pointer, click)
|
||||||
|
- Useful stuff for multiscreen displays
|
||||||
|
(special focus cycling modes, etc)
|
||||||
|
- Window decoration customization (theming)
|
||||||
|
with multiple decoration styles (dgroups)
|
||||||
|
- Hotkeys
|
||||||
- Plugins
|
- Plugins
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
# $NetBSD: Makefile,v 1.3 2003/04/07 08:20:59 freyr Exp $
|
# $NetBSD: Makefile,v 1.4 2003/05/15 11:14:49 lsed Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
DISTNAME= golem-0.0.5
|
DISTNAME= golem-0.0.5
|
||||||
|
@ -9,9 +9,41 @@ MAINTAINER= reide@darkest.org
|
||||||
HOMEPAGE= http://golem.sourceforge.net/
|
HOMEPAGE= http://golem.sourceforge.net/
|
||||||
COMMENT= Fast and lightweight yet customizable window manager
|
COMMENT= Fast and lightweight yet customizable window manager
|
||||||
|
|
||||||
GNU_CONFIGURE= YES
|
|
||||||
USE_BUILDLINK2= YES
|
USE_BUILDLINK2= YES
|
||||||
|
USE_PKGINSTALL= YES
|
||||||
USE_GMAKE= YES
|
USE_GMAKE= YES
|
||||||
USE_X11BASE= YES
|
USE_X11= YES
|
||||||
|
GNU_CONFIGURE= YES
|
||||||
|
|
||||||
|
CONFIGURE_ARGS= --enable-i18n
|
||||||
|
|
||||||
|
.if exists(${X11BASE}/include/X11/extensions/Xinerama.h)
|
||||||
|
CONFIGURE_ARGS+= --enable-xinerama
|
||||||
|
.endif
|
||||||
|
|
||||||
|
GOLEM_WITH_SOUND?= NO
|
||||||
|
|
||||||
|
.if !empty(GOLEM_WITH_SOUND:M[Yy][Ee][Ss])
|
||||||
|
BUILD_DEFS= GOLEM_WITH_SOUND
|
||||||
|
CONFIGURE_ARGS+= --enable-sound
|
||||||
|
PLIST_SUBST= NOT_SOUND=
|
||||||
|
.include "../../audio/esound/buildlink2.mk"
|
||||||
|
.else
|
||||||
|
PLIST_SUBST= NOT_SOUND="@comment "
|
||||||
|
.endif
|
||||||
|
|
||||||
|
CFLAGS= -DPKG_SYSCONFDIR=\"\\\"${PKG_SYSCONFDIR}\\\"\"
|
||||||
|
|
||||||
|
EGDIR= ${PREFIX}/share/examples/golem
|
||||||
|
CONF_FILES= ${EGDIR}/golemrc.default ${PKG_SYSCONFDIR}/golemrc
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
@${SED} ${FILES_SUBST_SED} ${WRKSRC}/sample.golem/golemrc > \
|
||||||
|
${WRKSRC}/golemrc
|
||||||
|
${RM} -f ${WRKSRC}/sample.golem/golemrc*
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
${INSTALL_DATA_DIR} ${EGDIR}
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/golemrc ${EGDIR}/golemrc.default
|
||||||
|
|
||||||
.include "../../mk/bsd.pkg.mk"
|
.include "../../mk/bsd.pkg.mk"
|
||||||
|
|
160
golem/PLIST
160
golem/PLIST
|
@ -1,4 +1,4 @@
|
||||||
@comment $NetBSD: PLIST,v 1.2 2003/04/06 11:40:47 thomasklausner Exp $
|
@comment $NetBSD: PLIST,v 1.3 2003/05/15 11:14:49 lsed Exp $
|
||||||
bin/golem
|
bin/golem
|
||||||
bin/golem.install
|
bin/golem.install
|
||||||
lib/golem/plugins/animations.so
|
lib/golem/plugins/animations.so
|
||||||
|
@ -9,12 +9,26 @@ lib/golem/plugins/pager.so
|
||||||
lib/golem/plugins/pier.so
|
lib/golem/plugins/pier.so
|
||||||
lib/golem/plugins/setroot.so
|
lib/golem/plugins/setroot.so
|
||||||
lib/golem/plugins/simple_menus.so
|
lib/golem/plugins/simple_menus.so
|
||||||
|
${NOT_SOUND}lib/golem/plugins/sound.so
|
||||||
lib/golem/plugins/start_slide.so
|
lib/golem/plugins/start_slide.so
|
||||||
lib/golem/plugins/wmclass_defs.so
|
lib/golem/plugins/wmclass_defs.so
|
||||||
share/golem/themes/AbsoluteE/forplug/setroot/bg_2.jpg
|
man/man1/golem.1
|
||||||
share/golem/themes/AbsoluteE/forplug/setroot/bg.jpg
|
share/examples/golem/golemrc.default
|
||||||
share/golem/themes/AbsoluteE/forplug/setroot/bg_v.jpg
|
share/golem/plugins/animations/rc
|
||||||
share/golem/themes/AbsoluteE/forplug/setroot/rc
|
share/golem/plugins/box_iconify/rc
|
||||||
|
share/golem/plugins/box_iconify/tile.xpm
|
||||||
|
share/golem/plugins/gnome/rc
|
||||||
|
share/golem/plugins/mwm_hints/rc
|
||||||
|
share/golem/plugins/pager/rc
|
||||||
|
share/golem/plugins/pier/daemon.xpm
|
||||||
|
share/golem/plugins/pier/netscape.xpm
|
||||||
|
share/golem/plugins/pier/rc
|
||||||
|
share/golem/plugins/setroot/rc
|
||||||
|
share/golem/plugins/simple_menus/rc
|
||||||
|
${NOT_SOUND}share/golem/plugins/sound/rc
|
||||||
|
share/golem/plugins/start_slide/README
|
||||||
|
share/golem/plugins/start_slide/rc
|
||||||
|
share/golem/plugins/wmclass_defs/rc
|
||||||
share/golem/themes/AbsoluteE/bar_focused_far.xpm
|
share/golem/themes/AbsoluteE/bar_focused_far.xpm
|
||||||
share/golem/themes/AbsoluteE/bar_focused_mid.xpm
|
share/golem/themes/AbsoluteE/bar_focused_mid.xpm
|
||||||
share/golem/themes/AbsoluteE/bar_focused_near.xpm
|
share/golem/themes/AbsoluteE/bar_focused_near.xpm
|
||||||
|
@ -33,7 +47,12 @@ share/golem/themes/AbsoluteE/border_vert_mid.xpm
|
||||||
share/golem/themes/AbsoluteE/border_vert_mid_foc.xpm
|
share/golem/themes/AbsoluteE/border_vert_mid_foc.xpm
|
||||||
share/golem/themes/AbsoluteE/border_vert_near.xpm
|
share/golem/themes/AbsoluteE/border_vert_near.xpm
|
||||||
share/golem/themes/AbsoluteE/border_vert_near_foc.xpm
|
share/golem/themes/AbsoluteE/border_vert_near_foc.xpm
|
||||||
|
share/golem/themes/AbsoluteE/forplug/setroot/bg.jpg
|
||||||
|
share/golem/themes/AbsoluteE/forplug/setroot/bg_2.jpg
|
||||||
|
share/golem/themes/AbsoluteE/forplug/setroot/bg_v.jpg
|
||||||
|
share/golem/themes/AbsoluteE/forplug/setroot/rc
|
||||||
share/golem/themes/AbsoluteE/rc
|
share/golem/themes/AbsoluteE/rc
|
||||||
|
share/golem/themes/MudGolem/README
|
||||||
share/golem/themes/MudGolem/forplug/pager/focpagedwin.xpm
|
share/golem/themes/MudGolem/forplug/pager/focpagedwin.xpm
|
||||||
share/golem/themes/MudGolem/forplug/pager/nonsel.xpm
|
share/golem/themes/MudGolem/forplug/pager/nonsel.xpm
|
||||||
share/golem/themes/MudGolem/forplug/pager/pagedwin.xpm
|
share/golem/themes/MudGolem/forplug/pager/pagedwin.xpm
|
||||||
|
@ -45,8 +64,8 @@ share/golem/themes/MudGolem/forplug/setroot/Enigmas-Oven-2.jpg
|
||||||
share/golem/themes/MudGolem/forplug/setroot/rc
|
share/golem/themes/MudGolem/forplug/setroot/rc
|
||||||
share/golem/themes/MudGolem/forplug/simple_menus/rc
|
share/golem/themes/MudGolem/forplug/simple_menus/rc
|
||||||
share/golem/themes/MudGolem/forplug/simple_menus/submenu.xpm
|
share/golem/themes/MudGolem/forplug/simple_menus/submenu.xpm
|
||||||
share/golem/themes/MudGolem/forplug/start_slide/logo.xpm
|
|
||||||
share/golem/themes/MudGolem/forplug/start_slide/bg.xpm
|
share/golem/themes/MudGolem/forplug/start_slide/bg.xpm
|
||||||
|
share/golem/themes/MudGolem/forplug/start_slide/logo.xpm
|
||||||
share/golem/themes/MudGolem/forplug/start_slide/rc
|
share/golem/themes/MudGolem/forplug/start_slide/rc
|
||||||
share/golem/themes/MudGolem/forplug/start_slide/trim.xpm
|
share/golem/themes/MudGolem/forplug/start_slide/trim.xpm
|
||||||
share/golem/themes/MudGolem/forplug/wmclass_defs/rc
|
share/golem/themes/MudGolem/forplug/wmclass_defs/rc
|
||||||
|
@ -84,12 +103,11 @@ share/golem/themes/MudGolem/images/unf/title_left_near.xpm
|
||||||
share/golem/themes/MudGolem/images/unf/title_top.xpm
|
share/golem/themes/MudGolem/images/unf/title_top.xpm
|
||||||
share/golem/themes/MudGolem/images/unf/title_top_far.xpm
|
share/golem/themes/MudGolem/images/unf/title_top_far.xpm
|
||||||
share/golem/themes/MudGolem/images/unf/title_top_near.xpm
|
share/golem/themes/MudGolem/images/unf/title_top_near.xpm
|
||||||
|
share/golem/themes/MudGolem/rc
|
||||||
share/golem/themes/MudGolem/styles/common.rc
|
share/golem/themes/MudGolem/styles/common.rc
|
||||||
share/golem/themes/MudGolem/styles/default.rc
|
share/golem/themes/MudGolem/styles/default.rc
|
||||||
share/golem/themes/MudGolem/styles/leftside.rc
|
share/golem/themes/MudGolem/styles/leftside.rc
|
||||||
share/golem/themes/MudGolem/styles/small.rc
|
share/golem/themes/MudGolem/styles/small.rc
|
||||||
share/golem/themes/MudGolem/README
|
|
||||||
share/golem/themes/MudGolem/rc
|
|
||||||
share/golem/themes/eBlueSteel/forplug/pier/rc
|
share/golem/themes/eBlueSteel/forplug/pier/rc
|
||||||
share/golem/themes/eBlueSteel/forplug/pier/tile.xpm
|
share/golem/themes/eBlueSteel/forplug/pier/tile.xpm
|
||||||
share/golem/themes/eBlueSteel/forplug/setroot/All-Good-People-4.jpg
|
share/golem/themes/eBlueSteel/forplug/setroot/All-Good-People-4.jpg
|
||||||
|
@ -146,22 +164,13 @@ share/golem/themes/eBlueSteel/images/unf/trim_left_near.xpm
|
||||||
share/golem/themes/eBlueSteel/images/unf/trim_right_far.xpm
|
share/golem/themes/eBlueSteel/images/unf/trim_right_far.xpm
|
||||||
share/golem/themes/eBlueSteel/images/unf/trim_top_mid.xpm
|
share/golem/themes/eBlueSteel/images/unf/trim_top_mid.xpm
|
||||||
share/golem/themes/eBlueSteel/images/unf/zoom.xpm
|
share/golem/themes/eBlueSteel/images/unf/zoom.xpm
|
||||||
|
share/golem/themes/eBlueSteel/rc
|
||||||
share/golem/themes/eBlueSteel/styles/common.rc
|
share/golem/themes/eBlueSteel/styles/common.rc
|
||||||
share/golem/themes/eBlueSteel/styles/default.rc
|
share/golem/themes/eBlueSteel/styles/default.rc
|
||||||
share/golem/themes/eBlueSteel/styles/small.rc
|
share/golem/themes/eBlueSteel/styles/small.rc
|
||||||
share/golem/themes/eBlueSteel/styles/transient.rc
|
share/golem/themes/eBlueSteel/styles/transient.rc
|
||||||
share/golem/themes/eBlueSteel/styles/verysmall.rc
|
share/golem/themes/eBlueSteel/styles/verysmall.rc
|
||||||
share/golem/themes/eBlueSteel/rc
|
|
||||||
share/golem/themes/eBlueSteel/vixar.ttf
|
share/golem/themes/eBlueSteel/vixar.ttf
|
||||||
share/golem/themes/microGUI/forplug/pager/focpagedwin.xpm
|
|
||||||
share/golem/themes/microGUI/forplug/pager/pagedwin.xpm
|
|
||||||
share/golem/themes/microGUI/forplug/pager/rc
|
|
||||||
share/golem/themes/microGUI/forplug/pier/rc
|
|
||||||
share/golem/themes/microGUI/forplug/pier/tile.xpm
|
|
||||||
share/golem/themes/microGUI/forplug/start_slide/greybg.xpm
|
|
||||||
share/golem/themes/microGUI/forplug/start_slide/logo.xpm
|
|
||||||
share/golem/themes/microGUI/forplug/start_slide/rc
|
|
||||||
share/golem/themes/microGUI/forplug/start_slide/trim.xpm
|
|
||||||
share/golem/themes/microGUI/bar_left_top.xpm
|
share/golem/themes/microGUI/bar_left_top.xpm
|
||||||
share/golem/themes/microGUI/bar_left_top_unfoc.xpm
|
share/golem/themes/microGUI/bar_left_top_unfoc.xpm
|
||||||
share/golem/themes/microGUI/bar_vert.xpm
|
share/golem/themes/microGUI/bar_vert.xpm
|
||||||
|
@ -171,6 +180,15 @@ share/golem/themes/microGUI/bottom_near.xpm
|
||||||
share/golem/themes/microGUI/close.xpm
|
share/golem/themes/microGUI/close.xpm
|
||||||
share/golem/themes/microGUI/close_clicked.xpm
|
share/golem/themes/microGUI/close_clicked.xpm
|
||||||
share/golem/themes/microGUI/close_unfoc.xpm
|
share/golem/themes/microGUI/close_unfoc.xpm
|
||||||
|
share/golem/themes/microGUI/forplug/pager/focpagedwin.xpm
|
||||||
|
share/golem/themes/microGUI/forplug/pager/pagedwin.xpm
|
||||||
|
share/golem/themes/microGUI/forplug/pager/rc
|
||||||
|
share/golem/themes/microGUI/forplug/pier/rc
|
||||||
|
share/golem/themes/microGUI/forplug/pier/tile.xpm
|
||||||
|
share/golem/themes/microGUI/forplug/start_slide/greybg.xpm
|
||||||
|
share/golem/themes/microGUI/forplug/start_slide/logo.xpm
|
||||||
|
share/golem/themes/microGUI/forplug/start_slide/rc
|
||||||
|
share/golem/themes/microGUI/forplug/start_slide/trim.xpm
|
||||||
share/golem/themes/microGUI/maximize.xpm
|
share/golem/themes/microGUI/maximize.xpm
|
||||||
share/golem/themes/microGUI/maximize_clicked.xpm
|
share/golem/themes/microGUI/maximize_clicked.xpm
|
||||||
share/golem/themes/microGUI/maximize_unfoc.xpm
|
share/golem/themes/microGUI/maximize_unfoc.xpm
|
||||||
|
@ -189,10 +207,10 @@ share/golem/themes/microGUI/top_white.xpm
|
||||||
share/golem/themes/microGUI/transient_top.xpm
|
share/golem/themes/microGUI/transient_top.xpm
|
||||||
share/golem/themes/microGUI/transient_top_far.xpm
|
share/golem/themes/microGUI/transient_top_far.xpm
|
||||||
share/golem/themes/microGUI/transient_top_near.xpm
|
share/golem/themes/microGUI/transient_top_near.xpm
|
||||||
share/golem/themes/twm/forplug/simple_menus/rc
|
|
||||||
share/golem/themes/twm/barchecker.xpm
|
share/golem/themes/twm/barchecker.xpm
|
||||||
share/golem/themes/twm/bborder.xpm
|
share/golem/themes/twm/bborder.xpm
|
||||||
share/golem/themes/twm/bborder_unf.xpm
|
share/golem/themes/twm/bborder_unf.xpm
|
||||||
|
share/golem/themes/twm/forplug/simple_menus/rc
|
||||||
share/golem/themes/twm/iconify.xpm
|
share/golem/themes/twm/iconify.xpm
|
||||||
share/golem/themes/twm/lborder.xpm
|
share/golem/themes/twm/lborder.xpm
|
||||||
share/golem/themes/twm/lborder_unf.xpm
|
share/golem/themes/twm/lborder_unf.xpm
|
||||||
|
@ -201,69 +219,55 @@ share/golem/themes/twm/rborder_unf.xpm
|
||||||
share/golem/themes/twm/rc
|
share/golem/themes/twm/rc
|
||||||
share/golem/themes/twm/resize.xpm
|
share/golem/themes/twm/resize.xpm
|
||||||
share/golem/themes/twm/topbar.xpm
|
share/golem/themes/twm/topbar.xpm
|
||||||
share/golem/plugins/box_iconify/tile.xpm
|
|
||||||
share/golem/plugins/box_iconify/rc
|
|
||||||
share/golem/plugins/simple_menus/rc
|
|
||||||
share/golem/plugins/start_slide/README
|
|
||||||
share/golem/plugins/start_slide/rc
|
|
||||||
share/golem/plugins/gnome/rc
|
|
||||||
share/golem/plugins/pier/daemon.xpm
|
|
||||||
share/golem/plugins/pier/netscape.xpm
|
|
||||||
share/golem/plugins/pier/rc
|
|
||||||
share/golem/plugins/mwm_hints/rc
|
|
||||||
share/golem/plugins/pager/rc
|
|
||||||
share/golem/plugins/setroot/rc
|
|
||||||
share/golem/plugins/animations/rc
|
|
||||||
share/golem/plugins/wmclass_defs/rc
|
|
||||||
share/golem/golemrc
|
|
||||||
man/man1/golem.1
|
|
||||||
@dirrm lib/golem/plugins
|
|
||||||
@dirrm lib/golem
|
|
||||||
@dirrm share/golem/themes/AbsoluteE/forplug/setroot
|
|
||||||
@dirrm share/golem/themes/AbsoluteE/forplug
|
|
||||||
@dirrm share/golem/themes/AbsoluteE
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug/pager
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug/pier
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug/setroot
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug/simple_menus
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug/start_slide
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug/wmclass_defs
|
|
||||||
@dirrm share/golem/themes/MudGolem/forplug
|
|
||||||
@dirrm share/golem/themes/MudGolem/images/foc
|
|
||||||
@dirrm share/golem/themes/MudGolem/images/pressed
|
|
||||||
@dirrm share/golem/themes/MudGolem/images/unf
|
|
||||||
@dirrm share/golem/themes/MudGolem/images
|
|
||||||
@dirrm share/golem/themes/MudGolem/styles
|
|
||||||
@dirrm share/golem/themes/MudGolem
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/forplug/pier
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/forplug/setroot
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/forplug/simple_menus
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/forplug/start_slide
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/forplug
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/images/foc
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/images/pressed
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/images/unf
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/images
|
|
||||||
@dirrm share/golem/themes/eBlueSteel/styles
|
|
||||||
@dirrm share/golem/themes/eBlueSteel
|
|
||||||
@dirrm share/golem/themes/microGUI/forplug/pager
|
|
||||||
@dirrm share/golem/themes/microGUI/forplug/pier
|
|
||||||
@dirrm share/golem/themes/microGUI/forplug/start_slide
|
|
||||||
@dirrm share/golem/themes/microGUI/forplug
|
|
||||||
@dirrm share/golem/themes/microGUI
|
|
||||||
@dirrm share/golem/themes/twm/forplug/simple_menus
|
@dirrm share/golem/themes/twm/forplug/simple_menus
|
||||||
@dirrm share/golem/themes/twm/forplug
|
@dirrm share/golem/themes/twm/forplug
|
||||||
@dirrm share/golem/themes/twm
|
@dirrm share/golem/themes/twm
|
||||||
|
@dirrm share/golem/themes/microGUI/forplug/start_slide
|
||||||
|
@dirrm share/golem/themes/microGUI/forplug/pier
|
||||||
|
@dirrm share/golem/themes/microGUI/forplug/pager
|
||||||
|
@dirrm share/golem/themes/microGUI/forplug
|
||||||
|
@dirrm share/golem/themes/microGUI
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/styles
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/images/unf
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/images/pressed
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/images/foc
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/images
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/forplug/start_slide
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/forplug/simple_menus
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/forplug/setroot
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/forplug/pier
|
||||||
|
@dirrm share/golem/themes/eBlueSteel/forplug
|
||||||
|
@dirrm share/golem/themes/eBlueSteel
|
||||||
|
@dirrm share/golem/themes/MudGolem/styles
|
||||||
|
@dirrm share/golem/themes/MudGolem/images/unf
|
||||||
|
@dirrm share/golem/themes/MudGolem/images/pressed
|
||||||
|
@dirrm share/golem/themes/MudGolem/images/foc
|
||||||
|
@dirrm share/golem/themes/MudGolem/images
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug/wmclass_defs
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug/start_slide
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug/simple_menus
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug/setroot
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug/pier
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug/pager
|
||||||
|
@dirrm share/golem/themes/MudGolem/forplug
|
||||||
|
@dirrm share/golem/themes/MudGolem
|
||||||
|
@dirrm share/golem/themes/AbsoluteE/forplug/setroot
|
||||||
|
@dirrm share/golem/themes/AbsoluteE/forplug
|
||||||
|
@dirrm share/golem/themes/AbsoluteE
|
||||||
@dirrm share/golem/themes
|
@dirrm share/golem/themes
|
||||||
@dirrm share/golem/plugins/box_iconify
|
|
||||||
@dirrm share/golem/plugins/simple_menus
|
|
||||||
@dirrm share/golem/plugins/start_slide
|
|
||||||
@dirrm share/golem/plugins/gnome
|
|
||||||
@dirrm share/golem/plugins/pier
|
|
||||||
@dirrm share/golem/plugins/mwm_hints
|
|
||||||
@dirrm share/golem/plugins/pager
|
|
||||||
@dirrm share/golem/plugins/setroot
|
|
||||||
@dirrm share/golem/plugins/animations
|
|
||||||
@dirrm share/golem/plugins/wmclass_defs
|
@dirrm share/golem/plugins/wmclass_defs
|
||||||
|
@dirrm share/golem/plugins/start_slide
|
||||||
|
${NOT_SOUND}@dirrm share/golem/plugins/sound
|
||||||
|
@dirrm share/golem/plugins/simple_menus
|
||||||
|
@dirrm share/golem/plugins/setroot
|
||||||
|
@dirrm share/golem/plugins/pier
|
||||||
|
@dirrm share/golem/plugins/pager
|
||||||
|
@dirrm share/golem/plugins/mwm_hints
|
||||||
|
@dirrm share/golem/plugins/gnome
|
||||||
|
@dirrm share/golem/plugins/box_iconify
|
||||||
|
@dirrm share/golem/plugins/animations
|
||||||
@dirrm share/golem/plugins
|
@dirrm share/golem/plugins
|
||||||
@dirrm share/golem
|
@dirrm share/golem
|
||||||
|
@dirrm share/examples/golem
|
||||||
|
@dirrm lib/golem/plugins
|
||||||
|
@dirrm lib/golem
|
||||||
|
|
|
@ -1,5 +1,8 @@
|
||||||
$NetBSD: distinfo,v 1.2 2003/04/09 17:56:11 thomasklausner Exp $
|
$NetBSD: distinfo,v 1.3 2003/05/15 11:14:49 lsed Exp $
|
||||||
|
|
||||||
SHA1 (golem-0.0.5.tar.gz) = 5939acf109502a2f962e20fa933b31970fb2ed74
|
SHA1 (golem-0.0.5.tar.gz) = 5939acf109502a2f962e20fa933b31970fb2ed74
|
||||||
Size (golem-0.0.5.tar.gz) = 748348 bytes
|
Size (golem-0.0.5.tar.gz) = 748348 bytes
|
||||||
SHA1 (patch-aa) = 2c2bb75dce922316a3360cc4e0fdcfdc97209527
|
SHA1 (patch-aa) = 2c2bb75dce922316a3360cc4e0fdcfdc97209527
|
||||||
|
SHA1 (patch-ab) = b9dc76afd9aecc96699944951d592c99b9d60c2f
|
||||||
|
SHA1 (patch-ac) = c3e61f79f0783aaaa06723f53029a7b67b1a2a9c
|
||||||
|
SHA1 (patch-ad) = ca2f91ea4587148543811729c8afc8e474b1c1ba
|
||||||
|
|
13
golem/patches/patch-ab
Normal file
13
golem/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
$NetBSD: patch-ab,v 1.1 2003/05/15 11:14:49 lsed Exp $
|
||||||
|
|
||||||
|
--- src/rcfile.y.orig 2002-05-22 01:06:25.000000000 +0200
|
||||||
|
+++ src/rcfile.y 2003-05-15 11:46:30.000000000 +0200
|
||||||
|
@@ -536,7 +536,7 @@
|
||||||
|
*/
|
||||||
|
fp = fopen(rcfn, "r");
|
||||||
|
if (!fp) {
|
||||||
|
- snprintf(filedir, MAXPATHLEN, "%s/golem/", DATADIR);
|
||||||
|
+ snprintf(filedir, MAXPATHLEN, "%s/", PKG_SYSCONFDIR);
|
||||||
|
snprintf(rcfn, sizeof(rcfn), "%s%s", filedir, filename);
|
||||||
|
fp = fopen(rcfn, "r");
|
||||||
|
if (!fp)
|
49
golem/patches/patch-ac
Normal file
49
golem/patches/patch-ac
Normal file
|
@ -0,0 +1,49 @@
|
||||||
|
$NetBSD: patch-ac,v 1.1 2003/05/15 11:14:49 lsed Exp $
|
||||||
|
|
||||||
|
--- sample.golem/golemrc.orig 2001-12-08 07:08:39.000000000 +0100
|
||||||
|
+++ sample.golem/golemrc 2003-05-15 12:23:37.000000000 +0200
|
||||||
|
@@ -5,11 +5,11 @@
|
||||||
|
#
|
||||||
|
# Include theme rcfile
|
||||||
|
#
|
||||||
|
-.include "themes/MudGolem/rc"
|
||||||
|
-#.include "themes/eBlueSteel/rc"
|
||||||
|
-#.include "themes/twm/rc"
|
||||||
|
-#.include "themes/AbsoluteE/rc"
|
||||||
|
-#.include "themes/microGUI/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/themes/MudGolem/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/themes/eBlueSteel/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/themes/twm/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/themes/AbsoluteE/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/themes/microGUI/rc"
|
||||||
|
|
||||||
|
#
|
||||||
|
# Define general options.
|
||||||
|
@@ -160,16 +160,16 @@
|
||||||
|
# wmclass_defs after mwm_hints if you want it to override
|
||||||
|
# what mwmhints has set.
|
||||||
|
#
|
||||||
|
-.include "plugins/pier/rc"
|
||||||
|
-.include "plugins/simple_menus/rc"
|
||||||
|
-.include "plugins/pager/rc"
|
||||||
|
-.include "plugins/box_iconify/rc"
|
||||||
|
-.include "plugins/animations/rc"
|
||||||
|
-.include "plugins/mwm_hints/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/plugins/pier/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/plugins/simple_menus/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/plugins/pager/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/plugins/box_iconify/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/plugins/animations/rc"
|
||||||
|
+.include "@PREFIX@/share/golem/plugins/mwm_hints/rc"
|
||||||
|
|
||||||
|
# other plugins you may be interested in
|
||||||
|
-#.include "plugins/sound/rc"
|
||||||
|
-#.include "plugins/gnome/rc"
|
||||||
|
-#.include "plugins/setroot/rc"
|
||||||
|
-#.include "plugins/wmclass_defs/rc"
|
||||||
|
-#.include "plugins/start_slide/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/plugins/sound/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/plugins/gnome/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/plugins/setroot/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/plugins/wmclass_defs/rc"
|
||||||
|
+#.include "@PREFIX@/share/golem/plugins/start_slide/rc"
|
24
golem/patches/patch-ad
Normal file
24
golem/patches/patch-ad
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
$NetBSD: patch-ad,v 1.1 2003/05/15 11:14:49 lsed Exp $
|
||||||
|
|
||||||
|
--- util/golem.install.in.orig 2001-11-18 22:14:19.000000000 +0100
|
||||||
|
+++ util/golem.install.in 2003-05-15 12:31:56.000000000 +0200
|
||||||
|
@@ -28,8 +28,8 @@
|
||||||
|
#
|
||||||
|
|
||||||
|
# the makefile will replace this with real stuff
|
||||||
|
-BINDIR= #bindir#
|
||||||
|
-DATADIR= #datadir#
|
||||||
|
+BINDIR=#bindir#
|
||||||
|
+DATADIR=#datadir#
|
||||||
|
|
||||||
|
#
|
||||||
|
# functions to make the .xsession and .xinitrc files
|
||||||
|
@@ -74,7 +74,7 @@
|
||||||
|
|
||||||
|
echo "Copying configuration files to ~/.golem..."
|
||||||
|
mkdir -p ~/.golem
|
||||||
|
-cp ${DATADIR}/golem/golemrc ~/.golem/
|
||||||
|
+cp ${DATADIR}/examples/golem/golemrc.default ~/.golem/golemrc
|
||||||
|
cp -R ${DATADIR}/golem/plugins ~/.golem/
|
||||||
|
find ~/.golem/ -type f | xargs chmod 644
|
||||||
|
|
Loading…
Reference in a new issue