Imported to pkgsrc tree.

This commit is contained in:
Ryo ONODERA 2011-10-13 10:55:09 +00:00 committed by Thomas Klausner
parent c3ea48d588
commit 6af1adb821
5 changed files with 0 additions and 88 deletions

View file

@ -1,22 +0,0 @@
Sigil is a multi-platform WYSIWYG ebook editor. It is designed to
edit books in ePub format. Features:
* Free and open source software under GPLv3
* Multi-platform: runs on Windows, Linux and Mac
* Full Unicode support: everything you see in Sigil is in UTF-16
* Advanced automatic conversion of all imported documents to Unicode
* Full EPUB spec support
* WYSIWYG editing
* Multiple Views: Book View, Code View and Split View
* Metadata editor with full support for all possible metadata
entries (more than 200) with full descriptions for each
* Multi-level Table Of Contents editor
* Book View fully supports the display of any XHTML document
possible under the OPS spec
* SVG support and basic XPGT support
* Currently imports TXT, HTML and EPUB files
* Currently exports EPUB and SGF (Sigil native format)
* Embedded HTML Tidy; all imported documents are thoroughly
cleaned; changing views cleans the document so no matter how
much you screw up your code, it will fix it (usually )
* An actually usable user interface

View file

@ -1,36 +0,0 @@
# $NetBSD: Makefile,v 1.2 2011/08/20 21:33:36 thomasklausner Exp $
#
DISTNAME= Sigil-0.3.4-Code
PKGNAME= ${DISTNAME:S/-Code//}
CATEGORIES= editors
MASTER_SITES= http://sigil.googlecode.com/files/
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://code.google.com/p/sigil/
COMMENT= Multi-platform WYSIWYG ebook editor (for the ePub format)
LICENSE= gnu-gpl-v3
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= c c++
USE_CMAKE= yes
BUILDLINK_TRANSFORM+= l:BoostParts:boost_date_time:boost_filesystem:boost_regex:boost_system:boost_thread:boost_program_options
BUILDLINK_TRANSFORM+= l:Xerces:xerces-c
BUILDLINK_TRANSFORM+= l:zlib:z
.include "../../mk/compiler.mk"
# GCC 4.4 and above needs this
.if !empty(PKGSRC_COMPILER:Mgcc) && !empty(CC_VERSION:Mgcc-4.[4-9]*)
_WRAP_EXTRA_ARGS.CXX+= -std=c++0x
.endif
.include "../../textproc/xerces-c/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../x11/qt4-libs/buildlink3.mk"
.include "../../x11/qt4-tools/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/05/13 04:05:18 ryo-on Exp $
bin/sigil
share/applications/sigil.desktop
share/pixmaps/sigil.png

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2011/05/13 04:05:18 ryo-on Exp $
SHA1 (Sigil-0.3.4-Code.zip) = 50e90f067465336674364d85456dc2c283d0d75f
RMD160 (Sigil-0.3.4-Code.zip) = b0f785f4bfe4124fa050d21732ab7f50e046bef6
Size (Sigil-0.3.4-Code.zip) = 9970901 bytes
SHA1 (patch-CMakeLists.txt) = 38868db3334124ab3bd19d0a332473a5ea47bad4

View file

@ -1,20 +0,0 @@
$NetBSD: patch-CMakeLists.txt,v 1.1.1.1 2011/05/13 04:05:18 ryo-on Exp $
* Use external libraries.
--- CMakeLists.txt.orig 2011-01-12 02:32:16.000000000 +0000
+++ CMakeLists.txt
@@ -56,10 +56,10 @@ set( NO_TEST_EXE 1 )
add_subdirectory( src/tidyLib )
add_subdirectory( src/ZipArchive )
-add_subdirectory( src/BoostParts )
-add_subdirectory( src/Xerces )
+add_subdirectory( src/BoostParts )
+#add_subdirectory( src/Xerces )
add_subdirectory( src/XercesExtensions )
-add_subdirectory( src/zlib )
+#add_subdirectory( src/zlib )
add_subdirectory( src/zipios )
add_subdirectory( src/FlightCrew )
add_subdirectory( src/Sigil )