Fix build on 1.6 branch, I don't have any 1.6.x box, but I think
that it will work. Is anyone brave enough to test this?
This commit is contained in:
parent
c45497b1b4
commit
6b776cde78
4 changed files with 48 additions and 54 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2003/08/28 14:26:23 jeremy-c-reed Exp $
|
||||
$NetBSD: distinfo,v 1.8 2003/09/01 20:59:02 xtraeme Exp $
|
||||
|
||||
SHA1 (X430src-1.tgz) = 3aaf219e8c2d3eb299f150bd4a2554a84a19354b
|
||||
Size (X430src-1.tgz) = 10993622 bytes
|
||||
|
@ -24,7 +24,7 @@ SHA1 (patch-an) = 21228e83a69e779b3672b06391af6cedc2ba7ea4
|
|||
SHA1 (patch-ao) = 17ede6e7c6c232f9fe2804d7ab4addd85b5cd25c
|
||||
SHA1 (patch-ap) = d684198cb6b6822b91612f1f283fe6af316753a2
|
||||
SHA1 (patch-aq) = 912f4da4903b7ddfd7381aa42feb781bea3ba389
|
||||
SHA1 (patch-ar) = dc2cd430ed18f950e32e55a262de845e905199ad
|
||||
SHA1 (patch-ar) = 129171c7ce2bfb08a6fef06e8ed77e7031a29eb0
|
||||
SHA1 (patch-as) = 5bfc792b879c859745b5dd1e71ac3e57ea9a7a37
|
||||
SHA1 (patch-at) = 89a4bcd4351d7b2967da744619e3912b2efa7138
|
||||
SHA1 (patch-au) = c5ac603011861914fbe7be160973d0e67a5f208a
|
||||
|
|
|
@ -1,20 +1,13 @@
|
|||
$NetBSD: patch-ar,v 1.1.1.1 2003/07/23 20:33:53 xtraeme Exp $
|
||||
$NetBSD: patch-ar,v 1.2 2003/09/01 20:59:02 xtraeme Exp $
|
||||
|
||||
--- config/cf/NetBSD.cf.in.orig 2003-07-21 09:42:40.000000000 +0000
|
||||
+++ config/cf/NetBSD.cf.in 2003-07-21 09:47:58.000000000 +0000
|
||||
@@ -89,22 +89,28 @@
|
||||
|
||||
#define HasVarRun YES
|
||||
#define HasVarDb YES
|
||||
+#define HasShadowPasswd NO
|
||||
--- config/cf/NetBSD.cf.in.orig 2003-09-01 22:15:38.000000000 +0200
|
||||
+++ config/cf/NetBSD.cf.in 2003-09-01 22:17:27.000000000 +0200
|
||||
@@ -92,21 +92,6 @@
|
||||
|
||||
#define InstallXloadSetGID NO
|
||||
|
||||
-/* Defines for using the GNU pth thread library -- experimental */
|
||||
+#ifndef NetBSDThreads
|
||||
+# define NetBSDThreads YES
|
||||
+#endif
|
||||
|
||||
-
|
||||
-#ifdef NetBSDPth
|
||||
-#define PthreadHLocation -I/usr/local/include /* where is pthread.h? */
|
||||
-#define LibPthreadLocation -L/usr/local/lib /* where is libpthread? */
|
||||
|
@ -23,36 +16,24 @@ $NetBSD: patch-ar,v 1.1.1.1 2003/07/23 20:33:53 xtraeme Exp $
|
|||
-#define SystemMTDefines -D_REENTRANT PthreadHLocation
|
||||
-#define ThreadsLibraries LibPthreadLocation -Wl,-rpath,/usr/local/lib -lpthread
|
||||
-#define SharedX11Reqs ThreadsLibraries
|
||||
+#if NetBSDThreads && \
|
||||
+ ((OSMajorVersion > 1) || \
|
||||
+ (OSMajorVersion == 1 && OSMinorVersion > 6) || \
|
||||
+ (OSMajorVersion == 1 && OSMinorVersion == 6 && OSTeenyVersion >= 13))
|
||||
+
|
||||
+# define HasPosixThreads YES
|
||||
+# define ThreadedX YES
|
||||
+# define HasThreadSafeAPI YES
|
||||
+# define ThreadsLibraries -lpthread
|
||||
+# define LibraryMTDefines -DUSE_NBSD_THREADLIB
|
||||
+# define SystemMTDefines -D_REENTRANT
|
||||
+# define MTSafeAPIDefines -DXUSE_MTSAFE_API -DXNO_MTSAFE_PWDAPI
|
||||
#else
|
||||
-#else
|
||||
-#define HasPosixThreads NO
|
||||
-#define ThreadedX NO
|
||||
+# define ThreadedX NO
|
||||
#endif
|
||||
|
||||
-#endif
|
||||
-
|
||||
/*
|
||||
@@ -122,8 +128,7 @@
|
||||
|
||||
* Compiler Features
|
||||
*/
|
||||
@@ -123,7 +108,7 @@
|
||||
#define MkdirHierCmd mkdir -p
|
||||
|
||||
-#undef CcCmd
|
||||
#undef CcCmd
|
||||
-#define CcCmd gcc
|
||||
+#define CcCmd @@PKGSRC_CC@@
|
||||
#ifndef DefaultCCOptions
|
||||
#if defined(UseInstalled)
|
||||
#define DefaultCCOptions /**/
|
||||
@@ -143,7 +148,7 @@
|
||||
@@ -143,7 +128,7 @@
|
||||
#define UseGccMakeDepend YES
|
||||
#endif
|
||||
|
||||
|
@ -61,25 +42,20 @@ $NetBSD: patch-ar,v 1.1.1.1 2003/07/23 20:33:53 xtraeme Exp $
|
|||
#define StandardCppOptions -traditional
|
||||
#define StandardCppDefines /**/
|
||||
#define PreProcessCmd CcCmd -E
|
||||
@@ -191,10 +196,10 @@
|
||||
# ifndef DefaultGcc2i386Opt
|
||||
# if OSMajorVersion > 1 || (OSMajorVersion == 1 && OSMinorVersion > 2)
|
||||
/* The GCC strength-reduce bug is fixed for NetBSD 1.3 and later */
|
||||
-# define DefaultGcc2i386Opt -O2
|
||||
+# define DefaultGcc2i386OpT
|
||||
@@ -194,7 +179,7 @@
|
||||
# define DefaultGcc2i386Opt -O2
|
||||
# endif
|
||||
# endif
|
||||
-# define OptimizedCDebugFlags DefaultGcc2i386Opt
|
||||
+# define OptimizedCDebugFlags @@PKGSRC_CFLAGS@@
|
||||
+# define OptimizedCDebugFlags @@PKGSRC_CFLAGS@@
|
||||
# if OSMajorVersion < 1
|
||||
# define ServerOSDefines XFree86ServerOSDefines -DXNO_SYSCONF
|
||||
# else
|
||||
@@ -204,7 +209,7 @@
|
||||
# define ServerExtraSysLibs -li386
|
||||
# endif
|
||||
#else
|
||||
-# define OptimizedCDebugFlags -O2
|
||||
+# define OptimizedCDebugFlags @@PKGSRC_CFLAGS@@
|
||||
# if defined(SparcArchitecture)
|
||||
# define ServerOSDefines -DDDXOSINIT
|
||||
# elif defined(AlphaArchitecture)
|
||||
@@ -648,3 +633,7 @@
|
||||
#ifndef UseSeparateConfDir
|
||||
#define UseSeparateConfDir NO /* We don't want appdefs in "/etc/X11". */
|
||||
#endif
|
||||
+
|
||||
+/* TheadedX */
|
||||
+
|
||||
+
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.16 2003/08/28 22:10:46 blef Exp $
|
||||
# $NetBSD: Makefile.common,v 1.17 2003/09/01 20:59:01 xtraeme Exp $
|
||||
#
|
||||
# XBUILD_DIRS is the group of directories under ${WRKSRC} that will
|
||||
# be built in.
|
||||
|
@ -47,7 +47,7 @@ USE_GNU_TOOLS+= make
|
|||
|
||||
# Operating Systems to pass our compiler options (CC, CXX, CPP, CFLAGS)
|
||||
|
||||
SYSTEMS= NetBSD FreeBSD linux
|
||||
SYSTEMS= FreeBSD linux NetBSD
|
||||
|
||||
.if !defined(NO_XFREE86_TARGETS)
|
||||
|
||||
|
@ -95,6 +95,7 @@ pre-configure:
|
|||
-e "s|@@PKGSRC_CXX@@|${CXX}|g" \
|
||||
-e "s|@@PKGSRC_CPP@@|${CPP}|g" \
|
||||
-e "s|@@PKGSRC_CFLAGS@@|${CFLAGS}|g" \
|
||||
-e "s|@LOCALBASE@|${LOCALBASE}|g" \
|
||||
-e "s|-I${LOCALBASE}/include||" \
|
||||
-e "s|-I${X11BASE}/include||" \
|
||||
${WRKSRC}/config/cf/${F}.cf.in > \
|
||||
|
@ -102,6 +103,24 @@ pre-configure:
|
|||
.endfor
|
||||
.undef F
|
||||
|
||||
# Check if we have a native threads implementation
|
||||
|
||||
.if ${OPSYS} == "NetBSD" && !exists(/usr/include/pthread.h)
|
||||
${ECHO} "#define TheadedX NO" >> ${WRKSRC}/config/cf/NetBSD.cf
|
||||
.else
|
||||
@( \
|
||||
cd ${WRKSRC}/config/cf && \
|
||||
${ECHO} "#define HasPosixThreads YES" >> NetBSD.cf; \
|
||||
${ECHO} "#define ThreadedX YES" >> NetBSD.cf; \
|
||||
${ECHO} "#define HasThreadSafeAPI YES" >> NetBSD.cf; \
|
||||
${ECHO} "#define ThreadsLibraries -lpthread" >> NetBSD.cf; \
|
||||
${ECHO} "#define LibraryMTDefines -DUSE_NBSD_THREADLIB" >> NetBSD.cf; \
|
||||
${ECHO} "#define SystemMTDefines -D_REENTRANT" >> NetBSD.cf; \
|
||||
${ECHO} "#define MTSafeAPIDefines -DXUSE_MTSAFE_API -DXNO_MTSAFE_PWDAPI" \
|
||||
>> NetBSD.cf \
|
||||
)
|
||||
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if !target(do-configure)
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$Id: TODO,v 1.1 2003/09/01 18:06:01 xtraeme Exp $
|
||||
$Id: TODO,v 1.2 2003/09/01 20:59:01 xtraeme Exp $
|
||||
|
||||
* Doesn't build on NetBSD 1.6.x (I'm looking at it)
|
||||
* Fix trouble with x11-links
|
||||
* Fix trouble of Jeremy C.Reed on Linux
|
||||
* We need to test/build this on more platforms than x86
|
||||
|
|
Loading…
Reference in a new issue