Initial import of gemrb-0.6.0:
GemRB (Game Engine Made with preRendered Background) is a "port" (actually new implementation) of the original Infinity Engine (the one of Baldur's Gate, Icewind Dale, Planescape: Torment, etc...) to Linux/Unix, MacOS X and Windows with some enhancements. Do you like creating a game like Baldur's Gate? It means that you either need some of the original games data somewhere on your harddisk, or you can try to use data from Dragonlance Total Conversion project. The original games data have to be either installed on windows partition and mounted to your Linux/Unix filesystem, installed on windows and then copied to your filesystem, or extracted manually from the CDs using tool `unshield'.
This commit is contained in:
parent
251bb9099b
commit
6db1d066bc
6 changed files with 1878 additions and 0 deletions
14
gemrb/DESCR
Normal file
14
gemrb/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
GemRB (Game Engine Made with preRendered Background) is a "port"
|
||||
(actually new implementation) of the original Infinity Engine (the one
|
||||
of Baldur's Gate, Icewind Dale, Planescape: Torment, etc...) to
|
||||
Linux/Unix, MacOS X and Windows with some enhancements. Do you like
|
||||
creating a game like Baldur's Gate?
|
||||
|
||||
It means that you either need some of the original games data
|
||||
somewhere on your harddisk, or you can try to use data from
|
||||
Dragonlance Total Conversion project.
|
||||
|
||||
The original games data have to be either installed on windows
|
||||
partition and mounted to your Linux/Unix filesystem, installed on
|
||||
windows and then copied to your filesystem, or extracted manually from
|
||||
the CDs using tool `unshield'.
|
30
gemrb/Makefile
Normal file
30
gemrb/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/12/08 22:38:45 thomasklausner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gemrb-0.6.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gemrb/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://gemrb.sourceforge.net/
|
||||
COMMENT= Open Source clone of the Infinity Engine
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
BUILDLINK_TRANSFORM+= rm:-Werror
|
||||
INSTALL_MAKE_FLAGS+= sysconfdir=${PREFIX}/share/examples/gemrb
|
||||
|
||||
.include "../../audio/freealut/buildlink3.mk"
|
||||
.include "../../audio/openal/buildlink3.mk"
|
||||
.include "../../audio/libvorbis/buildlink3.mk"
|
||||
.include "../../devel/SDL/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
1791
gemrb/PLIST
Normal file
1791
gemrb/PLIST
Normal file
File diff suppressed because it is too large
Load diff
7
gemrb/distinfo
Normal file
7
gemrb/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/12/08 22:38:45 thomasklausner Exp $
|
||||
|
||||
SHA1 (gemrb-0.6.0.tar.gz) = bc59f6111bb40a4a9b9c78ab9b7521d8e2da35f7
|
||||
RMD160 (gemrb-0.6.0.tar.gz) = 5c5d04a62453abae02a270eaa56676419fa5dbb3
|
||||
Size (gemrb-0.6.0.tar.gz) = 2227197 bytes
|
||||
SHA1 (patch-aa) = 1a52f0070e55353bfab61808c849c8b774cac855
|
||||
SHA1 (patch-ab) = 314174073b087e259783704bd7dd274c0fac4b72
|
26
gemrb/patches/patch-aa
Normal file
26
gemrb/patches/patch-aa
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/12/08 22:38:46 thomasklausner Exp $
|
||||
|
||||
Compilation on NetBSD-4.99.7/amd64 fails if these are not
|
||||
commented out. Better solution happily accepted...
|
||||
|
||||
--- gemrb/plugins/ACMImporter/general.h.orig 2005-02-23 22:20:52.000000000 +0000
|
||||
+++ gemrb/plugins/ACMImporter/general.h
|
||||
@@ -25,7 +25,9 @@
|
||||
// Interplay ACM signature
|
||||
#define IP_ACM_SIG 0x01032897
|
||||
|
||||
+#if 0
|
||||
#pragma pack (push, 1)
|
||||
+#endif
|
||||
struct ACM_Header {
|
||||
unsigned int signature;
|
||||
unsigned int samples;
|
||||
@@ -34,6 +36,8 @@ struct ACM_Header {
|
||||
unsigned short levels : 4;
|
||||
unsigned short subblocks : 12;
|
||||
};
|
||||
+#if 0
|
||||
#pragma pack (pop)
|
||||
+#endif
|
||||
|
||||
#endif
|
10
gemrb/patches/patch-ab
Normal file
10
gemrb/patches/patch-ab
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2009/12/08 22:38:46 thomasklausner Exp $
|
||||
|
||||
--- gemrb/CMakeLists.txt.orig 2009-08-18 15:23:48.000000000 +0000
|
||||
+++ gemrb/CMakeLists.txt
|
||||
@@ -15,4 +15,4 @@ ELSE(WIN32)
|
||||
ENDIF(WIN32)
|
||||
|
||||
INSTALL( TARGETS gemrb DESTINATION ${CMAKE_INSTALL_PREFIX})
|
||||
-INSTALL( FILES GemRB.cfg.sample GemRB.cfg.subdir.sample DESTINATION ${CMAKE_INSTALL_PREFIX} )
|
||||
+INSTALL( FILES GemRB.cfg.sample GemRB.cfg.subdir.sample DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/gemrb )
|
Loading…
Reference in a new issue