Intial import scim-1.4.4.

SCIM is Smart Common Input Method.

Currently the SCIM project has a wide range of input methods (some may need
other libraries), covering more than 30 languages, including
(Simplified/Traditional) Chinese, Japanese, Korean and many European languages.
What's more, Composing/Dead key support is one of the built-in features.
In addition, several projects have been established to design IMEngines for
SCIM and others supply their own SCIM plugins.
This commit is contained in:
Rui-Xiang Guo 2006-02-01 11:26:04 +00:00 committed by Thomas Klausner
parent abb41ad884
commit 6e8b684d44
6 changed files with 204 additions and 0 deletions

6
scim/DESCR Normal file
View file

@ -0,0 +1,6 @@
Currently the SCIM project has a wide range of input methods (some may need
other libraries), covering more than 30 languages, including
(Simplified/Traditional) Chinese, Japanese, Korean and many European languages.
What's more, Composing/Dead key support is one of the built-in features.
In addition, several projects have been established to design IMEngines for
SCIM and others supply their own SCIM plugins.

35
scim/Makefile Normal file
View file

@ -0,0 +1,35 @@
# $NetBSD: Makefile,v 1.1.1.1 2006/02/01 11:26:04 rxg Exp $
#
DISTNAME= scim-1.4.4
CATEGORIES= inputmethod
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=scim/}
MAINTAINER= rxg@NetBSD.org
HOMEPAGE= http://www.scim-im.org/
COMMENT= Smart Common Input Method
BUILD_USES_MSGFMT= yes
PKG_SYSCONFSUBDIR= scim
USE_PKGLOCALEDIR= yes
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config
USE_TOOLS+= gmake # make scim-setup.desktop
PKGCONFIG_OVERRIDE= scim-gtkutils.pc.in
PKGCONFIG_OVERRIDE+= scim-x11utils.pc.in
PKGCONFIG_OVERRIDE+= scim.pc.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
GTK2_IMMODULES= yes
.include "../../mk/bsd.prefs.mk"
EGDIR= ${PREFIX}/share/examples/scim
CONF_FILES= ${EGDIR}/config ${PKG_SYSCONFDIR}/config
CONF_FILES+= ${EGDIR}/global ${PKG_SYSCONFDIR}/global
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

122
scim/PLIST Normal file
View file

@ -0,0 +1,122 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/02/01 11:26:04 rxg Exp $
bin/scim
bin/scim-config-agent
bin/scim-setup
include/scim-1.0/gtk/scimkeyselection.h
include/scim-1.0/gtk/scimstringview.h
include/scim-1.0/gtk/scimtrayicon.h
include/scim-1.0/scim.h
include/scim-1.0/scim_attribute.h
include/scim-1.0/scim_backend.h
include/scim-1.0/scim_bind.h
include/scim-1.0/scim_compose_key.h
include/scim-1.0/scim_config_base.h
include/scim-1.0/scim_config_module.h
include/scim-1.0/scim_config_path.h
include/scim-1.0/scim_connection.h
include/scim-1.0/scim_debug.h
include/scim-1.0/scim_event.h
include/scim-1.0/scim_exception.h
include/scim-1.0/scim_filter.h
include/scim-1.0/scim_filter_manager.h
include/scim-1.0/scim_filter_module.h
include/scim-1.0/scim_frontend.h
include/scim-1.0/scim_frontend_module.h
include/scim-1.0/scim_global_config.h
include/scim-1.0/scim_helper.h
include/scim-1.0/scim_helper_manager.h
include/scim-1.0/scim_helper_module.h
include/scim-1.0/scim_hotkey.h
include/scim-1.0/scim_iconv.h
include/scim-1.0/scim_imengine.h
include/scim-1.0/scim_imengine_module.h
include/scim-1.0/scim_lookup_table.h
include/scim-1.0/scim_module.h
include/scim-1.0/scim_object.h
include/scim-1.0/scim_panel_agent.h
include/scim-1.0/scim_panel_client.h
include/scim-1.0/scim_panel_common.h
include/scim-1.0/scim_pointer.h
include/scim-1.0/scim_property.h
include/scim-1.0/scim_signals.h
include/scim-1.0/scim_slot.h
include/scim-1.0/scim_socket.h
include/scim-1.0/scim_trans_commands.h
include/scim-1.0/scim_transaction.h
include/scim-1.0/scim_types.h
include/scim-1.0/scim_utility.h
include/scim-1.0/x11/scim_x11_utils.h
lib/gtk-2.0/immodules/im-scim.la
lib/libscim-1.0.la
lib/libscim-gtkutils-1.0.la
lib/libscim-x11utils-1.0.la
lib/pkgconfig/scim-gtkutils.pc
lib/pkgconfig/scim-x11utils.pc
lib/pkgconfig/scim.pc
lib/scim-1.0/1.4.0/Config/simple.la
lib/scim-1.0/1.4.0/Config/socket.la
lib/scim-1.0/1.4.0/Filter/sctc.la
lib/scim-1.0/1.4.0/FrontEnd/socket.la
lib/scim-1.0/1.4.0/FrontEnd/x11.la
lib/scim-1.0/1.4.0/Helper/setup.la
lib/scim-1.0/1.4.0/IMEngine/rawcode.la
lib/scim-1.0/1.4.0/IMEngine/socket.la
lib/scim-1.0/1.4.0/SetupUI/aaa-frontend-setup.la
lib/scim-1.0/1.4.0/SetupUI/aaa-imengine-setup.la
lib/scim-1.0/1.4.0/SetupUI/panel-gtk-setup.la
lib/scim-1.0/scim-helper-launcher
lib/scim-1.0/scim-helper-manager
lib/scim-1.0/scim-launcher
lib/scim-1.0/scim-panel-gtk
share/applications/scim-setup.desktop
share/control-center-2.0/capplets/scim-setup.desktop
share/examples/scim/config
share/examples/scim/global
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/ko/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/pa/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/scim.mo
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/scim.mo
share/pixmaps/scim-setup.png
share/scim/icons/down.png
share/scim/icons/full-letter.png
share/scim/icons/full-punct.png
share/scim/icons/half-letter.png
share/scim/icons/half-punct.png
share/scim/icons/help.png
share/scim/icons/keyboard.png
share/scim/icons/left.png
share/scim/icons/menu.png
share/scim/icons/pin-down.png
share/scim/icons/pin-up.png
share/scim/icons/rawcode.png
share/scim/icons/right.png
share/scim/icons/sctc-sc-to-tc.png
share/scim/icons/sctc-tc-to-sc.png
share/scim/icons/sctc.png
share/scim/icons/setup.png
share/scim/icons/trademark.png
share/scim/icons/up.png
@dirrm share/scim/icons
@dirrm share/scim
@comment in xdg-dirs: @dirrm share/pixmaps
@dirrm share/examples/scim
@comment in gnome2-dirs: @dirrm share/control-center-2.0/capplets
@comment in gnome2-dirs: @dirrm share/control-center-2.0
@comment in xdg-dirs: @dirrm share/applications
@dirrm lib/scim-1.0/1.4.0/SetupUI
@dirrm lib/scim-1.0/1.4.0/IMEngine
@dirrm lib/scim-1.0/1.4.0/Helper
@dirrm lib/scim-1.0/1.4.0/FrontEnd
@dirrm lib/scim-1.0/1.4.0/Filter
@dirrm lib/scim-1.0/1.4.0/Config
@dirrm lib/scim-1.0/1.4.0
@dirrm lib/scim-1.0
@comment in gtk2: @dirrm lib/gtk-2.0/immodules
@dirrm include/scim-1.0/x11
@dirrm include/scim-1.0/gtk
@dirrm include/scim-1.0

22
scim/buildlink3.mk Normal file
View file

@ -0,0 +1,22 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2006/02/01 11:26:04 rxg Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
SCIM_BUILDLINK3_MK:= ${SCIM_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= scim
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nscim}
BUILDLINK_PACKAGES+= scim
.if !empty(SCIM_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.scim+= scim>=1.4.4
BUILDLINK_RECOMMENDED.scim+= scim>=1.4.4
BUILDLINK_PKGSRCDIR.scim?= ../../wip/scim
.endif # SCIM_BUILDLINK3_MK
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

6
scim/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2006/02/01 11:26:04 rxg Exp $
SHA1 (scim-1.4.4.tar.gz) = f6d7cb0ca70d9c3430e460bef58e78ba04919137
RMD160 (scim-1.4.4.tar.gz) = e2025f246b82583fff6bc0237fa747d5ff2a6816
Size (scim-1.4.4.tar.gz) = 2610165 bytes
SHA1 (patch-aa) = 12a2271e1d405b53208ce25d9c323c1f2dcb3c6f

13
scim/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/02/01 11:26:04 rxg Exp $
--- configs/Makefile.in.orig 2006-01-22 01:09:28.000000000 +0800
+++ configs/Makefile.in
@@ -316,7 +316,7 @@ prefix = @prefix@
program_transform_name = @program_transform_name@
sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
-sysconfdir = @sysconfdir@
+sysconfdir = $(prefix)/share/examples
target_alias = @target_alias@
MAINTAINERCLEANFILES = Makefile.in
CLEANFILES = *.bak