Ur-Quan Masters is a port of the original Star Control 2 for 3DO Consoles.

The project started in August 2002, when Toys For Bob  released the partially
ported sources of Star Control 2 3DO version to the fan community. Our goal
is to port this wonderful game to current personal computers and operating
systems. It is and will remain 100% free of charge, and anyone can contribute
to the project and thus help make it even better.
This commit is contained in:
Ben Collver 2004-12-16 16:03:50 +00:00 committed by Thomas Klausner
parent 7bf9cdd9c9
commit 6edbfe8963
8 changed files with 181 additions and 0 deletions

7
uqm/DESCR Normal file
View file

@ -0,0 +1,7 @@
Ur-Quan Masters is a port of the original Star Control 2 for 3DO Consoles.
The project started in August 2002, when Toys For Bob released the partially
ported sources of Star Control 2 3DO version to the fan community. Our goal
is to port this wonderful game to current personal computers and operating
systems. It is and will remain 100% free of charge, and anyone can contribute
to the project and thus help make it even better.

44
uqm/Makefile Normal file
View file

@ -0,0 +1,44 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/12/16 16:03:50 bencollver Exp $
#
DISTNAME= uqm-0.3-source
PKGNAME= uqm-0.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=sc2/}
EXTRACT_SUFX= .tgz
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DISTFILES+= uqm-0.3-content.zip
MAINTAINER= ben@NetBSD.org
HOMEPAGE= http://sc2.sourceforge.net/
COMMENT= Star Control 2
PKG_INSTALLATION_TYPES= overwrite pkgviews
USE_BUILDLINK3= YES
USE_X11= YES
WRKSRC= ${WRKDIR}/${PKGNAME}
DIST_SUBDIR= uqm
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
do-configure:
cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} LIBOSSAUDIO=${LIBOSSAUDIO} \
./build.sh uqm config
do-build:
cd ${WRKSRC} && ./build.sh uqm
do-install:
cd ${WRKSRC} && ./build.sh uqm install
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/uqm-0.3-content.zip \
${PREFIX}/share/uqm/content/packages
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../audio/openal/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../multimedia/libogg/buildlink3.mk"
.include "../../mk/ossaudio.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

9
uqm/PLIST Normal file
View file

@ -0,0 +1,9 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/12/16 16:03:50 bencollver Exp $
bin/uqm
lib/uqm/uqm
share/uqm/content/version
@dirrm share/uqm/content/packages/addons
@dirrm share/uqm/content/packages
@dirrm share/uqm/content
@dirrm share/uqm
@dirrm lib/uqm

14
uqm/TODO Normal file
View file

@ -0,0 +1,14 @@
* This doesn't currently work under NetBSD 1.6.2 and GNU PTH.
- SDL_SemWait is returning -1, which indicates an error
- src/sc2code/libs/threads/sdl/sdlthreads.h
#define NativeSetSemaphore(sem) \
SDL_SemWait ((sem))
- src/sc2code/libs/threads/thrcommon.c
int
SetSemaphore (Semaphore sem)
[...]
i = NativeSetSemaphore ((NativeSemaphore) sem);

9
uqm/distinfo Normal file
View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2004/12/16 16:03:50 bencollver Exp $
SHA1 (uqm/uqm-0.3-source.tgz) = 3e1c8560dc05f2e02c0ac38eed7cbd4ca5a58602
Size (uqm/uqm-0.3-source.tgz) = 906653 bytes
SHA1 (uqm/uqm-0.3-content.zip) = 41e7d68b1317d766d804e690f399d7d11a3b8912
Size (uqm/uqm-0.3-content.zip) = 12554418 bytes
SHA1 (patch-aa) = 446f447d851afe0ab1f1b67af7d1e2c80077ccbe
SHA1 (patch-ab) = 208ff1d8ea69febb94710919aad5aa84c6730a82
SHA1 (patch-ac) = acad0c6831988f2d6a83b553e46cf05c76c3948c

43
uqm/patches/patch-aa Normal file
View file

@ -0,0 +1,43 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/12/16 16:03:50 bencollver Exp $
--- build/unix/config_proginfo.orig Tue Jul 15 11:29:34 2003
+++ build/unix/config_proginfo
@@ -30,7 +30,7 @@ PROG_sed_VERSION=''
PROG_make_NAME="Make"
case "$OSNAME" in
- FreeBSD|OpenBSD)
+ FreeBSD|OpenBSD|NetBSD)
PROG_make_FILE="gmake"
;;
*)
@@ -81,6 +81,7 @@ LIB_openal_NAME="OpenAL"
LIB_openal_CFLAGS=""
case "$OSNAME" in
FreeBSD|OpenBSD) LIB_openal_LDFLAGS="-L/usr/local/lib -pthread -lopenal" ;;
+ NetBSD) LIB_openal_LDFLAGS="-lpthread -lopenal ${LIBOSSAUDIO}" ;;
MINGW32*) LIB_openal_LDFLAGS="-lopenal32" ;;
*) LIB_openal_LDFLAGS="-lopenal" ;;
esac
@@ -92,6 +93,10 @@ case "$OSNAME" in
LIB_opengl_CFLAGS="-I/usr/X11R6/include -D_THREAD_SAFE"
LIB_opengl_LDFLAGS="-L/usr/X11R6/lib -lX11 -lXext -pthread -lGL"
;;
+ NetBSD)
+ LIB_opengl_CFLAGS="-D_THREAD_SAFE"
+ LIB_opengl_LDFLAGS="-lX11 -lXext -lpthread -lGL -lm"
+ ;;
MINGW32*)
LIB_opengl_CFLAGS=""
LIB_opengl_LDFLAGS="-lopengl32"
@@ -117,6 +122,10 @@ case "$OSNAME" in
FreeBSD|OpenBSD)
LIB_vorbisfile_CFLAGS="-I/usr/local/include"
LIB_vorbisfile_LDFLAGS="-L/usr/local/lib -lvorbisfile -lvorbis"
+ ;;
+ NetBSD)
+ LIB_vorbisfile_CFLAGS=""
+ LIB_vorbisfile_LDFLAGS="-lvorbisfile -lvorbis"
;;
QNX)
LIB_vorbisfile_CFLAGS=""

29
uqm/patches/patch-ab Normal file
View file

@ -0,0 +1,29 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/12/16 16:03:50 bencollver Exp $
--- build/unix/build.config.orig Tue Dec 7 15:47:41 2004
+++ build/unix/build.config
@@ -2,7 +2,7 @@
# Include build functions used here
. build/unix/config_functions
-. build/unix/menu_functions
+#. build/unix/menu_functions
. build/unix/ansi
@@ -195,6 +195,15 @@ prefix="$INPUT_install_prefix_VALUE" \
eval INSTALL_LIBDIR="${INPUT_install_libdir_VALUE%/}/"
prefix="$INPUT_install_prefix_VALUE" \
eval INSTALL_SHAREDIR="${INPUT_install_sharedir_VALUE%/}/"
+
+# menu is not good for bulk build environments
+debug_action
+graphics_opengl_action
+sound_openal_action
+ioformat_stdio_zip_action
+INSTALL_BINDIR=${PREFIX}/bin/
+INSTALL_LIBDIR=${PREFIX}/lib/
+INSTALL_SHAREDIR=${PREFIX}/share/
# Set the content dir
CONTENTDIR="${INSTALL_SHAREDIR}uqm/content"

26
uqm/patches/patch-ac Normal file
View file

@ -0,0 +1,26 @@
$NetBSD: patch-ac,v 1.1.1.1 2004/12/16 16:03:50 bencollver Exp $
--- src/sc2code/libs/uio/stdio/stdio.c.orig Sun Aug 31 11:40:01 2003
+++ src/sc2code/libs/uio/stdio/stdio.c
@@ -32,6 +32,21 @@
// for readdir_r
# include <dirent.h>
#endif
+#if defined(__NetBSD__) && !defined(readdir_r)
+int readdir_r(DIR *dirp, struct dirent *entry, struct dirent **result)
+{
+ struct dirent *my_result;
+
+ my_result = readdir(dirp);
+ if (my_result == NULL) {
+ *result = NULL;
+ } else {
+ *entry = *my_result;
+ *result = entry;
+ }
+ return 0; /* how do i detect if readdir() fails? */
+}
+#endif
#include <stdio.h>
#include <sys/types.h>
#include <errno.h>