Import digitemp-3.6.0 as wip/digitemp.
Digitemp is program to read temperature from serial and USB thermometers
This commit is contained in:
parent
61efb4e925
commit
6f02a4421a
7 changed files with 76 additions and 0 deletions
1
digitemp/DESCR
Normal file
1
digitemp/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
Digitemp is program to read temperature from serial and USB thermometers
|
15
digitemp/MESSAGE
Normal file
15
digitemp/MESSAGE
Normal file
|
@ -0,0 +1,15 @@
|
|||
===========================================================================
|
||||
$Id: MESSAGE,v 1.1.1.1 2011/10/29 06:08:03 errellion Exp $
|
||||
First initialize and create config:
|
||||
|
||||
digitemp -s /dev/tty00 -i
|
||||
|
||||
Then use generated config to read temperature from all sensors:
|
||||
|
||||
digitemp -a
|
||||
|
||||
or specify one:
|
||||
|
||||
digitemp -t 0
|
||||
|
||||
===========================================================================
|
21
digitemp/Makefile
Normal file
21
digitemp/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/10/29 06:08:03 errellion Exp $
|
||||
#
|
||||
|
||||
DISTNAME= digitemp-3.6.0
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= http://www.digitemp.com/software/linux/
|
||||
|
||||
MAINTAINER= bartosz@maciejewski.org
|
||||
HOMEPAGE= http://www.digitemp.com/
|
||||
COMMENT= Reads temperature from serial and USB thermometers
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
INSTALLATION_DIRS= bin
|
||||
PKG_DESTDIR_SUPPORT= destdir
|
||||
USE_TOOLS+= gmake
|
||||
BUILD_TARGET= ds9097
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097 ${DESTDIR}${PREFIX}/bin/digitemp
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
digitemp/PLIST
Normal file
2
digitemp/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/10/29 06:08:03 errellion Exp $
|
||||
bin/digitemp
|
7
digitemp/distinfo
Normal file
7
digitemp/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/10/29 06:08:03 errellion Exp $
|
||||
|
||||
SHA1 (digitemp-3.6.0.tar.gz) = 68be8b577ba2db3cab3bc59524c3f5917113da56
|
||||
RMD160 (digitemp-3.6.0.tar.gz) = c1011dd160d7d47fca585e5cdb4df727b870dfde
|
||||
Size (digitemp-3.6.0.tar.gz) = 290107 bytes
|
||||
SHA1 (patch-src_digitemp.c) = 00fc1511c1425ec20b1f8bbb4445cd7a54aa342c
|
||||
SHA1 (patch-userial_ds9097_linuxses.c) = c51775b26abd859cccea91da333306627c23d6d4
|
17
digitemp/patches/patch-src_digitemp.c
Normal file
17
digitemp/patches/patch-src_digitemp.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-src_digitemp.c,v 1.1.1.1 2011/10/29 06:08:03 errellion Exp $
|
||||
|
||||
--- src/digitemp.c.orig 2008-08-28 04:42:48.000000000 +0000
|
||||
+++ src/digitemp.c
|
||||
@@ -79,10 +79,10 @@
|
||||
#if DARWIN
|
||||
#include <machine/endian.h>
|
||||
#endif
|
||||
-#if FREEBSD
|
||||
+#if FREEBSD || NETBSD
|
||||
#include <sys/endian.h>
|
||||
#endif
|
||||
-#if !defined(DARWIN) && !defined(FREEBSD)
|
||||
+#if !defined(DARWIN) && !defined(FREEBSD) && !defined(NETBSD)
|
||||
#include <endian.h>
|
||||
#endif
|
||||
|
13
digitemp/patches/patch-userial_ds9097_linuxses.c
Normal file
13
digitemp/patches/patch-userial_ds9097_linuxses.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-userial_ds9097_linuxses.c,v 1.1.1.1 2011/10/29 06:08:03 errellion Exp $
|
||||
|
||||
--- userial/ds9097/linuxses.c.orig 2007-06-07 21:25:58.000000000 +0000
|
||||
+++ userial/ds9097/linuxses.c
|
||||
@@ -55,7 +55,7 @@ struct termios term_orig[MAX_PORTNUM]; /
|
||||
SMALLINT owAcquire(int portnum, char *port_zstr)
|
||||
{
|
||||
/* Open the serial port */
|
||||
- if ((fd[portnum] = open(port_zstr, O_RDWR)) == -1)
|
||||
+ if ((fd[portnum] = open(port_zstr, O_RDWR|O_NONBLOCK)) == -1)
|
||||
{
|
||||
OWERROR(OWERROR_GET_SYSTEM_RESOURCE_FAILED);
|
||||
perror("owAcquire: failed to open device");
|
Loading…
Reference in a new issue