Merged into pkgsrc.

This commit is contained in:
Aleksej Saushev 2008-06-29 07:38:35 +00:00 committed by Thomas Klausner
parent 96d0166bfa
commit 70c3a23617
19 changed files with 0 additions and 1633 deletions

View file

@ -1,6 +0,0 @@
Wine is a program which allows running Microsoft Windows programs
(including DOS, Windows 3.x and Win32 executables) on Unix. It consists
of a program loader which loads and executes an Microsoft Windows binary,
and a library that implements Windows API calls using their Unix or X11
equivalents. The library may also be used for porting Win32 code into
native Unix executables.

View file

@ -1,64 +0,0 @@
# $NetBSD: Makefile,v 1.13 2008/06/18 11:46:04 asau Exp $
DISTNAME= wine-1.0
PKGNAME= ${DISTNAME:S/0-/0/}
CATEGORIES= emulators
MASTER_SITES= http://ibiblio.org/pub/linux/system/emulators/wine/ \
${MASTER_SITE_SOURCEFORGE:=wine/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= asau@inbox.ru, adam.hoka@gmail.com
HOMEPAGE= http://www.winehq.com/
COMMENT= Free implementation of the Windows(tm) runtime on POSIX
BUILD_DEPENDS+= fontforge-[0-9]*:../../fonts/fontforge
ONLY_FOR_PLATFORM= NetBSD-1.5Z*-i386 NetBSD-1.6*-i386 NetBSD-[2-9]*-i386
ONLY_FOR_PLATFORM+= FreeBSD-*-i386 Linux-*-i386 SunOS-*-i386 Darwin-*-i386
ONLY_FOR_PLATFORM+= *-*-x86_64
PKG_DESTDIR_SUPPORT= user-destdir
USE_DIRS+= xdg-1.1
USE_LANGUAGES= c
USE_LIBTOOL= yes
USE_NCURSES= yes
USE_TOOLS+= bison flex gmake mktemp
GNU_CONFIGURE= yes
UNLIMIT_RESOURCES= datasize
REPLACE_PERL+= tools/winemaker tools/winedump/function_grep.pl
# The Wine configure script has problems locating the libraries in the
# buildlink directory, so prepend all of the LDFLAGS necessary to link
# against the libraries.
#
CONFIGURE_ENV+= X_LIBS=${LDFLAGS:M*:Q}
CONFIGURE_ENV+= CFLAGS=${CFLAGS:M*:Q}\ -DDEVOSSAUDIO="\"${DEVOSSAUDIO}\""
LIBS+= ${LDFLAGS}
.include "options.mk"
# Sample code how to fall back to particular GCC version:
#
# .include "../../mk/compiler.mk"
# .if !empty(CC_VERSION:Mgcc-4*)
#
# .include "../../lang/gcc34/buildlink3.mk"
#
# pre-configure:
# ${ECHO} "GCC 4.x detected, falling back to GCC 3.4!"
# . include "../../lang/gcc34/preconfigure.mk"
# .endif
post-install:
.for tool in fnt2bdf
${LIBTOOL} --mode=install ${INSTALL_PROGRAM} ${WRKSRC}/tools/${tool} \
${DESTDIR}${PREFIX}/bin
.endfor
.include "../../devel/ncurses/buildlink3.mk"
.include "../../textproc/libxslt/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST.FreeBSD,v 1.1 2008/05/25 17:16:04 hoka_adam Exp $
bin/wine-pthread

View file

@ -1,4 +0,0 @@
@comment $NetBSD: PLIST.Linux,v 1.1 2008/05/25 17:16:04 hoka_adam Exp $
bin/wine-pthread
bin/wine-kthread
bin/wine-preloader

File diff suppressed because it is too large Load diff

View file

@ -1,8 +0,0 @@
$Id: TODO,v 1.5 2008/05/27 09:07:57 asau Exp $
* FIX BUILDLINK3!
* Make it run on NetBSD
* Send patches upstream!
* NetBSD-4.99.54/amd64:
actxprxy_servprov_p.c:272:2: error: #error Currently only Wine and WIN32 are supported.
* Recheck x11 and other options after update to 1.0 RC2.

View file

@ -1,30 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
WINE_BUILDLINK3_MK:= ${WINE_BUILDLINK3_MK}+
.if ${BUILDLINK_DEPTH} == "+"
BUILDLINK_DEPENDS+= wine
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nwine}
BUILDLINK_PACKAGES+= wine
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}wine
.if ${WINE_BUILDLINK3_MK} == "+"
BUILDLINK_API_DEPENDS.wine+= wine>=0.9.6nb1
BUILDLINK_PKGSRCDIR.wine?= ../../emulators/wine
.endif # WINE_BUILDLINK3_MK
pkgbase:= wine
.include "../../mk/pkg-build-options.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.if !empty(PKG_BUILD_OPTIONS.wine:Mopengl)
.include "../../graphics/glu/buildlink3.mk"
.include "../../graphics/glut/buildlink3.mk"
.endif
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/libungif/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,15 +0,0 @@
$NetBSD: distinfo,v 1.8 2008/06/18 11:06:37 asau Exp $
SHA1 (wine-1.0.tar.bz2) = 84150abdda18bc34b187335c6862718a6e08d255
RMD160 (wine-1.0.tar.bz2) = 1dbfa38e54e7d6269ad4110f22b2791393fd3b59
Size (wine-1.0.tar.bz2) = 13981030 bytes
SHA1 (patch-aa) = e3d323598d7850b5e0d68bba0c2eab6ceb7ef307
SHA1 (patch-ab) = 66c1f1ec98674d15c7a72e8ac16105c28aa25e91
SHA1 (patch-ac) = e28e9ea8563546a41672f16c8e111e5d37ffbe92
SHA1 (patch-ad) = 978bdd94b75a2d671d5ed97d7664ff60488683cd
SHA1 (patch-ae) = a4f39995baf5511ddc70b4e1c006a159a86eeb22
SHA1 (patch-af) = b2a380937f2e3933144b564c51e8b250c046c467
SHA1 (patch-ag) = c4bf5a592ad5cad67ff933c5da418c58d6e1367a
SHA1 (patch-ai) = a334ee48b949f9f5d4356beed3b422ee032619c2
SHA1 (patch-aj) = fa9d3baad8d3b895edc6275c2b6da23daa941a09
SHA1 (patch-ak) = 5f9836d5b6c957a2a6828b1979c1beeb4e900b31

View file

@ -1,71 +0,0 @@
# $NetBSD: options.mk,v 1.3 2008/05/26 20:58:51 hoka_adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.wine
PKG_SUPPORTED_OPTIONS= cups opengl sane ssl dbus x11 esound
PKG_SUGGESTED_OPTIONS= opengl ssl x11 esound
.include "../../mk/bsd.options.mk"
PLIST_VARS+= x11 opengl
.if !empty(PKG_OPTIONS:Mesound)
.include "../../audio/esound/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mldap)
.include "../../databases/openldap-client/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-ldap
.endif
.if !empty(PKG_OPTIONS:Mdbus)
.include "../../sysutils/dbus/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-dbus
.endif
.if !empty(PKG_OPTIONS:Mcups)
.include "../../print/cups/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-cups
.endif
.if !empty(PKG_OPTIONS:Mx11)
.include "../../x11/libICE/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXcursor/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXi/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXrandr/buildlink3.mk"
.include "../../x11/libXrender/buildlink3.mk"
.include "../../x11/libXxf86vm/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/lcms/buildlink3.mk"
.include "../../graphics/libungif/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
PLIST.x11= yes
.else
CONFIGURE_ARGS+= --without-dbus
.endif
.if !empty(PKG_OPTIONS:Mssl)
.include "../../security/openssl/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-openssl
.endif
.if !empty(PKG_OPTIONS:Mopengl) && !empty(PKG_OPTIONS:Mx11)
.include "../../graphics/glu/buildlink3.mk"
.include "../../graphics/glut/buildlink3.mk"
PLIST.opengl= yes
.else
CONFIGURE_ARGS+= --without-opengl
.endif
.if !empty(PKG_OPTIONS:Msane)
.include "../../graphics/sane-backends/buildlink3.mk"
.endif

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 2008/05/14 13:59:11 asau Exp $
--- Make.rules.in.orig Fri May 9 21:42:56 2008
+++ Make.rules.in Wed May 14 16:21:23 2008
@@ -120,7 +120,7 @@
CLEAN_TARGETS = $(IDL_GEN_C_SRCS) $(IDL_GEN_HEADERS) $(IDL_TLB_SRCS:.idl=.tlb) $(IDL_P_SRCS:%=dlldata.c) \
$(BISON_SRCS:.y=.tab.c) $(BISON_SRCS:.y=.tab.h) $(LEX_SRCS:.l=.yy.c) $(MC_SRCS:.mc=.mc.rc)
-OBJS = $(C_SRCS:.c=.o) $(BISON_SRCS:.y=.tab.o) $(LEX_SRCS:.l=.yy.o) $(IDL_GEN_C_SRCS:.c=.o) $(EXTRA_OBJS)
+OBJS = $(EXTRA_OBJS) $(C_SRCS:.c=.o) $(BISON_SRCS:.y=.tab.o) $(LEX_SRCS:.l=.yy.o) $(IDL_GEN_C_SRCS:.c=.o)
RCOBJS = $(RC_SRCS:.rc=.res.o)
LINTS = $(C_SRCS:.c=.ln)

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/ntdll/cdrom.c.orig 2005-07-20 10:28:27.000000000 +0000
+++ dlls/ntdll/cdrom.c
@@ -64,6 +64,16 @@
#endif
#ifdef HAVE_LINUX_CDROM_H
# include <linux/cdrom.h>
+#else
+# ifndef CD_FRAMES
+# define CD_FRAMES 75
+# endif
+# ifndef CDROM_MSF
+# define CDROM_MSF 0x02
+# endif
+# ifndef CD_SECS
+# define CD_SECS 60
+# endif
#endif
#ifdef HAVE_LINUX_UCDROM_H
# include <linux/ucdrom.h>

View file

@ -1,25 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/ntdll/directory.c.orig 2007-08-24 16:34:33.000000000 +0200
+++ dlls/ntdll/directory.c
@@ -128,6 +128,20 @@ static inline int getdents64( int fd, ch
#endif /* linux */
#define IS_OPTION_TRUE(ch) ((ch) == 'y' || (ch) == 'Y' || (ch) == 't' || (ch) == 'T' || (ch) == '1')
+#if defined(__NetBSD_Version__) && __NetBSD_Version__ >= 399000800
+/*
+ * workaround for obsolete getdirentries() which returns
+ * the old 32-bit inode struct dirent, while dirent.h has the
+ * new 64-bit inode struct dirent inode since 3.99.8
+ */
+int compat_netbsd_getdirentries(int fd, char *buf, int nbytes, long *basep)
+{
+ *basep = (long)lseek(fd, 0, SEEK_CUR);
+ return getdents(fd, buf, (size_t)nbytes);
+}
+#define getdirentries compat_netbsd_getdirentries
+#endif
+
#define IS_SEPARATOR(ch) ((ch) == '\\' || (ch) == '/')
#define INVALID_NT_CHARS '*','?','<','>','|','"'

View file

@ -1,40 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/iphlpapi/ipstats.c.orig 2007-07-13 19:46:16.000000000 +0200
+++ dlls/iphlpapi/ipstats.c
@@ -28,6 +28,10 @@
#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
+#if defined(__NetBSD__)
+#include <sys/param.h>
+#endif
+#include <unistd.h>
#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>
#endif
@@ -740,7 +744,11 @@ DWORD getNumRoutes(void)
/* Ignore all entries except for gateway routes which aren't
multicast */
+#if !defined(RTF_MULTICAST)
+ if (!(rtm->rtm_flags & RTF_GATEWAY))
+#else
if (!(rtm->rtm_flags & RTF_GATEWAY) || (rtm->rtm_flags & RTF_MULTICAST))
+#endif
continue;
RouteCount++;
@@ -813,8 +821,12 @@ DWORD getRouteTable(PMIB_IPFORWARDTABLE
/* Ignore all entries except for gateway routes which aren't
multicast */
+#if !defined(RTF_MULTICAST)
+ if (!(rtm->rtm_flags & RTF_GATEWAY))
+#else
if (!(rtm->rtm_flags & RTF_GATEWAY) ||
(rtm->rtm_flags & RTF_MULTICAST))
+#endif
continue;
memset (&table->table[table->dwNumEntries], 0,

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/winex11.drv/opengl.c.orig 2006-09-15 08:03:29.000000000 +0200
+++ dlls/winex11.drv/opengl.c
@@ -48,6 +48,7 @@ WINE_DECLARE_DEBUG_CHANNEL(opengl);
#endif
#ifdef HAVE_GL_GLX_H
# include <GL/glx.h>
+# include <GL/glxext.h>
#endif
#ifdef HAVE_GL_GLEXT_H
# include <GL/glext.h>

View file

@ -1,86 +0,0 @@
$NetBSD: patch-af,v 1.2 2008/02/19 04:09:21 asau Exp $
--- dlls/ntdll/signal_i386.c.orig 2008-02-08 18:44:36.000000000 +0300
+++ dlls/ntdll/signal_i386.c 2008-02-19 02:55:19.000000000 +0300
@@ -198,7 +198,7 @@
#endif /* bsdi */
-#if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__)
+#if (defined(__NetBSD__) && (__NetBSD_Version__ < 200000000)) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__)
typedef struct sigcontext SIGCONTEXT;
@@ -331,6 +331,46 @@
#endif /* __APPLE__ */
+#if defined(__NetBSD__) && (__NetBSD_Version__ >= 200000000)
+# include <sys/ucontext.h>
+# include <sys/types.h>
+# include <signal.h>
+
+typedef ucontext_t SIGCONTEXT;
+
+#define EAX_sig(context) ((context)->uc_mcontext.__gregs[_REG_EAX])
+#define EBX_sig(context) ((context)->uc_mcontext.__gregs[_REG_EBX])
+#define ECX_sig(context) ((context)->uc_mcontext.__gregs[_REG_ECX])
+#define EDX_sig(context) ((context)->uc_mcontext.__gregs[_REG_EDX])
+#define ESI_sig(context) ((context)->uc_mcontext.__gregs[_REG_ESI])
+#define EDI_sig(context) ((context)->uc_mcontext.__gregs[_REG_EDI])
+#define EBP_sig(context) ((context)->uc_mcontext.__gregs[_REG_EBP])
+
+#define CS_sig(context) ((context)->uc_mcontext.__gregs[_REG_CS])
+#define DS_sig(context) ((context)->uc_mcontext.__gregs[_REG_DS])
+#define ES_sig(context) ((context)->uc_mcontext.__gregs[_REG_ES])
+#define FS_sig(context) ((context)->uc_mcontext.__gregs[_REG_FS])
+#define GS_sig(context) ((context)->uc_mcontext.__gregs[_REG_GS])
+#define SS_sig(context) ((context)->uc_mcontext.__gregs[_REG_SS])
+
+#define EFL_sig(context) ((context)->uc_mcontext.__gregs[_REG_EFL])
+
+#define EIP_sig(context) (*((unsigned long*)&(context)->uc_mcontext.__gregs[_REG_EIP]))
+#define ESP_sig(context) (*((unsigned long*)&(context)->uc_mcontext.__gregs[_REG_ESP]))
+
+#define FPU_sig(context) ((FLOATING_SAVE_AREA*)&((context)->uc_mcontext.__fpregs.__fp_reg_set.__fpchip_state))
+#define FPUX_sig(context) ((XMM_SAVE_AREA32 *)&((context)->uc_mcontext.__fpregs.__fp_reg_set.__fp_xmm_state))
+
+#define TRAP_sig(context) ((context)->uc_mcontext.__gregs[_REG_TRAPNO])
+#define ERROR_sig(context) ((context)->uc_mcontext.__gregs[_REG_ERR])
+
+#define FAULT_ADDRESS (__siginfo->si_addr)
+
+#define HANDLER_DEF(name) void name( int __signal, siginfo_t *__siginfo, SIGCONTEXT *__context )
+#define HANDLER_CONTEXT (__context)
+
+#endif /* __NetBSD__ */
+
WINE_DEFAULT_DEBUG_CHANNEL(seh);
typedef int (*wine_signal_handler)(unsigned int sig);
@@ -365,8 +405,13 @@
TRAP_x86_PAGEFLT = T_PAGEFLT, /* Page fault */
TRAP_x86_ARITHTRAP = T_ARITHTRAP, /* Floating point exception */
TRAP_x86_ALIGNFLT = T_ALIGNFLT, /* Alignment check exception */
+#if defined(__NetBSD__)
+ TRAP_x86_MCHK = T_MCA, /* Machine check exception */
+ TRAP_x86_CACHEFLT = T_XMM /* Cache flush exception */
+#else
TRAP_x86_MCHK = T_MCHK, /* Machine check exception */
TRAP_x86_CACHEFLT = T_XMMFLT /* Cache flush exception */
+#endif
#else
TRAP_x86_DIVIDE = 0, /* Division by zero exception */
TRAP_x86_TRCTRAP = 1, /* Single-step exception */
@@ -1512,7 +1557,11 @@
#endif /* HAVE_SIGALTSTACK */
sig_act.sa_mask = server_block_set;
+#if defined(__NetBSD__) && (__NetBSD_Version__ < 200000000)
+ sig_act.sa_flags = SA_RESTART;
+#else
sig_act.sa_flags = SA_SIGINFO | SA_RESTART;
+#endif
#ifdef SA_ONSTACK
sig_act.sa_flags |= SA_ONSTACK;
#endif

View file

@ -1,58 +0,0 @@
$NetBSD: patch-ag,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/ntdll/signal_x86_64.c.orig 2006-10-13 14:43:39.000000000 +0000
+++ dlls/ntdll/signal_x86_64.c
@@ -93,6 +93,53 @@ typedef struct ucontext SIGCONTEXT;
#endif /* linux */
+#if defined(__NetBSD__) && (__NetBSD_Version__ >= 200000000)
+# include <sys/ucontext.h>
+# include <sys/types.h>
+# include <signal.h>
+
+typedef ucontext_t SIGCONTEXT;
+
+#define RAX_sig(context) ((context)->uc_mcontext.__gregs[_REG_RAX])
+#define RBX_sig(context) ((context)->uc_mcontext.__gregs[_REG_RBX])
+#define RCX_sig(context) ((context)->uc_mcontext.__gregs[_REG_RCX])
+#define RDX_sig(context) ((context)->uc_mcontext.__gregs[_REG_RDX])
+#define RSI_sig(context) ((context)->uc_mcontext.__gregs[_REG_RSI])
+#define RDI_sig(context) ((context)->uc_mcontext.__gregs[_REG_RDI])
+#define RBP_sig(context) ((context)->uc_mcontext.__gregs[_REG_RBP])
+#define R8_sig(context) ((context)->uc_mcontext.__gregs[_REG_R8])
+#define R9_sig(context) ((context)->uc_mcontext.__gregs[_REG_R9])
+#define R10_sig(context) ((context)->uc_mcontext.__gregs[_REG_R10])
+#define R11_sig(context) ((context)->uc_mcontext.__gregs[_REG_R11])
+#define R12_sig(context) ((context)->uc_mcontext.__gregs[_REG_R12])
+#define R13_sig(context) ((context)->uc_mcontext.__gregs[_REG_R13])
+#define R14_sig(context) ((context)->uc_mcontext.__gregs[_REG_R14])
+#define R15_sig(context) ((context)->uc_mcontext.__gregs[_REG_R15])
+
+#define CS_sig(context) ((context)->uc_mcontext.__gregs[_REG_CS])
+#define DS_sig(context) ((context)->uc_mcontext.__gregs[_REG_DS])
+#define ES_sig(context) ((context)->uc_mcontext.__gregs[_REG_ES])
+#define FS_sig(context) ((context)->uc_mcontext.__gregs[_REG_FS])
+#define GS_sig(context) ((context)->uc_mcontext.__gregs[_REG_GS])
+#define SS_sig(context) ((context)->uc_mcontext.__gregs[_REG_SS])
+
+#define EFL_sig(context) ((context)->uc_mcontext.__gregs[_REG_RFL])
+
+#define RIP_sig(context) (*((unsigned long*)&(context)->uc_mcontext.__gregs[_REG_RIP]))
+#define RSP_sig(context) (*((unsigned long*)&(context)->uc_mcontext.__gregs[_REG_URSP]))
+
+#define TRAP_sig(context) ((context)->uc_mcontext.__gregs[_REG_TRAPNO])
+#define ERROR_sig(context) ((context)->uc_mcontext.__gregs[_REG_ERR])
+
+#define FAULT_CODE (__siginfo->si_code)
+#define FAULT_ADDRESS (__siginfo->si_addr)
+
+#define HANDLER_DEF(name) void name( int __signal, siginfo_t *__siginfo, SIGCONTEXT *__context )
+#define HANDLER_CONTEXT (__context)
+
+#define FPU_sig(context) ((XMM_SAVE_AREA32 *)((context)->uc_mcontext.__fpregs))
+#endif /* __NetBSD__ */
+
enum i386_trap_code
{
TRAP_x86_UNKNOWN = -1, /* Unknown fault (TRAP_sig not defined) */

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ai,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- include/winternl.h.orig 2005-11-11 09:56:44.000000000 +0100
+++ include/winternl.h
@@ -22,6 +22,7 @@
#define __WINE_WINTERNL_H
#include <windef.h>
+#include <stdarg.h>
#ifdef __cplusplus
extern "C" {

View file

@ -1,24 +0,0 @@
$NetBSD: patch-aj,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/wineoss.drv/oss.c.orig 2005-12-24 10:24:01.000000000 +0100
+++ dlls/wineoss.drv/oss.c
@@ -42,7 +42,9 @@ static LRESULT OSS_drvLoad(void)
{
TRACE("()\n");
OSS_WaveInit();
+#ifdef HAVE_OSS_MIDI
OSS_MidiInit();
+#endif
OSS_MixerInit();
OSS_AuxInit();
return 1;
@@ -55,7 +57,9 @@ static LRESULT OSS_drvFree(void)
{
TRACE("()\n");
OSS_WaveExit();
+#ifdef HAVE_OSS_MIDI
OSS_MidiExit();
+#endif
OSS_MixerExit();
OSS_AuxExit();
return 1;

View file

@ -1,40 +0,0 @@
$NetBSD: patch-ak,v 1.1.1.1 2008/02/18 20:21:02 asau Exp $
--- dlls/ntdll/file.c.orig 2007-06-29 19:36:20.000000000 +0200
+++ dlls/ntdll/file.c
@@ -1843,6 +1843,35 @@ static NTSTATUS get_device_info( int fd,
info->DeviceType = FILE_DEVICE_DISK_FILE_SYSTEM;
break;
}
+#elif defined(__NetBSD__)
+ struct statvfs stfs;
+
+ if (fstatvfs( fd, &stfs) < 0)
+ info->DeviceType = FILE_DEVICE_DISK_FILE_SYSTEM;
+ else if (!strncmp("cd9660", stfs.f_fstypename,
+ sizeof(stfs.f_fstypename)))
+ {
+ info->DeviceType = FILE_DEVICE_CD_ROM_FILE_SYSTEM;
+ info->Characteristics |= FILE_REMOVABLE_MEDIA;
+ }
+ else if (!strncmp("nfs", stfs.f_fstypename,
+ sizeof(stfs.f_fstypename)))
+ {
+ info->DeviceType = FILE_DEVICE_NETWORK_FILE_SYSTEM;
+ info->Characteristics |= FILE_REMOTE_DEVICE;
+ }
+ else if (!strncmp("procfs", stfs.f_fstypename,
+ sizeof(stfs.f_fstypename)))
+ info->DeviceType = FILE_DEVICE_VIRTUAL_DISK;
+ else
+ info->DeviceType = FILE_DEVICE_DISK_FILE_SYSTEM;
+ if (stfs.f_flag & MNT_RDONLY)
+ info->Characteristics |= FILE_READ_ONLY_DEVICE;
+ if (!(stfs.f_flag & MNT_LOCAL))
+ {
+ info->DeviceType = FILE_DEVICE_NETWORK_FILE_SYSTEM;
+ info->Characteristics |= FILE_REMOTE_DEVICE;
+ }
#elif defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__APPLE__)
struct statfs stfs;