Update to 0.9.0. No Changelog provided on vendor site; in fact you even

can't produce CVS diffs easy, as vendor switched from CVS to SVN in the
middle of development. Anyway, this version is a huge step forward, as there
were no release in about 6 months - but the development was very activley
continued.
This commit is contained in:
Michal Pasternak 2004-05-25 20:32:04 +00:00 committed by Thomas Klausner
parent 3242192763
commit 7119425d75
4 changed files with 662 additions and 547 deletions

View file

@ -1,23 +1,23 @@
# $NetBSD: Makefile,v 1.10 2004/03/29 23:49:37 mpasternak Exp $
# $NetBSD: Makefile,v 1.11 2004/05/25 20:32:04 mpasternak Exp $
#
DISTNAME= Quotient-0.8.8
DISTNAME= Quotient-0.9.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=divmod/}
MASTER_SITES= http://www.divmod.org/users/release/divmod/
MAINTAINER= dotz@irc.pl
HOMEPAGE= http://www.divmod.org/Home/Projects/Quotient/index.html
COMMENT= E-mail server, messaging server (IM/IRC) and IP telephony
USE_BUILDLINK3= yes
DEPENDS+= ${PYPKGPREFIX}-Lupy>=0.2.1:../../textproc/py-Lupy
DEPENDS+= ${PYPKGPREFIX}-twisted>=1.3.0:../../net/py-twisted
DEPENDS+= ${PYPKGPREFIX}-spambayes>=1.0a7:../../wip/py-spambayes
DEPENDS+= ${PYPKGPREFIX}-bsddb>=0:../../wip/py-bsddb
DEPENDS+= ${PYPKGPREFIX}-nevow>=0.2.0:../../wip/py-nevow
PY_PATCHPLIST= yes
PYDISTUTILSPKG= yes
DEPENDS+= ${PYPKGPREFIX}-Lupy>=0.1.5.5.1:../../textproc/py-Lupy
DEPENDS+= ${PYPKGPREFIX}-twisted>=1.2.0:../../wip/py-twisted
DEPENDS+= ${PYPKGPREFIX}-spambayes>=1.0a7:../../wip/py-spambayes
DEPENDS+= ${PYPKGPREFIX}-bsddb>=0:../../wip/py-bsddb
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2003/12/18 02:49:44 mpasternak Exp $
$NetBSD: distinfo,v 1.5 2004/05/25 20:32:05 mpasternak Exp $
SHA1 (Quotient-0.8.8.tar.gz) = 6a0af26131afaf06e5b826ebaeaa522b5cb6624f
Size (Quotient-0.8.8.tar.gz) = 592613 bytes
SHA1 (Quotient-0.9.0.tar.gz) = 4d43a02e3bd92e7edffbe6511aa25c309d043f1b
Size (Quotient-0.9.0.tar.gz) = 3039852 bytes
SHA1 (patch-aa) = c81caacd6a57272dcdac880ef93511983a21b34d

View file

@ -1,17 +0,0 @@
$NetBSD: patch-aa,v 1.3 2003/11/20 16:48:15 mpasternak Exp $
--- atop/store.py~ Sat Nov 15 21:07:28 2003
+++ atop/store.py Thu Nov 20 17:35:20 2003
@@ -17,7 +17,11 @@
from os.path import join as opj
-from bsddb.db import *
+try:
+ from bsddb.db import *
+except ImportError:
+ # Thu Nov 20 17:34:51 CET 2003: for NetBSD by <dotz@irc.pl>
+ from bsddb3.db import *
from twisted.python import log
from twisted.python import plugin