Import tcptunnel-0.7 as wip/tcptunnel.
Tcptunnel is a simple TCP port forwarder. This tool listens to a local TCP port and all the received data is sent to a remote host. It can be used to redirect TCP based protocols like HTTP, IRC, NNTP, SSH or SMTP.
This commit is contained in:
parent
194651abda
commit
721d8da731
5 changed files with 59 additions and 0 deletions
4
tcptunnel/DESCR
Normal file
4
tcptunnel/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Tcptunnel is a simple TCP port forwarder. This tool listens to a local
|
||||
TCP port and all the received data is sent to a remote host. It can be
|
||||
used to redirect TCP based protocols like HTTP, IRC, NNTP, SSH or
|
||||
SMTP.
|
16
tcptunnel/Makefile
Normal file
16
tcptunnel/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/06/03 02:20:00 phonohawk Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tcptunnel-0.7
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.vakuumverpackt.de/tcptunnel/
|
||||
|
||||
MAINTAINER= pho@cielonegro.org
|
||||
COMMENT= Simple TCP port forwarder
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
do-configure:
|
||||
${RUN} cd ${WRKSRC} && \
|
||||
${SH} ./configure --prefix=${PREFIX:Q}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
tcptunnel/PLIST
Normal file
2
tcptunnel/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2013/06/03 02:20:00 phonohawk Exp $
|
||||
bin/tcptunnel
|
6
tcptunnel/distinfo
Normal file
6
tcptunnel/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/06/03 02:20:00 phonohawk Exp $
|
||||
|
||||
SHA1 (tcptunnel-0.7.tar.gz) = bfa186ff57602d761cd21d1354aa89463cf8fe4f
|
||||
RMD160 (tcptunnel-0.7.tar.gz) = 0c2a3894a49a855f2c58e983753d8a4896b7db1a
|
||||
Size (tcptunnel-0.7.tar.gz) = 11789 bytes
|
||||
SHA1 (patch-src_Makefile.in) = f7de789da3526402076d37a798ae52d32ae33cec
|
31
tcptunnel/patches/patch-src_Makefile.in
Normal file
31
tcptunnel/patches/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.1 2013/06/03 02:20:00 phonohawk Exp $
|
||||
|
||||
Hunk 1:
|
||||
I have no idea why the original Makefile.in is doing this...
|
||||
|
||||
Hunk 2:
|
||||
Add DESTDIR support.
|
||||
|
||||
--- src/Makefile.in.orig 2013-02-03 13:03:43.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -6,7 +6,7 @@ CFLAGS = -Wall -I./
|
||||
LDFLAGS = @LDFLAGS@
|
||||
OBJS = tcptunnel.o
|
||||
|
||||
-BINDIR = @PREFIX@
|
||||
+BINDIR = @PREFIX@/bin
|
||||
INSTALL = install
|
||||
STRIP = strip
|
||||
RM = /bin/rm -f
|
||||
@@ -23,9 +23,8 @@ tcptunnel: $(OBJS)
|
||||
$(CP) $(NAME) ..
|
||||
|
||||
install:
|
||||
- $(INSTALL) -d $(BINDIR)
|
||||
- $(INSTALL) -m 0755 $(NAME) $(BINDIR)
|
||||
- $(STRIP) $(BINDIR)/$(NAME)
|
||||
+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
|
||||
+ $(INSTALL) -m 0755 $(NAME) $(DESTDIR)$(BINDIR)
|
||||
|
||||
uninstall:
|
||||
$(RM) $(BINDIR)/$(NAME)
|
Loading…
Reference in a new issue