Remove valknut and associated dclib and libootool.

This software is no longer maintained by the original author.
Please see wip/linuxdcpp for a good alternative client software.
This commit is contained in:
Tobias Nygren 2006-10-22 20:10:44 +00:00 committed by Thomas Klausner
parent 97dd19e340
commit 74d4fccfc7
23 changed files with 1 additions and 462 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.2406 2006/10/21 11:40:54 adrian_p Exp $
# $Id: Makefile,v 1.2407 2006/10/22 20:10:44 tnn2 Exp $
#
COMMENT= WIP pkgsrc packages
@ -181,7 +181,6 @@ SUBDIR+= darcnes-svgalib
SUBDIR+= db1
SUBDIR+= dbf
SUBDIR+= dbvi
SUBDIR+= dclib
SUBDIR+= ddate
SUBDIR+= debian_base
SUBDIR+= debian_glib
@ -582,7 +581,6 @@ SUBDIR+= libnettle
SUBDIR+= libneural
SUBDIR+= libnjb
SUBDIR+= libobby
SUBDIR+= libootool
SUBDIR+= libopenmodeller
SUBDIR+= libp11
SUBDIR+= libpano12
@ -1416,7 +1414,6 @@ SUBDIR+= urlgfe
SUBDIR+= uschedule
SUBDIR+= ussp-push
SUBDIR+= util-linux
SUBDIR+= valknut
SUBDIR+= vcdgear
SUBDIR+= vche
SUBDIR+= videoproto

View file

@ -1,2 +0,0 @@
DClib is a library for connecting to "Direct Connect" peer-to-peer networks.
It is currently used by the Valknut client.

View file

@ -1,18 +0,0 @@
# $NetBSD: Makefile,v 1.11 2006/02/15 17:18:08 tnn2 Exp $
#
DISTNAME= dclib
CATEGORIES= net
MAINTAINER= tnn+nbsd@nygren.pp.se
HOMEPAGE= http://dcgui.berlios.de/
COMMENT= Direct Connect P2P library (cvs version)
USE_TOOLS+= pkg-config
PKGCONFIG_OVERRIDE+= dclib.pc.in
.include "../../wip/valknut/Makefile.common"
.include "../../wip/libootool/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,80 +0,0 @@
@comment $NetBSD: PLIST,v 1.6 2006/02/18 23:09:54 tnn2 Exp $
@comment xxx the following header files are removed on dclib HEAD
include/dclib/core/casyncdns.h
include/dclib/core/cbytearray.h
include/dclib/core/cbz.h
include/dclib/core/ccallback.h
include/dclib/core/cconnection.h
include/dclib/core/cfile.h
include/dclib/core/clist.h
include/dclib/core/cmanager.h
include/dclib/core/cmd4.h
include/dclib/core/cmd5.h
include/dclib/core/cobject.h
include/dclib/core/csingleton.h
include/dclib/core/csocket.h
include/dclib/core/cssl.h
include/dclib/core/cstring.h
include/dclib/core/cstringlist.h
include/dclib/core/cthread.h
include/dclib/core/czlib.h
include/dclib/dcos.h
include/dclib/hash/tigertree.h
include/dclib/hash/tiger.h
@comment end xxx
include/dclib/cclient.h
include/dclib/cclientssl.h
include/dclib/cconfig.h
include/dclib/cconnectionmanager.h
include/dclib/cdcproto.h
include/dclib/cdownloadmanager.h
include/dclib/cdownloadqueue.h
include/dclib/cencrypt.h
include/dclib/cfilemanager.h
include/dclib/chttp.h
include/dclib/chublistmanager.h
include/dclib/clistenmanager.h
include/dclib/cmessagehandler.h
include/dclib/core/cbase32.h
include/dclib/core/cbase64.h
include/dclib/core/cdir.h
include/dclib/core/che3.h
include/dclib/core/clisten.h
include/dclib/core/clogfile.h
include/dclib/core/cplugin.h
include/dclib/core/cxml.h
include/dclib/core/filecopy.h
include/dclib/core/platform.h
include/dclib/core/types.h
include/dclib/cpluginmanager.h
include/dclib/cquerymanager.h
include/dclib/csearchindex.h
include/dclib/csearchmanager.h
include/dclib/csearchsocket.h
include/dclib/csharelist.h
include/dclib/ctransfer.h
include/dclib/cuserlist.h
include/dclib/cutils.h
include/dclib/dclib.h
include/dclib/dcobject.h
@comment include/dclib/hash/Encoder.h
@comment include/dclib/hash/HashValue.h
@comment include/dclib/hash/MerkleTree.h
@comment tinclude/dclib/hash/TigerHash.h
@comment include/dclib/hash/compat.h
@comment include/dclib/xfer/cxfercommunication.h
@comment include/dclib/xfer/cxferfilecheck.h
@comment include/dclib/xfer/cxferfilecopy.h
@comment include/dclib/xfer/cxferhandler.h
@comment include/dclib/xfer/cxfermanager.h
@comment include/dclib/xfer/cxferqueue.h
@comment include/dclib/xfer/cxferrequest.h
@comment include/dclib/xfer/cxfersharelist.h
@comment include/dclib/xfer/cxferusrban.h
@comment include/dclib/xfer/cxferusrslot.h
lib/libdc.la
lib/pkgconfig/dclib.pc
@dirrm include/dclib/core
@dirrm include/dclib/hash
@comment dirrm include/dclib/xfer
@dirrm include/dclib

View file

@ -1,22 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.6 2006/04/06 07:17:06 jeremy-c-reed Exp $
.include "../../wip/valknut/Makefile.version"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
DCLIB_BUILDLINK3_MK:= ${DCLIB_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= dclib
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ndclib}
BUILDLINK_PACKAGES+= dclib
.if !empty(DCLIB_BUILDLINK3_MK:M+)
BUILDLINK_API_DEPENDS.dclib+= dclib>=${VALKNUT_PKG_VERSION}
BUILDLINK_PKGSRCDIR.dclib?= ../../wip/dclib
.endif # DCLIB_BUILDLINK3_MK
.include "../../wip/libootool/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,4 +0,0 @@
$NetBSD: distinfo,v 1.8 2006/02/18 23:09:54 tnn2 Exp $
SHA1 (patch-aa) = 75f945cbe1a64b938c7970b5dfb3ecdbb78cb774
SHA1 (patch-ab) = b825bb401e892cdeffcd9b154c6f4a70114eed74

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.1 2004/11/11 23:44:15 tnn2 Exp $
--- dclib/core/fsusage.h.orig 2004-11-12 00:33:57.000000000 +0100
+++ dclib/core/fsusage.h
@@ -52,8 +52,8 @@ struct fs_usage
# endif
extern "C" {
-int get_fs_usage PARAMS ((const char *path, const char *disk,
- struct fs_usage *fsp));
+int get_fs_usage (const char *path, const char *disk,
+ struct fs_usage *fsp);
}
#endif

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.3 2006/02/15 16:08:07 tnn2 Exp $
--- admin/detect-autoconf.sh.orig 2006-02-15 15:34:07.000000000 +0100
+++ admin/detect-autoconf.sh
@@ -95,9 +95,5 @@ checkWhich ()
done
}
-checkWhich
-checkAutoconf
-checkAutoheader
-checkAutomakeAclocal
export WHICH AUTOHEADER AUTOCONF AUTOM4TE AUTOMAKE ACLOCAL

View file

@ -1,2 +0,0 @@
A collection of c++ classes for (among other things) bzip2, libxml2
and OpenSSL.

View file

@ -1,20 +0,0 @@
# $NetBSD: Makefile,v 1.3 2006/02/18 23:09:54 tnn2 Exp $
#
DISTNAME= libootool
CATEGORIES= devel
MAINTAINER= tnn+nbsd@nygren.pp.se
HOMEPAGE= http://dcgui.berlios.de/
COMMENT= Free to use c++ utility classes (used by wip/valknut)
BROKEN= xxx: re-enable this package when wip/valknut tracks HEAD
BROKEN+= and actually requires it.
.include "../../wip/valknut/Makefile.common"
.include "../../devel/zlib/buildlink3.mk"
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,26 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2006/02/15 17:33:51 tnn2 Exp $
include/libootool/core/cbytearray.h
include/libootool/core/cbz.h
include/libootool/core/ccallback.h
include/libootool/core/ccallbacklist.h
include/libootool/core/cfile.h
include/libootool/core/clist.h
include/libootool/core/cmanager.h
include/libootool/core/cmutex.h
include/libootool/core/cobject.h
include/libootool/core/csingleton.h
include/libootool/core/cstring.h
include/libootool/core/cstringlist.h
include/libootool/core/cthread.h
include/libootool/core/czlib.h
include/libootool/core/os.h
include/libootool/socket/casyncdns.h
include/libootool/socket/cconnection.h
include/libootool/socket/cdns.h
include/libootool/socket/csocket.h
include/libootool/socket/cssl.h
include/libootool/socket/ctraffic.h
lib/libootool.la
@dirrm include/libootool/core
@dirrm include/libootool/socket
@dirrm include/libootool

View file

@ -1,30 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.3 2006/04/06 07:16:57 jeremy-c-reed Exp $
.include "../../wip/valknut/Makefile.version"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
LIBOOTOOL_BUILDLINK3_MK:= ${LIBOOTOOL_BUILDLINK3_MK}+
# broken, but we can still pull in the other dependencies for dclib
.if 0 #XXX
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= libootool
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibootool}
BUILDLINK_PACKAGES+= libootool
.if !empty(LIBOOTOOL_BUILDLINK3_MK:M+)
BUILDLINK_API_DEPENDS.libootool+= libootool>=${VALKNUT_PKG_VERSION}
BUILDLINK_PKGSRCDIR.libootool?= ../../wip/libootool
.endif # LIBOOTOOL_BUILDLINK3_MK
.endif # XXX
.include "../../devel/zlib/buildlink3.mk"
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,3 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2006/02/15 15:58:28 tnn2 Exp $
SHA1 (patch-ab) = b825bb401e892cdeffcd9b154c6f4a70114eed74

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2006/02/15 15:58:28 tnn2 Exp $
--- admin/detect-autoconf.sh.orig 2006-02-15 15:34:07.000000000 +0100
+++ admin/detect-autoconf.sh
@@ -95,9 +95,5 @@ checkWhich ()
done
}
-checkWhich
-checkAutoconf
-checkAutoheader
-checkAutomakeAclocal
export WHICH AUTOHEADER AUTOCONF AUTOM4TE AUTOMAKE ACLOCAL

View file

@ -1,5 +0,0 @@
Valknut is a program that uses the Direct Connect protocol to connect
to peer-to-peer filesharing hubs. It is compatible with other DC clients,
such as the original DC from Neomodus, DC++ and derivatives. Valknut also
interoperates with all common DC hub software. It uses the QT toolkit
for user interaction.

View file

@ -1,20 +0,0 @@
# $NetBSD: Makefile,v 1.10 2006/02/18 23:15:19 tnn2 Exp $
#
DISTNAME= valknut
CATEGORIES= net x11
MAINTAINER= tnn+nbsd@nygren.pp.se
HOMEPAGE= http://dcgui.berlios.de/
COMMENT= Direct Connect client using the QT toolkit (cvs version)
BUILD_DEPENDS+= qt3-tools-3.*:../../x11/qt3-tools
.include "Makefile.common"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../x11/qt3-libs/buildlink3.mk"
.include "../../wip/dclib/buildlink3.mk"
.include "../../mk/x11.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,23 +0,0 @@
# $NetBSD $
.include "../../wip/valknut/Makefile.version"
PKGNAME= ${DISTNAME}-${VALKNUT_PKG_VERSION}
MASTER_SITES= http://download.berlios.de/dcgui/
USE_LANGUAGES= c c++
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
USE_TOOLS+= autoconf automake gmake
AUTOMAKE_REQD= 1.9
CVS_REPOSITORIES= ${DISTNAME}
CVS_ROOT.${DISTNAME}= :pserver:anonymous:@cvs.dcgui.berlios.de:/cvsroot/dcgui
CVS_MODULE.${DISTNAME}= ${DISTNAME}
CONFIGURE_ARGS+= --enable-debug=full # per recommendation
.include "../../wip/mk/cvs-package.mk"
pre-configure:
cd ${WRKDIR}/${DISTNAME} && ${SH} admin/cvs.sh cvs

View file

@ -1,8 +0,0 @@
# $NetBSD $
.include "../../mk/bsd.prefs.mk"
#VALKNUT_PKG_VERSION!= ${DATE} +%Y%m%d
# HEAD is currently too broken to use
CVS_TAG= dc-0_3_8
VALKNUT_PKG_VERSION= 0.3.8

View file

@ -1,119 +0,0 @@
@comment $NetBSD: PLIST,v 1.3 2006/02/18 23:09:54 tnn2 Exp $
bin/valknut
share/valknut/COPYING
share/valknut/icons/appl/default/back.xpm
share/valknut/icons/appl/default/ball_green.xpm
share/valknut/icons/appl/default/ball_red.xpm
share/valknut/icons/appl/default/ball_yellow.xpm
share/valknut/icons/appl/default/bookmark_add.xpm
share/valknut/icons/appl/default/bookmark_folder.xpm
share/valknut/icons/appl/default/configure.xpm
share/valknut/icons/appl/default/configure_22x22.xpm
share/valknut/icons/appl/default/connect_creating.xpm
share/valknut/icons/appl/default/connect_no.xpm
share/valknut/icons/appl/default/connected.xpm
share/valknut/icons/appl/default/down.xpm
share/valknut/icons/appl/default/download.xpm
share/valknut/icons/appl/default/edit.xpm
share/valknut/icons/appl/default/editadd.xpm
share/valknut/icons/appl/default/editcopy.xpm
share/valknut/icons/appl/default/editdelete.xpm
share/valknut/icons/appl/default/exit.xpm
share/valknut/icons/appl/default/fileclose.xpm
share/valknut/icons/appl/default/filefind.xpm
share/valknut/icons/appl/default/find.xpm
share/valknut/icons/appl/default/find_22x22.xpm
share/valknut/icons/appl/default/flag_bosnian.xpm
share/valknut/icons/appl/default/flag_brazilian.xpm
share/valknut/icons/appl/default/flag_czech.xpm
share/valknut/icons/appl/default/flag_denmark.xpm
share/valknut/icons/appl/default/flag_english.xpm
share/valknut/icons/appl/default/flag_finland.xpm
share/valknut/icons/appl/default/flag_france.xpm
share/valknut/icons/appl/default/flag_germany.xpm
share/valknut/icons/appl/default/flag_greek.xpm
share/valknut/icons/appl/default/flag_hungary.xpm
share/valknut/icons/appl/default/flag_iceland.xpm
share/valknut/icons/appl/default/flag_italy.xpm
share/valknut/icons/appl/default/flag_latvian.xpm
share/valknut/icons/appl/default/flag_netherland.xpm
share/valknut/icons/appl/default/flag_norway.xpm
share/valknut/icons/appl/default/flag_poland.xpm
share/valknut/icons/appl/default/flag_romania.xpm
share/valknut/icons/appl/default/flag_russia.xpm
share/valknut/icons/appl/default/flag_slovak.xpm
share/valknut/icons/appl/default/flag_spain.xpm
share/valknut/icons/appl/default/flag_sweden.xpm
share/valknut/icons/appl/default/folder_blue.xpm
share/valknut/icons/appl/default/folder_blue_open.xpm
share/valknut/icons/appl/default/folder_red.xpm
share/valknut/icons/appl/default/globe.xpm
share/valknut/icons/appl/default/gv.xpm
share/valknut/icons/appl/default/help.xpm
share/valknut/icons/appl/default/icon_128x128.icns
share/valknut/icons/appl/default/icon_128x128.png
share/valknut/icons/appl/default/icon_16x16.png
share/valknut/icons/appl/default/icon_22x22.png
share/valknut/icons/appl/default/icon_22x22.xpm
share/valknut/icons/appl/default/icon_24x24.png
share/valknut/icons/appl/default/icon_32x32.png
share/valknut/icons/appl/default/icon_48x48.png
share/valknut/icons/appl/default/icon_64x64.png
share/valknut/icons/appl/default/icon_operator.xpm
share/valknut/icons/appl/default/icon_user.xpm
share/valknut/icons/appl/default/icon_user_away.xpm
share/valknut/icons/appl/default/info.xpm
share/valknut/icons/appl/default/info_22x22.xpm
share/valknut/icons/appl/default/message.xpm
share/valknut/icons/appl/default/notconnected.xpm
share/valknut/icons/appl/default/open.xpm
share/valknut/icons/appl/default/player_pause.xpm
share/valknut/icons/appl/default/player_play.xpm
share/valknut/icons/appl/default/reload.xpm
share/valknut/icons/appl/default/reload_22x22.xpm
share/valknut/icons/appl/default/save.xpm
share/valknut/icons/appl/default/server.xpm
share/valknut/icons/appl/default/splash.xpm
share/valknut/icons/appl/default/spy.xpm
share/valknut/icons/appl/default/ssl_no.xpm
share/valknut/icons/appl/default/ssl_yes.xpm
share/valknut/icons/appl/default/transfer.xpm
share/valknut/icons/appl/default/translate.xpm
share/valknut/icons/appl/default/up.xpm
share/valknut/icons/appl/default/view_sidetree.xpm
share/valknut/icons/emot/default/emoticons.xml
share/valknut/icons/emot/default/emoticons.xpm
share/valknut/icons/user/default/usericons.xml
share/valknut/icons/user/default/usericons.xpm
share/valknut/translation/valknut.bs.qm
share/valknut/translation/valknut.cs.qm
share/valknut/translation/valknut.da.qm
share/valknut/translation/valknut.de.qm
share/valknut/translation/valknut.el.qm
share/valknut/translation/valknut.en_GB.qm
share/valknut/translation/valknut.es.qm
share/valknut/translation/valknut.fi.qm
share/valknut/translation/valknut.fr.qm
share/valknut/translation/valknut.hu.qm
share/valknut/translation/valknut.is.qm
share/valknut/translation/valknut.it.qm
share/valknut/translation/valknut.lv.qm
share/valknut/translation/valknut.nb.qm
share/valknut/translation/valknut.nl.qm
share/valknut/translation/valknut.pl.qm
share/valknut/translation/valknut.pt_br.qm
share/valknut/translation/valknut.ro.qm
share/valknut/translation/valknut.rus.qm
share/valknut/translation/valknut.sk.qm
share/valknut/translation/valknut.sv.qm
@dirrm share/valknut/icons/appl/default
@dirrm share/valknut/icons/appl
@dirrm share/valknut/icons/emot/default
@dirrm share/valknut/icons/emot
@dirrm share/valknut/icons/user/default
@dirrm share/valknut/icons/user
@dirrm share/valknut/icons
@dirrm share/valknut/sounds/default
@dirrm share/valknut/sounds
@dirrm share/valknut/translation
@dirrm share/valknut

View file

@ -1,2 +0,0 @@
Make it able to shutdown properly without
PTHREAD_DIAGASSERT=A set in the environment.

View file

@ -1,4 +0,0 @@
$NetBSD: distinfo,v 1.6 2006/02/15 17:47:52 tnn2 Exp $
SHA1 (patch-aa) = fad21b0e93a654573af7a9f729cd8b53fc095884
SHA1 (patch-ab) = b825bb401e892cdeffcd9b154c6f4a70114eed74

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 2006/02/15 17:47:53 tnn2 Exp $
--- admin/acinclude.m4.in.orig 2006-02-15 18:12:11.000000000 +0100
+++ admin/acinclude.m4.in
@@ -2497,7 +2497,7 @@ dnl if headers _and_ libraries are missi
dnl continue with a warning (the user will get no jpeg support in khtml)
dnl if only one is missing, it means a configuration error, but we still
dnl only warn
-if test -n "$jpeg_incdir" && test -n "$LIBJPEG" ; then
+if test 1 = 1 ; then
AC_DEFINE_UNQUOTED(HAVE_LIBJPEG, 1, [Define if you have libjpeg])
else
if test -n "$jpeg_incdir" || test -n "$LIBJPEG" ; then

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ab,v 1.1 2006/02/15 17:48:40 tnn2 Exp $
--- admin/detect-autoconf.sh.orig 2006-02-15 15:34:07.000000000 +0100
+++ admin/detect-autoconf.sh
@@ -95,9 +95,5 @@ checkWhich ()
done
}
-checkWhich
-checkAutoconf
-checkAutoheader
-checkAutomakeAclocal
export WHICH AUTOHEADER AUTOCONF AUTOM4TE AUTOMAKE ACLOCAL