Update to version 1.2 (which incorporated patch-aa).
This commit is contained in:
parent
ab84c25e2d
commit
77c69bf3b3
3 changed files with 6 additions and 52 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.4 2007/08/10 15:02:35 bsadewitz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2007/09/10 06:10:45 bsadewitz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= openbsd-input-ws-1.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= openbsd-input-ws-1.2
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://xenocara.org/src/
|
||||
|
||||
|
@ -17,8 +16,6 @@ USE_LIBTOOL= yes
|
|||
USE_TOOLS+= pkg-config
|
||||
USE_LANGUAGES= c
|
||||
|
||||
CPPFLAGS+= -DMOTION_EVENT_HACK # XXX testing
|
||||
|
||||
.include "../../wip/modular-xorg-server/buildlink3.mk"
|
||||
.include "../../x11/xproto/buildlink3.mk"
|
||||
.include "../../x11/inputproto/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2007/08/10 15:02:35 bsadewitz Exp $
|
||||
$NetBSD: distinfo,v 1.4 2007/09/10 06:10:45 bsadewitz Exp $
|
||||
|
||||
SHA1 (openbsd-input-ws-1.1.tar.gz) = d74b53bd0efddd92873bc5b2b4064c98d91d3131
|
||||
RMD160 (openbsd-input-ws-1.1.tar.gz) = a37925b87c4cc136ba7149aa0505d2c49d6ce61d
|
||||
Size (openbsd-input-ws-1.1.tar.gz) = 318681 bytes
|
||||
SHA1 (openbsd-input-ws-1.2.tar.gz) = a313e27f8c3ce999e71b23eab9102e6332d16f9d
|
||||
RMD160 (openbsd-input-ws-1.2.tar.gz) = 39d3244c5e11a3902fc385d68ece8704faf305bf
|
||||
Size (openbsd-input-ws-1.2.tar.gz) = 318780 bytes
|
||||
SHA1 (patch-aa) = 6567517dcee84dce931ae9a52ff96c33563f5c5b
|
||||
|
|
|
@ -1,43 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2007/08/10 15:02:35 bsadewitz Exp $
|
||||
|
||||
--- src/ws.c.orig 2007-05-26 13:24:45.000000000 -0400
|
||||
+++ src/ws.c
|
||||
@@ -371,8 +371,18 @@ wsProc(DeviceIntPtr pWS, int what)
|
||||
map[i + 1] = i + 1;
|
||||
InitPointerDeviceStruct((DevicePtr)pWS, map,
|
||||
min(priv->buttons, NBUTTONS),
|
||||
- miPointerGetMotionEvents, wsControlProc,
|
||||
- miPointerGetMotionBufferSize());
|
||||
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 0
|
||||
+ miPointerGetMotionEvents,
|
||||
+#else
|
||||
+ GetMotionHistory,
|
||||
+#endif
|
||||
+ wsControlProc,
|
||||
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 0
|
||||
+ miPointerGetMotionBufferSize()
|
||||
+#else
|
||||
+ GetMotionHistorySize(), NAXES
|
||||
+#endif
|
||||
+ );
|
||||
xf86InitValuatorAxisStruct(pWS, 0, 0, -1, 1, 0, 1);
|
||||
xf86InitValuatorDefaults(pWS, 0);
|
||||
|
||||
@@ -458,7 +468,7 @@ wsReadInput(InputInfoPtr pInfo)
|
||||
n /= sizeof(struct wscons_event);
|
||||
while( n-- ) {
|
||||
int buttons = priv->lastButtons;
|
||||
- int dx = 0, dy = 0, dz, dw = 0;
|
||||
+ int dx = 0, dy = 0, dz = 0, dw = 0;
|
||||
int zbutton = 0, wbutton = 0;
|
||||
|
||||
ax = 0; ay = 0;
|
||||
@@ -526,7 +536,7 @@ wsReadInput(InputInfoPtr pInfo)
|
||||
/* relative motion event */
|
||||
DBG(3, ErrorF("postMotionEvent dX %d dY %d\n",
|
||||
dx, dy));
|
||||
-#if 0
|
||||
+#ifdef MOTION_EVENT_HACK
|
||||
priv->x += dx;
|
||||
if (priv->x < priv->min_x) priv->x = priv->min_x;
|
||||
if (priv->x > priv->max_x) priv->x = priv->max_x;
|
Loading…
Reference in a new issue