Disable cppunit tests crashing on NetBSD
This commit is contained in:
parent
5832f2cdee
commit
785bd06d73
3 changed files with 50 additions and 0 deletions
16
libreoffice/patches/patch-hwpfilter_Module_hwpfilter.mk
Normal file
16
libreoffice/patches/patch-hwpfilter_Module_hwpfilter.mk
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-hwpfilter_Module_hwpfilter.mk,v 1.1 2011/10/24 14:34:36 ftigeot Exp $
|
||||
|
||||
--- hwpfilter/Module_hwpfilter.mk.orig 2011-10-17 16:49:48.000000000 +0000
|
||||
+++ hwpfilter/Module_hwpfilter.mk
|
||||
@@ -32,9 +32,11 @@ $(eval $(call gb_Module_add_targets,hwpf
|
||||
Library_hwp \
|
||||
))
|
||||
|
||||
+ifneq ($(OS),NETBSD)
|
||||
$(eval $(call gb_Module_add_check_targets,hwpfilter,\
|
||||
CppunitTest_hwpfilter_test_hwpfilter \
|
||||
RdbTarget_hwpfilter_test_hwpfilter \
|
||||
))
|
||||
+endif
|
||||
|
||||
# vim: set noet sw=4 ts=4:
|
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-lotuswordpro_Module_lotuswordpro.mk,v 1.1 2011/10/24 14:34:36 ftigeot Exp $
|
||||
|
||||
--- lotuswordpro/Module_lotuswordpro.mk.orig 2011-10-17 16:49:48.000000000 +0000
|
||||
+++ lotuswordpro/Module_lotuswordpro.mk
|
||||
@@ -32,9 +32,11 @@ $(eval $(call gb_Module_add_targets,lotu
|
||||
Library_lwpft \
|
||||
))
|
||||
|
||||
+ifneq ($(OS),NETBSD)
|
||||
$(eval $(call gb_Module_add_check_targets,lotuswordpro,\
|
||||
CppunitTest_lotuswordpro_test_lotuswordpro \
|
||||
RdbTarget_lotuswordpro_test_lotuswordpro \
|
||||
))
|
||||
+endif
|
||||
|
||||
# vim: set noet sw=4 ts=4:
|
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-writerfilter_Module_writerfilter.mk,v 1.1 2011/10/24 14:34:36 ftigeot Exp $
|
||||
|
||||
--- writerfilter/Module_writerfilter.mk.orig 2011-10-17 16:49:48.000000000 +0000
|
||||
+++ writerfilter/Module_writerfilter.mk
|
||||
@@ -38,11 +38,13 @@ $(eval $(call gb_Module_add_targets,writ
|
||||
Package_writerfilter_generated \
|
||||
))
|
||||
|
||||
+ifneq ($(OS),NETBSD)
|
||||
$(eval $(call gb_Module_add_check_targets,writerfilter,\
|
||||
CppunitTest_writerfilter_doctok \
|
||||
CppunitTest_writerfilter_rtftok \
|
||||
RdbTarget_writerfilter_rtftok \
|
||||
))
|
||||
+endif
|
||||
|
||||
$(eval $(call gb_Module_add_subsequentcheck_targets,writerfilter,\
|
||||
JunitTest_writerfilter_complex \
|
Loading…
Reference in a new issue