This is an updated version of x11/gdm, rewritten for GNOME 2.

x11/gdm-2.2.0 in pkgsrc is based on GNOME 1, so it should be renamed
when this package is moved to pkgsrc.
This commit is contained in:
Min Sik Kim 2004-01-10 04:11:20 +00:00 committed by Thomas Klausner
parent efd875a92b
commit 79768307e2
11 changed files with 8022 additions and 0 deletions

12
gdm/DESCR Normal file
View file

@ -0,0 +1,12 @@
GDM is the GNOME Display Manager, it is the little proggie that runs
in the background, runs your X sessions, presents you with a login box
and then tells you to piss off because you forgot your password. It
does pretty much everything that you would want to use xdm for, but
doesn't involve as much crack. It doesn't use any code from xdm, and
has a more paranoid and safer design overall. It also includes many
features over xdm, the biggest one of which is that it is more user
friendly, even if your X setup is failing. The goal is that users
should never, ever have to use the command line to customize or
troubleshoot gdm. It of course supports xdmcp, and in fact extends
xdmcp a little bit in places where I thought xdm was lacking (but is
still compatible with xdm's xdmcp).

104
gdm/Makefile Normal file
View file

@ -0,0 +1,104 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/01/10 04:11:20 minskim Exp $
#
DISTNAME= gdm-2.4.4.7
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gdm/2.4/} \
${MASTER_SITE_LOCAL}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= mjl@NetBSD.org
HOMEPAGE= http://www.gnome.org/
COMMENT= Gnome Display Manager - a re-implementation of the xdm program
USE_BUILDLINK2= YES
USE_PKGINSTALL= YES
USE_PKGLOCALEDIR= YES
GNU_CONFIGURE= YES
USE_X11= YES
USE_LIBTOOL= YES
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
LOCALSTATEDIR= /var
CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR}
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ENV+= X11BASE=${X11BASE} GDMOWN=${GDMOWN} GDMGRP=${GDMGRP}
MAKE_ENV+= ROOT_USER=${ROOT_USER} ROOT_GROUP=${ROOT_GROUP}
MAKE_ENV+= CHMOD=${CHMOD} CHOWN=${CHOWN}
PLIST_SUBST+= PKG_SYSCONFDIR=${PKG_SYSCONFDIR}
PLIST_SUBST+= LOCALSTATEDIR="${LOCALSTATEDIR}"
EGDIR= ${PREFIX}/share/examples
CONF_FILES= ${EGDIR}/dm/Sessions/default.desktop \
${PKG_SYSCONFDIR}/dm/Sessions/default.desktop
.for f in gdm.conf locale.alias \
modules/AccessDwellMouseEvents modules/AccessKeyMouseEvents \
modules/factory-AccessDwellMouseEvents \
modules/factory-AccessKeyMouseEvents
CONF_FILES+= ${EGDIR}/gdm/$f \
${PKG_SYSCONFDIR}/gdm/$f
.endfor
SUPPORT_FILES_MODE= 0755
.for f in Init/Default PostSession/Default PreSession/Default \
XKeepsCrashing Xsession
SUPPORT_FILES+= ${EGDIR}/gdm/$f \
${PKG_SYSCONFDIR}/gdm/$f
.endfor
RCD_SCRIPTS= gdm
SUBST_CLASSES+= desktop
SUBST_MESSAGE.desktop= "Enabling sessions."
SUBST_STAGE.desktop= post-patch
SUBST_FILES.desktop= config/default.desktop.in config/gnome.desktop.in
SUBST_SED.desktop= -e 's/^_//g'
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS"
CFLAGS+= -DSunOS
GDMOWN= daemon
GDMGRP= other
.else
GDMOWN= daemon
GDMGRP= daemon
.endif
BUILD_DEFS+= USE_PAM
.if defined(USE_PAM)
DEPENDS+= PAM-[0-9]*:../../security/PAM
PLIST_SUBST+= PAM_MISC=""
.else
PLIST_SUBST+= PAM_MISC="@comment "
SUBST_CLASSES+= pam
SUBST_MESSAGE.pam= "Disabling PAM."
SUBST_STAGE.pam= post-patch
SUBST_FILES.pam= configure
SUBST_SED.pam= -e 's:security/pam_appl.h:nopam:g'
.endif
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/gdm
${INSTALL_DATA} ${DISTDIR}/Daemon.README ${PREFIX}/share/doc/gdm
${INSTALL_DATA} ${DISTDIR}/Daemon.png ${PREFIX}/share/pixmaps
${MKDIR} -m 755 ${PKG_SYSCONFDIR}/dm/Sessions
${MKDIR} -m 755 ${PKG_SYSCONFDIR}/gdm/Init
${MKDIR} -m 755 ${PKG_SYSCONFDIR}/gdm/PostSession
${MKDIR} -m 755 ${PKG_SYSCONFDIR}/gdm/PreSession
${MKDIR} -m 755 ${PKG_SYSCONFDIR}/gdm/modules
.include "../../devel/gettext-lib/buildlink2.mk"
.include "../../devel/pkgconfig/buildlink2.mk"
.include "../../devel/libglade2/buildlink2.mk"
.include "../../devel/libgnome/buildlink2.mk"
.include "../../devel/libgnomeui/buildlink2.mk"
.include "../../graphics/libart2/buildlink2.mk"
.include "../../graphics/libgnomecanvas/buildlink2.mk"
.include "../../graphics/librsvg2/buildlink2.mk"
.include "../../textproc/intltool/buildlink2.mk"
.include "../../textproc/libxml2/buildlink2.mk"
.include "../../textproc/scrollkeeper/omf.mk"
.include "../../x11/gtk2/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

171
gdm/PLIST Normal file
View file

@ -0,0 +1,171 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/01/10 04:11:20 minskim Exp $
bin/gdm
bin/gdm-binary
bin/gdmXnest
bin/gdmXnestchooser
bin/gdmchooser
bin/gdmflexiserver
bin/gdmgreeter
bin/gdmlogin
bin/gdmphotosetup
bin/gdmsetup
bin/gdmthemetester
etc/rc.d/gdm
lib/gtk-2.0/modules/libdwellmouselistener.a
lib/gtk-2.0/modules/libdwellmouselistener.la
lib/gtk-2.0/modules/libdwellmouselistener.so
lib/gtk-2.0/modules/libkeymouselistener.a
lib/gtk-2.0/modules/libkeymouselistener.la
lib/gtk-2.0/modules/libkeymouselistener.so
${PAM_MISC}libexec/gdmaskpass
libexec/gdmtranslate
man/man1/gdm.1
sbin/gdm-restart
sbin/gdm-safe-restart
sbin/gdm-stop
sbin/gdmconfig
share/applications/gdmflexiserver-xnest.desktop
share/applications/gdmflexiserver.desktop
share/applications/gdmsetup.desktop
share/doc/gdm/Daemon.README
share/examples/dm/Sessions/default.desktop
share/examples/gdm/Init/Default
share/examples/gdm/PostLogin/Default.sample
share/examples/gdm/PostSession/Default
share/examples/gdm/PreSession/Default
share/examples/gdm/XKeepsCrashing
share/examples/gdm/Xsession
share/examples/gdm/factory-gdm.conf
share/examples/gdm/gdm.conf
share/examples/gdm/locale.alias
share/examples/gdm/modules/AccessDwellMouseEvents
share/examples/gdm/modules/AccessKeyMouseEvents
share/examples/gdm/modules/factory-AccessDwellMouseEvents
share/examples/gdm/modules/factory-AccessKeyMouseEvents
share/gdm/gdmchooser.glade
share/gdm/gdmsetup.glade
share/gdm/themes/circles/GdmGreeterTheme.desktop
share/gdm/themes/circles/background.svg
share/gdm/themes/circles/circles.xml
share/gdm/themes/circles/flower.png
share/gdm/themes/circles/help.png
share/gdm/themes/circles/options.png
share/gdm/themes/circles/screenshot.png
share/gdm/themes/happygnome-list/GdmGreeterTheme.desktop
share/gdm/themes/happygnome-list/background.svg
share/gdm/themes/happygnome-list/disconnect.png
share/gdm/themes/happygnome-list/gnome-logo.png
share/gdm/themes/happygnome-list/happygnome.xml
share/gdm/themes/happygnome-list/options.png
share/gdm/themes/happygnome-list/screenshot.png
share/gdm/themes/happygnome-list/session.png
share/gdm/themes/happygnome-list/system.png
share/gdm/themes/happygnome/GdmGreeterTheme.desktop
share/gdm/themes/happygnome/background.svg
share/gdm/themes/happygnome/disconnect.png
share/gdm/themes/happygnome/gnome-logo.png
share/gdm/themes/happygnome/happygnome.xml
share/gdm/themes/happygnome/options.png
share/gdm/themes/happygnome/screenshot.png
share/gdm/themes/happygnome/session.png
share/gdm/themes/happygnome/system.png
share/gnome/capplets/gdmphotosetup.desktop
share/gnome/help/gdm/C/gdm.xml
share/gnome/help/gdm/C/legal.xml
${PKGLOCALEDIR}/locale/am/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ar/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/az/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/be/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/bg/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/bn/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ca/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/cy/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/el/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/et/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/eu/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/fa/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/fi/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ga/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/gl/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/he/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/hi/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/hu/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/id/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/is/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ko/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/lt/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/lv/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/mk/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ml/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/mn/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ms/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/nn/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/no/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/pt/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ro/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/sk/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/sl/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/sq/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/sr/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/sr@Latn/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/ta/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/th/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/uk/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/vi/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/wa/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/gdm-2.4.mo
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/gdm-2.4.mo
share/omf/gdm/gdm-C.omf
share/pixmaps/Daemon.png
share/pixmaps/gdm-foot-logo.png
share/pixmaps/gdm.png
share/pixmaps/login-photo.png
share/pixmaps/nobody.png
share/pixmaps/nohost.png
share/xsessions/gnome.desktop
@dirrm share/xsessions
@dirrm share/omf/gdm
@comment in scrollkeeper @dirrm share/omf
@dirrm share/gnome/help/gdm/C
@dirrm share/gnome/help/gdm
@comment @dirrm share/gnome/help
@dirrm share/gnome/capplets
@comment @dirrm share/gnome
@dirrm share/gdm/themes/happygnome-list
@dirrm share/gdm/themes/happygnome
@dirrm share/gdm/themes/circles
@dirrm share/gdm/themes
@dirrm share/gdm
@dirrm share/examples/gdm/modules
@dirrm share/examples/gdm/PreSession
@dirrm share/examples/gdm/PostSession
@dirrm share/examples/gdm/PostLogin
@dirrm share/examples/gdm/Init
@dirrm share/examples/gdm
@dirrm share/examples/dm/Sessions
@dirrm share/examples/dm
@dirrm share/doc/gdm
@comment @dirrm share/doc
@comment @dirrm share/applications
@comment @dirrm lib/gtk-2.0/modules
@unexec ${RM} -rf ${LOCALSTATEDIR}/gdm
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/gdm/modules 2>/dev/null || ${TRUE}
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/gdm/PreSession 2>/dev/null || ${TRUE}
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/gdm/PostSession 2>/dev/null || ${TRUE}
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/gdm/Init 2>/dev/null || ${TRUE}
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/gdm 2>/dev/null || ${TRUE}
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/dm/Session 2>/dev/null || ${TRUE}
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/dm 2>/dev/null || ${TRUE}

10
gdm/distinfo Normal file
View file

@ -0,0 +1,10 @@
$NetBSD: distinfo,v 1.1.1.1 2004/01/10 04:11:20 minskim Exp $
SHA1 (gdm-2.4.4.7.tar.bz2) = 8db05c6f0af247fc3d6bc0c32e69df7991eff0ae
Size (gdm-2.4.4.7.tar.bz2) = 2430455 bytes
SHA1 (patch-aa) = c657cd53520bde72af2eb26fc87875396d7b0d34
SHA1 (patch-ab) = 049d4fe8b6e71239392e7a8bae00006103dff309
SHA1 (patch-ac) = d810e16076aa69070f238900198a0050eaf12516
SHA1 (patch-ad) = a27c73a296013919a3a2db155de8ae1b22a38f28
SHA1 (patch-ae) = ebe1efbe4cf5cbde9bad75e5f700c8449fa2ee0b
SHA1 (patch-af) = b60e8ec5ee7fd4afa4c8ca16303a7250fd60cc6e

20
gdm/files/gdm.sh Executable file
View file

@ -0,0 +1,20 @@
#!/bin/sh
#
# $NetBSD: gdm.sh,v 1.1.1.1 2004/01/10 04:11:20 minskim Exp $
#
# PROVIDE: gdm
# REQUIRE: DAEMON LOGIN wscons
# KEYWORD: shutdown
. /etc/rc.subr
name="gdm"
rcvar=$name
command="@PREFIX@/bin/${name}"
pidfile="/var/run/${name}.pid"
required_files="@PREFIX@/etc/gdm/gdm.conf"
extra_commands="reload"
load_rc_config $name
run_rc_command "$1"

7394
gdm/patches/patch-aa Normal file

File diff suppressed because it is too large Load diff

24
gdm/patches/patch-ab Normal file
View file

@ -0,0 +1,24 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/01/10 04:11:20 minskim Exp $
--- config/gdm.conf.in.orig 2003-10-10 16:03:16.000000000 -0500
+++ config/gdm.conf.in
@@ -68,8 +68,8 @@ TimedLoginDelay=30
# you should create these user and group. Anyone found running this as
# someone too privilaged will get a kick in the ass. This should have
# access to only the gdm directories and files.
-User=gdm
-Group=gdm
+User=@GDMOWN@
+Group=@GDMGRP@
# To try to kill all clients started at greeter time or in the Init script.
# doesn't always work, only if those clients have a window of their own
#KillInitClients=true
@@ -237,7 +237,7 @@ Browser=false
# although gdm will be able to read a standard locale.alias file as well.
#LocaleFile=@EXPANDED_LOCALEDIR@/locale.alias
# Logo shown in the standard greeter
-#Logo=@EXPANDED_PIXMAPDIR@/gdm-foot-logo.png
+Logo=@EXPANDED_PIXMAPDIR@/Daemon.png
# The standard greeter should shake if a user entered the wrong username or
# password. Kind of cool looking
#Quiver=true

13
gdm/patches/patch-ac Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 2004/01/10 04:11:26 minskim Exp $
--- gui/modules/Makefile.in.orig 2004-01-09 18:28:33.000000000 -0600
+++ gui/modules/Makefile.in
@@ -23,7 +23,7 @@ bindir = @bindir@
sbindir = @sbindir@
libexecdir = @libexecdir@
datadir = @datadir@
-sysconfdir = @sysconfdir@
+sysconfdir = @datadir@/examples
sharedstatedir = @sharedstatedir@
localstatedir = @localstatedir@
libdir = @libdir@

102
gdm/patches/patch-ad Normal file
View file

@ -0,0 +1,102 @@
$NetBSD: patch-ad,v 1.1.1.1 2004/01/10 04:11:26 minskim Exp $
--- config/locale.alias.orig 2003-03-15 04:31:02.000000000 -0600
+++ config/locale.alias
@@ -24,65 +24,65 @@ Belarusian be_BY.UTF-8,be_BY
Bengali bn_BD.UTF-8,bn_BD
Bengali(India) bn_IN.UTF-8,bn_IN
Bosnian bs_BA.UTF-8,bs_BA
-Bulgarian bg_BG.UTF-8,bg_BG
-Catalan ca_ES.UTF-8,ca_ES
+Bulgarian bg_BG.UTF-8,bg_BG.CP1251
+Catalan ca_ES.UTF-8,ca_ES.ISO8859-15
Chinese(simplified) zh_CN.UTF-8,zh_CN
Chinese(traditional) zh_TW.UTF-8,zh_TW
-Croatian hr_HR.UTF-8,hr_HR
-Czech cs_CZ.UTF-8,cs_CZ
-Danish da_DK.UTF-8,da_DK
-Dutch nl_NL.UTF-8,nl_NL
+Croatian hr_HR.UTF-8,hr_HR.ISO8859-2
+Czech cs_CZ.UTF-8,cs_CZ.ISO8859-2
+Danish da_DK.UTF-8,da_DK.ISO8859-15
+Dutch nl_NL.UTF-8,nl_NL.ISO8859-15
English(American) en_US.UTF-8,en_US
-English(Australian) en_AU.UTF-8,en_AU
-English(British) en_GB.UTF-8,en_GB
+English(Australian) en_AU.UTF-8,en_AU.ISO8859-15
+English(British) en_GB.UTF-8,en_GB.ISO8859-15
English(Ireland) en_IE.UTF-8,en_IE
-Estonian et_EE.UTF-8,et_EE
-Finnish fi_FI.UTF-8,fi_FI
-French fr_FR.UTF-8,fr_FR
-Galician gl_ES.UTF-8,gl_ES
-German de_DE.UTF-8,de_DE
-Greek el_GR.UTF-8,el_GR
+Estonian et_EE.UTF-8,et
+Finnish fi_FI.UTF-8,fi_FI.ISO8859-15
+French fr_FR.UTF-8,fr_FR.ISO8859-15
+Galician gl_ES.UTF-8,gl
+German de_DE.UTF-8,de_DE.ISO8859-15
+Greek el_GR.UTF-8,el_GR.ISO8859-7
Gujarati gu_IN.UTF-8,gu_IN
-Hebrew he_IL.UTF-8,he_IL
+Hebrew he_IL.UTF-8,he
Hindi hi_IN.UTF-8,hi_IN
-Hungarian hu_HU.UTF-8,hu_HU
-Icelandic is_IS.UTF-8,is_IS
-Indonesian id_ID.UTF-8,id_ID
+Hungarian hu_HU.UTF-8,hu_HU.ISO8859-2
+Icelandic is_IS.UTF-8,is_IS.ISO8859-15
+Indonesian id_ID.UTF-8,id
Interlingua ia.UTF-8,ia
Irish ga_IE.UTF-8,ga_IE
-Italian it_IT.UTF-8,it_IT
-Japanese ja_JP.UTF-8,ja_JP
+Italian it_IT.UTF-8,it_IT.ISO8859-15
+Japanese ja_JP.UTF-8,ja_JP.eucJP
Kannada kn_IN.UTF-8,kn_IN
Korean ko_KR.UTF-8,ko_KR
Latvian lv_LV.UTF-8,lv_LV
-Lithuanian lt_LT.UTF-8,lt_LT
+Lithuanian lt_LT.UTF-8,lt_LT.ISO8859-4
Macedonian mk_MK.UTF-8,mk_MK
Malayalam ml_IN.UTF-8,ml_IN
Malay ms_MY.UTF-8,ms_MY
Marathi mr_IN.UTF-8,mr_IN
Mongolian mn_MN.UTF-8,mn_MN
-Norwegian(bokmal) no_NO.UTF-8,no_NO
+Norwegian(bokmal) no_NO.UTF-8,no_NO.ISO8859-15
Norwegian(nynorsk) nn_NO.UTF-8,nn_NO
Oriya or_IN.UTF-8,or_IN
Panjabi pa_IN.UTF-8,pa_IN
Persian fa_IR.UTF-8,fa_IR
-Polish pl_PL.UTF-8,pl_PL
+Polish pl_PL.UTF-8,pl_PL.ISO8859-2
Portuguese(Brazilian) pt_BR.UTF-8,pt_BR
-Portuguese pt_PT.UTF-8,pt_PT
-Romanian ro_RO.UTF-8,ro_RO
-Russian ru_RU.UTF-8,ru_RU
+Portuguese pt_PT.UTF-8,pt_PT.ISO8859-15
+Romanian ro_RO.UTF-8,ro
+Russian ru_RU.UTF-8,ru_RU.CP866
Serbian sr_YU.UTF-8,sr_YU
-Slovak sk_SK.UTF-8,sk_SK
-Slovenian sl_SI.UTF-8,sl_SI
-Spanish es_ES.UTF-8,es_ES
+Slovak sk_SK.UTF-8,sk_SK.ISO8859-2
+Slovenian sl_SI.UTF-8,sl_SI.ISO8859-2
+Spanish es_ES.UTF-8,es_ES.ISO8859-15
Spanish(Mexico) es_MX.UTF-8,es_MX
Swedish(Finland) sv_FI.UTF-8,sv_FI
-Swedish sv_SE.UTF-8,sv_SE
+Swedish sv_SE.UTF-8,sv_SE.ISO8859-15
Tamil ta_IN.UTF-8,ta_IN
Telugu te_IN.UTF-8,te_IN
Thai th_TH.UTF-8,th_TH
-Turkish tr_TR.UTF-8,tr_TR
-Ukrainian uk_UA.UTF-8,uk_UA
+Turkish tr_TR.UTF-8,tr
+Ukrainian uk_UA.UTF-8,uk_UA.KOI8-U
Vietnamese vi_VN.UTF-8,vi_VN
Walloon wa_BE.UTF-8,wa_BE
Welsh cy_GB.UTF-8,cy_GB

114
gdm/patches/patch-ae Normal file
View file

@ -0,0 +1,114 @@
$NetBSD: patch-ae,v 1.1.1.1 2004/01/10 04:11:26 minskim Exp $
--- config/Makefile.in.orig 2003-12-31 12:31:32.000000000 -0600
+++ config/Makefile.in
@@ -23,7 +23,7 @@ bindir = @bindir@
sbindir = @sbindir@
libexecdir = @libexecdir@
datadir = @datadir@
-sysconfdir = @sysconfdir@
+sysconfdir = @datadir@/examples
sharedstatedir = @sharedstatedir@
localstatedir = @localstatedir@
libdir = @libdir@
@@ -303,11 +303,11 @@ gettextfoo.h: XKeepsCrashing Xsession.in
install-data-hook: gdm.conf Xsession gnome.desktop default.desktop CDE.desktop Default PostSession PreSession
if test '!' -d $(DESTDIR)$(confdir); then \
$(mkinstalldirs) $(DESTDIR)$(confdir); \
- chmod 755 $(DESTDIR)$(confdir); \
+ ${CHMOD} 755 $(DESTDIR)$(confdir); \
fi
if test '!' -d $(DESTDIR)$(crossconfdir); then \
$(mkinstalldirs) $(DESTDIR)$(crossconfdir); \
- chmod 755 $(DESTDIR)$(crossconfdir); \
+ ${CHMOD} 755 $(DESTDIR)$(crossconfdir); \
fi
-if cmp -s $(DESTDIR)$(confdir)/gdm.conf $(DESTDIR)$(confdir)/factory-gdm.conf > /dev/null 2>&1 ; then \
cp -f $(DESTDIR)$(confdir)/gdm.conf $(DESTDIR)$(confdir)/gdm.conf.orig; \
@@ -324,16 +324,16 @@ install-data-hook: gdm.conf Xsession gno
-if test -f $(DESTDIR)$(localedir)/locale.alias; then \
cp -f $(DESTDIR)$(localedir)/locale.alias $(DESTDIR)$(localedir)/locale.alias.orig; \
fi
- $(INSTALL_DATA) $(srcdir)/locale.alias $(DESTDIR)$(localedir)/locale.alias
+ $(INSTALL_DATA) $(srcdir)/locale.alias $(DESTDIR)$(confdir)/locale.alias
if test '!' -d $(DESTDIR)$(bisessdir); then \
$(mkinstalldirs) $(DESTDIR)$(bisessdir); \
- chmod 755 $(DESTDIR)$(bisessdir); \
+ ${CHMOD} 755 $(DESTDIR)$(bisessdir); \
fi
if test '!' -d $(DESTDIR)$(instsessdir); then \
$(mkinstalldirs) $(DESTDIR)$(instsessdir); \
- chmod 755 $(DESTDIR)$(instsessdir); \
+ ${CHMOD} 755 $(DESTDIR)$(instsessdir); \
fi
-if test -f $(DESTDIR)$(bisessdir)/Default.desktop; then \
@@ -364,7 +364,7 @@ install-data-hook: gdm.conf Xsession gno
if test '!' -d $(DESTDIR)$(initdir); then \
$(mkinstalldirs) $(DESTDIR)$(initdir); \
- chmod 755 $(DESTDIR)$(initdir); \
+ ${CHMOD} 755 $(DESTDIR)$(initdir); \
fi
-if test -f $(DESTDIR)$(initdir)/Default; then \
cp -f $(DESTDIR)$(initdir)/Default $(DESTDIR)$(initdir)/Default.orig; \
@@ -373,13 +373,13 @@ install-data-hook: gdm.conf Xsession gno
if test '!' -d $(DESTDIR)$(postlogindir); then \
$(mkinstalldirs) $(DESTDIR)$(postlogindir); \
- chmod 755 $(DESTDIR)$(postlogindir); \
+ ${CHMOD} 755 $(DESTDIR)$(postlogindir); \
fi
$(INSTALL_SCRIPT) $(srcdir)/PostLogin $(DESTDIR)$(postlogindir)/Default.sample
if test '!' -d $(DESTDIR)$(predir); then \
$(mkinstalldirs) $(DESTDIR)$(predir); \
- chmod 755 $(DESTDIR)$(predir); \
+ ${CHMOD} 755 $(DESTDIR)$(predir); \
fi
-if test -f $(DESTDIR)$(predir)/Default; then \
cp -f $(DESTDIR)$(predir)/Default $(DESTDIR)$(predir)/Default.orig; \
@@ -388,7 +388,7 @@ install-data-hook: gdm.conf Xsession gno
if test '!' -d $(DESTDIR)$(postdir); then \
$(mkinstalldirs) $(DESTDIR)$(postdir); \
- chmod 755 $(DESTDIR)$(postdir); \
+ ${CHMOD} 755 $(DESTDIR)$(postdir); \
fi
-if test -f $(DESTDIR)$(postdir)/Default; then \
cp -f $(DESTDIR)$(postdir)/Default $(DESTDIR)$(postdir)/Default.orig; \
@@ -397,26 +397,26 @@ install-data-hook: gdm.conf Xsession gno
if test '!' -d $(DESTDIR)$(gnomercdir); then \
$(mkinstalldirs) $(DESTDIR)$(gnomercdir); \
- chmod 755 $(DESTDIR)$(gnomercdir); \
+ ${CHMOD} 755 $(DESTDIR)$(gnomercdir); \
fi
if test '!' -d $(DESTDIR)$(logdir); then \
$(mkinstalldirs) $(DESTDIR)$(logdir); \
- chown root.root $(DESTDIR)$(logdir); \
- chmod 755 $(DESTDIR)$(logdir); \
+ ${CHOWN} ${ROOT_USER}.${ROOT_GROUP} $(DESTDIR)$(logdir); \
+ ${CHMOD} 755 $(DESTDIR)$(logdir); \
fi
if test '!' -d $(DESTDIR)$(authdir); then \
$(mkinstalldirs) $(DESTDIR)$(authdir); \
- chown root.gdm $(DESTDIR)$(authdir); \
- chmod 1770 $(DESTDIR)$(authdir); \
+ ${CHOWN} ${ROOT_USER}.@GDMGRP@ $(DESTDIR)$(authdir); \
+ ${CHMOD} 1770 $(DESTDIR)$(authdir); \
fi
system=`uname`; \
if test -f /usr/include/security/pam_appl.h; then \
if test '!' -d $(DESTDIR)$(PAM_PREFIX)/pam.d; then \
$(mkinstalldirs) $(DESTDIR)$(PAM_PREFIX)/pam.d; \
- chmod 755 $(DESTDIR)$(PAM_PREFIX)/pam.d; \
+ ${CHMOD} 755 $(DESTDIR)$(PAM_PREFIX)/pam.d; \
fi; \
if test $$system = Linux && test '!' -f $(DESTDIR)$(PAM_PREFIX)/pam.d/gdm; then \
$(INSTALL_DATA) gdm $(DESTDIR)$(PAM_PREFIX)/pam.d/gdm; \

58
gdm/patches/patch-af Normal file
View file

@ -0,0 +1,58 @@
$NetBSD: patch-af,v 1.1.1.1 2004/01/10 04:11:26 minskim Exp $
--- configure.in.orig 2003-12-31 12:09:09.000000000 -0600
+++ configure.in
@@ -145,6 +145,8 @@ fi
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(LDFLAGS)
+AC_SUBST(GDMOWN)
+AC_SUBST(GDMGRP)
dnl ## Language Support
GETTEXT_PACKAGE=gdm-2.4
@@ -537,29 +539,10 @@ else
AC_MSG_RESULT(no)
fi
-if test -x /usr/X11R6/bin/X; then
- X_PATH="/usr/bin/X11:/usr/X11R6/bin:/opt/X11R6/bin"
- X_SERVER_PATH="/usr/X11R6/bin"
- X_SERVER="/usr/X11R6/bin/X"
- X_CONF_PATH="/usr/bin/X11:/usr/X11R6/bin:/usr/local/bin:/opt/X11R6/bin"
-elif test -x /usr/openwin/bin/Xsun; then
- X_PATH="/usr/openwin/bin"
- X_SERVER_PATH="/usr/openwin/bin"
- X_SERVER="/usr/openwin/bin/Xsun"
- X_CONF_PATH="/usr/openwin/bin"
-elif test -x /opt/X11R6/bin/X; then
- X_PATH="/opt/X11R6/bin:/usr/X11R6/bin:/usr/bin/X11"
- X_SERVER_PATH="/opt/X11R6/bin"
- X_SERVER="/opt/X11R6/bin/X"
- X_CONF_PATH="/opt/X11R6/bin:/usr/local/bin:/usr/X11R6/bin:/usr/bin/X11"
-else
- # what to do, what to do, this is wrong, but this just sets the
- # defaults, perhaps this user is cross compiling or some such
- X_PATH="/usr/bin/X11:/usr/X11R6/bin:/opt/X11R6/bin"
- X_SERVER_PATH="/usr/X11R6/bin"
- X_SERVER="/usr/X11R6/bin/X"
- X_CONF_PATH="/usr/bin/X11:/usr/X11R6/bin:/usr/local/bin:/opt/X11R6/bin"
-fi
+X_PATH="${X11BASE}/bin"
+X_SERVER_PATH="${X11BASE}/bin"
+X_SERVER="${X11BASE}/bin/X"
+X_CONF_PATH="${X11BASE}/bin"
AC_SUBST(X_PATH)
AC_SUBST(X_SERVER)
AC_SUBST(X_SERVER_PATH)
@@ -612,7 +595,10 @@ po/Makefile.in
vicious-extensions/Makefile
docs/Makefile
docs/C/Makefile
+config/CDE.desktop
+config/default.desktop
config/gdm.conf
+config/gnome.desktop
config/Xsession
config/Default
config/PreSession