GPS::Garmin provides an object-oriented interface to Garmin

GPS receivers. This way it's possible to access the stored
tracks and waypoint on the receiver using the serial port.
Right now there is no possibility to transfer to the device.
This commit is contained in:
Ulrich Habel 2006-11-06 20:32:19 +00:00 committed by Thomas Klausner
parent a28c92b512
commit 79b2063615
6 changed files with 42 additions and 0 deletions

4
p5-GPS-Garmin/DESCR Normal file
View file

@ -0,0 +1,4 @@
GPS::Garmin provides an object-oriented interface to Garmin
GPS receivers. This way it's possible to access the stored
tracks and waypoint on the receiver using the serial port.
Right now there is no possibility to tranfer to the device.

18
p5-GPS-Garmin/Makefile Normal file
View file

@ -0,0 +1,18 @@
# $NetBSD: Makefile,v 1.1.1.1 2006/11/06 20:32:19 uhabel Exp $
DISTNAME= perl-GPS-0.15
PKGNAME= p5-GPS-Garmin-0.15
CATEGORIES= perl5 geography
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=../by-authors/id/S/SR/SREZIC/}
MAINTAINER= uli@habel.name
HOMEPAGE= http://search.cpan.org/dist/perl-GPS/
COMMENT= GPS::Garmin access module for Perl
PKG_INSTALLATION_TYPES= overwrite pkgviews
PERL5_PACKLIST= auto/GPS/Garmin/.packlist
DEPENDS+= p5-Device-SerialPort>=0.12:../../comms/p5-Device-SerialPort
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

1
p5-GPS-Garmin/PLIST Normal file
View file

@ -0,0 +1 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/11/06 20:32:19 uhabel Exp $

2
p5-GPS-Garmin/TODO Normal file
View file

@ -0,0 +1,2 @@
Package itself seems to be finished. perl-GPS is somewhat unmaintained and newer GPS devices are not supported. If you use a Garmin etrex I included a patch for it.
Ulrich Habel <uli@habel.name>

6
p5-GPS-Garmin/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2006/11/06 20:32:19 uhabel Exp $
SHA1 (perl-GPS-0.15.tar.gz) = c8f67b2018b4c9785cffe6091776d0d229403cc0
RMD160 (perl-GPS-0.15.tar.gz) = 5d5396db4684ca63ed0d2ed02dbf8e595f528735
Size (perl-GPS-0.15.tar.gz) = 23657 bytes
SHA1 (patch-aa) = 3d3903421f81459121d25f88e2052deebe56eea0

View file

@ -0,0 +1,11 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/11/06 20:32:19 uhabel Exp $
--- Garmin.pm.orig 2006-11-04 00:39:10.000000000 +0100
+++ Garmin.pm 2006-11-04 00:39:37.000000000 +0100
@@ -169,6 +169,7 @@
|| $self->{product_id} == 315 # etrex vista c
|| $self->{product_id} == 111 # emap
|| $self->{product_id} == 248 # gecko 201
+ || $self->{product_id} == 295 # etrex yellow
# XXX add more devices here ...
) {
$self->{handler} = GPS::Garmin::Handler::EtrexVenture->new($self);