Initial import of dasm 212.

Package provided by mor <mor@linex.com> via PR pkg/19899.

DASM is a highly evolved cross assembler for
6502, 6803 and 68HC11 processors.  Very
popular for hacking/cross-devoloping on
old 6502-based video game systems from
Atari, Nintendo, etc... Processes output
from the Distella Atari ROM disassembler
(also in pkgsrc/devel) without modification.
This commit is contained in:
Juan Romero Pardines 2003-09-17 18:38:53 +00:00
parent efbeb0abb1
commit 7c1a45d460
7 changed files with 84 additions and 0 deletions

7
dasm/DESCR Normal file
View file

@ -0,0 +1,7 @@
DASM is a highly evolved cross assembler for
6502, 6803 and 68HC11 processors. Very
popular for hacking/cross-devoloping on
old 6502-based video game systems from
Atari, Nintendo, etc... Processes output
from the Distella Atari ROM disassembler
(also in pkgsrc/devel) without modification.

27
dasm/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/09/17 18:38:53 xtraeme Exp $
#
DISTNAME= dasm212
PKGNAME= dasm-2.12
CATEGORIES= devel cross
MASTER_SITES= http://members.cox.net/rcolbert/zip/
EXTRACT_SUFX= .zip
MAINTAINER= mor@linex.com
HOMEPAGE= http://members.cox.net/rcolbert/index.htm
COMMENT= Professional-grade multi-CPU cross-assembler for 6502, 6803 and 68HC11
NO_CONFIGURE: YES
post-extract:
${MKDIR} ${WRKSRC}
${MV} ${WRKDIR}/*.c ${WRKSRC}
${MV} ${WRKDIR}/*.h ${WRKSRC}
do-build:
@files/build.sh ${WRKSRC} ${CC}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dasm ${PREFIX}/bin
.include "../../mk/bsd.pkg.mk"

1
dasm/PLIST Normal file
View file

@ -0,0 +1 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/09/17 18:38:53 xtraeme Exp $

7
dasm/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2003/09/17 18:38:53 xtraeme Exp $
SHA1 (dasm212.zip) = cf14367131bc3490ab75a349d07ee276e114967d
Size (dasm212.zip) = 63734 bytes
SHA1 (patch-aa) = d55b2bae98b9ffc97ecb8346cd5d76d7f679bdbf
SHA1 (patch-ab) = fe0be091de33cb637828fb02b9e184425126923b
SHA1 (build.sh) = 56eef59dc399d80059371b7f1153e031d6478386

13
dasm/files/build.sh Executable file
View file

@ -0,0 +1,13 @@
#!/bin/sh
WRKSRC="$1"
CC="$2"
cd ${WRKSRC}
for obj in mne6502 mne6303 mne6811 mne68705 ops globals main symbols exp ; do
echo "compile object: $obj.c -> $obj.o"
${CC} -g -O2 -c -o $obj.o $obj.c ; done
echo "compile mne6502.o mne6303.o mne6811.o mne68705.o ops.o globals.o main.o symbols.o exp. -> dasm"
${CC} -g -O2 -o dasm mne6502.o mne6303.o mne6811.o mne68705.o ops.o globals.o main.o symbols.o exp.o

13
dasm/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/09/17 18:38:53 xtraeme Exp $
--- asm.h.orig Thu Feb 26 19:54:52 1998
+++ asm.h Sat Jan 18 00:47:24 2003
@@ -40,7 +40,7 @@
typedef unsigned char ubyte;
typedef unsigned uword;
-typedef long ulong;
+// typedef long ulong;
#define MNE struct _MNE
#define MACRO struct _MACRO

16
dasm/patches/patch-ab Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/09/17 18:38:53 xtraeme Exp $
--- main.c.orig Mon Mar 2 06:28:34 1998
+++ main.c Sat Jan 18 00:47:53 2003
@@ -199,9 +199,9 @@
#if OlafDol
Localdollarindex = Lastlocaldollarindex = 0;
#endif
- _fmode = 0x8000;
+ // _fmode = 0x8000;
FI_temp = fopen(F_outfile, "w");
- _fmode = 0;
+ // _fmode = 0;
Fisclear = 1;
CheckSum = 0;
if (FI_temp == NULL) {