Import maloc-1.4 as wip/maloc.

MALOC (Minimal Abstraction Layer for Object-oriented C) is a small, portable,
abstract C environment library for object-oriented C programming. MALOC is used
as the foundation layer for a number of scientific applications, including MC,
SG, and APBS. MALOC can be used as a small stand-alone abstraction
environment for writing portable C programs which need access to resources which
are typically architecture dependent, such as INET sockets, timing routines, and
so on. MALOC provides abstract datatypes, memory management routines, timing
routines, machine epsilon, access to UNIX and INET sockets, MPI, and so on.
All things that can vary from one architecture to another are abstracted out of
an application code and placed in MALOC.
This commit is contained in:
Kamel Ibn Aziz Derouiche 2011-03-25 18:11:59 +00:00 committed by Thomas Klausner
parent 88c6bd4303
commit 7c25ddac93
6 changed files with 350 additions and 0 deletions

10
maloc/DESCR Normal file
View file

@ -0,0 +1,10 @@
MALOC (Minimal Abstraction Layer for Object-oriented C) is a small, portable,
abstract C environment library for object-oriented C programming. MALOC is used
as the foundation layer for a number of scientific applications, including MC,
SG, and APBS. MALOC can be used as a small stand-alone abstraction
environment for writing portable C programs which need access to resources which
are typically architecture dependent, such as INET sockets, timing routines, and
so on. MALOC provides abstract datatypes, memory management routines, timing
routines, machine epsilon, access to UNIX and INET sockets, MPI, and so on.
All things that can vary from one architecture to another are abstracted out of
an application code and placed in MALOC.

30
maloc/Makefile Normal file
View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/03/25 18:11:59 jihbed Exp $
#
DISTNAME= maloc-1.4
CATEGORIES= devel
MASTER_SITES= http://www.fetk.org/codes/download/
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= http://fetk.org/codes/maloc/
COMMENT= Minimal Abstraction Layer for Object-oriented C
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}/maloc
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= bison
USE_GNU_READLINE= yes
USE_LANGUAGES= c fortran
CONFIGURE_ARGS+= --enable-mpi
#CONFIGURE_ARGS+= --enable-efence
.include "../../devel/ncurses/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/mpi.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

267
maloc/PLIST Normal file
View file

@ -0,0 +1,267 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/03/25 18:11:59 jihbed Exp $
include/maloc/maloc.h
include/maloc/maloc_base.h
include/maloc/psh.h
include/maloc/vcom.h
include/maloc/vio.h
include/maloc/vmem.h
include/maloc/vmp.h
include/maloc/vmpi.h
include/maloc/vnm.h
include/maloc/vpred.h
include/maloc/vset.h
include/maloc/vsh.h
include/maloc/vsys.h
lib/libmaloc.la
share/doc/maloc/api/html/a00001.html
share/doc/maloc/api/html/a00002.html
share/doc/maloc/api/html/a00003.html
share/doc/maloc/api/html/a00004.html
share/doc/maloc/api/html/a00005.html
share/doc/maloc/api/html/a00006.html
share/doc/maloc/api/html/a00007.html
share/doc/maloc/api/html/a00008.html
share/doc/maloc/api/html/a00008_source.html
share/doc/maloc/api/html/a00009.html
share/doc/maloc/api/html/a00009_source.html
share/doc/maloc/api/html/a00010.html
share/doc/maloc/api/html/a00010_source.html
share/doc/maloc/api/html/a00011.html
share/doc/maloc/api/html/a00011_source.html
share/doc/maloc/api/html/a00012.html
share/doc/maloc/api/html/a00012_source.html
share/doc/maloc/api/html/a00013.html
share/doc/maloc/api/html/a00013_source.html
share/doc/maloc/api/html/a00014.html
share/doc/maloc/api/html/a00014_source.html
share/doc/maloc/api/html/a00015.html
share/doc/maloc/api/html/a00015_source.html
share/doc/maloc/api/html/a00016.html
share/doc/maloc/api/html/a00016_source.html
share/doc/maloc/api/html/a00017.html
share/doc/maloc/api/html/a00017_source.html
share/doc/maloc/api/html/a00018.html
share/doc/maloc/api/html/a00018_source.html
share/doc/maloc/api/html/a00019.html
share/doc/maloc/api/html/a00019_source.html
share/doc/maloc/api/html/a00020.html
share/doc/maloc/api/html/a00020_source.html
share/doc/maloc/api/html/a00021.html
share/doc/maloc/api/html/a00021_source.html
share/doc/maloc/api/html/a00022.html
share/doc/maloc/api/html/a00022_source.html
share/doc/maloc/api/html/a00023.html
share/doc/maloc/api/html/a00024.html
share/doc/maloc/api/html/a00025.html
share/doc/maloc/api/html/a00026.html
share/doc/maloc/api/html/a00027.html
share/doc/maloc/api/html/a00028.html
share/doc/maloc/api/html/a00029.html
share/doc/maloc/api/html/a00030.html
share/doc/maloc/api/html/a00032.map
share/doc/maloc/api/html/a00032.md5
share/doc/maloc/api/html/a00032.png
share/doc/maloc/api/html/a00033.map
share/doc/maloc/api/html/a00033.md5
share/doc/maloc/api/html/a00033.png
share/doc/maloc/api/html/a00034.map
share/doc/maloc/api/html/a00034.md5
share/doc/maloc/api/html/a00034.png
share/doc/maloc/api/html/a00035.map
share/doc/maloc/api/html/a00035.md5
share/doc/maloc/api/html/a00035.png
share/doc/maloc/api/html/a00036.map
share/doc/maloc/api/html/a00036.md5
share/doc/maloc/api/html/a00036.png
share/doc/maloc/api/html/a00037.map
share/doc/maloc/api/html/a00037.md5
share/doc/maloc/api/html/a00037.png
share/doc/maloc/api/html/a00038.map
share/doc/maloc/api/html/a00038.md5
share/doc/maloc/api/html/a00038.png
share/doc/maloc/api/html/a00039.map
share/doc/maloc/api/html/a00039.md5
share/doc/maloc/api/html/a00039.png
share/doc/maloc/api/html/a00040.map
share/doc/maloc/api/html/a00040.md5
share/doc/maloc/api/html/a00040.png
share/doc/maloc/api/html/a00041.map
share/doc/maloc/api/html/a00041.md5
share/doc/maloc/api/html/a00041.png
share/doc/maloc/api/html/a00042.map
share/doc/maloc/api/html/a00042.md5
share/doc/maloc/api/html/a00042.png
share/doc/maloc/api/html/a00043.map
share/doc/maloc/api/html/a00043.md5
share/doc/maloc/api/html/a00043.png
share/doc/maloc/api/html/a00044.map
share/doc/maloc/api/html/a00044.md5
share/doc/maloc/api/html/a00044.png
share/doc/maloc/api/html/a00045.map
share/doc/maloc/api/html/a00045.md5
share/doc/maloc/api/html/a00045.png
share/doc/maloc/api/html/a00046.map
share/doc/maloc/api/html/a00046.md5
share/doc/maloc/api/html/a00046.png
share/doc/maloc/api/html/a00047.map
share/doc/maloc/api/html/a00047.md5
share/doc/maloc/api/html/a00047.png
share/doc/maloc/api/html/a00048.map
share/doc/maloc/api/html/a00048.md5
share/doc/maloc/api/html/a00048.png
share/doc/maloc/api/html/a00049.map
share/doc/maloc/api/html/a00049.md5
share/doc/maloc/api/html/a00049.png
share/doc/maloc/api/html/a00050.map
share/doc/maloc/api/html/a00050.md5
share/doc/maloc/api/html/a00050.png
share/doc/maloc/api/html/a00051.map
share/doc/maloc/api/html/a00051.md5
share/doc/maloc/api/html/a00051.png
share/doc/maloc/api/html/a00052.map
share/doc/maloc/api/html/a00052.md5
share/doc/maloc/api/html/a00052.png
share/doc/maloc/api/html/a00053.map
share/doc/maloc/api/html/a00053.md5
share/doc/maloc/api/html/a00053.png
share/doc/maloc/api/html/a00054.map
share/doc/maloc/api/html/a00054.md5
share/doc/maloc/api/html/a00054.png
share/doc/maloc/api/html/a00055.map
share/doc/maloc/api/html/a00055.md5
share/doc/maloc/api/html/a00055.png
share/doc/maloc/api/html/a00056.map
share/doc/maloc/api/html/a00056.md5
share/doc/maloc/api/html/a00056.png
share/doc/maloc/api/html/a00057.html
share/doc/maloc/api/html/a00058.html
share/doc/maloc/api/html/a00059.html
share/doc/maloc/api/html/a00060.html
share/doc/maloc/api/html/a00061.html
share/doc/maloc/api/html/a00062.map
share/doc/maloc/api/html/a00062.md5
share/doc/maloc/api/html/a00062.png
share/doc/maloc/api/html/a00063.html
share/doc/maloc/api/html/a00064.map
share/doc/maloc/api/html/a00064.md5
share/doc/maloc/api/html/a00064.png
share/doc/maloc/api/html/a00065.html
share/doc/maloc/api/html/annotated.html
share/doc/maloc/api/html/classes.html
share/doc/maloc/api/html/doxygen.png
share/doc/maloc/api/html/files.html
share/doc/maloc/api/html/functions.html
share/doc/maloc/api/html/functions_vars.html
share/doc/maloc/api/html/globals.html
share/doc/maloc/api/html/globals_0x65.html
share/doc/maloc/api/html/globals_0x69.html
share/doc/maloc/api/html/globals_0x6e.html
share/doc/maloc/api/html/globals_0x72.html
share/doc/maloc/api/html/globals_0x75.html
share/doc/maloc/api/html/globals_0x76.html
share/doc/maloc/api/html/globals_defs.html
share/doc/maloc/api/html/globals_enum.html
share/doc/maloc/api/html/globals_eval.html
share/doc/maloc/api/html/globals_func.html
share/doc/maloc/api/html/globals_type.html
share/doc/maloc/api/html/graph_legend.dot
share/doc/maloc/api/html/graph_legend.html
share/doc/maloc/api/html/graph_legend.png
share/doc/maloc/api/html/index.html
share/doc/maloc/api/html/maloc.css
share/doc/maloc/api/html/modules.html
share/doc/maloc/api/html/tab_b.gif
share/doc/maloc/api/html/tab_l.gif
share/doc/maloc/api/html/tab_r.gif
share/doc/maloc/api/html/tabs.css
share/doc/maloc/api/latex/Makefile
share/doc/maloc/api/latex/a00001.tex
share/doc/maloc/api/latex/a00002.tex
share/doc/maloc/api/latex/a00003.tex
share/doc/maloc/api/latex/a00004.tex
share/doc/maloc/api/latex/a00005.tex
share/doc/maloc/api/latex/a00006.tex
share/doc/maloc/api/latex/a00007.tex
share/doc/maloc/api/latex/a00008.tex
share/doc/maloc/api/latex/a00009.tex
share/doc/maloc/api/latex/a00010.tex
share/doc/maloc/api/latex/a00011.tex
share/doc/maloc/api/latex/a00012.tex
share/doc/maloc/api/latex/a00013.tex
share/doc/maloc/api/latex/a00014.tex
share/doc/maloc/api/latex/a00015.tex
share/doc/maloc/api/latex/a00016.tex
share/doc/maloc/api/latex/a00017.tex
share/doc/maloc/api/latex/a00018.tex
share/doc/maloc/api/latex/a00019.tex
share/doc/maloc/api/latex/a00020.tex
share/doc/maloc/api/latex/a00021.tex
share/doc/maloc/api/latex/a00022.tex
share/doc/maloc/api/latex/a00023.tex
share/doc/maloc/api/latex/a00024.tex
share/doc/maloc/api/latex/a00025.tex
share/doc/maloc/api/latex/a00026.tex
share/doc/maloc/api/latex/a00027.tex
share/doc/maloc/api/latex/a00028.tex
share/doc/maloc/api/latex/a00029.tex
share/doc/maloc/api/latex/a00030.tex
share/doc/maloc/api/latex/a00032.eps
share/doc/maloc/api/latex/a00032.md5
share/doc/maloc/api/latex/a00033.eps
share/doc/maloc/api/latex/a00033.md5
share/doc/maloc/api/latex/a00034.eps
share/doc/maloc/api/latex/a00034.md5
share/doc/maloc/api/latex/a00035.eps
share/doc/maloc/api/latex/a00035.md5
share/doc/maloc/api/latex/a00036.eps
share/doc/maloc/api/latex/a00036.md5
share/doc/maloc/api/latex/a00037.eps
share/doc/maloc/api/latex/a00037.md5
share/doc/maloc/api/latex/a00038.eps
share/doc/maloc/api/latex/a00038.md5
share/doc/maloc/api/latex/a00039.eps
share/doc/maloc/api/latex/a00039.md5
share/doc/maloc/api/latex/a00040.eps
share/doc/maloc/api/latex/a00040.md5
share/doc/maloc/api/latex/a00041.eps
share/doc/maloc/api/latex/a00041.md5
share/doc/maloc/api/latex/a00042.eps
share/doc/maloc/api/latex/a00042.md5
share/doc/maloc/api/latex/a00043.eps
share/doc/maloc/api/latex/a00043.md5
share/doc/maloc/api/latex/a00044.eps
share/doc/maloc/api/latex/a00044.md5
share/doc/maloc/api/latex/a00045.eps
share/doc/maloc/api/latex/a00045.md5
share/doc/maloc/api/latex/a00046.eps
share/doc/maloc/api/latex/a00046.md5
share/doc/maloc/api/latex/a00047.eps
share/doc/maloc/api/latex/a00047.md5
share/doc/maloc/api/latex/a00048.eps
share/doc/maloc/api/latex/a00048.md5
share/doc/maloc/api/latex/a00049.eps
share/doc/maloc/api/latex/a00049.md5
share/doc/maloc/api/latex/a00050.eps
share/doc/maloc/api/latex/a00050.md5
share/doc/maloc/api/latex/a00051.eps
share/doc/maloc/api/latex/a00051.md5
share/doc/maloc/api/latex/a00052.eps
share/doc/maloc/api/latex/a00052.md5
share/doc/maloc/api/latex/a00053.eps
share/doc/maloc/api/latex/a00053.md5
share/doc/maloc/api/latex/a00054.eps
share/doc/maloc/api/latex/a00054.md5
share/doc/maloc/api/latex/a00055.eps
share/doc/maloc/api/latex/a00055.md5
share/doc/maloc/api/latex/a00056.eps
share/doc/maloc/api/latex/a00056.md5
share/doc/maloc/api/latex/a00062.eps
share/doc/maloc/api/latex/a00062.md5
share/doc/maloc/api/latex/a00064.eps
share/doc/maloc/api/latex/a00064.md5
share/doc/maloc/api/latex/annotated.tex
share/doc/maloc/api/latex/doxygen.sty
share/doc/maloc/api/latex/files.tex
share/doc/maloc/api/latex/index.tex
share/doc/maloc/api/latex/modules.tex
share/doc/maloc/api/latex/refman.tex

13
maloc/buildlink3.mk Normal file
View file

@ -0,0 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/03/25 18:11:59 jihbed Exp $
BUILDLINK_TREE+= maloc
.if !defined(MALOC_BUILDLINK3_MK)
MALOC_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.maloc+= maloc>=1.4
BUILDLINK_PKGSRCDIR.maloc?= ../../wip/maloc
.endif # MALOC_BUILDLINK3_MK
BUILDLINK_TREE+= -maloc

6
maloc/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2011/03/25 18:11:59 jihbed Exp $
SHA1 (maloc-1.4.tar.gz) = e5a677463a88a8022babf0ed896cb086f00d10bd
RMD160 (maloc-1.4.tar.gz) = 52890e85bf94073409a30e80006ae933cc7b738b
Size (maloc-1.4.tar.gz) = 797520 bytes
SHA1 (patch-aa) = 043a8b358f5260f86de85a01e0e63726e88f0f0c

24
maloc/patches/patch-aa Normal file
View file

@ -0,0 +1,24 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/03/25 18:11:59 jihbed Exp $
--- doc/doxygen/Makefile.in.orig 2010-08-12 05:40:10.000000000 +0000
+++ doc/doxygen/Makefile.in 2010-12-22 16:22:51.000000000 +0000
@@ -178,7 +178,7 @@
builddir = @builddir@
datadir = @datadir@
datarootdir = @datarootdir@
-docdir = @prefix@/doc/maloc
+docdir = @prefix@/share/doc/maloc
dot_path = @dot_path@
doxygen_path = @doxygen_path@
dvidir = @dvidir@
@@ -434,8 +434,8 @@
$(doxygen_path) $(top_srcdir)/doc/doxygen/maloc.dox
install-docDATA:
- mkdir -p $(docdir)
- cp -r ../api $(docdir)/
+ mkdir -p $(DESTDIR)$(docdir)
+ cp -r ../api $(DESTDIR)$(docdir)/
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.