Import tc-2.3.1 (svn version) as wip/tc-svn.

TC2 provides T-Code and TUT-Code input methods for Emacs users. T-Code
and TUT-Code are called "Kanji Direct Input Method", and desiged to be
more efficient Japanese input method than Kana-Kanji translation.

For more infomation, please look into these web sites.
  T-Code   -> http://openlab.ring.gr.jp/tcode/index.html
           -> http://groups.google.com/group/tcode
  TUT-Code -> http://www.crew.sfc.keio.ac.jp/~chk/
This commit is contained in:
Makoto Fujiwara 2011-05-23 13:37:52 +00:00 committed by Thomas Klausner
parent 3fbdefab54
commit 7d64b9b0db
15 changed files with 409 additions and 0 deletions

8
tc-svn/DESCR Normal file
View file

@ -0,0 +1,8 @@
TC2 provides T-Code and TUT-Code input methods for Emacs users. T-Code
and TUT-Code are called "Kanji Direct Input Method", and desiged to be
more efficient Japanese input method than Kana-Kanji translation.
For more infomation, please look into these web sites.
T-Code -> http://openlab.ring.gr.jp/tcode/index.html
-> http://groups.google.com/group/tcode
TUT-Code -> http://www.crew.sfc.keio.ac.jp/~chk/

14
tc-svn/MESSAGE Normal file
View file

@ -0,0 +1,14 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
;; (1) README file in Japanese is at ${PREFIX}/share/tc/README.euc.
;; Please note the email address mentioned is obsolete now.
;; (2) setup file may be at ~/.tc and the sample is at
;; ${PREFIX}/share/example/tc/sample.tc
;;
;; (3) You may have following line in Emacs init file.
(set-language-environment 'Japanese)
(require 'tc-setup)
;; (4) use C-\ to toggle Japanese/Alphanumeric input
;; (5) Info at M-x info RET mT-code RET
;; (6) The personal setting may be at the value of tcode-data-directory.
===========================================================================

67
tc-svn/Makefile Normal file
View file

@ -0,0 +1,67 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
DISTNAME= tc-2.3.1
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME}
PKGREVISION= ${_SVN_PKGVERSION:S/.//g}
CATEGORIES= inputmethod
MAINTAINER= makoto@ki.nu
HOMEPAGE= http://openlab.ring.gr.jp/tcode/index.html
COMMENT= 2-stroke non associative direct input for Kanji
# tc is in GPL2, kw is unknown for the moment
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/tcode/tc
PKG_DESTDIR_SUPPORT= user-destdir
INSTALLATION_DIRS= ${EMACS_INFOPREFIX} \
${EMACS_LISPPREFIX}/${DISTNAME} \
share/examples/tc
EMACS_MODULES= base
# Instead of USE_TOOLS+=, avoid to conflict with autoconf
USE_TOOLS= aclocal automake14 autoconf213 gmake
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= ${CONFIGURE_ARGS.${EMACS_FLAVOR}}
MAKEFLAGS+= EMACS=${EMACS_BIN:Q}
MESSAGE_SUBST+= LISPDIR=${EMACS_LISPPREFIX:Q}
INFO_FILES= YES
SVN_ROOT.tcode= http://tcode.googlecode.com/svn/trunk/
SVN_REPOSITORIES= tcode
CONFIGURE_ARGS.emacs= --with-lispdir=${EMACS_LISPPREFIX}/${DISTNAME}
CONFIGURE_ARGS.emacs+= --datadir=${PREFIX}/share
#.include "options.mk"
PLIST_SUBST+= DISTNAME=${DISTNAME}
SUBST_CLASSES+= tc
SUBST_STAGE.tc= post-configure
SUBST_FILES.tc+= bushu-util/bushu2canna
SUBST_FILES.tc+= bushu-util/where
SUBST_FILES.tc+= mazegaki/mkcertain.pl
SUBST_SED.tc+= -e s\|@PERL@\|${PERL5:Q}\|g
##BUILD_DEPENDS+= automake14
.include "options.mk"
pre-configure:
( cd ${WRKSRC} && \
aclocal ;\
automake-1.4 --add-missing; \
autoconf ; \
)
post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/tc/README.euc
${INSTALL_DATA} ${WRKSRC}/doc/manual.pdf ${DESTDIR}${PREFIX}/share/tc
${INSTALL_DATA} ${WRKSRC}/doc/sample.tc ${DESTDIR}${PREFIX}/share/examples/tc
.include "../../editors/emacs/modules.mk"
.include "../../wip/mk/svn-package.mk"
.include "../../mk/bsd.pkg.mk"

88
tc-svn/PLIST Normal file
View file

@ -0,0 +1,88 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
bin/tcinput
info/tc.info
${EMACS_LISPPREFIX}/tc-2.3.1/eelll.el
${EMACS_LISPPREFIX}/tc-2.3.1/eelll.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-bitmap.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-bushu.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-bushu.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-complete.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-complete.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-help.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-help.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-image.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-inst.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-inst.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-is18.el
${NOTFOR_emacs22}${EMACS_LISPPREFIX}/tc-2.3.1/tc-is18.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-is19.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-is20.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-ja-alnum.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-ja-alnum.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-jiscode.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-jiscode.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-mazegaki.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-mazegaki.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-mkmzdic.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-pre.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-setup.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-setup.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-stat.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-stat.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-sysdep.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-tbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-tbl.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc-util.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc-util.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tc.el
${EMACS_LISPPREFIX}/tc-2.3.1/tc.elc
${EMACS_LISPPREFIX}/tc-2.3.1/try-etbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/try-etbl.elc
${EMACS_LISPPREFIX}/tc-2.3.1/try-tbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/try-tbl.elc
${EMACS_LISPPREFIX}/tc-2.3.1/ttc-ltbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/ttc-ltbl.elc
${EMACS_LISPPREFIX}/tc-2.3.1/ttc-rtbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/ttc-rtbl.elc
${EMACS_LISPPREFIX}/tc-2.3.1/ttc-tbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/ttc-tbl.elc
${EMACS_LISPPREFIX}/tc-2.3.1/tutc-tbl.el
${EMACS_LISPPREFIX}/tc-2.3.1/tutc-tbl.elc
share/examples/tc/sample.tc
share/tc/EELLLTXT
share/tc/EELLLTXT.tut
share/tc/README.euc
share/tc/bushu.expand
share/tc/bushu.index2
share/tc/bushu.rev
share/tc/bushu2canna
share/tc/ccdef.tcode
share/tc/greece.maz
share/tc/init.el
share/tc/itaiji.maz
share/tc/jukujiku.maz
share/tc/load-path.el
share/tc/manual.pdf
share/tc/mazegaki.dic
share/tc/mkcertain.pl
share/tc/order.txt
share/tc/parts.txt
share/tc/pd_kihon.yom
share/tc/skk-startup.el
share/tc/symbol.rev
share/tc/t1200.dat
share/tc/t1353.dat
share/tc/t225.dat
share/tc/t300.dat
share/tc/t400.dat
share/tc/t450.dat
share/tc/t575.dat
share/tc/t675.dat
share/tc/t900.dat
share/tc/tc-bitmap-8x16
share/tc/tc-ki2.el
share/tc/tc-skki.el
share/tc/tchars.txt
share/tc/tcode.txt
share/tc/want.txt
share/tc/where

11
tc-svn/distinfo Normal file
View file

@ -0,0 +1,11 @@
$NetBSD: distinfo,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
SHA1 (patch-BATCH-SORT) = 010e31b306445435b001d995dfcc8b5158d752e0
SHA1 (patch-bushu-util_bushu2canna) = 9573de81b6f9ef7a225fc954b618f7905e648821
SHA1 (patch-bushu-util_where) = 07bd3faf178ef57b9cc0afae20f56dbf83cc1d6d
SHA1 (patch-configure.in) = a49449a060880a7cc2bb8b3ccc2b239c585aab76
SHA1 (patch-etc_Makefile.am) = c7ace055cd1a7fa56f86443837eb8ec869912b8d
SHA1 (patch-etc_bushu.rev) = 53259ef27da2b3e57ff9834957c8ee9b2fe4f833
SHA1 (patch-lisp_tc-sysdep.el) = c084309d6e9a3aef480a5a2db9a8bda552f74570
SHA1 (patch-mazegaki_Makefile.am) = ad4781757a6eb4053e0999ddfd091ef33edca418
SHA1 (patch-mazegaki_mkcertain.pl) = d2b525316863aee93d2072b094adc45aba0fc55a

13
tc-svn/options.mk Normal file
View file

@ -0,0 +1,13 @@
# $NetBSD: options.mk,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.tc
PKG_SUPPORTED_OPTIONS= enable-symbol-rev
PKG_SUGGESTED_OPTIONS=
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Menable-symbol-rev)
# enable symbol.rev to be included in bushu.rev
# This will get, for example, upper arrow with UE(up) + YA(arrow)
CONFIGURE_ARGS+= --enable-symbol-rev
.endif

View file

@ -0,0 +1,46 @@
$NetBSD: patch-BATCH-SORT,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
Emacs code for batch-sort in emacs-internal-code
--- BATCH-SORT.orig 2011-04-14 07:32:32.000000000 +0000
+++ BATCH-SORT
@@ -0,0 +1,39 @@
+; -*- emacs-lisp -*-
+;;; batch-sort-file.el ---
+
+;; Copyright (C) 2010 Makoto Fujiwara
+
+;; Author: Makoto Fujiwara <makoto@modena.i.ki.nu>
+;; Keywords:
+
+;; This program is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation, either version 3 of the License, or
+;; (at your option) any later version.
+
+;; This program is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+
+;; You should have received a copy of the GNU General Public License
+;; along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+;;; Commentary:
+
+;;; Code:
+(provide 'batch-sort-file)
+
+(defun batch-sort-file()
+ "Just sort file, important thing is: done by emacs internal code order"
+ (interactive)
+ (set 'in_file (car command-line-args-left))
+ (set 'out_file(car (cdr command-line-args-left)))
+ (message (concat " *** sorting `" in_file "' to `" out_file "' by internal code order"))
+ (setq coding-system-for-read 'euc-japan)
+ (insert-file-contents in_file)
+ (sort-lines nil (point-min) (point-max))
+ (set-buffer-file-coding-system 'euc-japan)
+ (write-file out_file)
+)
+;;; batch-sort-file.el ends here

View file

@ -0,0 +1,12 @@
$NetBSD: patch-bushu-util_bushu2canna,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
Interpreter fix
--- bushu-util/bushu2canna.orig 2011-04-14 13:36:56.000000000 +0000
+++ bushu-util/bushu2canna
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl5
+#!@PERL@
$target = "bushu.select";
$target = shift if @ARGV;

View file

@ -0,0 +1,12 @@
$NetBSD: patch-bushu-util_where,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
Interpreter fix
--- bushu-util/where.orig 2011-04-14 13:36:56.000000000 +0000
+++ bushu-util/where
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl5
+#!@PERL@
require 5.000;

View file

@ -0,0 +1,33 @@
$NetBSD: patch-configure.in,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
Add --enable-symbol-rev for configure (by mef@)
--- configure.in.orig 2011-04-16 11:35:11.000000000 +0900
+++ configure.in 2011-04-16 16:51:55.000000000 +0900
@@ -35,6 +35,18 @@
--with-lispdir=DIR Emacs Lisp files in DIR,
lispdir=${withval})
+SYMBOLREV=no
+AC_ARG_ENABLE(symbol-rev,
+[AS_HELP_STRING([--enable-symbol-rev],
+ [Includes symbol.rev in bushu.rev Default: none])],
+if test "${enableval}" = "yes"; then
+ SYMBOLREV=yes
+else
+ SYMBOLREV=no
+fi
+)
+ AC_MSG_RESULT(checking symbol-rev .. ${SYMBOLREV})
+
dnl AC_ARG_WITH(makeinfo,dnl
dnl --with-makeinfo Specify how to build info files,
dnl [ MAKEINFO="$withval" ])
@@ -63,6 +75,7 @@
AC_SUBST(EMACS_PACKAGE_DIR)
AC_SUBST(MAKEINFO)
AC_SUBST(EMACS)
+AC_SUBST(SYMBOLREV)
AC_SUBST(INSTALL)
AC_SUBST(INSTALLINFO)
INSTALL_SCRIPT=$INSTALL

View file

@ -0,0 +1,34 @@
$NetBSD: patch-etc_Makefile.am,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
(1) To merge sybmol.rev (if configured with --enable-symbol-rev)
(2) To sort bushu.exand by emacs-internal-code order
--- etc/Makefile.am.orig 2011-04-24 20:50:27.000000000 +0900
+++ etc/Makefile.am 2011-04-25 00:25:25.000000000 +0900
@@ -4,11 +4,22 @@
pkgdata_DATA = $(DISTDATA) bushu.expand bushu.index2
EXTRA_DIST = $(DISTDATA) mk-bdic
+BATCH_SORT = ../BATCH-SORT
+RM = ${RM}
-bushu.expand bushu.index2: bushu.rev
- @echo '*** compiling bushu dictionary ***'
- @echo '*** this may take a few minutes ***'
+bushu.expand bushu.index2: bushu.rev $(BATCH_SORT)
+ @echo ' *** Taking care bushu.rev and sorting it'
+ @if [ .${SYMBOLREV} = ."yes" ]; then \
+ cat bushu.rev symbol.rev > bushu.rev.tmp ;\
+ echo ' *** symbol.rev will be included in bushu.rev ***'; \
+ else \
+ mv bushu.rev bushu.rev.tmp ;\
+ echo ' *** symbol.rev will NOT be included in bushu.rev ***'; \
+ fi
+ $(EMACS) -q -no-site-file -batch -l $(BATCH_SORT) -f batch-sort-file bushu.rev.tmp bushu.rev
+ @echo ' *** compiling bushu dictionary ***'
+ @echo ' *** this may take a few minutes ***'
$(EMACS) -q -no-site-file -batch -l $(srcdir)/mk-bdic
clean:
- $(RM) bushu.expand bushu.index2
+ $(RM) -f bushu.expand bushu.index2

View file

@ -0,0 +1,23 @@
$NetBSD: patch-etc_bushu.rev,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
Just adding few entries for combination.
--- etc/bushu.rev.orig 2011-04-24 20:50:27.000000000 +0900
+++ etc/bushu.rev 2011-04-24 21:04:34.000000000 +0900
@@ -594,6 +594,7 @@
九乙丿
倶イ具
句口勹
+筍竹旬
区匚メ
狗独句
玖王久
@@ -4184,7 +4185,7 @@
煥火奐
煕熙1
熈丿熙
-煦日句
+煦句点
煢勞丸
煌火皇
煖火爰

View file

@ -0,0 +1,15 @@
$NetBSD: patch-lisp_tc-sysdep.el,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
To work with emacs-22 or later
--- lisp/tc-sysdep.el.orig 2011-04-14 05:04:48.000000000 +0000
+++ lisp/tc-sysdep.el
@@ -228,7 +228,7 @@ BODY should be a list of lisp expression
;;;
;;; Fix incompatibilities between 18 and 19.
;;;
-(if (string-match "^\\(19\\|2[01]\\)" emacs-version)
+(if (string-match "^\\(19\\|2[0-9]\\)" emacs-version)
(progn
(defun tcode-redo-command (ch)
"キー CH を現在のキーマップで再実行する"

View file

@ -0,0 +1,21 @@
$NetBSD: patch-mazegaki_Makefile.am,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
To sort mazegaki.dic in emacs-internal-code order
--- mazegaki/Makefile.am.orig 2011-04-16 11:35:10.000000000 +0900
+++ mazegaki/Makefile.am 2011-04-16 21:34:16.000000000 +0900
@@ -14,11 +14,14 @@
$(DISTDATA)
DICS = greece.maz jukujiku.maz itaiji.maz
+BATCH_SORT = ../BATCH-SORT
RM = /bin/rm
mazegaki.dic: $(DICS)
$(RM) -f $@
$(EMACS) -q -no-site-file -batch -l $(srcdir)/mk-mzdic
+ mv mazegaki.dic mazegaki.dic.tmp
+ $(EMACS) -q -no-site-file -batch -l $(BATCH_SORT) -f batch-sort-file mazegaki.dic.tmp mazegaki.dic
# pd_kihon.yom: step1
# ./step2.pl

View file

@ -0,0 +1,12 @@
$NetBSD: patch-mazegaki_mkcertain.pl,v 1.1.1.1 2011/05/23 13:37:52 makoto Exp $
Interpreter fix
--- mazegaki/mkcertain.pl.orig 2011-04-14 14:10:06.000000000 +0000
+++ mazegaki/mkcertain.pl
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl5
+#!@PERL@
use Term::Cap;
use Term::Complete;