Update to 0.12.8

CHANGES:
0.12.8
    #560, space leak (fixed)
0.12.7
    Allow deepseq-1.3
    Allow QuickCheck-2.5
    Support bytestring-0.10 (NFData instances added)
0.12.6
    #515, don't crash on malformed characters (use ? instead)
0.12.5
    Add optRawTag to Render, to ensure script's don't get escaped
0.12.4
    #487, fix the behaviour of ~== for TagComment and others
0.12.3
    GHC 7.2 compatibility
0.12.2
    Add StringLike instances for Text
0.12.1
    Add parseOptionsEntities and improve documentation
0.12
    Upgrade to QuickCheck 2.4.*
    Export toTagRep
    Make the -download flag off by default
    Eliminate HTTP dependency
    Eliminate mtl dependency
0.11.1
    Support --flags=-download to eliminate the network dependency
0.11
    #326, <a "foo"> is no longer treated as an attribute
    Add Eq/Ord instances to Tree
    Don't mark Text.HTML.TagSoup.Tree as preliminary
    #325, \r should be treated as whitespace
0.10.1
    #322, don't change ' to &apos; in render (do what the docs say)
0.10
    Improve the cabal file, make the test program off by default
    Expose Text.HTML.TagSoup.Match again (was hidden accidentally)
0.9
    #294, let optEntityData see if there was a ';' (CHANGES API)
    Numeric/hex entities in attributes were misparsed
    #149, add escapeHTML function
This commit is contained in:
Ryosuke Moro 2013-08-21 15:44:27 +00:00 committed by Thomas Klausner
parent a71b9d2302
commit 7fe2b17e05
5 changed files with 10 additions and 49 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2010/02/09 04:12:57 phonohawk Exp $
# $NetBSD: Makefile,v 1.4 2013/08/21 15:44:27 szptvlfn Exp $
#
DISTNAME= tagsoup-0.8
DISTNAME= tagsoup-0.12.8
CATEGORIES= textproc
MAINTAINER= pho@cielonegro.org
@ -10,6 +10,5 @@ COMMENT= Haskell library for parsing unstructured HTML code
LICENSE= modified-bsd
.include "../../wip/mk/haskell.mk"
.include "../../wip/hs-mtl/buildlink3.mk"
.include "../../wip/hs-network/buildlink3.mk"
.include "../../wip/hs-text/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,5 @@
@comment $NetBSD: PLIST,v 1.3 2010/02/09 04:12:57 phonohawk Exp $
@comment $NetBSD: PLIST,v 1.4 2013/08/21 15:44:27 szptvlfn Exp $
lib/tagsoup-${PKGVERSION}/${HASKELL_VERSION}/HStagsoup-${PKGVERSION}.o
lib/tagsoup-${PKGVERSION}/${HASKELL_VERSION}/Text/HTML/Download.hi
lib/tagsoup-${PKGVERSION}/${HASKELL_VERSION}/Text/HTML/Download.p_hi
lib/tagsoup-${PKGVERSION}/${HASKELL_VERSION}/Text/HTML/TagSoup.hi
lib/tagsoup-${PKGVERSION}/${HASKELL_VERSION}/Text/HTML/TagSoup.p_hi
lib/tagsoup-${PKGVERSION}/${HASKELL_VERSION}/Text/HTML/TagSoup/Entity.hi

View file

@ -1,15 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.4 2010/02/09 04:12:57 phonohawk Exp $
# $NetBSD: buildlink3.mk,v 1.5 2013/08/21 15:44:27 szptvlfn Exp $
BUILDLINK_TREE+= hs-tagsoup
.if !defined(HS_TAGSOUP_BUILDLINK3_MK)
HS_TAGSOUP_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.hs-tagsoup+= hs-tagsoup>=0.8
BUILDLINK_API_DEPENDS.hs-tagsoup+= hs-tagsoup>=0.12.8
BUILDLINK_PKGSRCDIR.hs-tagsoup?= ../../wip/hs-tagsoup
.include "../../wip/hs-mtl/buildlink3.mk"
.include "../../wip/hs-network/buildlink3.mk"
.endif # HS_TAGSOUP_BUILDLINK3_MK
BUILDLINK_TREE+= -hs-tagsoup

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.2 2010/02/09 04:12:57 phonohawk Exp $
$NetBSD: distinfo,v 1.3 2013/08/21 15:44:27 szptvlfn Exp $
SHA1 (tagsoup-0.8.tar.gz) = 0ec3382ffb54c8e2812eed6e01f6e775739baf4d
RMD160 (tagsoup-0.8.tar.gz) = 9c2bad3d731f84e7e543ec32b54eb5f1bb8f6127
Size (tagsoup-0.8.tar.gz) = 28208 bytes
SHA1 (patch-aa) = 06b991b71006b66412d05eb7d1e6a4ccfd4c56e9
SHA1 (tagsoup-0.12.8.tar.gz) = b588803b0878897eef40de9b3cb6aa190ef02c06
RMD160 (tagsoup-0.12.8.tar.gz) = 70064ae8062411471981c746792c270571fe1ebe
Size (tagsoup-0.12.8.tar.gz) = 30647 bytes

View file

@ -1,33 +0,0 @@
$NetBSD: patch-aa,v 1.1 2010/02/09 04:12:57 phonohawk Exp $
--- tagsoup.cabal.orig 2010-01-08 05:13:27.000000000 +0900
+++ tagsoup.cabal
@@ -20,10 +20,6 @@ description:
extra-source-files:
tagsoup.htm
-flag testprog
- default: True
- description: Build the test program
-
library
ghc-options: -O2
build-depends: base == 4.*, network, mtl, containers, bytestring
@@ -44,17 +40,3 @@ library
Text.HTML.TagSoup.Render
Text.HTML.TagSoup.Specification
Text.HTML.TagSoup.Type
-
-executable tagsoup
- ghc-options: -O2
- if flag(testprog)
- buildable: True
- else
- buildable: False
- build-depends: QuickCheck == 2.1.*, time, deepseq == 1.1.0.0, HTTP
-
- main-is: Main.hs
- other-modules:
- TagSoup.Benchmark
- TagSoup.Sample
- TagSoup.Test