Fix build with png-1.4.

This commit is contained in:
Thomas Klausner 2010-06-22 10:38:33 +00:00
parent 0ca7d7127a
commit 81c04f0ddc
2 changed files with 32 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.3 2010/05/30 08:13:24 thomasklausner Exp $
$NetBSD: distinfo,v 1.4 2010/06/22 10:38:33 thomasklausner Exp $
SHA1 (patch-aa) = f64ce63ebc50f03d0d3bee793c2a81bf5d060c3f
SHA1 (patch-ab) = 0df33a50940c85c7c1c2514eae7a51f477896865
SHA1 (patch-ac) = 84d86fdc611bb07ab81719a856a50ae329a5c963
SHA1 (patch-alsa_m4) = ede3cde78b73945904e181a1cceb6e80be63c8e9
SHA1 (patch-audiooss_C) = e02915ba294100cd8394d618a309ac496bfdc652
SHA1 (patch-bluedottheme-Makefile_am) = cbb0ac28b6bcde2e91a03039e2747c3a59375882

View file

@ -0,0 +1,30 @@
$NetBSD: patch-ac,v 1.1 2010/06/22 10:38:33 thomasklausner Exp $
--- plugins/shapewipe/shapewipe.C.orig 2010-06-22 09:57:51.000000000 +0000
+++ plugins/shapewipe/shapewipe.C
@@ -386,7 +386,7 @@ int ShapeWipeMain::read_pattern_image(in
}
png_ptr = png_create_read_struct(PNG_LIBPNG_VER_STRING,
- png_voidp_NULL, png_error_ptr_NULL, png_error_ptr_NULL);
+ NULL, NULL, NULL);
if (!png_ptr)
{
@@ -399,14 +399,14 @@ int ShapeWipeMain::read_pattern_image(in
info_ptr = png_create_info_struct(png_ptr);
if (!info_ptr)
{
- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
+ png_destroy_read_struct(&png_ptr, NULL, NULL);
return 1;
}
end_info = png_create_info_struct(png_ptr);
if (!end_info)
{
- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
return 1;
}