Import mysql5-embedded, embedded version of MySQL 5 server.

From wiz, tweaked by me.
This commit is contained in:
Mark Davies 2008-11-09 20:00:22 +00:00 committed by Thomas Klausner
parent bd2fd13aee
commit 826c87cfe0
23 changed files with 566 additions and 0 deletions

15
mysql5-embedded/DESCR Normal file
View file

@ -0,0 +1,15 @@
MySQL is a SQL (Structured Query Language) database server. SQL is the
most popular database language in the world. MySQL is a client-server
implementation that consists of a server daemon `mysqld' and many
different client programs/libraries.
The main goals of MySQL are speed and robustness.
The base upon which MySQL is built is a set of routines that have been
used in a highly demanding production environment for many years. While
MySQL is still in development it already offers a rich and highly useful
function set.
The official way to pronounce 'MySQL' is 'My Ess Que Ell' (Not MY-SEQUEL).
This package contains the MySQL server programs and libraries.

69
mysql5-embedded/Makefile Normal file
View file

@ -0,0 +1,69 @@
# $NetBSD: Makefile,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
PKGNAME= ${DISTNAME:S/-/-embedded-/}
COMMENT= MySQL 5, a free SQL database (embedded)
PKG_DESTDIR_SUPPORT= user-destdir
.include "../../databases/mysql5-client/Makefile.common"
MAKE_JOBS_SAFE= no
CONFIGURE_ARGS+= --with-embedded-server
CONFIGURE_ARGS+= --with-libwrap
CONFIGURE_ARGS+= --with-raid
CONFIGURE_ARGS+= --without-berkeley-db
CONFIGURE_ARGS+= --without-mysqlfs
PTHREAD_OPTS+= require
CONFIGURE_ARGS+= --with-pthreads
BUILD_DIRS= strings regex mysys dbug myisam myisammrg heap innobase vio libmysqld
CFLAGS+= -fPIC -DPIC -I../libmysql
CXXFLAGS+= -fPIC -DPIC -I../libmysql
INSTALLATION_DIRS= lib/mysql
.include "../../mk/bsd.prefs.mk"
.if !empty(PKGSRC_COMPILER:Msunpro)
CFLAGS+= -D_POSIX_C_SOURCE=199506L -D__EXTENSIONS__
CXXFLAGS+= -D_POSIX_C_SOURCE=199506L -D__EXTENSIONS__
.endif
.include "../../databases/mysql5-client/buildlink3.mk"
.include "../../security/tcp_wrappers/buildlink3.mk"
# We only need readline to placate the configure script. None of the
# binaries are actually linked against -lreadline, so make this only
# a build-time dependency.
#
BUILDLINK_DEPMETHOD.readline= build
.include "../../devel/readline/buildlink3.mk"
post-configure:
cd ${WRKSRC}/include && cp -f config.h my_config.h
cd ${WRKSRC}/sql && mv client_settings.h away
post-build:
cd ${WRKSRC} && \
${MKDIR} libmysqld/work && \
cd libmysqld/work && \
ar -x ../libmysqld.a && \
${CC} -shared -Wl,-soname,libmysqld.so.0 -o libmysqld.so.0.0.1 *.o \
-lwrap -lz -lpthread -lcrypt -lssl -lcrypto -lrt -lstdc++ -lm -lc
do-install:
cd ${WRKSRC}/libmysqld && \
${INSTALL_LIB} libmysqld.a ${DESTDIR}${PREFIX}/lib/mysql
cd ${WRKSRC}/libmysqld/work && \
${INSTALL_LIB} libmysqld.so.0.0.1 ${DESTDIR}${PREFIX}/lib/mysql
cd ${DESTDIR}${PREFIX}/lib/mysql && ${RM} -f libmysqld.so && \
ln -s libmysqld.so.0.0.1 libmysqld.so
cd ${DESTDIR}${PREFIX}/lib/mysql && ${RM} -f libmysqld.so.0 && \
ln -s libmysqld.so.0.0.1 libmysqld.so.0
cd ${WRKSRC}/libmysqld/examples && \
${INSTALL_PROGRAM} mysql_client_test_embedded mysqltest_embedded \
${DESTDIR}${PREFIX}/bin
.include "../../mk/bsd.pkg.mk"

8
mysql5-embedded/PLIST Normal file
View file

@ -0,0 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
bin/mysql_client_test_embedded
bin/mysqltest_embedded
lib/mysql/libmysqld.a
lib/mysql/libmysqld.so
lib/mysql/libmysqld.so.0
lib/mysql/libmysqld.so.0.0.1
@unexec ${RMDIR} %D/lib/mysql 2>/dev/null || ${TRUE}

View file

@ -0,0 +1,23 @@
# $NetBSD: buildlink3.mk,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
MYSQL_EMBEDDED_BUILDLINK3_MK:= ${MYSQL_EMBEDDED_BUILDLINK3_MK}+
.if ${BUILDLINK_DEPTH} == "+"
BUILDLINK_DEPENDS+= mysql-embedded
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nmysql-embedded}
BUILDLINK_PACKAGES+= mysql-embedded
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}mysql-embedded
.if ${MYSQL_EMBEDDED_BUILDLINK3_MK} == "+"
BUILDLINK_API_DEPENDS.mysql-embedded+= mysql-embedded>=5.0.67
BUILDLINK_PKGSRCDIR.mysql-embedded?= ../../wip/mysql5-embedded
.endif # MYSQL_EMBEDDED_BUILDLINK3_MK
.include "../../databases/mysql5-client/buildlink3.mk"
.include "../../security/tcp_wrappers/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

23
mysql5-embedded/distinfo Normal file
View file

@ -0,0 +1,23 @@
$NetBSD: distinfo,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
SHA1 (mysql-5.0.67.tar.gz) = 168090a4698a3a5efa2f2c9380a4352d4433d377
RMD160 (mysql-5.0.67.tar.gz) = 05d38a5f8d91cb4dac1ee446af96b28163bd3722
Size (mysql-5.0.67.tar.gz) = 28370810 bytes
SHA1 (patch-aa) = 913ffbbd5ce8496f412d30515fb5ecef23854023
SHA1 (patch-ab) = 7d3ff56e929f93b4843d62014a3f5f37cc1e84bc
SHA1 (patch-ac) = 27ff5ccd1d3d1f8e4e9e72b74f723a3502357242
SHA1 (patch-ad) = b3246e3b2a666dffb72830c3ca30050a1e1263ca
SHA1 (patch-ae) = dc67ad03f9ea370b17a45f73e974013e0ac48d71
SHA1 (patch-af) = 256de04aefd067ac7bdf8a6d1d817723efa6c6ec
SHA1 (patch-ag) = 6412da46f0d891b64d90c2e3f9b79a1ec442d617
SHA1 (patch-ah) = 7f0a59e03ced1f0c5947a807d99cb6fad64be597
SHA1 (patch-ai) = 56d3f66a903224b8d27213480e7ea3e485e52f1d
SHA1 (patch-aj) = c3a0d3df30775e19017ca0835fbc15ea879b0c55
SHA1 (patch-ak) = 27698a132b42519e267dda0584a75eae1b74edea
SHA1 (patch-al) = 3b58ef9a835dc9cf39ff720516e5319d332f08f1
SHA1 (patch-am) = 3820fde3c4124822cba9a2e6265f21b08d8276d5
SHA1 (patch-an) = 4017b68e0b67c07810f756a2bfbc138ede5c954d
SHA1 (patch-bf) = 87be24d45f0d3f48ea2b911025eb41696d088299
SHA1 (patch-ca) = 97fe10dc40c5995b174f8e07dc5e22a72b9913f4
SHA1 (patch-cb) = f7dbc53f2405bf8a38c3d307dc68560a1b79ed01
SHA1 (patch-cc) = 0f4bc2bc83291c42381e39339e9b6507b7fd151a

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- Makefile.in.orig 2007-07-04 14:10:07.000000000 +0100
+++ Makefile.in 2007-07-15 18:10:44.000000000 +0100
@@ -374,12 +374,8 @@
EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
README COPYING EXCEPTIONS-CLIENT CMakeLists.txt
-SUBDIRS = . include @docs_dirs@ @zlib_dir@ @yassl_dir@ \
- @readline_topdir@ sql-common scripts \
- @thread_dirs@ pstack \
- @sql_union_dirs@ @man_dirs@ tests \
- netware @libmysqld_dirs@ \
- @bench_dirs@ support-files @tools_dirs@
+SUBDIRS = . include @thread_dirs@ pstack @sql_server_dirs@ tests \
+ @bench_dirs@ support-files
DIST_SUBDIRS = . include @docs_dirs@ zlib \
@readline_topdir@ sql-common \

View file

@ -0,0 +1,32 @@
$NetBSD: patch-ab,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- tests/Makefile.in.orig 2007-11-15 14:08:50.000000000 +0000
+++ tests/Makefile.in 2007-12-13 23:57:31.000000000 +0000
@@ -96,7 +96,7 @@
am_mysql_client_test_OBJECTS = mysql_client_test.$(OBJEXT) \
my_memmem.$(OBJEXT)
mysql_client_test_OBJECTS = $(am_mysql_client_test_OBJECTS)
-am__DEPENDENCIES_1 = $(top_builddir)/libmysql/libmysqlclient.la
+am__DEPENDENCIES_1 =
am__DEPENDENCIES_2 =
mysql_client_test_DEPENDENCIES = $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_2)
@@ -106,7 +106,7 @@
thread_test_SOURCES = thread_test.c
thread_test_OBJECTS = thread_test.$(OBJEXT)
thread_test_LDADD = $(LDADD)
-thread_test_DEPENDENCIES = $(top_builddir)/libmysql/libmysqlclient.la
+thread_test_DEPENDENCIES =
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/include
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@@ -404,8 +404,7 @@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
$(openssl_includes)
-LDADD = @CLIENT_EXTRA_LDFLAGS@ \
- $(top_builddir)/libmysql/libmysqlclient.la
+LDADD = @CLIENT_EXTRA_LDFLAGS@ -lmysqlclient
mysql_client_test_LDADD = $(LDADD) $(CXXLDFLAGS)
mysql_client_test_SOURCES = mysql_client_test.c\

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ac,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- libmysqld/examples/mysql.cc.orig 2008-08-04 12:19:04.000000000 +0000
+++ libmysqld/examples/mysql.cc
@@ -2263,9 +2263,9 @@ static char **new_mysql_completion (cons
*/
#if defined(USE_NEW_READLINE_INTERFACE) || defined(USE_LIBEDIT_INTERFACE)
-char *no_completion(const char*,int)
+int no_completion(const char*,int)
#else
-char *no_completion()
+int no_completion()
#endif
{
return 0; /* No filename completion */

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ad,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- sql/mysqld.cc.orig 2008-08-04 15:20:07.000000000 +0300
+++ sql/mysqld.cc 2008-09-16 13:46:29.000000000 +0300
@@ -181,7 +181,7 @@
int initgroups(const char *,unsigned int);
#endif
-#if defined(__FreeBSD__) && defined(HAVE_IEEEFP_H)
+#if (defined(__FreeBSD__) || defined(__DragonFly__)) && defined(HAVE_IEEEFP_H)
#include <ieeefp.h>
#ifdef HAVE_FP_EXCEPT // Fix type conflict
typedef fp_except fp_except_t;
@@ -3705,7 +3705,7 @@
init_ssl();
#ifdef HAVE_LIBWRAP
- libwrapName= my_progname+dirname_length(my_progname);
+ libwrapName= (char *)my_progname+dirname_length(my_progname);
openlog(libwrapName, LOG_PID, LOG_AUTH);
#endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- mysys/my_gethwaddr.c.orig 2007-03-05 20:21:11.000000000 +0100
+++ mysys/my_gethwaddr.c
@@ -30,7 +30,7 @@ static my_bool memcpy_and_test(uchar *to
return res;
}
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__DragonFly__)
#include <net/ethernet.h>
#include <sys/sysctl.h>

View file

@ -0,0 +1,15 @@
$NetBSD: patch-af,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
Patch reported: http://bugs.mysql.com/bug.php?id=23293&thanks=4
--- config/ac-macros/readline.m4.orig 2006-10-14 19:03:29.000000000 +0200
+++ config/ac-macros/readline.m4 2006-10-14 19:03:37.000000000 +0200
@@ -26,7 +26,7 @@
#include "readline/readline.h"
],
[
- char res= *(*rl_completion_entry_function)(0,0);
+ char res= (*rl_completion_entry_function)(0,0);
completion_matches(0,0);
],
[

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- man/Makefile.in.orig 2008-08-04 15:22:07.000000000 +0300
+++ man/Makefile.in 2008-09-16 13:48:02.000000000 +0300
@@ -354,7 +354,7 @@
yassl_libs = @yassl_libs@
yassl_taocrypt_extra_cxxflags = @yassl_taocrypt_extra_cxxflags@
zlib_dir = @zlib_dir@
-man1_MANS = @man1_files@
+man1_MANS = mysqld_multi.1
man8_MANS = @man8_files@
EXTRA_DIST = $(man1_MANS) $(man8_MANS)
all: all-am

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ah,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- include/Makefile.in.orig 2007-07-04 14:09:35.000000000 +0100
+++ include/Makefile.in 2007-07-15 18:12:08.000000000 +0100
@@ -364,13 +364,7 @@
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
my_list.h my_alloc.h typelib.h
-pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
- my_xml.h mysql_embed.h \
- my_pthread.h my_no_pthread.h raid.h \
- decimal.h errmsg.h my_global.h my_net.h \
- my_getopt.h sslopt-longopts.h my_dir.h \
- sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
- m_ctype.h my_attribute.h $(HEADERS_GEN)
+pkginclude_HEADERS =
noinst_HEADERS = config-win.h config-os2.h config-netware.h \
heap.h my_bitmap.h\

View file

@ -0,0 +1,30 @@
$NetBSD: patch-ai,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- include/my_pthread.h.orig 2008-08-04 15:19:12.000000000 +0300
+++ include/my_pthread.h 2008-09-16 13:48:57.000000000 +0300
@@ -18,7 +18,13 @@
#ifndef _my_pthread_h
#define _my_pthread_h
+/* defines __NetBSD_Version__ */
+#if defined(__NetBSD__)
+#include <sys/param.h>
+#endif
+
#include <errno.h>
+#include <signal.h>
#ifndef ETIME
#define ETIME ETIMEDOUT /* For FreeBSD */
#endif
@@ -326,7 +332,11 @@
#endif
#ifndef HAVE_NONPOSIX_SIGWAIT
+#if defined (__NetBSD__) && (__NetBSD_Version__ < 106130000)
+#define my_sigwait(A,B) __pthread_sigwait((A),(B))
+#else
#define my_sigwait(A,B) sigwait((A),(B))
+#endif
#else
int my_sigwait(const sigset_t *set,int *sig);
#endif

View file

@ -0,0 +1,103 @@
$NetBSD: patch-aj,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- scripts/mysqld_safe.sh.orig 2007-03-05 20:21:13.000000000 +0100
+++ scripts/mysqld_safe.sh
@@ -331,6 +331,14 @@ then
ulimit -c $core_file_size
fi
+datemsg()
+{
+ echo -n $(date +'%y%M%d %H:%M:%S')" "
+ echo "$*"
+}
+
+exec >>$err_log 2>&1
+
#
# If there exists an old pid file, check if the daemon is already running
# Note: The switches to 'ps' may depend on your operating system
@@ -341,18 +349,16 @@ then
then
if @FIND_PROC@
then # The pid contains a mysqld process
- echo "A mysqld process already exists"
- echo "A mysqld process already exists at " `date` >> $err_log
+ datemsg "A mysqld process already exists"
exit 1
fi
fi
rm -f $pid_file
if test -f $pid_file
then
- echo "Fatal error: Can't remove the pid file: $pid_file"
- echo "Fatal error: Can't remove the pid file: $pid_file at " `date` >> $err_log
- echo "Please remove it manually and start $0 again"
- echo "mysqld daemon not started"
+ datemsg "Fatal error: Can't remove the pid file: $pid_file"
+ datemsg "Please remove it manually and start $0 again"
+ datemsg "mysqld daemon not started"
exit 1
fi
fi
@@ -365,11 +371,11 @@ fi
# Alternatively, you can start mysqld with the "myisam-recover" option. See
# the manual for details.
#
-# echo "Checking tables in $DATADIR"
+# datemsg "Checking tables in $DATADIR"
# $MY_BASEDIR_VERSION/bin/myisamchk --silent --force --fast --medium-check $DATADIR/*/*.MYI
# $MY_BASEDIR_VERSION/bin/isamchk --silent --force $DATADIR/*/*.ISM
-echo "Starting $MYSQLD daemon with databases from $DATADIR"
+datemsg "Starting $MYSQLD daemon with databases from $DATADIR"
# Does this work on all systems?
#if type ulimit | grep "shell builtin" > /dev/null
@@ -377,7 +383,7 @@ echo "Starting $MYSQLD daemon with datab
# ulimit -n 256 > /dev/null 2>&1 # Fix for BSD and FreeBSD systems
#fi
-echo "`date +'%y%m%d %H:%M:%S mysqld started'`" >> $err_log
+datemsg "mysqld started"
while true
do
rm -f $safe_mysql_unix_port $pid_file # Some extra safety
@@ -389,7 +395,7 @@ do
fi
if test ! -f $pid_file # This is removed if normal shutdown
then
- echo "STOPPING server from pid file $pid_file"
+ datemsg "STOPPING server from pid file $pid_file"
break
fi
@@ -402,7 +408,7 @@ do
# kill -9 is used or the process won't react on the kill.
numofproces=`ps xaww | grep -v "grep" | grep "$ledir/$MYSQLD\>" | grep -c "pid-file=$pid_file"`
- echo -e "\nNumber of processes running now: $numofproces" | tee -a $err_log
+ datemsg -e "\nNumber of processes running now: $numofproces"
I=1
while test "$I" -le "$numofproces"
do
@@ -415,16 +421,14 @@ do
# echo "TEST $I - $T **"
if kill -9 $T
then
- echo "$MYSQLD process hanging, pid $T - killed" | tee -a $err_log
+ datemsg "$MYSQLD process hanging, pid $T - killed"
else
break
fi
I=`expr $I + 1`
done
fi
- echo "`date +'%y%m%d %H:%M:%S'` mysqld restarted" | tee -a $err_log
+ datemsg "mysqld restarted"
done
-echo "`date +'%y%m%d %H:%M:%S'` mysqld ended" | tee -a $err_log
-echo "" | tee -a $err_log
-
+datemsg "mysqld ended"

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ak,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- support-files/Makefile.in.orig 2007-11-15 14:08:49.000000000 +0000
+++ support-files/Makefile.in 2007-12-13 23:59:01.000000000 +0000
@@ -383,14 +383,7 @@
compiler_warnings.supp
SUBDIRS = MacOSX RHEL4-SElinux
-pkgdata_DATA = my-small.cnf \
- my-medium.cnf \
- my-large.cnf \
- my-huge.cnf \
- my-innodb-heavy-4G.cnf \
- mysql-log-rotate \
- binary-configure \
- ndb-config-2-node.ini
+pkgdata_DATA =
pkgdata_SCRIPTS = mysql.server \
mysqld_multi.server

View file

@ -0,0 +1,13 @@
$NetBSD: patch-al,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- myisam/Makefile.in.orig 2007-03-05 20:22:55.000000000 +0100
+++ myisam/Makefile.in
@@ -156,7 +156,7 @@ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUD
LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(DEFS) \
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
-CCLD = $(CC)
+CCLD = $(CXX)
LINK = $(LIBTOOL) --tag=CC --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
SOURCES = $(libmyisam_a_SOURCES) mi_test1.c mi_test2.c mi_test3.c \

View file

@ -0,0 +1,16 @@
$NetBSD: patch-am,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- extra/Makefile.in.orig 2007-05-21 06:05:42.000000000 +0200
+++ extra/Makefile.in 2007-05-21 06:05:59.000000000 +0200
@@ -437,10 +437,7 @@
../dbug/libdbug.a ../strings/libmystrings.a \
$(ZLIB_LIBS)
-BUILT_SOURCES = $(top_builddir)/include/mysqld_error.h \
- $(top_builddir)/include/sql_state.h \
- $(top_builddir)/include/mysqld_ername.h
-
+BUILT_SOURCES =
pkginclude_HEADERS = $(BUILT_SOURCES)
DISTCLEANFILES = $(BUILT_SOURCES)
# We never use SUBDIRS here, but needed for automake 1.6.3

View file

@ -0,0 +1,37 @@
$NetBSD: patch-an,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- mysql-test/Makefile.in.orig 2008-08-04 15:22:09.000000000 +0300
+++ mysql-test/Makefile.in 2008-09-16 13:52:20.000000000 +0300
@@ -371,7 +371,7 @@
@HAVE_NDBCLUSTER_DB_FALSE@USE_NDBCLUSTER = \"\"
@HAVE_NDBCLUSTER_DB_TRUE@USE_NDBCLUSTER = \"--ndbcluster\"
benchdir_root = $(prefix)
-testdir = $(benchdir_root)/mysql-test
+testdir = $(benchdir_root)/share/mysql-test
EXTRA_SCRIPTS = mysql-test-run-shell.sh install_test_db.sh valgrind.supp $(PRESCRIPTS)
EXTRA_DIST = $(EXTRA_SCRIPTS) suite
GENSCRIPTS = mysql-test-run-shell mysql-test-run install_test_db mtr
@@ -749,15 +749,14 @@
-rm -rf `find $(distdir)/suite -type d -name SCCS`
install-data-local:
- $(mkinstalldirs) \
- $(DESTDIR)$(testdir)/t \
- $(DESTDIR)$(testdir)/r \
- $(DESTDIR)$(testdir)/include \
- $(DESTDIR)$(testdir)/std_data \
- $(DESTDIR)$(testdir)/std_data/ndb_backup50_data_be \
- $(DESTDIR)$(testdir)/std_data/ndb_backup50_data_le \
- $(DESTDIR)$(testdir)/lib \
- $(DESTDIR)$(testdir)/std_data/funcs_1
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/t
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/r
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/include
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/std_data
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/std_data/ndb_backup50_data_be
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/std_data/ndb_backup50_data_le
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/lib
+ $(mkinstalldirs) $(DESTDIR)$(testdir)/std_data/funcs_1
$(INSTALL_DATA) $(srcdir)/README $(DESTDIR)$(testdir)
-$(INSTALL_DATA) $(srcdir)/t/*.def $(DESTDIR)$(testdir)/t
$(INSTALL_DATA) $(srcdir)/t/*.test $(DESTDIR)$(testdir)/t

View file

@ -0,0 +1,13 @@
$NetBSD: patch-bf,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
--- bdb/dist/configure.orig 2007-03-05 20:23:33.000000000 +0100
+++ bdb/dist/configure
@@ -5039,7 +5039,7 @@ fi
# we're using.
case "$host_os" in
sysv5UnixWare*|sysv5OpenUNIX8*)
- if test "$GCC" == "yes"; then
+ if test "$GCC" = "yes"; then
CPPFLAGS="$CPPFLAGS -pthread"
LDFLAGS="$LDFLAGS -pthread"
else

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ca,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
Before calling sigsend(), make sure the function actuall exists. Fixes
the build on NetBSD >= 4.99.49, in which the macro P_MYID is defined
somewhere unrelated to signals.
--- configure.in.orig 2008-08-04 15:19:07.000000000 +0300
+++ configure.in 2008-09-16 13:52:59.000000000 +0300
@@ -2001,7 +2001,7 @@
paths.h semaphore.h)
# Already-done: strcasecmp
-AC_CHECK_FUNCS(lstat putenv select setenv setlocale strcoll tcgetattr)
+AC_CHECK_FUNCS(lstat putenv select setenv setlocale sigsend strcoll tcgetattr)
AC_STAT_MACROS_BROKEN
MYSQL_SIGNAL_CHECK

View file

@ -0,0 +1,15 @@
$NetBSD: patch-cb,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
See patch-ca.
--- libmysqld/stacktrace.c.orig 2008-08-04 15:20:12.000000000 +0300
+++ libmysqld/stacktrace.c 2008-09-16 13:53:23.000000000 +0300
@@ -252,7 +252,7 @@
__gcov_flush();
#endif
pthread_kill(pthread_self(), sig);
-#if defined(P_MYID) && !defined(SCO)
+#if HAVE_SIGSEND && defined(P_MYID) && !defined(SCO)
/* On Solaris, the above kill is not enough */
sigsend(P_PID,P_MYID,sig);
#endif

View file

@ -0,0 +1,15 @@
$NetBSD: patch-cc,v 1.1 2008/11/09 20:00:22 mwdavies Exp $
See patch-ca.
--- sql/stacktrace.c.orig 2008-08-04 15:20:12.000000000 +0300
+++ sql/stacktrace.c 2008-09-16 13:53:45.000000000 +0300
@@ -252,7 +252,7 @@
__gcov_flush();
#endif
pthread_kill(pthread_self(), sig);
-#if defined(P_MYID) && !defined(SCO)
+#if HAVE_SIGSEND && defined(P_MYID) && !defined(SCO)
/* On Solaris, the above kill is not enough */
sigsend(P_PID,P_MYID,sig);
#endif