Update to 1.0.1.
This commit is contained in:
parent
fa1c567a2a
commit
82fb905739
5 changed files with 14 additions and 43 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.3 2010/09/04 10:57:57 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2010/09/07 09:30:33 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= groonga-1.0.0
|
||||
DISTNAME= groonga-1.0.1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://groonga.org/files/groonga/
|
||||
|
||||
|
@ -19,7 +19,7 @@ USE_TOOLS+= pkg-config
|
|||
.include "options.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR}
|
||||
CONFIGURE_ARGS+= --with-log-path=${VARBASE}/log/${PKGBASE}/${PKGBASE}.log
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
|
||||
PKGCONFIG_OVERRIDE+= groonga.pc.in
|
||||
|
||||
|
@ -30,6 +30,8 @@ INSTALL_MAKE_FLAGS+= sysconfdir=${PREFIX}/share/examples
|
|||
CONF_FILES+= share/examples/${PKGBASE}/groonga.conf \
|
||||
${PKGSYSCONFDIR}/groonga.conf
|
||||
|
||||
OWN_DIRS+= ${VARBASE}/log/${PKGBASE}
|
||||
|
||||
CHECK_WRKREF_SKIP+= bin/groonga
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2010/09/04 10:57:57 obache Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2010/09/07 09:30:33 obache Exp $
|
||||
bin/grntest
|
||||
bin/groonga
|
||||
include/groonga/groonga.h
|
||||
|
@ -8,6 +8,8 @@ lib/libgroonga.la
|
|||
lib/pkgconfig/groonga.pc
|
||||
man/man1/groonga.1
|
||||
share/examples/groonga/groonga.conf
|
||||
share/examples/groonga/init.d/redhat/groonga
|
||||
share/examples/groonga/init.d/redhat/sysconfig/groonga
|
||||
share/groonga/admin_html/css/admin.css
|
||||
share/groonga/admin_html/css/ui-lightness/images/ui-bg_diagonals-thick_18_b81900_40x40.png
|
||||
share/groonga/admin_html/css/ui-lightness/images/ui-bg_diagonals-thick_20_666666_40x40.png
|
||||
|
@ -29,6 +31,7 @@ share/groonga/admin_html/images/loading.gif
|
|||
share/groonga/admin_html/index.html
|
||||
share/groonga/admin_html/js/jquery-1.4.2.min.js
|
||||
share/groonga/admin_html/js/jquery-ui-1.8.1.custom.min.js
|
||||
share/groonga/admin_html/js/jquery.json-2.2.min.js
|
||||
share/groonga/doc/ja/html/.buildinfo
|
||||
share/groonga/doc/ja/html/_sources/characteristic.txt
|
||||
share/groonga/doc/ja/html/_sources/commands.txt
|
||||
|
@ -295,3 +298,4 @@ share/groonga/munin/plugins/groonga_memory
|
|||
share/groonga/munin/plugins/groonga_n_records
|
||||
share/groonga/munin/plugins/groonga_query_performance
|
||||
share/groonga/munin/plugins/groonga_status
|
||||
@pkgdir lib/groonga/modules/tokenizers
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2010/09/04 10:57:57 obache Exp $
|
||||
$NetBSD: distinfo,v 1.4 2010/09/07 09:30:33 obache Exp $
|
||||
|
||||
SHA1 (groonga-1.0.0.tar.gz) = d77e4f1fd37280b4dbfa61f1649cb2ac6d7c05cb
|
||||
RMD160 (groonga-1.0.0.tar.gz) = ac758b7716b635e99971f4025b5cdb700f8f478d
|
||||
Size (groonga-1.0.0.tar.gz) = 1569154 bytes
|
||||
SHA1 (groonga-1.0.1.tar.gz) = 50d79db24d750642e4019c24851c87091b0ce81b
|
||||
RMD160 (groonga-1.0.1.tar.gz) = 356d348cbcf0883df8ea10ccd4e1f0db8ad8beef
|
||||
Size (groonga-1.0.1.tar.gz) = 1601434 bytes
|
||||
SHA1 (patch-ac) = 2b65fedd57c822f36f66b0518ef4db8eca2416b3
|
||||
SHA1 (patch-ad) = a68cd2e7695163d1504a167dbfa63ed03262bb13
|
||||
SHA1 (patch-ae) = ba68675c82ed696eb6216319e5a6592881c5399c
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2010/09/04 10:57:57 obache Exp $
|
||||
|
||||
initialize variable
|
||||
http://sourceforge.jp/projects/groonga/lists/archive/commit/2010-September/000649.html
|
||||
|
||||
--- lib/util.c.orig 2010-08-25 05:03:33.000000000 +0000
|
||||
+++ lib/util.c
|
||||
@@ -554,7 +554,7 @@ grn_record_inspect(grn_ctx *ctx, grn_obj
|
||||
static grn_rc
|
||||
grn_uvector_record_inspect(grn_ctx *ctx, grn_obj *buf, grn_obj *obj)
|
||||
{
|
||||
- int i;
|
||||
+ int i = 0;
|
||||
grn_id *v, *ve;
|
||||
grn_obj record;
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2010/09/04 10:57:57 obache Exp $
|
||||
|
||||
suppress overflow
|
||||
http://sourceforge.jp/projects/groonga/lists/archive/commit/2010-September/000651.html
|
||||
|
||||
--- test/unit/core/test-inspect.c.orig 2010-08-06 04:36:11.000000000 +0000
|
||||
+++ test/unit/core/test-inspect.c
|
||||
@@ -307,7 +307,8 @@ test_time(void)
|
||||
g_time_val_from_iso8601("2010-05-31T11:50:29.29+0900", &g_time_value);
|
||||
time_value = grn_obj_open(context, GRN_BULK, 0, GRN_DB_TIME);
|
||||
GRN_TIME_SET(context, time_value,
|
||||
- g_time_value.tv_sec * G_USEC_PER_SEC + g_time_value.tv_usec);
|
||||
+ (gint64)g_time_value.tv_sec * G_USEC_PER_SEC +
|
||||
+ g_time_value.tv_usec);
|
||||
inspected = grn_inspect(context, NULL, time_value);
|
||||
cut_assert_equal_string(cut_take_printf("%ld.29", g_time_value.tv_sec),
|
||||
inspected_string());
|
Loading…
Reference in a new issue