alsa-plugins-jack: Import alsa-plugins-jack-1.1.1 as wip/alsa-plugins-jack

The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
functionality to the Linux operating system. ALSA has the following
significant features:

    * Efficient support for all types of audio interfaces, from consumer sound
      cards to professional multichannel audio interfaces.
    * Fully modularized sound drivers.
    * SMP and thread-safe design.
    * User space library (alsa-lib) to simplify application programming and
      provide higher level functionality.
    * Support for the older Open Sound System (OSS) API, providing binary
      compatibility for most OSS programs.

This package provides a jack plugin for ALSA.
This commit is contained in:
Yorick Hardy 2016-09-10 18:18:07 +02:00
parent 3de1d179b9
commit 8335da5316
7 changed files with 84 additions and 0 deletions

View file

@ -96,6 +96,7 @@ SUBDIR+= aldo
SUBDIR+= alive
SUBDIR+= alsa-lib-git
SUBDIR+= alsa-plugins
SUBDIR+= alsa-plugins-jack
SUBDIR+= alt-ergo
SUBDIR+= am-utils
SUBDIR+= am-utils-git

14
alsa-plugins-jack/DESCR Normal file
View file

@ -0,0 +1,14 @@
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
functionality to the Linux operating system. ALSA has the following
significant features:
* Efficient support for all types of audio interfaces, from consumer sound
cards to professional multichannel audio interfaces.
* Fully modularized sound drivers.
* SMP and thread-safe design.
* User space library (alsa-lib) to simplify application programming and
provide higher level functionality.
* Support for the older Open Sound System (OSS) API, providing binary
compatibility for most OSS programs.
This package provides an jack plugin for ALSA.

View file

@ -0,0 +1,32 @@
# $NetBSD$
#
DISTNAME= alsa-plugins-1.1.1
PKGNAME= ${DISTNAME:S/plugins/plugins-jack/}
CATEGORIES= audio
MASTER_SITES= ftp://ftp.alsa-project.org/pub/plugins/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.alsa-project.org/
COMMENT= Advanced Linux Sound Architecture (ALSA) - OSS plugin
LICENSE= gnu-lgpl-v2.1 OR gnu-gpl-v2
GNU_CONFIGURE= yes
USE_TOOLS= pkg-config gmake
USE_LIBTOOL= yes
.include "../../mk/bsd.prefs.mk"
CFLAGS.SunOS+= -DSOUND_MIXER_PHONEIN=SOUND_MIXER_PHONE
CFLAGS.SunOS+= -DSOUND_MIXER_PHONEOUT=SOUND_MIXER_MONO
CFLAGS.SunOS+= -DSOUND_MIXER_MONITOR=SOUND_MIXER_DEPTH
CFLAGS+= -DDEVOSSAUDIO=\"${DEVOSSAUDIO:U/dev/dsp}\"
LIBS+= ${LIBOSSAUDIO}
BUILD_DIRS= jack
.include "../../audio/alsa-lib/buildlink3.mk"
.include "../../audio/jack/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
alsa-plugins-jack/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD$
lib/alsa-lib/libasound_module_pcm_jack.la

View file

@ -0,0 +1,8 @@
$NetBSD$
SHA1 (alsa-plugins-1.1.1.tar.bz2) = 280eb0d9810e463059747d01760a5ac3f44d7057
RMD160 (alsa-plugins-1.1.1.tar.bz2) = a37a5d87a9760e6e4a1ac46179e5b19dc2e16ee0
SHA512 (alsa-plugins-1.1.1.tar.bz2) = 9dd277cb5cce144ce4e5e0010cebcba0f8634c783e7bcd80ce6d04b198d6de5150a2764df3087a39a468b5fb7c4578de2e252095568e811dedaa5e7ffdbeb7c9
Size (alsa-plugins-1.1.1.tar.bz2) = 366193 bytes
SHA1 (patch-aa) = ac2169b0a069bcf6ed60ca7ccd199ccd1988357f
SHA1 (patch-pcm_jack.c) = 865550f08614a10012ef1705c8b3a257e4e11905

View file

@ -0,0 +1,13 @@
$NetBSD$
--- configure.orig 2013-04-11 12:54:26.000000000 +0000
+++ configure
@@ -11718,7 +11718,7 @@ if ${ac_cv_lib_asound_snd_pcm_ioplug_cre
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lasound -ldl $LIBS"
+LIBS="-lasound $LIBS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */

View file

@ -0,0 +1,14 @@
$NetBSD$
Is byteswap.h needed (on Linux)? Breaks build on NetBSD.
--- jack/pcm_jack.c.orig 2013-04-11 11:43:08.000000000 +0000
+++ jack/pcm_jack.c
@@ -20,7 +20,6 @@
*
*/
-#include <byteswap.h>
#include <sys/shm.h>
#include <sys/types.h>
#include <sys/socket.h>