kid3 moved to pkgsrc/audio, thanks Sergey!
This commit is contained in:
parent
8a9d9c1136
commit
844f0b5745
6 changed files with 1 additions and 78 deletions
3
Makefile
3
Makefile
|
@ -1,4 +1,4 @@
|
|||
# $Id: Makefile,v 1.2315 2006/08/03 17:13:23 tvierling Exp $
|
||||
# $Id: Makefile,v 1.2316 2006/08/03 21:18:31 thomasklausner Exp $
|
||||
#
|
||||
|
||||
COMMENT= WIP pkgsrc packages
|
||||
|
@ -480,7 +480,6 @@ SUBDIR+= kapital
|
|||
SUBDIR+= kawa
|
||||
SUBDIR+= kbproto
|
||||
SUBDIR+= kchmviewer
|
||||
SUBDIR+= kid3
|
||||
SUBDIR+= kino
|
||||
SUBDIR+= kissme
|
||||
SUBDIR+= klamav
|
||||
|
|
13
kid3/DESCR
13
kid3/DESCR
|
@ -1,13 +0,0 @@
|
|||
With Kid3 you can:
|
||||
|
||||
* Edit ID3v1.1 tags, edit all ID3v2.3 frames
|
||||
* Convert between ID3v1.1 and ID3v2.3 tags
|
||||
* Edit Ogg/Vorbis and FLAC tags
|
||||
* Edit tags of multiple files, e.g. the artist, album, year and
|
||||
genre of all files of an album typically have the same values and
|
||||
can be set together.
|
||||
* Generate tags from filenames and filenames from tags
|
||||
* Rename and create directories from tags
|
||||
* Generate playlist files
|
||||
* Automatically convert upper and lower case and replace strings
|
||||
* Import from freedb.org, MusicBrainz and other sources of album data
|
|
@ -1,24 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.5 2006/07/31 21:59:28 shattered Exp $
|
||||
#
|
||||
|
||||
DISTNAME= kid3-0.7
|
||||
CATEGORIES= kde audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=kid3/}
|
||||
|
||||
MAINTAINER= shattered@users.sourceforge.net
|
||||
HOMEPAGE= http://kid3.sourceforge.net/
|
||||
COMMENT= KDE ID3 tagger
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES+= c c++
|
||||
|
||||
# Note: put app specific data files into kde dir
|
||||
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/kde
|
||||
|
||||
.include "../../meta-pkgs/kde3/kde3.mk"
|
||||
.include "../../audio/flac/buildlink3.mk"
|
||||
.include "../../audio/id3lib/buildlink3.mk"
|
||||
.include "../../audio/libtunepimp0.4/buildlink3.mk"
|
||||
.include "../../x11/kdelibs3/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
20
kid3/PLIST
20
kid3/PLIST
|
@ -1,20 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2006/04/18 00:46:34 jlamwww Exp $
|
||||
bin/kid3
|
||||
share/doc/kde/HTML/de/kid3/common
|
||||
share/doc/kde/HTML/de/kid3/index.cache.bz2
|
||||
share/doc/kde/HTML/de/kid3/index.docbook
|
||||
share/doc/kde/HTML/en/kid3/common
|
||||
share/doc/kde/HTML/en/kid3/index.cache.bz2
|
||||
share/doc/kde/HTML/en/kid3/index.docbook
|
||||
share/kde/applnk/Multimedia/kid3.desktop
|
||||
share/kde/apps/kid3/kid3ui.rc
|
||||
share/kde/icons/hicolor/16x16/apps/kid3.png
|
||||
share/kde/icons/hicolor/32x32/apps/kid3.png
|
||||
share/kde/icons/hicolor/48x48/apps/kid3.png
|
||||
share/locale/de/LC_MESSAGES/kid3.mo
|
||||
share/locale/es/LC_MESSAGES/kid3.mo
|
||||
share/locale/ru/LC_MESSAGES/kid3.mo
|
||||
@dirrm share/kde/apps/kid3
|
||||
@dirrm share/kde/applnk/Multimedia
|
||||
@dirrm share/doc/kde/HTML/en/kid3
|
||||
@dirrm share/doc/kde/HTML/de/kid3
|
|
@ -1,6 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.2 2006/07/16 12:33:54 shattered Exp $
|
||||
|
||||
SHA1 (kid3-0.7.tar.gz) = 21eacdf9511d119a6a2824c0f4bdb4fb8dd3ccfb
|
||||
RMD160 (kid3-0.7.tar.gz) = 9f7f4a17b5e048bfb4336b1cfe86afcf4c2f20cf
|
||||
Size (kid3-0.7.tar.gz) = 897741 bytes
|
||||
SHA1 (patch-aa) = 74a7b7bab91edc5101bb43eeabbf5a6c95bf389e
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/12/10 19:53:07 shattered Exp $
|
||||
|
||||
--- kid3/oggfile.cpp.orig 2005-10-13 15:54:34.000000000 +0000
|
||||
+++ kid3/oggfile.cpp
|
||||
@@ -143,7 +143,7 @@ bool OggFile::writeTags(bool force, bool
|
||||
bool setUtime = false;
|
||||
struct utimbuf times;
|
||||
if (preserve) {
|
||||
- int fd = ::fileno(fpIn);
|
||||
+ int fd = fileno(fpIn);
|
||||
if (fd >= 0) {
|
||||
struct stat fileStat;
|
||||
if (::fstat(fd, &fileStat) == 0) {
|
Loading…
Reference in a new issue