Add alternative valuators code (use by defining MOTION_EVENT_HACK). From
xenocara CVS. Make sure dz is set to 0 when the rest of the axes are. Bump rev.
This commit is contained in:
parent
2a0bbd5509
commit
85e1d34f14
3 changed files with 26 additions and 5 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.3 2007/08/06 04:30:20 bsadewitz Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2007/08/10 15:02:35 bsadewitz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= openbsd-input-ws-1.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://xenocara.org/src/
|
||||
|
||||
|
@ -16,7 +17,9 @@ USE_LIBTOOL= yes
|
|||
USE_TOOLS+= pkg-config
|
||||
USE_LANGUAGES= c
|
||||
|
||||
.include "../../x11/modular-xorg-server/buildlink3.mk"
|
||||
CPPFLAGS+= -DMOTION_EVENT_HACK # XXX testing
|
||||
|
||||
.include "../../wip/modular-xorg-server/buildlink3.mk"
|
||||
.include "../../x11/xproto/buildlink3.mk"
|
||||
.include "../../x11/inputproto/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2007/08/06 04:30:20 bsadewitz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2007/08/10 15:02:35 bsadewitz Exp $
|
||||
|
||||
SHA1 (openbsd-input-ws-1.1.tar.gz) = d74b53bd0efddd92873bc5b2b4064c98d91d3131
|
||||
RMD160 (openbsd-input-ws-1.1.tar.gz) = a37925b87c4cc136ba7149aa0505d2c49d6ce61d
|
||||
Size (openbsd-input-ws-1.1.tar.gz) = 318681 bytes
|
||||
SHA1 (patch-aa) = d9a7286d65bad53834ad6220f3ad1b6116865557
|
||||
SHA1 (patch-aa) = 6567517dcee84dce931ae9a52ff96c33563f5c5b
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.1 2007/08/06 04:30:20 bsadewitz Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2007/08/10 15:02:35 bsadewitz Exp $
|
||||
|
||||
--- src/ws.c.orig 2007-05-26 13:24:45.000000000 -0400
|
||||
+++ src/ws.c
|
||||
|
@ -23,3 +23,21 @@ $NetBSD: patch-aa,v 1.1 2007/08/06 04:30:20 bsadewitz Exp $
|
|||
xf86InitValuatorAxisStruct(pWS, 0, 0, -1, 1, 0, 1);
|
||||
xf86InitValuatorDefaults(pWS, 0);
|
||||
|
||||
@@ -458,7 +468,7 @@ wsReadInput(InputInfoPtr pInfo)
|
||||
n /= sizeof(struct wscons_event);
|
||||
while( n-- ) {
|
||||
int buttons = priv->lastButtons;
|
||||
- int dx = 0, dy = 0, dz, dw = 0;
|
||||
+ int dx = 0, dy = 0, dz = 0, dw = 0;
|
||||
int zbutton = 0, wbutton = 0;
|
||||
|
||||
ax = 0; ay = 0;
|
||||
@@ -526,7 +536,7 @@ wsReadInput(InputInfoPtr pInfo)
|
||||
/* relative motion event */
|
||||
DBG(3, ErrorF("postMotionEvent dX %d dY %d\n",
|
||||
dx, dy));
|
||||
-#if 0
|
||||
+#ifdef MOTION_EVENT_HACK
|
||||
priv->x += dx;
|
||||
if (priv->x < priv->min_x) priv->x = priv->min_x;
|
||||
if (priv->x > priv->max_x) priv->x = priv->max_x;
|
||||
|
|
Loading…
Reference in a new issue