Ming is a c library for generating SWF ("Flash") format movies, plus a set

of wrappers for using the library from c++ and popular scripting languages
like PHP, Python, and Ruby. 

I added Python wrapper. I will not be adding wrappers for PHP and Ruby, feel
free to add them.
This commit is contained in:
Michal Pasternak 2003-11-26 17:08:13 +00:00
parent 979e8675ca
commit 86ae67d4fe
8 changed files with 95 additions and 0 deletions

3
ming/DESCR Normal file
View file

@ -0,0 +1,3 @@
Ming is a c library for generating SWF ("Flash") format movies, plus a set
of wrappers for using the library from c++ and popular scripting languages
like PHP, Python, and Ruby.

7
ming/Makefile Normal file
View file

@ -0,0 +1,7 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
#
PKGNAME= ${DISTNAME}
.include "../../wip/ming/Makefile.common"
.include "../../mk/bsd.pkg.mk"

14
ming/Makefile.common Normal file
View file

@ -0,0 +1,14 @@
# $NetBSD: Makefile.common,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
DISTNAME?= ming-0.2a
CATEGORIES?= graphics
MASTER_SITES?= ${MASTER_SITE_SOURCEFORGE:=ming/}
EXTRACT_SUFX?= .tgz
MAINTAINER?= dotz@irc.pl
HOMEPAGE?= http://ming.sourceforge.net/
COMMENT?= Create SWF (Macromedia Flash) files with this library
DISTINFO_FILE?= ${.CURDIR}/../ming/distinfo
COMMON_FILESDIR?= ${.CURDIR}/../ming/files
PATCHDIR?= ${.CURDIR}/../ming/patches

4
ming/PLIST Normal file
View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
include/ming.h
include/mingpp.h
lib/libming.so.0.2

9
ming/TODO Normal file
View file

@ -0,0 +1,9 @@
$Id: TODO,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
Create buildlink2.mk.
Add more modules! (there are bindings for PHP and Ruby, check the WWW page)
Please feel free to add more patches and more modules to it.
-- dotz@irc.pl

6
ming/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
SHA1 (ming-0.2a.tgz) = 9f8b4d9afcee51351b326e6f072352cc8ac013f5
Size (ming-0.2a.tgz) = 316447 bytes
SHA1 (patch-aa) = 662383f7b1021ec0ba782d35065aac364d5eb761
SHA1 (patch-ab) = 1fa437ff8c294667db5b0e4d89626b2d260f57cb

16
ming/patches/patch-aa Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
--- Makefile~ Fri Aug 17 19:05:49 2001
+++ Makefile Wed Nov 26 17:33:37 2003
@@ -1,9 +1,9 @@
#CC = gcc -g -pg -a # profiling flags
#CC = gcc -O5
-CC = gcc -g -Wall
+#CC = gcc -g -Wall
#PREFIX = /usr/local
-PREFIX = /usr
+#PREFIX = /usr
LIBDIR = ${PREFIX}/lib
INCLUDEDIR = ${PREFIX}/include

36
ming/patches/patch-ab Normal file
View file

@ -0,0 +1,36 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/11/26 17:08:13 mpasternak Exp $
--- py_ext/Makefile.orig Fri Aug 17 19:05:55 2001
+++ py_ext/Makefile Wed Nov 26 17:58:49 2003
@@ -1,5 +1,5 @@
-PYINCDIR = /usr/local/include/python2.0
-PYLIBDIR = /usr/local/lib/python2.0
+PYINCDIR = ${PYINC}
+PYLIBDIR = ${PYLIB}
#PYINCDIR = /usr/include/python1.5
#PYLIBDIR = /usr/lib/python1.5
@@ -7,7 +7,7 @@
all:
mingcmodule.so: ming_wrap.o
- gcc -g -Wall -shared -o mingcmodule.so ming_wrap.o -lming
+ gcc -g -Wall -Wl,${RPATH_FLAG} -shared -o mingcmodule.so ming_wrap.o -lming
mingc.pyd: ming_wrap.o
dllwrap --dllname mingc.pyd --driver-name gcc --def mingc.def \
@@ -15,7 +15,7 @@
--target=i386-mingw32 -Llib/ -lpython15
ming_wrap.o: ming_wrap.c
- gcc -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
+ gcc -g -Wall -I .. -I ${PYINCDIR} -I ${PREFIX}/include -fpic -c ming_wrap.c
../libming.a:
cd ..; make static
@@ -27,4 +27,4 @@
rm -f mingcmodule.so core *~ *.o ming.pyc
install:
- cp mingcmodule.so ming.py ${PYLIBDIR}/site-packages
+ cp mingcmodule.so ming.py ${PYSITELIB}