Another theme.

This commit is contained in:
Michal Pasternak 2003-11-27 02:45:33 +00:00 committed by Thomas Klausner
parent a4d4abb29f
commit 87d4ac4d80
6 changed files with 351 additions and 0 deletions

View file

@ -0,0 +1 @@
Nice theme for GTK+ 2.x

View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/11/27 02:45:33 mpasternak Exp $
DISTNAME= GTK2-LighthouseBlue-0.4
PKGNAME= gtk2-engines-lighthouseblue-0.4
WRKSRC= ${WRKDIR}/lighthouseblue
CATEGORIES= x11
MASTER_SITES= http://ftp.gnome.org/pub/GNOME/teams/art.gnome.org/themes/gtk2/
MAINTAINER= dotz@irc.pl
HOMEPAGE= http://art.gnome.org/
COMMENT= Theme engine for GTK+ 2.x
USE_BUILDLINK2= YES
USE_LIBTOOL= YES
USE_GMAKE= YES
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --disable-gtktest
.include "../../x11/gtk2/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/11/27 02:45:33 mpasternak Exp $
lib/gtk-2.0/2.2.0/engines/liblighthouseblue.so
lib/gtk-2.0/2.2.0/engines/liblighthouseblue.la
lib/gtk-2.0/2.2.0/engines/liblighthouseblue.a
share/themes/lighthouseblue/gtk-2.0/gtkrc
@dirrm share/themes/LighthouseBlue/gtk-2.0
@dirrm share/themes/Bluecurve

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2003/11/27 02:45:33 mpasternak Exp $
SHA1 (GTK2-LighthouseBlue-0.4.tar.gz) = 24b519d65a0842c1fff16cda29df95af4c6bff0d
Size (GTK2-LighthouseBlue-0.4.tar.gz) = 197063 bytes
SHA1 (patch-aa) = 8df0e54219e0f62584d216057e1b6f6767ad9cb8
SHA1 (patch-ab) = f1918a2e0c8ff8a7208de74574e85c5cdfd71dd1

View file

@ -0,0 +1,303 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/11/27 02:45:34 mpasternak Exp $
--- configure.orig Thu Oct 3 11:12:30 2002
+++ configure Thu Nov 27 03:39:58 2003
@@ -5624,297 +5624,8 @@
fi
# Check whether --enable-gtktest or --disable-gtktest was given.
-if test "${enable_gtktest+set}" = set; then
- enableval="$enable_gtktest"
- :
-else
- enable_gtktest=yes
-fi
+ enable_gtktest=no
-
- for module in .
- do
- case "$module" in
- gthread)
- gtk_config_args="$gtk_config_args gthread"
- ;;
- esac
- done
-
- if test x$gtk_config_exec_prefix != x ; then
- gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
- if test x${GTK_CONFIG+set} != xset ; then
- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
- fi
- fi
- if test x$gtk_config_prefix != x ; then
- gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
- if test x${GTK_CONFIG+set} != xset ; then
- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
- fi
- fi
-
- # Extract the first word of "gtk-config", so it can be a program name with args.
-set dummy gtk-config; ac_word=$2
-echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:5661: checking for $ac_word" >&5
-if eval "test \"`echo '$''{'ac_cv_path_GTK_CONFIG'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- case "$GTK_CONFIG" in
- /*)
- ac_cv_path_GTK_CONFIG="$GTK_CONFIG" # Let the user override the test with a path.
- ;;
- ?:/*)
- ac_cv_path_GTK_CONFIG="$GTK_CONFIG" # Let the user override the test with a dos path.
- ;;
- *)
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
- ac_dummy="$PATH"
- for ac_dir in $ac_dummy; do
- test -z "$ac_dir" && ac_dir=.
- if test -f $ac_dir/$ac_word; then
- ac_cv_path_GTK_CONFIG="$ac_dir/$ac_word"
- break
- fi
- done
- IFS="$ac_save_ifs"
- test -z "$ac_cv_path_GTK_CONFIG" && ac_cv_path_GTK_CONFIG="no"
- ;;
-esac
-fi
-GTK_CONFIG="$ac_cv_path_GTK_CONFIG"
-if test -n "$GTK_CONFIG"; then
- echo "$ac_t""$GTK_CONFIG" 1>&6
-else
- echo "$ac_t""no" 1>&6
-fi
-
- min_gtk_version=1.2.9
- echo $ac_n "checking for GTK - version >= $min_gtk_version""... $ac_c" 1>&6
-echo "configure:5696: checking for GTK - version >= $min_gtk_version" >&5
- no_gtk=""
- if test "$GTK_CONFIG" = "no" ; then
- no_gtk=yes
- else
- GTK_CFLAGS=`$GTK_CONFIG $gtk_config_args --cflags`
- GTK_LIBS=`$GTK_CONFIG $gtk_config_args --libs`
- gtk_config_major_version=`$GTK_CONFIG $gtk_config_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
- gtk_config_minor_version=`$GTK_CONFIG $gtk_config_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
- gtk_config_micro_version=`$GTK_CONFIG $gtk_config_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
- if test "x$enable_gtktest" = "xyes" ; then
- ac_save_CFLAGS="$CFLAGS"
- ac_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $GTK_CFLAGS"
- LIBS="$GTK_LIBS $LIBS"
- rm -f conf.gtktest
- if test "$cross_compiling" = yes; then
- echo $ac_n "cross compiling; assumed OK... $ac_c"
-else
- cat > conftest.$ac_ext <<EOF
-#line 5719 "configure"
-#include "confdefs.h"
-
-#include <gtk/gtk.h>
-#include <stdio.h>
-#include <stdlib.h>
-
-int
-main ()
-{
- int major, minor, micro;
- char *tmp_version;
-
- system ("touch conf.gtktest");
-
- /* HP/UX 9 (%@#!) writes to sscanf strings */
- tmp_version = g_strdup("$min_gtk_version");
- if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
- printf("%s, bad version string\n", "$min_gtk_version");
- exit(1);
- }
-
- if ((gtk_major_version != $gtk_config_major_version) ||
- (gtk_minor_version != $gtk_config_minor_version) ||
- (gtk_micro_version != $gtk_config_micro_version))
- {
- printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
- $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
- gtk_major_version, gtk_minor_version, gtk_micro_version);
- printf ("*** was found! If gtk-config was correct, then it is best\n");
- printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
- printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
- printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
- printf("*** required on your system.\n");
- printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
- printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
- printf("*** before re-running configure\n");
- }
-#if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
- else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
- (gtk_minor_version != GTK_MINOR_VERSION) ||
- (gtk_micro_version != GTK_MICRO_VERSION))
- {
- printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
- GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
- printf("*** library (version %d.%d.%d)\n",
- gtk_major_version, gtk_minor_version, gtk_micro_version);
- }
-#endif /* defined (GTK_MAJOR_VERSION) ... */
- else
- {
- if ((gtk_major_version > major) ||
- ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
- ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
- {
- return 0;
- }
- else
- {
- printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
- gtk_major_version, gtk_minor_version, gtk_micro_version);
- printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
- major, minor, micro);
- printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
- printf("***\n");
- printf("*** If you have already installed a sufficiently new version, this error\n");
- printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
- printf("*** being found. The easiest way to fix this is to remove the old version\n");
- printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
- printf("*** correct copy of gtk-config. (In this case, you will have to\n");
- printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
- printf("*** so that the correct libraries are found at run-time))\n");
- }
- }
- return 1;
-}
-
-EOF
-if { (eval echo configure:5797: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
-then
- :
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -fr conftest*
- no_gtk=yes
-fi
-rm -fr conftest*
-fi
-
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- fi
- if test "x$no_gtk" = x ; then
- echo "$ac_t""yes" 1>&6
- :
- else
- echo "$ac_t""no" 1>&6
- if test "$GTK_CONFIG" = "no" ; then
- echo "*** The gtk-config script installed by GTK could not be found"
- echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the GTK_CONFIG environment variable to the"
- echo "*** full path to gtk-config."
- else
- if test -f conf.gtktest ; then
- :
- else
- echo "*** Could not run GTK test program, checking why..."
- CFLAGS="$CFLAGS $GTK_CFLAGS"
- LIBS="$LIBS $GTK_LIBS"
- cat > conftest.$ac_ext <<EOF
-#line 5831 "configure"
-#include "confdefs.h"
-
-#include <gtk/gtk.h>
-#include <stdio.h>
-
-int main() {
- return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version));
-; return 0; }
-EOF
-if { (eval echo configure:5841: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- echo "*** The test program compiled, but did not run. This usually means"
- echo "*** that the run-time linker is not finding GTK or finding the wrong"
- echo "*** version of GTK. If it is not finding GTK, you'll need to set your"
- echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
- echo "*** to the installed location Also, make sure you have run ldconfig if that"
- echo "*** is required on your system"
- echo "***"
- echo "*** If you have an old version installed, it is best to remove it, although"
- echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
- echo "***"
- echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
- echo "*** came with the system with the command"
- echo "***"
- echo "*** rpm --erase --nodeps gtk gtk-devel"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means GTK was incorrectly installed"
- echo "*** or that you have moved GTK since it was installed. In the latter case, you"
- echo "*** may want to edit the gtk-config script: $GTK_CONFIG"
-fi
-rm -f conftest*
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- fi
- GTK_CFLAGS=""
- GTK_LIBS=""
- { echo "configure: error: *** GTK+-1.2.9 not installed - please install first ***" 1>&2; exit 1; }
- fi
-
-
- rm -f conf.gtktest
-
-echo $ac_n "checking for gtk_style_set_prop_experimental in -lgtk""... $ac_c" 1>&6
-echo "configure:5880: checking for gtk_style_set_prop_experimental in -lgtk" >&5
-ac_lib_var=`echo gtk'_'gtk_style_set_prop_experimental | sed 'y%./+-%__p_%'`
-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- ac_save_LIBS="$LIBS"
-LIBS="-lgtk $GTK_LIBS $LIBS"
-cat > conftest.$ac_ext <<EOF
-#line 5888 "configure"
-#include "confdefs.h"
-/* Override any gcc2 internal prototype to avoid an error. */
-/* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
-char gtk_style_set_prop_experimental();
-
-int main() {
-gtk_style_set_prop_experimental()
-; return 0; }
-EOF
-if { (eval echo configure:5899: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=no"
-fi
-rm -f conftest*
-LIBS="$ac_save_LIBS"
-
-fi
-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
- :
-else
- echo "$ac_t""no" 1>&6
-{ echo "configure: error: *** gtk_style_set_prop_experimental() not found; perhaps you have an old CVS version of GTK+ ***" 1>&2; exit 1; }
-fi
#AM_PATH_GDK_PIXBUF

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/11/27 02:45:34 mpasternak Exp $
--- themes/Makefile.in~ Thu Nov 27 03:39:58 2003
+++ themes/Makefile.in Thu Nov 27 03:41:11 2003
@@ -83,7 +83,7 @@
STRIP = @STRIP@
VERSION = @VERSION@
-SUBDIRS = gtk2 gtk1
+SUBDIRS = gtk2
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h
CONFIG_CLEAN_FILES =