"test ==" portability fixes. Regenerate check sums.
This commit is contained in:
parent
196613a4bb
commit
899ea9c131
4 changed files with 53 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.16 2009/03/22 22:56:35 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2009/03/22 23:53:18 asau Exp $
|
||||
|
||||
DISTNAME= mpich2-1.1b1
|
||||
PKGNAME= ${DISTNAME}
|
||||
|
@ -58,7 +58,5 @@ CONF_FILES+= share/${PKGBASE}/examples/mpicxx.conf \
|
|||
CONF_FILES+= share/${PKGBASE}/examples/mpif77.conf \
|
||||
${PKG_SYSCONFDIR}/mpif77.conf
|
||||
|
||||
CHECK_PORTABILITY_SKIP= src/mpid/ch3/channels/nemesis/configure
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.8 2009/03/22 22:56:35 asau Exp $
|
||||
$NetBSD: distinfo,v 1.9 2009/03/22 23:53:18 asau Exp $
|
||||
|
||||
SHA1 (mpich2-1.1b1.tar.gz) = 1b53a31fb8a5443971a1c875d03d0213ec7ad724
|
||||
RMD160 (mpich2-1.1b1.tar.gz) = 2996aa8c29d516d443ce3b75d3901aa53d353d24
|
||||
Size (mpich2-1.1b1.tar.gz) = 17426538 bytes
|
||||
SHA1 (patch-aa) = 568e45fdcaa1bc279c249cfbf18a8e96240ef3c3
|
||||
SHA1 (patch-ac) = b956a355ef381d759077288916c40e32b022f178
|
||||
SHA1 (patch-ah) = 9c502109cacdbaa35089d26fc0fe54b8ba1f6008
|
||||
SHA1 (patch-ae) = c0c88b4b7c732f4ce7a761272a2f3856f2fd8d07
|
||||
SHA1 (patch-af) = d55a5bcda83c5453f13bfe4a7ef16eacc7da393b
|
||||
SHA1 (patch-ah) = 26595e779416893d0f406c3d14c639e946c1779c
|
||||
|
|
24
mpi-ch/patches/patch-ae
Normal file
24
mpi-ch/patches/patch-ae
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ae,v 1.5 2009/03/22 23:53:18 asau Exp $
|
||||
|
||||
"test ==" portability fixes.
|
||||
|
||||
--- src/mpid/ch3/channels/nemesis/configure.orig 2009-03-18 19:24:45.000000000 +0300
|
||||
+++ src/mpid/ch3/channels/nemesis/configure 2009-03-23 02:27:16.000000000 +0300
|
||||
@@ -5436,7 +5436,7 @@
|
||||
|
||||
fi;
|
||||
|
||||
- if test "${net}" == "newmad" ; then
|
||||
+ if test "${net}" = "newmad" ; then
|
||||
if test "${ac_cv_header_nm_public_h+set}" = set; then
|
||||
{ $as_echo "$as_me:$LINENO: checking for nm_public.h" >&5
|
||||
$as_echo_n "checking for nm_public.h... " >&6; }
|
||||
@@ -5810,7 +5810,7 @@
|
||||
fi
|
||||
fi;
|
||||
|
||||
- if test "${net}" == "elan" ; then
|
||||
+ if test "${net}" = "elan" ; then
|
||||
echo "=== You're about to use the experimental Nemesis/Elan network module."
|
||||
echo "=== This module has not been thoroughly tested and some performance issues remain."
|
||||
if test "${ac_cv_header_elan_elan_h+set}" = set; then
|
24
mpi-ch/patches/patch-af
Normal file
24
mpi-ch/patches/patch-af
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-af,v 1.3 2009/03/22 23:53:18 asau Exp $
|
||||
|
||||
Portability fixes to send upstream.
|
||||
|
||||
--- src/mpid/ch3/channels/nemesis/configure.in.orig 2009-03-06 01:44:18.000000000 +0300
|
||||
+++ src/mpid/ch3/channels/nemesis/configure.in 2009-03-23 02:24:43.000000000 +0300
|
||||
@@ -276,7 +276,7 @@
|
||||
AC_DEFINE([ENABLE_COMM_OVERRIDES], 1, [define to add per-vc function pointers to override send and recv functions])
|
||||
fi;
|
||||
|
||||
- if test "${net}" == "newmad" ; then
|
||||
+ if test "${net}" = "newmad" ; then
|
||||
AC_CHECK_HEADER([nm_public.h], , [
|
||||
AC_MSG_ERROR(['nm_public.h not found. Did you specify --with-newmad= ?'])
|
||||
])
|
||||
@@ -293,7 +293,7 @@
|
||||
fi
|
||||
fi;
|
||||
|
||||
- if test "${net}" == "elan" ; then
|
||||
+ if test "${net}" = "elan" ; then
|
||||
echo "=== You're about to use the experimental Nemesis/Elan network module."
|
||||
echo "=== This module has not been thoroughly tested and some performance issues remain."
|
||||
AC_CHECK_HEADER([elan/elan.h], , [
|
Loading…
Reference in a new issue