Update 6.01 to 6.1, See COMMIT_LOG for Changes.

This commit is contained in:
Makoto Fujiwara 2015-01-18 07:50:32 +00:00 committed by Thomas Klausner
parent f146d41daf
commit 89aa4d0c6b
5 changed files with 52 additions and 242 deletions

View file

@ -1,193 +1,27 @@
(Upstream) Bump version 5.11 to 6.0.1
(Upstream) update 6.0.1 to 6.1
----------------------------------------------------------------------
Version 6.0.1:
Current:
* Major changes compared to the previous version:
- Programmer types in configuration file are no longer keywords but
specified as string.
So you need to change 'type = XYZ;' to 'type = "XYZ";' in own
config files. (internal: The parser does not need to know all
programmer types now, new programmers will update only the table
in pgm_type.c.)
- The erase cycle counter (formerly options -y / -Y) has been
removed.
- Specifying a -U option without a memory type (short form of
option argument list) now defaults to "application" memory for
Xmega devices, and "flash" for everything else. This ensures
the Xmega bootloader is not accidentally touched.
- For programmers that support it, the default erase method is a
page erase now, rather than a chip erase (Xmega only).
- Keep track of input file contents
Memory segments are being tracked to remember whether they've
been actually read from a file. Only segments that came from a
file are being programmed into the device, or considered for
verification. This drastically improves handling speed for
sparse files (e.g. files that have a second bootloader segment),
and it ensures the device contents is actually compared for
everything mentioned in the file (even in case the file has
large 0xFF blocks).
- The -U option now accepts ELF files as input files, and extracts
the appropriate section contents that matches the requested memory
region. To enable this feature, the host system used for the
compilation must have a libelf around, including the respective
header files (i.e., package "libelf-devel" on many Linux systems).
- Programmers and parts lists
They are now sorted at output with '-c ?'/'-p ?'. (patch #7671:
Sorting programmers and parts lists for console output)
Programmers and parts lists in documentation generated from lists
mentioned above. (patch #7687: Autogenerating programmers and
parts lists for docs)
Output list of programmer types with '-c ?type', add list to
documentation
- Configuration files now accepts parent parts/programmers, parts
starting with '.' (eg. .xmega) are not included in output parts
list and can be used as abstract parents
(bug #34302: Feature request : device configuration with parent classes)
(patch #7688: Implement parent programmers feature)
- Additional config files which are read after default can be
specified on command line using '-C +filename'
(patch #7699 Read additional config files)
- "Safemode" can now be turned off by default from within a
configuration file (like ~/.avrduderc).
- The new option -l logfile allows to redirect diagnostic messages
to a logfile rather than stderr. Useful to record debugging
traces, in particular in environments which do not offer
shell-style redirection functionality for standard streams.
- When leaving debugWIRE mode, immediately retry with ISP rather
than bailing out completely.
- The USBasp programmer implementation now supports detailed traces
with -vvv, and device communication traces with -vvvv.
- The "verbose" terminal mode command allows to query or modify the
verbosity level.
* New devices supported:
- ATmega48P (patch #7629 add support for atmega48p)
- AT90PWM316 (bug #21797: AT90PWM316: New part description)
- ATxmega16D4, ATxmega32D4, ATxmega64D4, ATxmega128D4
- ATmega256RFR2, ATmega128RFR2, ATmega64RFR2, ATmega2564RFR2,
ATmega1284RFR2, ATmega644RFR2
- ATtiny1634
- ATxmega128A1U, ATxmega128A3U, ATxmega128A4U, ATxmega128B1,
ATxmega128B3, ATxmega128C3, ATxmega128D3, ATxmega16A4U,
ATxmega16C4, ATxmega192A3U, ATxmega192C3, ATxmega192D3,
ATxmega256A3BU, ATxmega256A3U, ATxmega256C3, ATxmega256D3,
ATxmega32A4U, ATxmega32C4, ATxmega384C3, ATxmega384D3,
ATxmega64A1U, ATxmega64A3U, ATxmega64A4U, ATxmega64B1,
ATxmega64B3, ATxmega64C3, ATxmega64D3
- ATtiny43U
- ATmega406
- ATxmega8E5, ATxmega16E5, ATxmega32E5
- ATtiny20, ATtiny40
- Atmel EDBG protocol support added (JTAGICE3, XplainedPro, Atmel-ICE)
* New programmers supported:
- linuxgpio
+ any (embedded) Linux system with 4 GPIOs available can be used
as a programmer with little or no additional hardware.
- avrftdi
+ o-link (patch #7672 adding support for O-Link (FTDI based
JTAG) as programmer)
+ 4232h (patch #7715 FT4232H support)
- TPI support
+ openmoko (bug #37977 Support for Openmoko Debug Board)
- usbasp
+ nibobee (previously specified as '-c usbasp -P nibobee)
+ usbasp-clone (same as usbasp but ignores vendor and product
string, checks only vid/pid)
- ftdi_syncbb (new type for synchronous bitbanging with ft232r/ft245r)
+ ft245r (FT245R Synchronous BitBang, miso = D1, sck = D0, mosi
= D2, reset = D4)
+ ft232r (FT232R Synchronous BitBang, miso = RxD, sck = RTS,
mosi = TxD, reset = DTR)
+ bwmega (BitWizard ftdi_atmega builtin programmer, miso = DSR,
sck = DCD, mosi = CTS, reset = RI)
+ arduino-ft232r (Arduino: FT232R connected to ISP, miso = CTS
X3(1), sck = DSR X3(2), mosi = DCD X3(3), reset = RI X3(4))
+ diecimila (alias for arduino-ft232r)
- pickit2
- Atmel JTAGICE3
- buspirate_bb (TPI programming using the BusPirate in bitbang mode)
- Atmel DFU, using FLIP protocol version 1 (AT90USB and ATmega*U* devices),
or version 2 (Xmega devices)
- Atmel-ICE (ARM/AVR), JTAG, PDI, debugWIRE, ISP modi
* Bugfixes
- bug #34027: avrdude AT90S1200 Problem
- bug #34518: loading intel hex files > 64k using record-type 4
- patch #7667: Minor memory handling fixes
- patch #7680: Fixing timeout problem in ser_recv in ser_win32.c
- patch #7693: Fix config file atmel URLs (+ URLs in
avrdude.texi and avrpart.h)
- bug #21663: AT90PWM efuse incorrect, bug #30438: efuse bits
written as 0 on at90pwmxx parts
- bug #35261: avrftdi uses wrong interface in avrftdi_paged_(write|load)
- patch #7437 modifications to Bus Pirate module
- patch #7686 Updating buspirate ascii mode to current firmware,
use AUX as clock generator, and setting of serial receive
timeout
- bug #34768 Proposition: Change the name of the AVR32 devices
- patch #7718: Merge global data of avrftdi in a private data
structure
- bug #35208: avrdude 5.11 on freebsd 8.2-STABLE does not reset
Arduino Uno properly
- bug #34518: loading intel hex files > 64k using record-type 4
(Extended Linear Address Record)
- bug #34027: avrdude AT90S1200 Problem
- bug #30451: Accessing some Xmega memory sections gives not
supported error
- bug #28744: Can't load bootloader to xmega128a1
- bug #29019: pagel/bs2 warning when uploading using stk500 to xmega
- bug #30756: When setting SUT to 64ms on XMEGA, avrdude doesn't
read device signature
- bug #37265: wrong page sizes for XMega64xx in avrdude.conf
- bug #37942: Latest SVN can't program in dragon_jtag mode
- patch #7876 JTAGICE mkII fails to connect to attiny if debugwire
is enabled AND target has a very slow clock
- bug #39893: Verification failure with AVRISPmkII and Xmega
- bug #38713: Compilation of the documentation breaks with texinfo-5
- bug #38023: avrdude doesn't return an error code when attempting
to upload an invalid Intel HEX file
- bug #39794: warnings when building avrdude 6.0rc1 under CentOS 6.4
- bug #35800: Compilation error on certain systems if parport is disabled
- bug #38307: Can't write usersig of an xmega256a3
- bug #38580: Current svn head, xmega and fuses, all fuses tied to fuse0
- bug #39691: Buffer overrun when reading EEPROM byte with JTAGICE3
- bug #38951: AVR109 use byte offset instead of word offset
- patch #7769: Write flash fails for AVR910 programmers
- bug #38732: Support for ATtiny1634
- bug #36901: flashing Atmega32U4 EEPROM produces garbage on chip
- bug #28344: chip_erase_delay too short for ATmega324P, 644, 644P, and 1284P
- bug #34277: avrdude reads wrong byte order if using avr911 (aka butterfly)
- bug #35456: The progress bar for STK500V2 programmer is "wrong".
- patch #5708: avrdude should make 10 synchronization attempts instead of just one
- patch #7606: ATtiny43u support
- patch #7657: Add ATmega406 support for avrdude using DRAGON + JTAG
- bug #35474: Feature request: print fuse values in safemode output.
- patch #7710: usb_libusb: Check VID/PID before opening device
- [no-id]: Fix SCK period adjustment for STK500v2
- bug #40040: Support for ATtiny20 and ATtiny40
- bug #40055: AVRDUDE segfaults when writing eeprom
- bug #40055: AVRDUDE segfaults when writing eeprom
- bug #40085: Typo fix in fuses report (for 6.1-svn-20130917)
- bug #40782: Verify errors for object size > 16 k on x32e5 due
to typo in avrdude.conf
- bug #40817: Elf file support (possibly) not working on 6.0.1 windows build
- bug #40897: AT Mega2560 not correctly programmed with stk500(v1)
ISP (solution patch)
- bug #41357: OS X: Avrdude messes with the usb stack?
- bug #41402: dfu.c missing include <stdint.h>
- patch #7896: DFU FLIPv2 programming support
- patch #XXXX: xxx
* Internals:
- (Some) programmers can take a list of USB PIDs now.

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2013/10/10 05:12:27 makoto Exp $
# $NetBSD: Makefile,v 1.6 2015/01/18 07:50:32 makoto Exp $
DISTNAME= avrdude-6.0.1
DISTNAME= avrdude-6.1
CATEGORIES= cross
MASTER_SITES= http://download.savannah.gnu.org/releases/avrdude/

View file

@ -1,29 +1,30 @@
@comment $NetBSD: PLIST,v 1.1 2013/10/06 09:41:40 makoto Exp $
@comment $NetBSD: PLIST,v 1.2 2015/01/18 07:50:32 makoto Exp $
bin/avrdude
info/avrdude.info
man/man1/avrdude.1
share/doc/${PKGNAME}/avrdude-html/avrdude.html
share/doc/${PKGNAME}/avrdude-html/avrdude_1.html
share/doc/${PKGNAME}/avrdude-html/avrdude_10.html
share/doc/${PKGNAME}/avrdude-html/avrdude_11.html
share/doc/${PKGNAME}/avrdude-html/avrdude_12.html
share/doc/${PKGNAME}/avrdude-html/avrdude_13.html
share/doc/${PKGNAME}/avrdude-html/avrdude_14.html
share/doc/${PKGNAME}/avrdude-html/avrdude_15.html
share/doc/${PKGNAME}/avrdude-html/avrdude_16.html
share/doc/${PKGNAME}/avrdude-html/avrdude_17.html
share/doc/${PKGNAME}/avrdude-html/avrdude_18.html
share/doc/${PKGNAME}/avrdude-html/avrdude_19.html
share/doc/${PKGNAME}/avrdude-html/avrdude_2.html
share/doc/${PKGNAME}/avrdude-html/avrdude_20.html
share/doc/${PKGNAME}/avrdude-html/avrdude_3.html
share/doc/${PKGNAME}/avrdude-html/avrdude_4.html
share/doc/${PKGNAME}/avrdude-html/avrdude_5.html
share/doc/${PKGNAME}/avrdude-html/avrdude_6.html
share/doc/${PKGNAME}/avrdude-html/avrdude_7.html
share/doc/${PKGNAME}/avrdude-html/avrdude_8.html
share/doc/${PKGNAME}/avrdude-html/avrdude_9.html
share/doc/${PKGNAME}/avrdude-html/avrdude_abt.html
share/doc/${PKGNAME}/avrdude-html/avrdude_toc.html
share/doc/${PKGNAME}/avrdude.pdf
share/doc/${PKGNAME}/avrdude.ps
share/examples/avrdude/avrdude.conf
share/doc/${DISTNAME}/avrdude-html/avrdude.html
share/doc/${DISTNAME}/avrdude-html/avrdude_1.html
share/doc/${DISTNAME}/avrdude-html/avrdude_10.html
share/doc/${DISTNAME}/avrdude-html/avrdude_11.html
share/doc/${DISTNAME}/avrdude-html/avrdude_12.html
share/doc/${DISTNAME}/avrdude-html/avrdude_13.html
share/doc/${DISTNAME}/avrdude-html/avrdude_14.html
share/doc/${DISTNAME}/avrdude-html/avrdude_15.html
share/doc/${DISTNAME}/avrdude-html/avrdude_16.html
share/doc/${DISTNAME}/avrdude-html/avrdude_17.html
share/doc/${DISTNAME}/avrdude-html/avrdude_18.html
share/doc/${DISTNAME}/avrdude-html/avrdude_19.html
share/doc/${DISTNAME}/avrdude-html/avrdude_2.html
share/doc/${DISTNAME}/avrdude-html/avrdude_3.html
share/doc/${DISTNAME}/avrdude-html/avrdude_4.html
share/doc/${DISTNAME}/avrdude-html/avrdude_5.html
share/doc/${DISTNAME}/avrdude-html/avrdude_6.html
share/doc/${DISTNAME}/avrdude-html/avrdude_7.html
share/doc/${DISTNAME}/avrdude-html/avrdude_8.html
share/doc/${DISTNAME}/avrdude-html/avrdude_9.html
share/doc/${DISTNAME}/avrdude-html/avrdude_abt.html
share/doc/${DISTNAME}/avrdude-html/avrdude_toc.html
share/doc/${DISTNAME}/avrdude.pdf
share/doc/${DISTNAME}/avrdude.ps

View file

@ -1,13 +1,12 @@
$NetBSD: distinfo,v 1.3 2013/10/06 10:59:20 makoto Exp $
$NetBSD: distinfo,v 1.4 2015/01/18 07:50:32 makoto Exp $
SHA1 (avrdude-6.0.1.tar.gz) = b0f440f1b1ba3890da6e5b752003ca99e550e3bf
RMD160 (avrdude-6.0.1.tar.gz) = 412483e87c88d9111729db6e3f94acc81b04e145
Size (avrdude-6.0.1.tar.gz) = 692284 bytes
SHA1 (avrdude-6.1.tar.gz) = 15525cbff5918568ef3955d871dbb94feaf83c79
RMD160 (avrdude-6.1.tar.gz) = f2c31951c0941e86ff6deab6bd0348b54d05658c
Size (avrdude-6.1.tar.gz) = 714595 bytes
SHA1 (patch-aa) = 619f682af2e8eff36684993b331ba37cd1b446b6
SHA1 (patch-ab) = a9105ae562c078eec5c87df6e7f27a80184bb6d4
SHA1 (patch-ac) = df871808200e5732f77d50ef2d7fb51234173445
SHA1 (patch-ad) = f9e7465b355f5b3feda8868287d6aaa5cd1dcd28
SHA1 (patch-ae) = 4ad74b5abe90ddf29dd419043a2e6026f704d1c9
SHA1 (patch-af) = 4ae54ce739ff41964fe56bc1b3e85611288a6e0c
SHA1 (patch-ag) = 2a6a13c2878d28e476ec6ee747e7ca5d2e023468
SHA1 (patch-fileio_c) = d0c01ae237bc5df0fd76d2362160d6946ef04846

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ag,v 1.1 2013/10/06 09:41:41 makoto Exp $
Work around AVRISP mkII initial sync stalls on NetBSD.
--- usb_libusb.c.orig 2010-01-19 10:39:11.000000000 +0000
+++ usb_libusb.c
@@ -237,6 +237,17 @@ static void usbdev_close(union filedescr
{
usb_dev_handle *udev = (usb_dev_handle *)fd->usb.handle;
+#if defined(__NetBSD__)
+#define USB_FEAT_ENDPOINT_HALT 0
+ /*
+ * Clear Feature Endpoint Halt to reset device's data toggle to DATA0.
+ * This way, when we reopen expecting DATA0, things don't time out.
+ */
+ usb_control_msg(udev, USB_TYPE_STANDARD | USB_RECIP_ENDPOINT,
+ USB_REQ_CLEAR_FEATURE, USB_FEAT_ENDPOINT_HALT,
+ fd->usb.rep & 0xf, NULL, 0, 100);
+#endif
+
(void)usb_release_interface(udev, usb_interface);
#if !( defined(__FreeBSD__) ) // || ( defined(__APPLE__) && defined(__MACH__) ) )