py-mlstats: remove, upstream disappeared.

This commit is contained in:
Thomas Klausner 2016-08-30 17:39:51 +02:00
parent 96e5295691
commit 8a934912e0
6 changed files with 0 additions and 91 deletions

View file

@ -3114,7 +3114,6 @@ SUBDIR+= py-minepy
SUBDIR+= py-minidb
SUBDIR+= py-mipp
SUBDIR+= py-mistune
SUBDIR+= py-mlstats
SUBDIR+= py-mmLib
SUBDIR+= py-mne
SUBDIR+= py-mochi

View file

@ -1,5 +0,0 @@
Mailing List Stats is a tool to analyze mailing list archives.
It can retrieve the archives from a remote web page (usually,
the archives web page), or read them from a local directory. It
generates a brief report, and write everything to a MySQL
database (called mlstats unless other name is indicated)

View file

@ -1,28 +0,0 @@
# $NetBSD: Makefile,v 1.7 2015/01/10 20:22:03 thomasklausner Exp $
DISTNAME= mlstats-0.4
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel python
MASTER_SITES= https://forge.morfeo-project.org/frs/download.php/777/
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= http://forge.morfeo-project.org/projects/libresoft-tools
COMMENT= Mailing lists analysis tool. Part of libresoft-tool
LICENSE= gnu-gpl-v2
DEPENDS+= ${PYPKGPREFIX}-mysqldb-[0-9]*:../../databases/py-mysqldb
# Force using "curl" for fetching the distribution file. It is only available
# over HTTPS and "curl" is the only fetch program which always supports HTTPS.
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
PYDISTUTILSPKG= yes
PYTHON_VERSIONS_INCOMPATIBLE= 34 35 # py-mysqldb
post-extract:
${MV} ${WRKSRC}/mlstats ${WRKSRC}/mlstats${PYVERSSUFFIX}
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,30 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2012/11/16 23:19:39 noud4 Exp $
bin/mlstats${PYVERSSUFFIX}
${PYSITELIB}/pymlstats/__init__.py
${PYSITELIB}/pymlstats/__init__.pyc
${PYSITELIB}/pymlstats/__init__.pyo
${PYSITELIB}/pymlstats/analyzer.py
${PYSITELIB}/pymlstats/analyzer.pyc
${PYSITELIB}/pymlstats/analyzer.pyo
${PYSITELIB}/pymlstats/database.py
${PYSITELIB}/pymlstats/database.pyc
${PYSITELIB}/pymlstats/database.pyo
${PYSITELIB}/pymlstats/datamodel.py
${PYSITELIB}/pymlstats/datamodel.pyc
${PYSITELIB}/pymlstats/datamodel.pyo
${PYSITELIB}/pymlstats/fileextractor.py
${PYSITELIB}/pymlstats/fileextractor.pyc
${PYSITELIB}/pymlstats/fileextractor.pyo
${PYSITELIB}/pymlstats/htmlparser.py
${PYSITELIB}/pymlstats/htmlparser.pyc
${PYSITELIB}/pymlstats/htmlparser.pyo
${PYSITELIB}/pymlstats/main.py
${PYSITELIB}/pymlstats/main.pyc
${PYSITELIB}/pymlstats/main.pyo
${PYSITELIB}/pymlstats/utils.py
${PYSITELIB}/pymlstats/utils.pyc
${PYSITELIB}/pymlstats/utils.pyo
${PYSITELIB}/pymlstats/version.py
${PYSITELIB}/pymlstats/version.pyc
${PYSITELIB}/pymlstats/version.pyo
man/man1/mlstats.1

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.2 2012/11/16 23:19:39 noud4 Exp $
SHA1 (mlstats-0.4.tar.gz) = d49fcf6f4fc970e2a9495be9eb69f61d2c7f92ba
RMD160 (mlstats-0.4.tar.gz) = f2829c0f7abfeaffdae711f23624ab225ef3fe2d
Size (mlstats-0.4.tar.gz) = 26440 bytes
SHA1 (patch-aa) = 6e77b97af7cb806b01383b42f9b68b99628cc4e9

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/04/27 22:34:10 jihbed Exp $
--- setup.py.orig 2011-04-23 22:06:03.000000000 +0100
+++ setup.py 2011-04-23 22:07:21.000000000 +0100
@@ -28,6 +28,7 @@
@contact: herraiz@gsyc.escet.urjc.es
"""
+import sys
from distutils.core import setup
from pymlstats.version import mlstats_version
@@ -45,6 +46,6 @@
url = "http://forge.morfeo-project.org/projects/libresoft-tools",
platforms = ["any"],
packages = ['pymlstats'],
- scripts = ['mlstats'],
- data_files = [('share/man/man1',['man/mlstats.1'])],
+ scripts = ['mlstats'+sys.version[:3]],
+ data_files = [('man/man1',['man/mlstats.1'])],
requires = ['MySQLdb'])