first commit

This commit is contained in:
fulvio ciriaco 2009-02-19 15:45:51 +00:00 committed by Thomas Klausner
parent 6baf26f251
commit 8af3080180
5 changed files with 104 additions and 0 deletions

1
autopsy/DESCR Normal file
View file

@ -0,0 +1 @@
browser interface to sleuthkit

27
autopsy/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1 2009/02/19 15:45:51 fulviociriaco Exp $
#
VERSION=2.21
DISTNAME= autopsy-${VERSION}
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=autopsy/}
MAINTAINER= oivulf@gmail.com
HOMEPAGE= http://www.sleuthkit.org/
COMMENT= Browser interface to sleuthkit
USE_LANGUAGES= c c++
USE_TOOLS+= gmake perl
do-build:
cd ${WRKSRC} && sh build ${PREFIX}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/autopsy ${PREFIX}/bin
${INSTALL_DATA_DIR} ${PREFIX}/share/autopsy/lib
${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/share/autopsy/lib
${INSTALL_DATA} ${WRKSRC}/conf.pl ${PREFIX}/share/autopsy/
${INSTALL_MAN} ${WRKSRC}/man/man1/* ${PREFIX}/${PKGMANDIR}/man1/
.include "../../sysutils/file/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

26
autopsy/PLIST Normal file
View file

@ -0,0 +1,26 @@
@comment $NetBSD: PLIST,v 1.1 2009/02/19 15:45:51 fulviociriaco Exp $
bin/autopsy
man/man1/autopsy.1
share/autopsy/conf.pl
share/autopsy/lib/Appsort.pm
share/autopsy/lib/Appview.pm
share/autopsy/lib/Args.pm
share/autopsy/lib/Caseman.pm
share/autopsy/lib/Data.pm
share/autopsy/lib/Exec.pm
share/autopsy/lib/File.pm
share/autopsy/lib/Filesystem.pm
share/autopsy/lib/Frame.pm
share/autopsy/lib/Fs.pm
share/autopsy/lib/Hash.pm
share/autopsy/lib/Kwsrch.pm
share/autopsy/lib/Main.pm
share/autopsy/lib/Meta.pm
share/autopsy/lib/Notes.pm
share/autopsy/lib/Print.pm
share/autopsy/lib/Timeline.pm
share/autopsy/lib/Vs.pm
share/autopsy/lib/define.pl
share/autopsy/lib/search.pl
@dirrm share/autopsy/lib
@dirrm share/autopsy

6
autopsy/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2009/02/19 15:45:51 fulviociriaco Exp $
SHA1 (autopsy-2.21.tar.gz) = 083f6e1794e19ad07989d088a35da16e9418c83b
RMD160 (autopsy-2.21.tar.gz) = d9b0c5c16c2462997cfe217211f46e1e75464204
Size (autopsy-2.21.tar.gz) = 387288 bytes
SHA1 (patch-aa) = ce8c451b1d3a8c18a04878fa8083e9b3be22fdcb

44
autopsy/patches/patch-aa Normal file
View file

@ -0,0 +1,44 @@
$NetBSD: patch-aa,v 1.1 2009/02/19 15:45:51 fulviociriaco Exp $
--- /dev/null 2009-02-19 16:35:50.000000000 +0100
+++ build
@@ -0,0 +1,39 @@
+(cat<<EOF
+#!${1}/bin/perl"
+
+use lib '${1}/share/autopsy/';
+use lib '${1}/share/autopsy/lib/';
+EOF
+cat base/autopsy.base) > autopsy
+chmod 0755 ./autopsy
+
+(cat<<EOF
+# Autopsy configuration settings
+
+# when set to 1, the server will stop after it receives no
+# connections for STIMEOUT seconds.
+\$USE_STIMEOUT = 0;
+\$STIMEOUT = 3600;
+
+# number of seconds that child waits for input from client
+\$CTIMEOUT = 15;
+
+# set to 1 to save the cookie value in a file (for scripting)
+\$SAVE_COOKIE = 1;
+
+\$INSTALLDIR = '${1}/share/autopsy/';
+
+# System Utilities
+\$GREP_EXE = '/usr/bin/grep';
+\$FILE_EXE = '/usr/bin/file';
+\$MD5_EXE = '/usr/bin/md5';
+\$SHA1_EXE = '';
+
+
+# Directories
+\$TSKDIR = '${1}/bin';
+\$NSRLDB = '';
+\$LOCKDIR = '${1}/share/autopsy/cases';
+EOF
+)> conf.pl
+