Add new package: audio/bmp-docklet

bmp-docklet is a plugin for Beep Media Player (BMP):

* Displays a icon in your systemtray and allows several tasks
like play/pause or hide and unhide the player. It displays
also the title of the current song as tooltips.
This commit is contained in:
Ian Zagorskih 2005-11-19 11:37:20 +00:00 committed by Thomas Klausner
parent 1d06d5e390
commit 8b2f5b10e7
6 changed files with 69 additions and 0 deletions

3
bmp-docklet/DESCR Normal file
View file

@ -0,0 +1,3 @@
Displays a icon in your systemtray and allows several tasks
like play/pause or hide and unhide the player. It displays
also the title of the current song as tooltips.

21
bmp-docklet/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1 2005/11/19 11:37:20 ianzag Exp $
#
DISTNAME= bmp-docklet-1.3
CATEGORIES= audio
MASTER_SITES= http://mark.xnull.de/bmp-docklet/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= ianzag@mail.ru
HOMEPAGE= http://mark.xnull.de/bmp-docklet.php
COMMENT= BMP Dock applet
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
USE_TOOLS+= pkg-config
USE_PKGLOCALEDIR= YES
.include "../../audio/bmp/buildlink3.mk"
# XXX Should we use BUILD_DEPENDS instead?
.include "../../textproc/intltool/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

8
bmp-docklet/PLIST Normal file
View file

@ -0,0 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2005/11/19 11:37:20 ianzag Exp $
lib/bmp/General/libdocklet.la
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/bmp-docklet.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/bmp-docklet.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/bmp-docklet.mo
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/bmp-docklet.mo
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/bmp-docklet.mo
@dirrm lib/bmp/General

7
bmp-docklet/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2005/11/19 11:37:20 ianzag Exp $
SHA1 (bmp-docklet-1.3.tar.bz2) = 8dae5ca29350ddc86e627fdf83d6b7336ac089c6
RMD160 (bmp-docklet-1.3.tar.bz2) = 278d460d1c2185414089a443a43acc251a318df7
Size (bmp-docklet-1.3.tar.bz2) = 285213 bytes
SHA1 (patch-aa) = 165ef568c130b6d9bfe834e9cd086949960fd5ef
SHA1 (patch-ab) = fb3c146837530f80acc499040f40a6d5d8a96ad0

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2005/11/19 11:37:20 ianzag Exp $
--- src/about.c.orig 2005-07-14 03:46:29.000000000 +0700
+++ src/about.c
@@ -2,6 +2,10 @@
# include "config.h"
#endif
+#ifdef ENABLE_NLS
+#include <locale.h>
+#endif
+
#include <glib.h>
#include <glib/gi18n.h>
#include <bmp/util.h>

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1 2005/11/19 11:37:20 ianzag Exp $
--- src/docklet.c.orig 2005-07-14 03:46:29.000000000 +0700
+++ src/docklet.c
@@ -21,6 +21,10 @@
# include "config.h"
#endif
+#ifdef ENABLE_NLS
+#include <locale.h>
+#endif
+
#include <glib.h>
#include <glib/gi18n.h>
#include <gtk/gtk.h>