[wip/tinyxml] Force the use of STL in tinyxml.h

This commit is contained in:
Anthony Mallet 2013-06-20 21:46:07 +00:00 committed by Thomas Klausner
parent c3b1d75c94
commit 8c109af9d4
3 changed files with 15 additions and 31 deletions

View file

@ -1,30 +0,0 @@
TinyXML parses an XML document, and builds from that a Document Object Model
(DOM) that can be read, modified, and saved.
There are different ways to access and interact with XML data. TinyXML uses a
Document Object Model (DOM), meaning the XML data is parsed into a C++ objects
that can be browsed and manipulated, and then written to disk or another output
stream. You can also construct an XML document from scratch with C++ objects
and write this to disk or another output stream.
TinyXML is designed to be easy and fast to learn. It is two headers and four
cpp files. Simply add these to your project and off you go. There is an example
file - xmltest.cpp - to get you started.
TinyXML is released under the ZLib license, so you can use it in open source or
commercial code. The details of the license are at the top of every source
file.
TinyXML attempts to be a flexible parser, but with truly correct and compliant
XML output. TinyXML should compile on any reasonably C++ compliant system. It
does not rely on exceptions or RTTI. It can be compiled with or without STL
support. TinyXML fully supports the UTF-8 encoding, and the first 64k character
entities.
TinyXML doesn't parse or use DTDs (Document Type Definitions) or XSLs
(eXtensible Stylesheet Language.) There are other parsers out there (check out
www.sourceforge.org, search for XML) that are much more fully featured. But
they are also much bigger, take longer to set up in your project, have a higher
learning curve, and often have a more restrictive license. If you are working
with browsers or have more complete XML needs, TinyXML is not the parser for
you.

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1 2013/06/20 21:09:26 anthony_mallet Exp $
$NetBSD: distinfo,v 1.2 2013/06/20 21:46:07 anthony_mallet Exp $
SHA1 (tinyxml_2_6_2.zip) = a425a22ff331dafa570b2a508a37a85a4eaa4127
RMD160 (tinyxml_2_6_2.zip) = 162880af0cb1a284268cc18ec582f51c55120a76
Size (tinyxml_2_6_2.zip) = 290881 bytes
SHA1 (patch-tinyxml.h) = 596bc733a557da45a2ec2e38ff40c6a3bd3a8986

View file

@ -0,0 +1,13 @@
--- tinyxml.h~ 2011-05-15 04:24:57.000000000 +0200
+++ tinyxml.h 2013-06-20 23:42:16.000000000 +0200
@@ -26,6 +26,10 @@
#ifndef TINYXML_INCLUDED
#define TINYXML_INCLUDED
+#ifndef TIXML_USE_STL
+# define TIXML_USE_STL
+#endif
+
#ifdef _MSC_VER
#pragma warning( push )
#pragma warning( disable : 4530 )