py-PgSQL is now in pkgsrc.

This commit is contained in:
Marc Recht 2003-09-09 13:50:06 +00:00
parent 0c0b9eb4ac
commit 8c325832be
6 changed files with 0 additions and 105 deletions

View file

@ -1,7 +0,0 @@
pyPgSQL is a package of two modules that provide a Python DB-API 2.0 compliant
interface to PostgreSQL databases. The first module, libpq, exports the
PostgreSQL C API to Python. This module is written in C and can be compiled
into Python or can be dynamically loaded on demand. The second module, PgSQL,
provides the DB-API 2.0 compliant interface and support for various PostgreSQL
data types, such as INT8, NUMERIC, MONEY, BOOL, ARRAYS, etc. This module is
written in Python.

View file

@ -1,27 +0,0 @@
# $NetBSD: Makefile,v 1.3 2003/07/26 13:38:40 marc Exp $
#
DISTNAME= pyPgSQL-2.4
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py//}
WRKSRC= ${WRKDIR}/pypgsql
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pypgsql/}
MAINTAINER= marc@informatik.uni-bremen.de
HOMEPAGE= http://pypgsql.sourceforge.net/
COMMENT= Python DB-API 2.0 compliant interface to PostgreSQL
USE_BUILDLINK2= YES
PYDISTUTILSPKG= YES
PYBINMODULE= YES
PY_PATCHPLIST= YES
post-install:
${PYTHONBIN} -O ${LOCALBASE}/${PYLIB}/compileall.py \
${LOCALBASE}/${PYSITELIB}/pyPgSQL
.include "../../lang/python/extension.mk"
.include "../../lang/python/application.mk"
.include "../../time/py-mxDateTime/buildlink2.mk"
.include "../../databases/postgresql-lib/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,13 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/04/05 21:46:29 marc Exp $
${PYSITELIB}/pyPgSQL/PgSQL.py
${PYSITELIB}/pyPgSQL/PgSQL.pyc
${PYSITELIB}/pyPgSQL/PgSQL.pyo
${PYSITELIB}/pyPgSQL/__init__.py
${PYSITELIB}/pyPgSQL/__init__.pyc
${PYSITELIB}/pyPgSQL/__init__.pyo
${PYSITELIB}/pyPgSQL/libpq/__init__.py
${PYSITELIB}/pyPgSQL/libpq/__init__.pyc
${PYSITELIB}/pyPgSQL/libpq/__init__.pyo
${PYSITELIB}/pyPgSQL/libpq/libpqmodule.so
@dirrm ${PYSITELIB}/pyPgSQL/libpq
@dirrm ${PYSITELIB}/pyPgSQL

View file

@ -1,22 +0,0 @@
# $NetBSD: buildlink2.mk,v 1.2 2003/07/26 13:38:40 marc Exp $
.include "../../lang/python/pyversion.mk"
.if !defined(PYPGSQL_BUILDLINK2_MK)
PYPGSQL_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= pyPgSQL
BUILDLINK_DEPENDS.pyPgSQL?= ${PYPKGPREFIX}-PgSQL>=2.4
BUILDLINK_PKGSRCDIR.pyPgSQL?= ../../wip/py-PgSQL
EVAL_PREFIX+= BUILDLINK_PREFIX.pyPgSQL=${PYPKGPREFIX}-PgSQL
BUILDLINK_PREFIX.pyPgSQL_DEFAULT= ${LOCALBASE}
.include "../../time/py-mxDateTime/buildlink2.mk"
.include "../../databases/postgresql-lib/buildlink2.mk"
BUILDLINK_TARGETS+= pyPgSQL-buildlink
pyPgSQL-buildlink: _BUILDLINK_USE
.endif # PYPGSQL_BUILDLINK2_MK

View file

@ -1,5 +0,0 @@
$NetBSD: distinfo,v 1.2 2003/07/26 13:38:40 marc Exp $
SHA1 (pyPgSQL-2.4.tar.gz) = 478135830e0bf4fc9496452ee3b88de4c218488f
Size (pyPgSQL-2.4.tar.gz) = 152139 bytes
SHA1 (patch-aa) = f8db2a753eb76bece779936fae69be60794c0327

View file

@ -1,31 +0,0 @@
$NetBSD: patch-aa,v 1.2 2003/07/26 13:38:40 marc Exp $
--- libpqmodule.c.orig 2003-06-17 03:28:30.000000000 +0200
+++ libpqmodule.c 2003-07-26 15:26:34.000000000 +0200
@@ -791,7 +791,7 @@
return PgInt8_FromString(s, (char **)NULL, 10);
}
- PyErr_SetString(PyExc_TypeError, "a string or numeric is requireed");
+ PyErr_SetString(PyExc_TypeError, "a string or numeric is required");
return (PyObject *)NULL;
}
#endif
@@ -855,7 +855,7 @@
return PgInt2_FromString(s, (char **)NULL, 10);
}
- PyErr_SetString(PyExc_TypeError, "a string or numeric is requireed");
+ PyErr_SetString(PyExc_TypeError, "a string or numeric is required");
return (PyObject *)NULL;
}
@@ -907,7 +907,7 @@
return libPQbool_FromString(self, args);
}
- PyErr_SetString(PyExc_TypeError, "a string or numeric is requireed");
+ PyErr_SetString(PyExc_TypeError, "a string or numeric is required");
return (PyObject *)NULL;
}