Adding required patches. No idea HTF this didn't happen on import.
This commit is contained in:
parent
eaffa667b1
commit
8d44589f78
3 changed files with 57 additions and 0 deletions
25
higan/patches/patch-higan_Makefile
Normal file
25
higan/patches/patch-higan_Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-higan_Makefile,v 1.1 2013/02/11 13:38:29 othyro Exp $
|
||||
|
||||
Add path to boost headers.
|
||||
Use pkgsrc infrastructure for libdl.
|
||||
|
||||
--- higan/Makefile.orig 2012-11-04 04:22:50.000000000 +0000
|
||||
+++ higan/Makefile
|
||||
@@ -16,7 +16,7 @@ target := ethos
|
||||
# compiler
|
||||
c := $(compiler) -std=gnu99
|
||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||
-flags := -I. -O3 -fomit-frame-pointer
|
||||
+flags := -I. -O3 -fomit-frame-pointer -I${PREFIX}/include/boost
|
||||
link := -s
|
||||
objects := libco
|
||||
|
||||
@@ -34,7 +34,7 @@ endif
|
||||
# platform
|
||||
ifeq ($(platform),x)
|
||||
flags += -march=native
|
||||
- link += -Wl,-export-dynamic -ldl -lX11 -lXext
|
||||
+ link += -Wl,-export-dynamic ${DL_LIBS} -lX11 -lXext
|
||||
else ifeq ($(platform),win)
|
||||
ifeq ($(arch),win32)
|
||||
flags += -m32
|
15
higan/patches/patch-higan_nall_Makefile
Normal file
15
higan/patches/patch-higan_nall_Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-higan_nall_Makefile,v 1.1 2013/02/11 13:38:29 othyro Exp $
|
||||
|
||||
Allow GCC to DTRT.
|
||||
|
||||
--- higan/nall/Makefile.orig 2013-01-14 18:27:28.000000000 +0000
|
||||
+++ higan/nall/Makefile
|
||||
@@ -40,7 +40,7 @@ ifeq ($(compiler),)
|
||||
else ifeq ($(platform),osx)
|
||||
compiler := gcc-mp-4.7
|
||||
else
|
||||
- compiler := gcc-4.7
|
||||
+ compiler := gcc
|
||||
endif
|
||||
endif
|
||||
|
17
higan/patches/patch-higan_nall_file.hpp
Normal file
17
higan/patches/patch-higan_nall_file.hpp
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-higan_nall_file.hpp,v 1.1 2013/02/11 13:38:29 othyro Exp $
|
||||
|
||||
Work around Linuxism.
|
||||
|
||||
--- higan/nall/file.hpp.orig 2013-01-14 18:27:28.000000000 +0000
|
||||
+++ higan/nall/file.hpp
|
||||
@@ -8,6 +8,10 @@
|
||||
#include <nall/windows/utf8.hpp>
|
||||
#include <nall/stream/memory.hpp>
|
||||
|
||||
+#ifndef stat64
|
||||
+#define stat64 stat
|
||||
+#endif
|
||||
+
|
||||
namespace nall {
|
||||
inline FILE* fopen_utf8(const string &utf8_filename, const char *mode) {
|
||||
#if !defined(_WIN32)
|
Loading…
Reference in a new issue