Add DragonFly support from x11/modular-xorg-server.
This commit is contained in:
parent
6713569d46
commit
8dc7670605
6 changed files with 71 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1 2007/02/05 03:44:13 bsadewitz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2007/02/06 18:24:52 bsadewitz Exp $
|
||||
|
||||
SHA1 (MesaLib-6.5.2.tar.bz2) = ba860bb6ee57c02202342dfd5927464a068ea18f
|
||||
RMD160 (MesaLib-6.5.2.tar.bz2) = 9a92d69110c066ae6734bcaafb78f222ac2df6d3
|
||||
|
@ -11,3 +11,8 @@ SHA1 (patch-ab) = 980fc43bfdb6ea204e5645308ff067121896c66a
|
|||
SHA1 (patch-ac) = 0f097f5b45480fa4fba341aedd75f1ea18202f2f
|
||||
SHA1 (patch-ad) = 3a188cb2797b7df79efe7304326461c34429848c
|
||||
SHA1 (patch-ae) = 6c58872798a30b31154dd7b167c84bf20ac417be
|
||||
SHA1 (patch-da) = 73faacda1088304025c5e05f3d58edaf9ae1145f
|
||||
SHA1 (patch-db) = 28913a094c8499536a71c8d4d7ca57a5efb25b39
|
||||
SHA1 (patch-dc) = 75df6f37b1cbc9574adb5ee66cb84d0f5ebac853
|
||||
SHA1 (patch-dd) = 4d0fd341ccfe1f1240faa8912beea3f15dc39207
|
||||
SHA1 (patch-de) = f887f3fd09406006b6165779b74be780b7fddd18
|
||||
|
|
13
modular-xorg-server-opengl/patches/patch-da
Normal file
13
modular-xorg-server-opengl/patches/patch-da
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-da,v 1.1 2007/02/06 18:24:52 bsadewitz Exp $
|
||||
|
||||
--- Xext/shm.c.orig 2007-02-05 20:58:14.000000000 +0000
|
||||
+++ Xext/shm.c
|
||||
@@ -156,7 +156,7 @@ static ShmFuncs fbFuncs = {fbShmCreatePi
|
||||
}
|
||||
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__) || defined(__DragonFly__)
|
||||
#include <sys/signal.h>
|
||||
|
||||
static Bool badSysCall = FALSE;
|
13
modular-xorg-server-opengl/patches/patch-db
Normal file
13
modular-xorg-server-opengl/patches/patch-db
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-db,v 1.1 2007/02/06 18:24:52 bsadewitz Exp $
|
||||
|
||||
--- Xext/xf86bigfont.c.orig 2007-02-05 21:02:23.000000000 +0000
|
||||
+++ Xext/xf86bigfont.c
|
||||
@@ -104,7 +104,7 @@ static unsigned int pagesize;
|
||||
|
||||
static Bool badSysCall = FALSE;
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__CYGWIN__) || defined(__DragonFly__)
|
||||
|
||||
#include <sys/signal.h>
|
||||
|
13
modular-xorg-server-opengl/patches/patch-dc
Normal file
13
modular-xorg-server-opengl/patches/patch-dc
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-dc,v 1.1 2007/02/06 18:24:52 bsadewitz Exp $
|
||||
|
||||
--- hw/xfree86/loader/os.c.orig 2007-02-05 21:03:59.000000000 +0000
|
||||
+++ hw/xfree86/loader/os.c
|
||||
@@ -42,6 +42,8 @@
|
||||
#define OSNAME "linux"
|
||||
#elif defined(__FreeBSD__)
|
||||
#define OSNAME "freebsd"
|
||||
+#elif defined(__DragonFly__)
|
||||
+#define OSNAME "dragonfly"
|
||||
#elif defined(__NetBSD__)
|
||||
#define OSNAME "netbsd"
|
||||
#elif defined(__OpenBSD__)
|
13
modular-xorg-server-opengl/patches/patch-dd
Normal file
13
modular-xorg-server-opengl/patches/patch-dd
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-dd,v 1.1 2007/02/06 18:24:52 bsadewitz Exp $
|
||||
|
||||
--- hw/xfree86/os-support/bus/Pci.h.orig 2007-02-05 21:08:10.000000000 +0000
|
||||
+++ hw/xfree86/os-support/bus/Pci.h
|
||||
@@ -235,7 +235,7 @@
|
||||
# if defined(linux)
|
||||
# define ARCH_PCI_INIT axpPciInit
|
||||
# define INCLUDE_XF86_MAP_PCI_MEM
|
||||
-# elif defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
+# elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
|
||||
# define ARCH_PCI_INIT freebsdPciInit
|
||||
# define INCLUDE_XF86_MAP_PCI_MEM
|
||||
# define INCLUDE_XF86_NO_DOMAIN
|
13
modular-xorg-server-opengl/patches/patch-de
Normal file
13
modular-xorg-server-opengl/patches/patch-de
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-de,v 1.1 2007/02/06 18:24:52 bsadewitz Exp $
|
||||
|
||||
--- hw/xfree86/os-support/bus/freebsdPci.c.orig 2007-02-05 21:09:30.000000000 +0000
|
||||
+++ hw/xfree86/os-support/bus/freebsdPci.c
|
||||
@@ -83,7 +83,7 @@ static pciBusInfo_t freebsdPci0 = {
|
||||
/* bridge */ NULL
|
||||
};
|
||||
|
||||
-#if !defined(__OpenBSD__) && !defined(__FreeBSD__)
|
||||
+#if !defined(__OpenBSD__) && !defined(__FreeBSD__) && !defined(__DragonFly__)
|
||||
#if X_BYTE_ORDER == X_BIG_ENDIAN
|
||||
#ifdef __sparc__
|
||||
#ifndef ASI_PL
|
Loading…
Reference in a new issue