Import kimera-tomoe-gtk-0.5 as wip/kimera-tomoe-gtk.

kimera-tomoe-gtk is an Kimera helper program for Tomoe.
This commit is contained in:
OBATA Akio 2010-05-14 11:07:58 +00:00 committed by Thomas Klausner
parent b1aa22e1b2
commit 8e21b79d2f
5 changed files with 54 additions and 0 deletions

1
kimera-tomoe-gtk/DESCR Normal file
View file

@ -0,0 +1 @@
kimera-tomoe-gtk is an Kimera helper program for Tomoe.

28
kimera-tomoe-gtk/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/05/14 11:07:58 obache Exp $
#
DISTNAME= kimera-tomoe-gtk-0.5
CATEGORIES= inputmethod
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP:=kimera/24906/}
MAINTAINER= obache@NetBSD.org
HOMEPAGE= http://kimera.sourceforge.jp/
COMMENT= Kimera helper program for Tomoe
LICENSE= gnu-lgpl-v2.1
DEPENDS+= kimera-[0-9]*:../../wip/kimera
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= pkg-config
SUBST_CLASSES+= libtomoe
SUBST_STAGE.libtomoe= pre-configure
SUBST_FILES.libtomoe= configure
SUBST_SED.libtomoe= -e 's/libtomoe-gtk/tomoe-gtk/g'
.include "../../inputmethod/tomoe-gtk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
kimera-tomoe-gtk/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/05/14 11:07:58 obache Exp $
bin/kimera-tomoe-gtk
share/locale/ja/LC_MESSAGES/kimera-tomoe-gtk.mo

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/05/14 11:07:58 obache Exp $
SHA1 (kimera-tomoe-gtk-0.5.tar.gz) = 39ab9ce3198fa294851c27736eb9da72a522d27a
RMD160 (kimera-tomoe-gtk-0.5.tar.gz) = ba8c77fffaaf4824f5a907e9cdced71cb78d81a0
Size (kimera-tomoe-gtk-0.5.tar.gz) = 334888 bytes
SHA1 (patch-aa) = 986162267dfe5e4c84c1fa07ce98dcce34e47fd4

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/05/14 11:07:58 obache Exp $
locale.h is required for setlocale(3) and LC_ALL.
--- src/kimera-tomoe-gtk.c.orig 2007-04-08 15:05:33.000000000 +0000
+++ src/kimera-tomoe-gtk.c
@@ -25,6 +25,9 @@
#ifdef HAVE_CONFIG_H
#include <config.h>
#endif /* HAVE_CONFIG_H */
+#ifdef HAVE_LOCALE_H
+#include <locale.h>
+#endif
#include <gtk/gtk.h>
#include <tomoe-gtk.h>
#include "intl.h"