Import cabot:

CABot is a set of scripts that help managing some parts of a PGP keysigning
process. It sends encrypted challenges to UIDs of an OpenPGP key, analyses the
replies and assists the key owner in signing them.
This commit is contained in:
Antoine Reilles 2005-11-12 23:59:31 +00:00 committed by Thomas Klausner
parent 6984be81af
commit 8f3fe74795
5 changed files with 91 additions and 0 deletions

3
cabot/DESCR Normal file
View file

@ -0,0 +1,3 @@
CABot is a set of scripts that help managing some parts of a PGP keysigning
process. It sends encrypted challenges to UIDs of an OpenPGP key, analyses the
replies and assists the key owner in signing them.

32
cabot/Makefile Normal file
View file

@ -0,0 +1,32 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/11/12 23:59:31 jtonio Exp $
DISTNAME= cabot-0.0.20050504
CATEGORIES= misc security
MASTER_SITES= http://alioth.debian.org/download.php/1034/
MAINTAINER= tonio@NetBSD.org
HOMEPAGE= http://cabot.alioth.debian.org/
COMMENT= Scripts that help managing a PGP keysigning process
DEPENDS+= p5-GnuPG-Interface>=0.34:../../security/p5-GnuPG-Interface
DEPENDS+= p5-Class-MethodMaker>=2.07:../../devel/p5-Class-MethodMaker
DEPENDS+= gnupg>=1.4.2:../../security/gnupg
USE_TOOLS+= gmake
USE_PKGINSTALL= yes
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
PERL5_CONFIGURE= no
REPLACE_PERL= Cabot.pm
EGDIR= ${PREFIX}/share/examples/cabot
CONF_FILES+= ${EGDIR}/cabot.conf ${PKG_SYSCONFDIR}/cabot.conf
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
MAKE_ENV+= PKG_PERL5_SITELIB=${PERL5_INSTALLVENDORLIB}
pre-install:
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/cabot.conf ${EGDIR}
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

37
cabot/PLIST Normal file
View file

@ -0,0 +1,37 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/11/12 23:59:31 jtonio Exp $
bin/ca-createsendout
bin/ca-dosign
bin/ca-recv
bin/ca-sendout
man/man1/ca-createsendout.1
man/man1/ca-dosign.1
man/man1/ca-recv.1
man/man1/ca-sendout.1
man/man5/ca-config.5
man/man7/ca-bot-noroot.7
man/man7/ca-bot.7
share/examples/cabot/cabot.conf
share/doc/cabot/AUTHORS
share/doc/cabot/COPYING
share/doc/cabot/ChangeLog
share/doc/cabot/README
share/doc/cabot/TODO
share/doc/cabot/ca-bot-noroot.html
share/doc/cabot/ca-bot-noroot.txt
share/doc/cabot/ca-bot.html
share/doc/cabot/ca-bot.txt
share/doc/cabot/ca-config.html
share/doc/cabot/ca-config.txt
share/doc/cabot/ca-createsendout.html
share/doc/cabot/ca-createsendout.txt
share/doc/cabot/ca-dosign.html
share/doc/cabot/ca-dosign.txt
share/doc/cabot/ca-recv.html
share/doc/cabot/ca-recv.txt
share/doc/cabot/ca-sendout.html
share/doc/cabot/ca-sendout.txt
share/doc/cabot/cabot-micro-howto.txt
share/doc/cabot/examples/cabotrc
${PERL5_SUB_INSTALLVENDORLIB}/Cabot.pm
@dirrm share/doc/cabot/examples
@dirrm share/doc/cabot

6
cabot/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/11/12 23:59:31 jtonio Exp $
SHA1 (cabot-0.0.20050504.tar.gz) = 3a3b87aa5527a0e6f41b6223206fed04f6cb08a6
RMD160 (cabot-0.0.20050504.tar.gz) = 71d6f58d3a74607c262f267b22cc0c7dd271a1c3
Size (cabot-0.0.20050504.tar.gz) = 85714 bytes
SHA1 (patch-aa) = 58a5137e7740adee7ec9c26d7e6e10d8951c050b

13
cabot/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/11/12 23:59:31 jtonio Exp $
--- Makefile.in.orig 2005-11-13 00:36:35.000000000 +0100
+++ Makefile.in
@@ -153,7 +153,7 @@ target_alias = @target_alias@
CONFIGURE_DEPENDENCIES = $(top_srcdir)/VERSION.m4
# Perl module
-perlmoddir = $(datadir)/perl5
+perlmoddir = ${PKG_PERL5_SITELIB}
perlmod_DATA = Cabot.pm
SUBDIRS = doc
bin_SCRIPTS = ca-createsendout ca-dosign ca-recv ca-sendout