Initial import of pkg-config-0.26 (the version depending on glib2).
TODO: There is pushback against having pkg-config depend on glib2, so for now this version is only in wip, but available for those who want to use it. -- wiz 20120307
This commit is contained in:
parent
4739ee4363
commit
8f9c222b05
6 changed files with 88 additions and 0 deletions
6
pkg-config/DESCR
Normal file
6
pkg-config/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
pkg-config is a system for managing library compile/link flags that
|
||||
works with automake and autoconf. It replaces the ubiquitous
|
||||
*-config scripts you may have seen with a single tool.
|
||||
|
||||
Despite its name, this project is not related to the NetBSD package
|
||||
system!
|
52
pkg-config/Makefile
Normal file
52
pkg-config/Makefile
Normal file
|
@ -0,0 +1,52 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2012/03/07 14:57:07 thomasklausner Exp $
|
||||
|
||||
DISTNAME= pkg-config-0.26
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://pkgconfig.freedesktop.org/releases/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://pkgconfig.freedesktop.org/
|
||||
COMMENT= System for managing library compile/link flags
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
# needed since it can't use pkg-config to find glib2...
|
||||
CONFIGURE_ARGS+= GLIB_CFLAGS="-I${BUILDLINK_PREFIX.glib2}/include/glib/glib-2.0 -I${BUILDLINK_PREFIX.glib2}/lib/glib-2.0/include"
|
||||
CONFIGURE_ARGS+= GLIB_LIBS="${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.glib2}/lib -L${BUILDLINK_PREFIX.glib2}/lib -lglib-2.0 -lintl"
|
||||
|
||||
# old name of the package
|
||||
CONFLICTS= pkgconfig-[0-9]*
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "IRIX"
|
||||
# configure bails out in subdir after re-parsing the cache
|
||||
CONFIGURE_ARGS+= --cache-file=/dev/null
|
||||
.endif
|
||||
|
||||
PKGCONFIG_EXTRA_PATHS= # empty
|
||||
|
||||
.if ${LOCALBASE} != ${X11BASE}
|
||||
PKGCONFIG_EXTRA_PATHS+= ${X11BASE}/lib/pkgconfig
|
||||
.endif
|
||||
|
||||
.if ${LOCALBASE} != "/usr"
|
||||
PKGCONFIG_EXTRA_PATHS+= /usr/lib/pkgconfig
|
||||
.endif
|
||||
|
||||
.if !empty(PKGCONFIG_EXTRA_PATHS)
|
||||
# First part of the value is taken from configure.in
|
||||
CONFIGURE_ARGS+= --with-pc-path='$${libdir}/pkgconfig:$${datadir}/pkgconfig:${PKGCONFIG_EXTRA_PATHS:ts:}'
|
||||
.endif
|
||||
|
||||
# needed for fifth test case
|
||||
BUILDLINK_PASSTHRU_DIRS= /private-dep /public-dep /requires-test
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../mk/dlopen.buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
pkg-config/PLIST
Normal file
5
pkg-config/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2012/03/07 14:57:07 thomasklausner Exp $
|
||||
bin/pkg-config
|
||||
man/man1/pkg-config.1
|
||||
share/aclocal/pkg.m4
|
||||
share/doc/pkg-config/pkg-config-guide.html
|
4
pkg-config/TODO
Normal file
4
pkg-config/TODO
Normal file
|
@ -0,0 +1,4 @@
|
|||
There is pushback against having pkg-config depend on glib2,
|
||||
so for now this version is only in wip, but available for those
|
||||
who want to use it.
|
||||
-- wiz 20120307
|
6
pkg-config/distinfo
Normal file
6
pkg-config/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2012/03/07 14:57:07 thomasklausner Exp $
|
||||
|
||||
SHA1 (pkg-config-0.26.tar.gz) = fd71a70b023b9087c8a7bb76a0dc135a61059652
|
||||
RMD160 (pkg-config-0.26.tar.gz) = face3d16ec338b9b1ab41d56d6e4d1a5624b52d0
|
||||
Size (pkg-config-0.26.tar.gz) = 396399 bytes
|
||||
SHA1 (patch-configure) = 6d936a40351077cf905aaf9ab9561fc813e03899
|
15
pkg-config/patches/patch-configure
Normal file
15
pkg-config/patches/patch-configure
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-configure,v 1.1.1.1 2012/03/07 14:57:07 thomasklausner Exp $
|
||||
|
||||
Arbitrary strings should not be passed to "eval".
|
||||
|
||||
--- configure.orig 2011-08-06 14:17:45.000000000 +0000
|
||||
+++ configure
|
||||
@@ -13439,7 +13439,7 @@ echo use_indirect_deps=$use_indirect_dep
|
||||
$as_echo_n "checking whether to list both direct and indirect dependencies... " >&6; }
|
||||
case $use_indirect_deps in
|
||||
auto)
|
||||
- deplibs_check_method=`(./libtool --config; echo eval echo '\"$deplibs_check_method\"') | sh`
|
||||
+ deplibs_check_method=`(./libtool --config; echo '\"$deplibs_check_method\"') | sh`
|
||||
if test "X$deplibs_check_method" = Xnone; then
|
||||
echo "foo: $deplibs_check_method" >&5
|
||||
use_indirect_deps=yes
|
Loading…
Reference in a new issue