Initial import of noip 1.6. Package provided by David Ferlier via PR
pkg/20215. This is a port of No-IP.com's dynamic DNS update client. When configured correctly, the client will check the local IP address at a given time interval for any changes. If the local IP address has changed it will notify the DNS servers at No-IP.com and update the IP corresponding to your No-IP/No-IP+ hostname.
This commit is contained in:
parent
3eadadd282
commit
918f4525b4
7 changed files with 118 additions and 0 deletions
5
noip/DESCR
Normal file
5
noip/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
This is a port of No-IP.com's dynamic DNS update client. When
|
||||
configured correctly, the client will check the local IP address at a
|
||||
given time interval for any changes. If the local IP address has
|
||||
changed it will notify the DNS servers at No-IP.com and update the IP
|
||||
corresponding to your No-IP/No-IP+ hostname.
|
38
noip/Makefile
Normal file
38
noip/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/09/02 06:11:09 xtraeme Exp $
|
||||
# $FreeBSD: ports/net/noip/Makefile,v 1.1 2002/06/25 09:32:28 ijliao Exp $
|
||||
|
||||
DISTNAME= noip_updater_v1.6
|
||||
PKGNAME= noip-1.6
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.no-ip.com/client/linux/
|
||||
|
||||
MAINTAINER= david@netbsd-fr.org
|
||||
COMMENT= Dynamic DNS update client from no-ip.com
|
||||
|
||||
ALL_TARGET= noip
|
||||
PKG_GROUPS= noip
|
||||
PKG_USERS= noip:noip
|
||||
|
||||
post-build:
|
||||
${CP} ${FILESDIR}/noip.sh ${WRKSRC}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/noip ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/noip.sh ${PREFIX}/etc/rc.d/noip
|
||||
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/noip
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/noip/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/README.FIRST ${PREFIX}/share/noip/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/noip/doc
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/noip
|
||||
${INSTALL_MAN} ${WRKSRC}/no-ip.conf.sample \
|
||||
${PREFIX}/share/examples/noip
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/noip.sh ${PREFIX}/share/examples/noip
|
||||
${CP} ${PREFIX}/share/examples/noip/no-ip.conf.sample \
|
||||
${PREFIX}/etc/no-ip.conf
|
||||
${CHMOD} 0600 ${PREFIX}/etc/no-ip.conf
|
||||
${CHOWN} noip:noip ${PREFIX}/etc/no-ip.conf
|
||||
|
||||
USE_PKGINSTALL= YES
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
10
noip/PLIST
Normal file
10
noip/PLIST
Normal file
|
@ -0,0 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/09/02 06:11:10 xtraeme Exp $
|
||||
bin/noip
|
||||
etc/no-ip.conf
|
||||
etc/rc.d/noip
|
||||
share/examples/noip/no-ip.conf.sample
|
||||
share/examples/noip/noip.sh
|
||||
share/noip/doc/COPYING
|
||||
share/noip/doc/README.FIRST
|
||||
@dirrm share/noip/doc
|
||||
@dirrm share/examples/noip
|
6
noip/distinfo
Normal file
6
noip/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/09/02 06:11:10 xtraeme Exp $
|
||||
|
||||
SHA1 (noip_updater_v1.6.tar.gz) = 60bea63cfe0996d900b44fe21992bcb214dd7a3d
|
||||
Size (noip_updater_v1.6.tar.gz) = 42343 bytes
|
||||
SHA1 (patch-aa) = c3dbddd4b32ab83c604b1296b3cc0d15af6197df
|
||||
SHA1 (patch-ab) = 09b598f971a63a9a7ca5b7400a80e9247213022b
|
13
noip/files/noip.sh
Normal file
13
noip/files/noip.sh
Normal file
|
@ -0,0 +1,13 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# PROVIDE: noip
|
||||
# REQUIRE: network
|
||||
|
||||
name="noip"
|
||||
command="/usr/pkg/bin/${name}"
|
||||
required_files="/usr/pkg/etc/no-ip.conf"
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
23
noip/patches/patch-aa
Normal file
23
noip/patches/patch-aa
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/09/02 06:11:10 xtraeme Exp $
|
||||
|
||||
--- no-ip.sh.orig Thu Oct 11 01:35:12 2001
|
||||
+++ no-ip.sh Wed Feb 5 05:21:13 2003
|
||||
@@ -1,7 +1,8 @@
|
||||
+#!/bin/sh
|
||||
#
|
||||
# configuration file builder script for no-ip
|
||||
#
|
||||
-CONFIG=./no-ip.conf
|
||||
+CONFIG=/usr/pkg/etc/no-ip.conf
|
||||
if [ -e $CONFIG ]
|
||||
then
|
||||
EXISTS=Y
|
||||
@@ -89,7 +90,7 @@
|
||||
#
|
||||
if [ "$NAT" = "N" ]
|
||||
then
|
||||
- devs=`tail +3 /proc/net/dev | awk -F: '{print $1}' | tr -d ' '|tr '\n' ' '`
|
||||
+ devs=`ifconfig -l`
|
||||
DEV=foo
|
||||
while [ "$DEV" = "foo" ]
|
||||
do
|
23
noip/patches/patch-ab
Normal file
23
noip/patches/patch-ab
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/09/02 06:11:10 xtraeme Exp $
|
||||
|
||||
--- noip.c.orig Thu Oct 11 01:48:12 2001
|
||||
+++ noip.c Wed Feb 5 05:24:27 2003
|
||||
@@ -95,8 +95,8 @@
|
||||
#define OURBUFLEN 8192
|
||||
#define IPLEN 16
|
||||
#define SAVEDIPFILE "/tmp/no-ip_save"
|
||||
-#define CONFIG_FILENAME "/usr/local/lib/no-ip.conf"
|
||||
-#define CONFIG_FILENAME_ETC "/usr/local/etc/no-ip.conf"
|
||||
+#define CONFIG_FILENAME "/usr/pkg/etc/no-ip.conf"
|
||||
+#define CONFIG_FILENAME_ETC "/usr/pkg/etc/no-ip.conf"
|
||||
#define CONFIGNUM 10
|
||||
#define CONFSTRLEN 1024
|
||||
#define NUMBER 2
|
||||
@@ -452,6 +452,7 @@
|
||||
else
|
||||
getip(IPaddress);
|
||||
#ifdef DEBUG
|
||||
+ if (debug)
|
||||
ErrMsg("! LIA = %s, IP = %s",Last_IP_Addr, IPaddress);
|
||||
#endif
|
||||
if ((*IPaddress != 0) &&
|
Loading…
Reference in a new issue