Import of ISC DHCP Server.

(This also provides Makefile.common used for ISC DHCP Client.)

This package provides the ISC Dynamic Host Configuration Protocol (DHCP)
server and DHCP relay agent.

It includes an DHCP (and BOOTP) server daemon used to distribute network
information, an Object Management API command shell for querying and
modifying DHCP server attributes (while it is running), and an agent
for relaying DHCP and BOOTP requests between subnets.
This commit is contained in:
Jeremy C. Reed 2003-12-06 08:37:38 +00:00 committed by Thomas Klausner
parent dd3fb0bff6
commit 93130dad81
9 changed files with 156 additions and 0 deletions

7
isc-dhcpd/DESCR Normal file
View file

@ -0,0 +1,7 @@
This package provides the ISC Dynamic Host Configuration Protocol (DHCP)
server and DHCP relay agent.
It includes an DHCP (and BOOTP) server daemon used to distribute network
information, an Object Management API command shell for querying and
modifying DHCP server attributes (while it is running), and an agent
for relaying DHCP and BOOTP requests between subnets.

9
isc-dhcpd/Makefile Normal file
View file

@ -0,0 +1,9 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/12/06 08:37:38 jeremy-c-reed Exp $
#
ISC_DHCP_TYPE= dhcpd
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Server
.include "../../wip/isc-dhcpd/Makefile.common"
.include "../../mk/bsd.pkg.mk"

43
isc-dhcpd/Makefile.common Normal file
View file

@ -0,0 +1,43 @@
# $NetBSD: Makefile.common,v 1.1.1.1 2003/12/06 08:37:39 jeremy-c-reed Exp $
#
DISTNAME= dhcp-3.0pl2
DHCP_VERSION= 3.0.2
PKGNAME= isc-${ISC_DHCP_TYPE}-${DHCP_VERSION}
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/ \
http://archive.progeny.com/isc/dhcp/ \
ftp://ftp.freenet.de/pub/ftp.isc.org/isc/dhcp/ \
ftp://ftp2.tw.freebsd.org/isc/dhcp/ \
http://public.planetmirror.com/pub/isc/dhcp/
MAINTAINER= reed@reedmedia.net
HOMEPAGE= http://www.isc.org/products/DHCP/
# XXX don't need nroff once patched
# XXX BUILD_DEPENDS+= groff-[0-9]*:../../textproc/groff
USE_BUILDLINK2= yes
HAS_CONFIGURE= yes
FILESDIR= ${.CURDIR}/../isc-dhcpd/files
VAR_DIR?= /var
pre-configure:
@${SED} \
-e "s|@@CC@@|${CC}|g" \
-e "s|@@CFLAGS@@|${CFLAGS}|g" \
-e "s|@@VAR_DIR@@|${VAR_DIR}|g" \
-e "s|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|g" \
-e "s|@@PREFIX@@|${PREFIX}|g" \
${FILESDIR}/site.conf >> ${WRKSRC}/site.conf
@${SED} \
-e "s|@@VAR_DIR@@|${VAR_DIR}|g" \
-e "s|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|g" \
-e "s|@@PREFIX@@|${PREFIX}|g" \
${FILESDIR}/site.h >> ${WRKSRC}/includes/site.h
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/isc-${ISC_DHCP_TYPE}
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/isc-${ISC_DHCP_TYPE}

31
isc-dhcpd/PLIST Normal file
View file

@ -0,0 +1,31 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/06 08:37:38 jeremy-c-reed Exp $
bin/omshell
include/dhcpctl.h
include/isc-dhcp/boolean.h
include/isc-dhcp/dst.h
include/isc-dhcp/int.h
include/isc-dhcp/lang.h
include/isc-dhcp/list.h
include/isc-dhcp/result.h
include/isc-dhcp/types.h
include/omapip/alloc.h
include/omapip/buffer.h
include/omapip/omapip.h
lib/libdhcpctl.a
lib/libomapi.a
man/man1/omshell.1
man/man3/dhcpctl.3
man/man3/omapi.3
man/man3/omshell.3
man/man5/dhcp-eval.5
man/man5/dhcp-options.5
man/man5/dhcpd.conf.5
man/man5/dhcpd.leases.5
man/man8/dhcpd.8
man/man8/dhcrelay.8
sbin/dhcpd
sbin/dhcrelay
share/doc/isc-dhcpd/README
@dirrm share/doc/isc-dhcpd
@dirrm include/omapip
@dirrm include/isc-dhcp

20
isc-dhcpd/TODO Normal file
View file

@ -0,0 +1,20 @@
set up patch for NetBSD, like:
includes/cf/netbsd.h
and common/bpf.c and common/fddi.c to use NETBSD_FDDI
(see NetBSD's /usr/src/dist/dhcp)
look at http://www.gentoo.org/cgi-bin/viewcvs.cgi/net-misc/dhcp/
should I have a "dhcp" user?
chroot?
what is paranoia patch?
Use MAKE_DIRS_PERMS for /var/db/dhcp
maybe should be named /var/db/isc-dhcp ?
does that conflict with other dhcp?
should this install shared libraries?
should this document the libraries/headers in DESCR?
patch the various Makefile.dist to change all target to use SEDMANPAGES instead
(so nroff is not done)

5
isc-dhcpd/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/12/06 08:37:38 jeremy-c-reed Exp $
SHA1 (dhcp-3.0pl2.tar.gz) = fed2f5d5b0a8688beb3f8403858f9390a6682f34
Size (dhcp-3.0pl2.tar.gz) = 865196 bytes
SHA1 (patch-aa) = 8ac42857f0c17791ad81169cb30788aff92a9566

23
isc-dhcpd/files/site.conf Normal file
View file

@ -0,0 +1,23 @@
CC = @@CC@@
CC_OPTIONS = @@CFLAGS@@
USERBINDIR = @@PREFIX@@/bin
BINDIR = @@PREFIX@@/sbin
CLIENTBINDIR = @@PREFIX@@/sbin
ADMMANDIR = @@PREFIX@@/man/man8
FFMANDIR = @@PREFIX@@/man/man5
LIBMANDIR = @@PREFIX@@/man/man3
USRMANDIR = @@PREFIX@@/man/man1
ADMMANEXT = .8
FFMANEXT = .5
LIBMANEXT = .3
USRMANEXT = .1
MANCAT = man
#ADMMANDIR = @@PREFIX@@/man/cat8
#FFMANDIR = @@PREFIX@@/man/cat5
#LIBMANDIR = @@PREFIX@@/man/cat3
#USRMANDIR = @@PREFIX@@/man/cat1
ETC = @@SYSCONFDIR@@/dhcp
RRUN = @@VAR_DIR@@/run
VARDB = @@VAR_DIR@@/db/dhcp
LIBDIR = @@PREFIX@@/lib
INCDIR = @@PREFIX@@/include

5
isc-dhcpd/files/site.h Normal file
View file

@ -0,0 +1,5 @@
#define _PATH_DHCPD_CONF "@@SYSCONFDIR@@/dhcp/dhcpd.conf"
#define _PATH_DHCPD_PID "@@VAR_DIR@@/run/dhcpd.pid"
#define _PATH_DHCPD_DB "@@VAR_DIR@@/db/dhcp/dhcpd.leases"
#define _PATH_DHCLIENT_DB "@@VAR_DIR@@/db/dhcp/dhclient.leases"
#define DHCPD_LOG_FACILITY LOG_LOCAL1

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/12/06 08:37:39 jeremy-c-reed Exp $
--- Makefile.dist.orig 2001-02-21 23:27:04.000000000 -0800
+++ Makefile.dist
@@ -17,7 +17,7 @@
# http://www.isc.org for more information.
#
-SUBDIRS= common $(MINIRES) dst omapip server client relay dhcpctl
+SUBDIRS= common $(MINIRES) dst omapip server relay dhcpctl
all:
@for dir in ${SUBDIRS}; do \