Put Evolution in tray.

This commit is contained in:
ndb 2013-12-24 19:40:41 +00:00 committed by Thomas Klausner
parent 185822b8ad
commit 964e6b3919
6 changed files with 60 additions and 1 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.5562 2013/12/24 19:02:43 noud4 Exp $
# $Id: Makefile,v 1.5563 2013/12/24 19:42:19 noud4 Exp $
COMMENT= WIP pkgsrc packages
@ -605,6 +605,7 @@ SUBDIR+= ever-note-mode
SUBDIR+= evilvte
SUBDIR+= evolution-couchdb
SUBDIR+= evolution-rss
SUBDIR+= evolution-tray
SUBDIR+= ewl
SUBDIR+= exact-image
SUBDIR+= exhume

2
evolution-tray/DESCR Normal file
View file

@ -0,0 +1,2 @@
This plugin is useful when you want to put evolution in "tray".
While in tray evolution in minimized and it's windows skips the pager.

20
evolution-tray/Makefile Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1 2013/12/24 19:40:41 noud4 Exp $
#
DISTNAME= evolution-tray-0.0.8
CATEGORIES= mail
MASTER_SITES= http://gnome.eu.org/
MAINTAINER= noud4@home.nl
HOMEPAGE= http://gnome.eu.org/index.php/Evolution_Tray
COMMENT= Put Evolution in tray
LICENSE= gnu-gpl-v2
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= intltool pkg-config gmake
USE_LANGUAGES+= c
.include "../../mail/evolution/buildlink3.mk"
.include "../../sysutils/libnotify/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
evolution-tray/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2013/12/24 19:40:41 noud4 Exp $
lib/evolution/2.32/plugins/liborg-gnome-evolution-tray.la
lib/evolution/2.32/plugins/org-gnome-evolution-tray.eplug

6
evolution-tray/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2013/12/24 19:40:41 noud4 Exp $
SHA1 (evolution-tray-0.0.8.tar.gz) = cd26765250209cdb6b17dee464b18c25c56aeed2
RMD160 (evolution-tray-0.0.8.tar.gz) = f6bfbea281e9480976bd830f9cfa5c8abf6e060c
Size (evolution-tray-0.0.8.tar.gz) = 348632 bytes
SHA1 (patch-configure) = bc2d210d274266404ac38089ce67698e828bb63d

View file

@ -0,0 +1,27 @@
$NetBSD: patch-configure,v 1.1 2013/12/24 19:40:41 noud4 Exp $
Add current pkgsrc evolution version as of 2013Q4
--- configure.orig 2013-12-23 21:20:55.000000000 +0000
+++ configure
@@ -12941,9 +12941,9 @@ if test -n "$EVOLUTION_VERSION"; then
break;
fi
else
- evo_versions='12 11 10 8 6 4'
+ evo_versions='32 12 11 10 8 6 4'
for i in $evo_versions; do
- EVOLUTION_VERSION=`$PKG_CONFIG --modversion evolution-shell-2.$i 2>/dev/null`
+ EVOLUTION_VERSION=`$PKG_CONFIG --modversion evolution-shell 2>/dev/null`
if test -n "$EVOLUTION_VERSION"; then
EVOLUTION_BASE_VERSION=2.$i
EVOLUTION_BASE_VERSION_S="-"$EVOLUTION_BASE_VERSION
@@ -13102,7 +13102,7 @@ else
$as_echo "yes" >&6; }
HAVE_LIBGCONFBRIDGE="yes"
fi
-if test "x$HAVE_LIBGCONFBRIDGE" == "xyes"; then
+if test "x$HAVE_LIBGCONFBRIDGE" = "xyes"; then
$as_echo "#define HAVE_LIBGCONFBRIDGE 1" >>confdefs.h