initial import of ObexPushDaemon for BlueZ

%% includes a nice hack to get out the pkgsrc jail ;)
This commit is contained in:
pancake ;) 2005-10-11 04:09:25 +00:00 committed by Thomas Klausner
parent f524da6f15
commit 9803dbebb7
5 changed files with 59 additions and 0 deletions

0
opd/DESCR Normal file
View file

29
opd/Makefile Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/10/11 04:09:25 poppnk Exp $
#
DISTNAME= opd-v0.2-2003-03-18
PKGNAME= opd-0.2
CATEGORIES= wip comms
MASTER_SITES= http://oss.bdit.de/download/
EXTRACT_SUFX= .tgz
MAINTAINER= pancake@phreaker.net
HOMEPAGE= http://oss.bdit.de/opd.html
COMMENT= OBEX PUSH daemon
WRKSRC= ${WRKDIR}/
# HaXoR trick to scape out of the pkgsrc jail ;)
#do-build:
# cd ${WRKSRC} && env PATH=/usr/bin /usr/bin/gcc \
# -L${PREFIX}/lib -I${PREFIX}/include *.c \
# ${CFLAGS} ${LDFLAGS} \
# -lbluetooth -lopenobex \
# -o opd
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/opd ${PREFIX}/bin
.include "../../comms/openobex/buildlink3.mk"
.include "../../wip/bluez-libs/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
opd/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/10/11 04:09:25 poppnk Exp $
bin/opd

6
opd/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/10/11 04:09:25 poppnk Exp $
SHA1 (opd-v0.2-2003-03-18.tgz) = c11572534f8a3c75499b861f008891ef77aa2876
RMD160 (opd-v0.2-2003-03-18.tgz) = a7cbaf41b601afb0b6c11e241377aa9a28ac91dc
Size (opd-v0.2-2003-03-18.tgz) = 9499 bytes
SHA1 (patch-aa) = 9368fa695c357f0107a804ab4d1c52eb26eea97a

22
opd/patches/patch-aa Normal file
View file

@ -0,0 +1,22 @@
--- Makefile.orig 2005-10-11 06:02:06.796840248 +0200
+++ Makefile 2005-10-11 06:02:26.308873968 +0200
@@ -4,10 +4,6 @@
VERSION=0.2
OBEX_VER=1.0.0
-CC = gcc
-LDFLAGS =
-
-CFLAGS = -I.
all : \
@@ -21,7 +17,7 @@
opd : $(BIPD_OBJECTS)
- $(CC) -o opd $(CFLAGS) $(BIPD_OBJECTS) -lopenobex -lbluetooth -lsdp $(LDFLAGS)
+ $(CC) -o opd $(CFLAGS) $(BIPD_OBJECTS) -lopenobex -lbluetooth $(LDFLAGS)
clean: